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1  What Are Tutorials?
Tutorials are text files with small file size and a mandatory file extension (*.tut). A
tutorial file contains the mandatory string #!scpi followed by a sequence of SCPI
commands. A set of tutorials is embedded in the software. The R&S SMW searches for
custom tutorial files in the var/user directory or on a connected USB memory stick.

When a tutorial file is started, the R&S SMW performs the configurations step-by-step.
Dialogs are opened and closed automatically; changed parameters are highlighted in
orange. Additional background information or explanations on the performed actions
are also displayed.

You can use the tutorials functionality to create interactive examples and demonstra-
tions, if for instance:
● The R&S SMW provides a new functionality that needs to be explained to different

users, like, for example, colleagues or customers
● There is a particular configuration or a comprehensive feature that needs a demon-

stration
● Your goal is to impart knowledge and skills, e.g. that the users are able to imitate

the required steps and understand the process.

2  How to Start a Tutorial
A set of tutorials is embedded in the software.

To start a tutorial in an interactive step-by-step mode

1. Press the [SETUP] key on the front panel.
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2. Scroll-down in the list, tap on the "Help" section to expand it. Tap on "Tutorials".

The "Tutorials" dialog opens.

3. Select "File > Load Predefined Tutorial".

4. Tap on a tutorial from the list. Confirm with "Select".

If the file contains a description, it is displayed.
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Note: If options are missing on the R&S SMW, they are marked read in the
"Required options" section of the file description.

5. Use the default mode, that is "Execution Mode > Interactive".

6. Tap on the "Start" button.

7. Observe the information displayed in the "Info" line (bottom of the display).

1 = Information on the performed action
2 = Progress bar
3 = "Next Step": confirms the execution of the step
4 = "Stop": terminates the tutorial

8. To execute a subsequent step, select the "Next Step" button.

A blinking cursor indicates the block or parameter affected by the step.
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The instrument performs the configurations step-by-step and expects your confir-
mation. Dialogs are opened and closed; changed parameters are highlighted in
orange.
Additional information is displayed in the "Info" line.

To stop the tutorial

The demonstration can be terminated at any time.

► Select the "Stop" button.

The demonstration stops.

You can reopen the "Tutorials" dialog and start another file or exit the tutorial mode.

To use the demonstration mode

1. Start the tutorials as described in "To start a tutorial in an interactive step-by-step
mode" on page 3.

2. In the "Tutorials" dialog, select "Execution Mode > Auto (Looped) 3 sec".

The configurations are performed automatically and your interaction is not
required.
Dialogs are opened and closed; changed parameters are highlighted in orange.
Additional information is displayed in the "Info" line.

3  Creating Custom Interactive Examples
The R&S SMW provides a dedicated "Create Tutorials" function that uses the integra-
ted SCPI recording function of the instrument. While configuring the instrument, this
function tracks the settings and automatically creates SCPI lists with the required
remote control commands.

To create your own tutorial

Perform the following main steps:

1. Start the integrated recording function of the instrument

2. Revise the recorded file, add mandatory and additional information

3. Store the tutorial file, transfer it to the instrument and play it
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3.1  How to Start the Integrated Recording Function

The "Create Tutorials" function is a password protected function that requires the pro-
tection level 1 password.

To unlock the protection level 1

1. On the instrument's front panel, press the [SETUP] key.

2. Select "Security > Protection > Protection Level 1 > Password"

3. Enter the protection level 1 password.
The default password is 123456.

To start the integrated recording function of the instrument

1. Select [SETUP] > "Help > Tutorials".

2. In the "Tutorials" dialog, select "Create".

The SCPI recording function is started.

3. Perform the configuration steps that need explanation.

The R&S SMW tracks the changes automatically.

Tip: If you perform an unnecessary step or make an undesired setting, no need to
terminate or restart recording.
Redundant or wrong information can be removed at a later stage, see "To revise
the recorded file and add additional information" on page 9.

4. Complete the configuration and terminate the recording.
That is, left click to access the context menu and select "Stop automatic SCPI
recording".

How to Start the Integrated Recording Function
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The "SCPI Sequence" dialog opens and displays the SCPI list with the remote con-
trol commands. Tracked are not only the settings but also the interactions with the
instrument, like opening and closing of dialogs and tabs.

Figure 3-1: "SCPI Sequence" dialog

1 = SCPI commands for setting of parameters
2 = dedicated SCPI commands for user interface control

For a description of the dedicated SCPI commands, see Chapter 4, "Related
Remote Control Commands", on page 11.

Export the recorded SCPI sequence as a plain SCPI text file and transfer the file
to your PC

1. In the "SCPI Sequence" dialog, select "Export".
Export the SCPI list as a plain SCPI text file with a user-defined name, e.g.
my_tutorial.

How to Start the Integrated Recording Function
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Per default, the text file is stored in the var/user directory of the instrument. The
mandatory file extension *.tut is assigned automatically.

2. Use one of the standard methods to transfer this file to your PC.
For example, use a USB memory stick or mount the var/user directory of the
R&S SMW in the explorer of your PC.

For step-by-step instructions:
● Refer to section "Files and Data Management" in the R&S SMW user manual
● Use the embedded help of the instrument.

3.2  How to Revise the Recorded File

To revise the recorded file and add additional information

1. Open the recorded file in a text editor, e.g. my_tutorial.tut.

2. Add the mandatory key string #!scpi. It must be the first SCPI command in the
file.

How to Revise the Recorded File
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3. We also recommend that you:

a) Add the *RST command right after the #!scpi string.
b) Use the :DISPlay:DIALog:CLOSe:ALL to close all opened dialogs.
c) Remove unnecessary SCPI commands.

For example, delete the commands :DISPlay:DIALog:CLOSe
"CSmwDlg_TutorialScpi" and :DISPlay:DIALog:CLOSe "SMUMenu"
without substitution.

d) Add empty lines and comments to simplify the reading.
To add internal comments, start a line with the hash sign #.

e) Use the :DISPlay:MESSage command to include lines with information, that
is displayed to the users.

f) Add a description that is displayed on tutorial start.
Ideally, it describes the goal and list the required options.

Figure 3-2: Example of a (partly) revised tutorial file

Line 1-6 = Description displayed on tutorial's start
Line 7, 11,... = Empty lines (improves readability)
Line 8 = Mandatory; the instrument recognizes tutorial files by the string #!SCPI
Line 9, 10 = Recommended at the beginning of a tutorial
Line 12, 14 = Comments
Line 20-25 = Recommended structure: show an info message, open the dialog or the tab, send the

required SCPI command to set the parameter

How to Revise the Recorded File
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Highlighting elements and inserting a blinking cursor

The methods and options introduced in the previous sections are sufficient to present a
new instrument's feature. User guidance can be also improved through elements' high-
lighting.

To highlight elements on the user interface, the tutorials use the special SCPI com-
mand :DISPlay:FOCus <ObjectName>.

The user interface identifiers (<ObjectName>) are company confidential information,
that can be retrieved only by the software developers.

3.3  How to Test Your Tutorial

To store the file and transfer it to the instrument

► Use one of the standard methods to transfer the *.tut file to the var/user direc-
tory of the instrument.
You can also start the *.tut file from a connected USB memory stick.

For step-by-step instructions, refer to section "Files and Data Management" in the
R&S SMW user manual.

To start the tutorial

1. Select [SETUP] > "Help > Tutorial".

2. Select "File > User Defined" and select the tutorial file.

If the file contains a description, it is displayed.

3. Select "Start".

4  Related Remote Control Commands
:DISPlay:DIALog:ID?........................................................................................................ 11
:DISPlay:DIALog:OPEN....................................................................................................12
:DISPlay:DIALog:CLOSe.................................................................................................. 12
:DISPlay:DIALog:CLOSe:ALL............................................................................................13
:DISPlay:MESSage.......................................................................................................... 13

:DISPlay:DIALog:ID?

Returns the dialog identifiers of the open dialogs in a string separated by blanks.
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Return values: 
<DialogIdList> <DialogID#1>< ><DialogID#2>< > ... < ><DialogID#n>

Dialog identifiers are string without blanks. Blanks are represen-
ted as $$.
Dialog identifiers <DialogID> are composed of two main parts:
<DialogName>[<OptionalParts>]
<DialogName>
Meaningful information, mandatory input parameter for the com-
mands:
:DISPlay:DIALog:OPEN on page 12
:DISPlay:DIALog:CLOSe on page 12

<Optional parts>
String of $<X> values, where <X> is a character, interpreted as
follows:
$q<DialogQualifier>: optional dialog qualifier, usually the
letter A or B, as displayed in the dialog title.
$i<Instances>: comma-separated list of instance indexes,
given in the order h,c,s,d,g,u,0. Default is zero; the termi-
nating ",0" can be omitted.
$t<TabIds>: comma-separated indexes or tab names;
required, if a dialog is composed of several tabs.
$x<Left>$y<Top>$h<Left>$w<Top>: position and size;
superfluous information.

Usage: Query only

:DISPlay:DIALog:OPEN <DialogId>

Opens the specified dialog.

Setting parameters: 
<DialogId> string

To find out the dialog identifier, use the query :DISPlay:
DIALog:ID?.
The <DialogName> part of the query result is mandatory.

Usage: Setting only

:DISPlay:DIALog:CLOSe <DialogId>

Closes the specified dialog.

Setting parameters: 
<DialogId> string

To find out the dialog identifier, use the query :DISPlay:
DIALog:ID?.
The <DialogName> part of the query result is sufficient.

Usage: Setting only
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:DISPlay:DIALog:CLOSe:ALL

Closes all open dialogs.

Recommended in the beginning of any tutorial.

Usage: Event

:DISPlay:MESSage <MessageText>

Defines a text that is displayed in the "Info" line.

The text is displayed until the "Next Step" button is pressed.

Parameters:
<MessageText> string, enclosed in apostrophes (')

To highlight a part of the text, use the standard HTML elements,
see "Overview of the supported HTML elements" on page 15.

Example: :DISPlay:MESSage 
'For <i>intra-band</i> 2x2x2 scenario, 
tap on the "I/Q Stream Mapping" tap.'

5  Learn More about the R&S SMW
For a comprehensive description of the R&S SMW capabilities and features including
the remote control refer to:
● The R&S SMW embedded help
● The R&S SMW user manual

The latest version is available for download on the product page at:
https://www.rohde-schwarz.com/manual/smw200a/

6  Annex
Example: Source code of a tutorial file (*.tut)
The following is the source code of the tutorial file
02_DigitallyModulatedSignal.tut.

The source code follows the recommended tutorial's structure. It includes comments
(that are the lines starting with the hash sign #).

The source code includes also the SCPI commands (:DISPlay:FOCus 
<ObjectName>) used to highlight parameters. These SCPI commands use internal
identifiers (<ObjectName>) and are not described here. The SCPI commands are pro-
vided for the sake of completeness.
The content has been formatted for better reading.

https://www.rohde-schwarz.com/manual/smw200a/
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<p><b>Goal:</b> 
Generating a simple WCDMA-3GPP (QPSK 45&deg; Offset) signal 
with the help of the "Custom Digital Modulation" functionality.</p>
<p><b>Required options</b>: R&S SMW base unit.</p>
<p><b>Initial situation:</b> 
Configuration performed in tutorial "01_UnmodulatedSignal".</p>
<p>Changed parameters are highlighted in orange.</p>

#!scpi
# recommended: preset the instrument and close all dialogs
*RST
:disp:dial:clos:all

# disp:foc command highlights the BB block
:disp:foc 'Baseband A'
:disp:mess 'In the block diagram, select "Baseband A".'

# Highlight the Baseband A button
:disp:foc ">>>>_Baseband A_BUTTON"
:disp:mess 'Navigate to the section "Misc>Custom Digital Mod..." and select it.'
:disp:foc "clk@>>>>_Baseband A_BUTTON"
# Open the Custom Dig Mod dialog
:disp:dial:open 'BasebandDigitalModMain$q$$A$t0'
:disp:mess 'The "Custom Digital Modulation" dialog opens.'

# Recommended order: 
# 1) Highlight the parameter
# 2) Display a message
# 3) Send the SCPI command
:disp:foc ">>>>IdPDbDmStan_H0_C0_S0_D0_COMBO_MENU"
:disp:mess 'Select "General>Set acc to standard>WCDMA-3GPP".'
:sour1:bb:dm:standard W3GP

# Highlight subsequently two parameters
:disp:foc "IdPDbDmSymbRate_H0_C0_S0_D0"
:disp:foc ">>>>IdPDbDmCoding_H0_C0_S0_D0_COMBO_BOX"
:disp:mess 'The "Symbol Rate" and "Coding" are set accordingly.'

:disp:foc ">>>>_IdPdDbDmState_H0_C0_S0_D0_SWITCH"
:disp:mess 'Select "General>State>On" to enable signal generation.'
:sour1:bb:dm:stat 1

# Removes the highlighting
:disp:foc ""
:disp:mess 'Tap on the "Modulation" tab.'
:disp:dial:open 'BasebandDigitalModMain$q$$A$t5'

:disp:foc ">>>>IdPDbDmModType_H0_C0_S0_D0_COMBO_MENU"
:disp:mess 'Note the used "Modulation Type", 
observe the constellation diagram and close the dialog.'
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:disp:dial:clos 'BasebandDigitalModMain$q$$A$t0'

:disp:foc "I/Q Mod A"
:disp:mess 'The instrument activates automatically "I/Q Mod A", 
uses the internal trigger and clock signals and' 
:disp:foc "Baseband A"
:disp:mess 'generates a WCDMA-3GPP signal, 
modulated  with a QPSK 45 deg Offset modulation.'

Overview of the supported HTML elements

Block elements:
● <p>: a paragraph of text
● <ul>: unordered list; list items are displayed with a bullet

Inline elements, used for styling purposes, e.g. to emphasize a range of text:
● <i>: emphasis displayed in italic type
● <b>: emphasis displayed in bold type

(not recommended for text in the "Info" line)
● <span>: text can be displayed in a different color or on a colored background

Example: 
<P><b>Required options:</b> R&S SMW equipped with: </p>
<ul>
  <li>first option</li>
  <li>second option</li>
</ul>
:DISPlay:MESSage 
'This the beginning of a <i>tutorial</i>'
:DISPlay:MESSage 'Press the <span style="background-color:blue">SETUP</span> key.'
:DISPlay:MESSage 
'<span style="color:red">End of tutorial</span>'
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