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1  Welcome to the IEEE 802.11 WLAN digital
standard
The options R&S SMW-K54/-K86/-K142/-K147 are firmware applications that add func-
tionality to generate signals in accordance with the wireless LAN standards
IEEE 802.11a/b/g/n/ac/p/j/ax/be. Table 1-1 provides an overview.

Table 1-1: Options and IEEE 802.11 standard

Option WLAN standard

R&S SMW-K54 IEEE 802.11a/b/g/n/p/j

R&S SMW-K86 IEEE 802.11ac

R&S SMW-K142 IEEE 802.11ax

R&S SMW-K147 IEEE 802.11be

For a detailed overview on required options and the WLAN technology, see Chapter 2,
"About the IEEE 802.11 WLAN options", on page 13.

This user manual contains a description of the functionality that the application pro-
vides, including remote control operation.

All functions not discussed in this manual are the same as in the base unit and are
described in the R&S SMW user manual. The latest version is available at:

www.rohde-schwarz.com/manual/SMW200A

Installation

You can find detailed installation instructions in the delivery of the option or in the
R&S SMW service manual.

1.1  Key features

The R&S SMW-K54/-K86/-K142/-K147 options support all mandatory and almost all
optional features of related IEEE 802.11 standards. The following list gives an overview
of the main features:
● Support of up to eight Tx antennas
● Support of transmission bandwidths from 20 MHz to 320 MHz, see
● 80 MHz and 160 MHz bandwidth with option R&S SMW-K86/-K142
● Support of all three operation modes: Legacy, Mixed Mode and Green Field
● Support of all legacy transmission modes (L-10 MHz, L-20 MHz, L-Duplicate, L-

Upper, L-Lower)
● Support of all 11n transmission modes (HT-20 MHz, HT-40 MHz, HT-Duplicate, HT-

Upper, HT-Lower)
● Support of all 11ac transmission modes with option R&S SMW-K86:

Key features

https://www.rohde-schwarz.com/manual/smw200a
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VHT-20 MHz, VHT-40 MHz, VHT-80 MHz, VHT-80+80 MHz, VHT-160 MHz
● Support of all 11ax transmission modes with option R&S SMW-K142:

HE-20 MHz, HE-40 MHz, HE-80 MHz, HE-80+80 MHz, HE-160 MHz
● Support of all 11be transmission modes with option R&S SMW-K147:

EHT-20 MHz, EHT-40 MHz, EHT-80 MHz, EHT-80+80 MHz, EHT-160 MHz,
EHT-320 MHz

● Additional support of the CCK and PBCC frames in accordance with
IEEE 820.11a/b/g standard

● Support of Space Time Block Coding (STBC) and Spatial Multiplexing
● Up to 8 spatial streams in all supported channel widths
● Multi-User MIMO available with 2 or more total spatial streams
● Configurable number of spatial streams, space time streams and additional spatial

streams,
● Configurable modulation per spatial stream
● Support of short guard interval
● Configurable state of the scramble, interleaver, time domain windowing and chan-

nel coding
● Configurable PPDU, MAC header and FCS
● Integrated frame block concept for the generation of sequence of cascaded frame

blocks with different configurations and data rates
● Support of simple diversity and MIMO tests (frequency flat MIMO channel simula-

tion) without additional channel simulator
● Simulation of real-time MIMO channel condition for instruments equipped with the

fading options R&S SMW-K74/-B14(x2)
● Support of up to 37 users in 802.11ax trigger frame user info field

1.2  Accessing the IEEE 802.11 WLAN dialog

To open the dialog with IEEE 802.11 WLAN settings

► In the block diagram of the R&S SMW, select "Baseband" > "IEEE 802.11".

A dialog box opens that displays the provided general settings.

The signal generation is not started immediately. To start signal generation with the
default settings, select "State" > "On".

1.3  What's new

This manual describes firmware version FW 5.30.047.xx and later of the
R&S®SMW200A.

What's new
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Compared to the previous version it provides the new features listed below:
● Trigger frame settings:

– Common info field bits and user info field variants, see "Common Info field and
User Info field variants" on page 87.

– Special user info subfield settings and additional reserved bits, see Chap-
ter 3.6.5.3, "Additional info settings", on page 95.

– User info field with deactivated special user info subfield, see "PHY Version ID"
on page 94, "UL Band Extension" on page 94, "Spatial Reuse1/Spatial
Reuse2" on page 94 and "U-SIG Disregard And Validate" on page 95.

– Corresponding remote commands added, see Chapter 6.9.5.5, "Trigger frame
settings", on page 208.

● IEEE 802.11ax preamble puncturing updated, see "About preamble puncturing"
on page 38, "Preamble puncturing in HE MU PPDUs" on page 39 and "Sub-
Chan#" on page 44.

● Time-based triggering, see "Time Based Trigger" on page 114 and "Trigger Time"
on page 114.

● Editorial changes

1.4  Documentation overview

This section provides an overview of the R&S SMW user documentation. Unless speci-
fied otherwise, you find the documents at:

www.rohde-schwarz.com/manual/smw200a

1.4.1  Getting started manual

Introduces the R&S SMW and describes how to set up and start working with the prod-
uct. Includes basic operations, typical measurement examples, and general informa-
tion, e.g. safety instructions, etc. A printed version is delivered with the instrument.

1.4.2  User manuals and help

Separate manuals for the base unit and the software options are provided for down-
load:
● Base unit manual

Contains the description of all instrument modes and functions. It also provides an
introduction to remote control, a complete description of the remote control com-
mands with programming examples, and information on maintenance, instrument
interfaces and error messages. Includes the contents of the getting started manual.

● Software option manual
Contains the description of the specific functions of an option. Basic information on
operating the R&S SMW is not included.

Documentation overview

http://www.rohde-schwarz.com/manual/smw200a
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The contents of the user manuals are available as help in the R&S SMW. The help
offers quick, context-sensitive access to the complete information for the base unit and
the software options.

All user manuals are also available for download or for immediate display on the Inter-
net.

1.4.3  Tutorials

The R&S SMW provides interactive examples and demonstrations on operating the
instrument in form of tutorials. A set of tutorials is available directly on the instrument.

1.4.4  Service manual

Describes the performance test for checking compliance with rated specifications, firm-
ware update, troubleshooting, adjustments, installing options and maintenance.

The service manual is available for registered users on the global Rohde & Schwarz
information system (GLORIS):

https://gloris.rohde-schwarz.com

1.4.5  Instrument security procedures

Deals with security issues when working with the R&S SMW in secure areas. It is avail-
able for download on the internet.

1.4.6  Printed safety instructions

Provides safety information in many languages. The printed document is delivered with
the product.

1.4.7  Data sheets and brochures

The data sheet contains the technical specifications of the R&S SMW. It also lists the
options and their order numbers and optional accessories.

The brochure provides an overview of the instrument and deals with the specific char-
acteristics.

See www.rohde-schwarz.com/brochure-datasheet/smw200a

1.4.8  Release notes and open source acknowledgment (OSA)

The release notes list new features, improvements and known issues of the current
firmware version, and describe the firmware installation.

Documentation overview

https://gloris.rohde-schwarz.com
http://www.rohde-schwarz.com/brochure-datasheet/smw200a
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The software makes use of several valuable open source software packages. An open-
source acknowledgment document provides verbatim license texts of the used open
source software.

See www.rohde-schwarz.com/firmware/smw200a

1.4.9  Application notes, application cards, white papers, etc.

These documents deal with special applications or background information on particu-
lar topics.

See www.rohde-schwarz.com/application/smw200a and www.rohde-schwarz.com/
manual/smw200a

1.4.10  Videos

Find various videos on Rohde & Schwarz products and test and measurement topics
on YouTube: https://www.youtube.com/@RohdeundSchwarz

On the menu bar, search for your product to find related videos.

Figure 1-1: Product search on YouTube

1.5  Scope

Tasks (in manual or remote operation) that are also performed in the base unit in the
same way are not described here.
In particular, it includes:
● Managing settings and data lists, like saving and loading settings, creating and

accessing data lists, or accessing files in a particular directory.
● Information on regular trigger, marker and clock signals and filter settings, if appro-

priate.
● General instrument configuration, such as checking the system configuration, con-

figuring networks and remote operation
● Using the common status registers

For a description of such tasks, see the R&S SMW user manual.

Scope

http://www.rohde-schwarz.com/firmware/smw200a
http://www.rohde-schwarz.com/application/smw200a
http://www.rohde-schwarz.com/manual/smw200a
http://www.rohde-schwarz.com/manual/smw200a
https://www.youtube.com/@RohdeundSchwarz
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1.6  Notes on screenshots

When describing the functions of the product, we use sample screenshots. These
screenshots are meant to illustrate as many as possible of the provided functions and
possible interdependencies between parameters. The shown values may not represent
realistic usage scenarios.

The screenshots usually show a fully equipped product, that is: with all options instal-
led. Thus, some functions shown in the screenshots may not be available in your par-
ticular product configuration.

Notes on screenshots
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2  About the IEEE 802.11 WLAN options

2.1  Required options

The basic equipment layout for generating IEEE 802.11 WLAN signals includes:
● Standard or wideband baseband generator (R&S SMW-B10/-B9)
● Baseband main module (R&S SMW-B13) or wideband baseband main module

(R&S SMW-B13XT)
● Frequency option (e.g. R&S SMW-B1003)
● Option IEEE 802.11a/b/g/n (R&S SMW-K54) per signal path
● Optional, option IEEE 802.11ac (R&S SMW-K86) per signal path
● Optional, option IEEE 802.11ax (R&S SMW-K142) per signal path
● Optional, option IEEE 802.11be (R&S SMW-K147) per signal path

You can generate signals via play-back of waveform files at the signal generator. To
create the waveform file using R&S WinIQSIM2, you do not need a specific option.

To play back the waveform file at the signal generator, you have two options:
● Install the R&S WinIQSIM2 option of the digital standard, e.g. R&S SMW-K255 for

playing LTE waveforms
● If supported, install the real-time option of the digital standard, e.g. R&S SMW-K55

for playing LTE waveforms

For more information, see data sheet.

2.2  About IEEE 802.11 WLAN technology

IEEE 802.11n is the extension of the WLAN IEEE 802.11a/g standard to nominal peak
data rates of 600 Mbps. Like IEEE 802.11a/g, IEEE 802.11n is also based on OFDM.
Also, IEEE 802.11n uses MIMO technology, up to 40 MHz bandwidth and special cod-
ing for increased throughput. The extension towards higher data rates is also known as
high throughput mode (HT mode) of 802.11n. The non-HT mode can be seen as the
part of 802.11n, which is backwards compatible to EEE 802.11a/g.

IEEE 802.11p is another extension to the WLAN IEEE 802.11a/g standard for the
usage of wireless access in vehicular environment, e.g. Car-to-Car (C2C), Vehicle-to-
Vehicle (V2V), intelligent transport systems (ITS).

IEEE 802.11ac further extends 802.11n to nominal peak data rates of 6240.0 Mbps.
Like IEEE 802.11a/g/n, IEEE 802.11ac is also based on OFDM. Also, IEEE 802.11ac
uses MIMO technology, up to 160 MHz bandwidth and special coding for increased
throughput. The extension towards higher data rates is also known as very high
throughput (VHT) mode of 802.11ac.

About IEEE 802.11 WLAN technology
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IEEE 802.11ax is aimed to improve the user experience and network performance in
dense deployments in the 2.4 GHz and 5 GHz band. It supports uplink and downlink
multi user MIMO and up to 160 MHz bandwidth. It is based on OFDM and OFDMA
modulation.

IEEE 802.11be further extends IEEE 802.11ax offering frequency bands at 2.4 GHz,
5 GHz and 6 GHz. It supports uplink and downlink multi-user MIMO and up to 320 MHz
bandwidth. It is also based on OFDM and OFDMA modulation.

A short comparison between the IEEE 802.11 standards is provided in Table 2-1 and
Table 2-2. Also, further reading links provide more detailed information about technol-
ogy and application of the IEEE 802.11 standards.

Table 2-1: Overview 802.11n, 802.11ac, 802.11ax and 802.11be*

Parameters 802.11n 802.11ac 802.11ax 802.11be

Frequency bands 2.4 GHz, 5 GHz 2.4 GHz, 5 GHz 2.4 GHz, 5 GHz 2.4 GHz, 5 GHz,
6 GHz

Channel bandwidth
(MHz)

20, 40 20, 40, 80, 80+80,
160

20, 40, 80, 80+80,
160

20, 40, 80, 80+80,
160, 320

Subcarrier spacing
(kHz)

312.5 312.5 78.125 78.125

Symbol time (us) 3.2 3.2 12.8 12.8

Cyclic prefix (us) 0.8 0.8, 0.4 0.8, 1.6, 3.2 0.8, 1.6, 3.2

Transmission tech-
nology

SISO, SU-MIMO SISO, SU-MIMO,
MU-MIMO

SISO, SU-MIMO,
MU-MIMO

SISO, SU-MIMO,
MU-MIMO

MU-MIMO  Downlink Uplink and down-
link

Uplink and down-
link

Modulation OFDM OFDM OFDM, OFDMA OFDM, OFDMA

Data subcarrier
modulation

BPSK, QPSK,
16QAM, 64QAM

BPSK, QPSK,
16QAM, 64QAM,
256QAM

BPSK, QPSK,
16QAM, 64QAM,
256QAM,
1024QAM

BPSK, QPSK,
16QAM, 64QAM,
256QAM,
1024QAM,
4096QAM

Coding BCC (mandatory)

LDPC (optional)

BCC (mandatory)

LDPC (optional)

BCC (mandatory)

LDPC (mandatory)

BCC (mandatory)

LDPC (mandatory)

Max. data rate
(Mbit/s)

600 6933.3 9607.8 46120

Further reading 1MA179 1MA192, 1GP94 1MA222, 1GP115 -

Table 2-2: Overview 802.11a, 802.11b, 802.11g, 802.11j and 802.11p

Parameters 802.11a 802.11b 802.11g 802.11j 802.11p

Frequency bands 5 GHz 2.4 GHz 2.4 GHz,
5 GHz

4.9 GHz to
5.0 GHz

5.85 GHz to
5.925 GHz

Channel bandwidth
(MHz)

20 20 20 10, 20 10, 20

About IEEE 802.11 WLAN technology
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Parameters 802.11a 802.11b 802.11g 802.11j 802.11p

Subcarrier spacing
(kHz)

312.5 312.5 312.5 312.5 312.5

Symbol time (us) 3.2 3.2 3.2 3.2 3.2

Cyclic prefix (us) 0.8 0.8 0.8 0.8 0.8

Transmission tech-
nology

SISO SISO SISO SISO SISO

Modulation OFDM DSSS DSSS, OFDM OFDM OFDM,
OFDMA

Data subcarrier
modulation

BPSK, QPSK,
16QAM,
64QAM

CCK, PBCC CCK, PBCC,
BPSK, QPSK,
16QAM,
64QAM

BPSK, QPSK,
16QAM,
64QAM

BPSK, QPSK,
16QAM,
64QAM

Coding BCC (manda-
tory)

LDPC
(optional)

BCC (manda-
tory)

LDPC
(optional)

BCC (manda-
tory)

LDPC (manda-
tory)

BCC (manda-
tory)

LDPC (manda-
tory)

BCC (manda-
tory)

LDPC (manda-
tory)

Max. data rate
(Mbit/s)

54 11 54   

Further reading 1MA69,
1GP56

1MA69,
1GP56

1MA69,
1GP56

1MA69,
1GP56

1MA152

For details, see the specifications of the IEEE Std 802.11™ WLAN standards.

2.3  Operation modes

The IEEE 802.11n standard defined the following three operation modes:
● Legacy mode

This mode is provided for backwards compatibility with the IEEE 802. a/g standard.
The mode is also known as Non-HT mode.

● Mixed Mode
A legacy preamble and header (L-STF, L-LTF and L-SIG) are wrapping the HT part
of the frame. The frame complies with OFDM-PHY and ERP-OFDM-PHY modes of
standards IEEE 802.11a/g.

● Green Field
In this mode, frames are being transmitted in a new high throughput format that
does not comply with the legacy mode. Green Field is an optional mode.

Figure 2-1 shows the packet formats of the different operation modes that can be trig-
gered by a device supporting the IEEE 802.11n standard.

Operation modes
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3

2

1

Figure 2-1: PLCP packet format for IEEE 802.11n

1 = Operation mode "Legacy"
2 = Operation mode "Mixed Mode"
3 = Operation mode "Green Field"

The Table 2-3 gives an overview of the frequency domain operation modes of the
physical layer. Note that the duplicate mode corresponds to repeating the same com-
plex numbers modulating the subcarriers of the upper channel on the lower channel.
Table 2-3: Frequency domain PHY operation

LM Legacy mode as in IEEE 802.11a/g

Also, the CCK and the PBCC frames as in IEEE 802.11b/g

HT-Mode Frequency: 20 MHz and 40 MHz, 1 to 4 spatial streams (HT Duplicate Mode
included)

Duplicate Non-HT mode IEEE 802.11a OFDM-PHY format, 20 MHz and 40 MHz dual operation, upper
channel rotated by 90˚ relative to lower channel

Upper mode Non-HT/HT frame in the upper 20 MHz channel

Lower mode Non-HT/HT frame in the lower 20 MHz channel

VHT-Mode Requires R&S SMW-K86.

Frequency 20 MHz, 40 MHz, 80 MHz, 160 MHz, 1...8 spatial streams

HE mode Requires R&S SMW-K142.

Frequency 20 MHz, 40 MHz, 80 MHz, 160 MHz, 1...8 spatial streams

EHT mode Requires R&S SMW-K147.

Frequency 320 MHz, 1 to 16 spatial streams

When operating in the OFDM 20 MHz mode, there are 64 subcarriers available; the
migration to 40 MHz mode offers 128 subcarriers with the same frequency spacing of
312.5 KHz. 80 MHz bandwidth is using 256 subcarriers, keeping the original frequency
spacing. With 160 MHz bandwidth, 512 subcarriers apply.

For IEEE 802.11ax in the OFDMA frequency allocation, the resource units (RU) can
contain 26, 52, 106, 242, 484 or 996 tones (aka subcarriers) and are in fixed locations.
The tones/subcarriers in the resource units are adjacent and contiguous except in the
middle of the channel where DC null carriers are present.

Operation modes
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2.4  Signal generation

The generation of an IEEE 802.11n/ac/ax signal is done in multiple steps. In high
throughput (HT) and very high throughput (VHT) modes, the data of a single user is
specially coded and transmitted via up to eight Tx antennas.

In this implementation, the mapping of the Tx antennas' signals to the output paths of
the instrument can be configured. This function can be used for the simulation of fre-
quency flat MIMO channel, i.e. one carrier analysis like BER tests for instance. Another
application of the configurable mapping is the possibility to generate a combined signal
from different antennas if there is one path instrument or limited number of baseband
paths.

Refer to Figure 2-2 for an overview of the signal flow for generation of such a signal in
HT mode.

Figure 2-2: IEEE 802.11 n/ac/ax transmission chain

Signal generation
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3  WLAN configuration and settings
Access:

► Select "Baseband > IEEE 802.11".

The remote commands required to define these settings are described in Chapter 6,
"Remote-control commands", on page 124.

● General settings......................................................................................................18
● Transmit antenna setup.......................................................................................... 22
● Frame block configuration.......................................................................................24
● PPDU configuration.................................................................................................31
● A-MPDU settings.....................................................................................................63
● MAC header and FCS configuration for frame block.............................................. 64
● Spatial mapping...................................................................................................... 96

3.1  General settings

Access:

► Select "Baseband > IEEE 802.11".

This dialog provides settings to configure default settings, "Save/Recall" settings
and settings to configure the transmission bandwidth.
Also, it displays the sample rate and provides access to settings to configure trans-
mit antennas, baseband filters and clipping.

Settings

State..............................................................................................................................19
Set to Default................................................................................................................ 19
Save/Recall................................................................................................................... 20
Generate Waveform File............................................................................................... 21
Transmission Bandwidth............................................................................................... 21

General settings
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Sample Rate................................................................................................................. 21
Transmit Antennas Setup..............................................................................................21
Filter/Clipping Settings.................................................................................................. 21

State
Activates the standard and deactivates all the other digital standards and digital modu-
lation modes in the same path.
Remote command: 
[:SOURce<hw>]:BB:WLNN:STATe on page 130

Set to Default
Calls the default settings. The values of the main parameters are listed in the following
table.

Parameter Value

General parameters  

"State" Not affected by "Set to Default"

"Transmission Bandwidth" 20 MHz

"Configure Baseband B from Baseband A" Off

"Tx Antennas" 1

"Filter" Cosine

"Clipping" Off

Frame blocks configuration  

"Frame Blocks" 1

"Frame Block Type" DATA

"Frame Blocks State" On

"Physical Mode" Mixed mode

"Tx Mode" HT-20 MHz

"Frames" 1

"Idle Time" 0.1 ms

"Data Source" PN9

TX antenna setup  

"Antennas" 1

"Mapping Coordinates" Cartesian

"Output" First set "Baseband", rest is set to Off

"Matrix Elements" ("Real", "Imaginary", "Magnitude",
"Phase")

All zero but diagonal = 1

PPDU configuration  

"Spatial Streams" 1

General settings
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Parameter Value

"Space Time Streams" 1

"Extended Spatial Streams" 0

"Space Time Block Coding" inactive

Parameter value  

"MCS" 1

"Data Rate (Mbps)" 13

"Data Bits Per Symbol" 52

"Stream 1" QPSK

"Channel Coding" BCC

"Coding Rate" ½

"Guard" Long

"Data Length" 1024 bytes

"Number of Data Symbols" 158

"Scrambler" "ON (user init)"

"Scrambler Init" 01

"Interleaver Active" ON

"Service Field" 0000

"Time Domain Windowing Active" On

"Transition Time" 100 ns

"Preamble/Header Active" ON

"Smoothing" ON

Spatial mapping  

"Mode" Spatial expansion

"Index k" 20

Remote command: 
[:SOURce<hw>]:BB:WLNN:PRESet on page 128

Save/Recall
Accesses the "Save/Recall" dialog, that is the standard instrument function for saving
and recalling the complete dialog-related settings in a file. The provided navigation
possibilities in the dialog are self-explanatory.
The settings are saved in a file with predefined extension. You can define the filename
and the directory, in that you want to save the file.
See also, chapter "File and Data Management" in the R&S SMW user manual.

General settings
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Remote command: 
[:SOURce<hw>]:BB:WLNN:SETTing:CATalog? on page 128
[:SOURce<hw>]:BB:WLNN:SETTing:LOAD on page 129
[:SOURce<hw>]:BB:WLNN:SETTing:STORe on page 129
[:SOURce<hw>]:BB:WLNN:SETTing:DELete on page 129

Generate Waveform File
With enabled signal generation, triggers the instrument to save the current settings of
an arbitrary waveform signal in a waveform file with predefined extension *.wv. You
can define the filename and the directory, in that you want to save the file.
Using the ARB modulation source, you can play back waveform files and/or process
the file to generate multi-carrier or multi-segment signals.
Remote command: 
[:SOURce<hw>]:BB:WLNN:WAVeform:CREate on page 130

Transmission Bandwidth
Selects the transmission bandwidth.
You can set the transmission bandwidth independent from the configuration of frame
blocks. If invalid settings in frame blocks occur, a warning message is displayed.

Click "Ok" to resolve invalid settings, corresponding parameters are set automatically
to their default values.
Remote command: 
[:SOURce<hw>]:BB:WLNN:BWidth on page 128

Sample Rate
Displays the sample rate of the signal specific for the selected bandwidth.
Remote command: 
[:SOURce<hw>]:BB:WLNN:SRATe? on page 136

Transmit Antennas Setup
Accesses the dialog for configuring the TX antennas, see Chapter 3.2, "Transmit
antenna setup", on page 22.
Remote command: 
n.a.

Filter/Clipping Settings
Accesses the dialog for setting baseband filtering and clipping, see Chapter 5.1, "Filter/
clipping settings", on page 107.

General settings
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3.2  Transmit antenna setup

Access:

► Select "Baseband > IEEE 802.11 > General > Transmit Antennas Setup".

This dialog is used to map the generated Tx chains to different destinations ("Base-
band A/B", "File" or "OFF") and makes it possible to combine different Tx antenna
signals.

Settings

Antennas....................................................................................................................... 22
Mapping Coordinates.................................................................................................... 22
Transmission Antenna Table.........................................................................................23

└ Output............................................................................................................. 23
└ Real/Magnitude...............................................................................................23
└ Imaginary/Phase.............................................................................................23

Antennas
Selects the number of transmit antennas to be used.
Remote command: 
[:SOURce<hw>]:BB:WLNN:ANTenna:MODE on page 150

Mapping Coordinates
Selects the coordinate system of the transmission chain matrix.
"Cartesian" Sets the Cartesian coordinates system ("Real", "Imaginary").
"Cylindrical" Sets the cylindrical coordinates system ("Magnitude", "Phase").
Remote command: 
[:SOURce<hw>]:BB:WLNN:ANTenna:SYSTem on page 150

Transmit antenna setup
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Transmission Antenna Table
Configures the output matrix and transmission chain matrix coefficients.
During signal calculation, the R&S SMW evaluates the transmission chain matrix and
takes into account the set phase ratios. However, the power ratio of the antennas is not
considered.
To generate a WLAN signal of antennas with different power level, set the power level
of the corresponding path to the desired level in the header display of the instrument.

Output ← Transmission Antenna Table
Selects the destination of the calculated IQ chains.
"OFF" No mapping takes place.
"Baseband A/B"

The IQ chain is output to the selected baseband. Exactly one output
stream can be mapped to a baseband.

"File" The IQ chain is saved in a file.
Remote command: 
[:SOURce<hw>]:BB:WLNN:ANTenna:TCHain<ch>:OUTPut:DESTination
on page 151
[:SOURce<hw>]:BB:WLNN:ANTenna:TCHain<ch>:OUTPut:FSELect
on page 151

Real/Magnitude ← Transmission Antenna Table
Enters the value of the real or the magnitude coordinates.
Remote command: 
For "Cartesian" mapping coordinates:
[:SOURce<hw>]:BB:WLNN:ANTenna:TCHain<ch>:TX<dir>:REAL on page 151
For "Cylindrical" mapping coordinates:
[:SOURce<hw>]:BB:WLNN:ANTenna:TCHain<ch>:TX<dir>:MAGNitude
on page 152

Imaginary/Phase ← Transmission Antenna Table
Enters the value of the imaginary or the phase coordinates.
Remote command: 
For Cartesian mapping coordinates:
[:SOURce<hw>]:BB:WLNN:ANTenna:TCHain<ch>:TX<dir>:IMAGinary
on page 152
For "Cylindrical" mapping coordinates:
[:SOURce<hw>]:BB:WLNN:ANTenna:TCHain<ch>:TX<dir>:PHASe on page 152

Transmit antenna setup
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3.3  Frame block configuration

Access:

► Select "Baseband > IEEE 802.11 > Frame Blocks".

This tab provides settings to select and configure a frame block.

Settings:

Std.................................................................................................................................24
Type.............................................................................................................................. 25
Physical Mode...............................................................................................................26
Tx Mode........................................................................................................................ 26
Frames.......................................................................................................................... 29
Idle Time /ms.................................................................................................................29
Data...............................................................................................................................29
Boost /dB.......................................................................................................................29
PPDU............................................................................................................................ 30
Data Rate /Mbps........................................................................................................... 30
State..............................................................................................................................30
Append..........................................................................................................................30
Insert............................................................................................................................. 30
Delete............................................................................................................................30
Copy..............................................................................................................................30
Paste............................................................................................................................. 30

Std.
Selects the IEEE 802.11 WLAN standard.
After selecting the standard, only settings that are relevant for the standard are availa-
ble. Affected parameters are "Type", "Physical Mode" and "Tx Mode", see Table 3-1.

Frame block configuration
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Table 3-1: Availability "Standard", "Type", "Physical Mode", "TxMode"

Standard Type Physical mode Txmode

User all all all

11a/g Data/Beacon/Trigger Legacy L-20MHz

L-Duplicate

L-Upper

L-Lower

11b/g Data/Beacon/Trigger Legacy CCK

PBCC

11p/j Data/Beacon/Trigger Legacy L-10MHz

11n all Mixed Mode/Green Field HT-20MHz

HT-40MHz

HT-Duplicate

HT-Upper

HT-Lower

11ac all Mixed Mode VHT-20MHz

VHT-40MHz

VHT-80MHz

VHT-80+80MHz

VHT-160MHz

11ax Data/Trigger Mixed Mode HE-20MHz

HE-40MHz

HE-80MHz

HE-80+80MHz

HE-160MHz

11be Data/Trigger Mixed Mode EHT-20MHz

EHT-40MHz

EHT-80MHz

EHT-160MHz

EHT-320MHz

Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:STANdard on page 158

Type
Selects the PPDU type.
"Data" Only "Data Long Training" fields are used to probe the channel.
"Sounding" Staggered preambles are used to probe additional dimension of the

MIMO channel.
"Type > Sounding" is not available for "Physical Mode > Legacy".

Frame block configuration
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"Beacon" A frame of type "Beacon" contains all the information about a net-
work, for example the beacon interval, capability information and the
IBSS parameter set. The access point (AP) of a service set periodi-
cally transmits the beacon frame to establish and maintain the net-
work.

"Trigger" A downlink trigger frame is generated to synchronize the transmission
of a DUT's trigger-based uplink frame.

Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:TYPE on page 159

Physical Mode
Selects the preamble design.
For "Physical Mode > Legacy", only "Type > Data" is available.
For 80 MHz transmission bandwidth and "Type > Data", you can only operate in "Phys-
ical Mode > Mixed Mode".
Note: "Physical Mode > Mixed Mode" transmissions can be detected by a physical
layer transceiver of 802.11a/g OFDM, MAC FCS would however fail.
"Legacy" Compatible with 802.11a/g OFDM devices. Also, CCK/PBCC frames

as defined in IEEE 802.11b/g are supported.
This mode applies to "Cylindrical" mapping coordinates.

"Mixed Mode" For High Throughput (HT), Very High Throughput(VHT) , High Effi-
ciency (HE), Extremely High Throughput (EHT) and 802.11a/g OFDM
devices.

"Green Field" For HT networks only.
Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:PMODe on page 157

Tx Mode
Sets the Tx mode.
The available Tx modes depend on the physical mode, see the tables below.
Table 3-2: Tx modes for "Type > Data/Trigger", and "Physical Mode > Legacy"

Tx mode Transmission bandwidth

20 MHz 40 MHz 80 MHz 160 MHz 320 MHz

L-10MHz x x x x -

L-20MHz x x x x -

L-Duplicate - x x x -

L-Upper - x x x -

L-Lower - x x x -

CCK x x x x -

PBCC x x x x -

Frame block configuration
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Table 3-3: Tx modes for "Type > Data/Trigger" and "Physical Mode > Mixed Mode"

Tx mode Transmission bandwidth

20 MHz 40 MHz 80 MHz 160 MHz 320 MHz

HT-20MHz x x x x -

HT-40MHz - x x x -

HT-Duplicate - x x x -

HT-Upper - x x x -

HT-Lower - x x x -

VHT-20MHz x x x x -

VHT-40MHz - x x x -

VHT-80MHz - - x x -

VHT-80+80MHz - - x x -

VHT-160MHz - - - x -

HE-20MHz x x x x -

HE-40MHz - x x x -

HE-80MHz - - x x -

HE-80+80MHz - - x x -

HE-160MHz - - - x -

EHT-20MHz x x x x -

EHT-40MHz - x x x -

EHT-80MHz - - x x -

EHT-160MHz - - - x -

EHT-320MHz - - - - x

Table 3-4: Tx modes for "Type > Data", and "Physical Mode > Green Field"

Tx mode Transmission bandwidth

20 MHz 40 MHz 80 MHz 160 MHz 320 MHz

HT-20MHz x x x x -

HT-40MHz - x x x -

HT-Duplicate - x x x -

HT-Upper - x x x -

HT-Lower - x x x -

Frame block configuration
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Table 3-5: Tx modes for "Type > Sounding" and "Physical Mode > Mixed Mode"

Tx mode Transmission bandwidth

20 MHz 40 MHz 80 MHz 160 MHz 320 MHz

HT-20MHz x x x x -

HT-40MHz - x x x -

HT-Duplicate - x x x -

HT-Upper - x x x -

HT-Lower - x x x -

VHT-20MHz x x x x -

VHT-40MHz - x x x -

VHT-80MHz - - x x -

VHT-80+80MHz - - x x -

VHT-160MHz - - - x -

Table 3-6: Tx modes for "Type > Sounding" and "Physical Mode > Green Field"

Tx mode Transmission bandwidth

20 MHz 40 MHz 80 MHz 160 MHz 320 MHz

HT-20MHz x x x x -

HT-40MHz - x x x -

HT-Duplicate - x x x -

HT-Upper - x x x -

HT-Lower - x x x -

Table 3-7: Tx modes for "Type > Beacon", and "Physical Mode > Legacy"

Tx mode Transmission bandwidth

20 MHz 40 MHz 80 MHz 160 MHz 320 MHz

L-10MHz x x x x -

L-20MHz x x x x -

L-Duplicate - x x x -

L-Upper - x x x -

L-Lower - x x x -

CCK x x x x -

PBCC x x x x -

Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:TMODe on page 158

Frame block configuration



WLAN configuration and settingsR&S®SMW-K54/-K86/-K142/-K147

29User Manual 1175.6749.02 ─ 28

Frames
Sets the number of frames to be transmitted in the current frame block.
Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:FCOunt on page 155

Idle Time /ms
Sets the time interval separating two frames in this frame block.
Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:ITIMe on page 157

Data
Selects the data source.
For "Std. > 11ax/11be", only the "A-MPDU" data source is available.
The following standard data sources are available:
● "All 0, All 1"

An internally generated sequence containing 0 data or 1 data.
● "PNxx"

An internally generated pseudo-random noise sequence.
● "Pattern"

An internally generated sequence according to a bit pattern.
Use the "Pattern" box to define the bit pattern.

● "Data List/Select DList"
A binary data from a data list, internally or externally generated.
Select "Select DList" to access the standard "Select List" dialog.
– Select the "Select Data List > navigate to the list file *.dm_iqd > Select" to

select an existing data list.
– Use the "New" and "Edit" functions to create internally new data list or to edit

an existing one.
– Use the standard "File Manager" function to transfer external data lists to the

instrument.
See also:
● Section "Modulation Data" in the R&S SMW user manual.
● Section "File and Data Management" in the R&S SMW user manual.
● Section "Data List Editor" in the R&S SMW user manual
Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:DATA on page 155
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:DATA:PATTern on page 156
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:DATA:DSELection on page 156

Boost /dB
Assigns a specific RMS power boost/attenuation to the corresponding frame block
modulation.
The power level of a frame block modulation is calculated as sum of the power boost
and the power level set in the header of the instrument.
Note: For optimal gated power mode functionality, make sure that at least one frame
block has a set power boost of 0 dB.

Frame block configuration
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Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:BOOSt on page 155

PPDU
When clicking "Conf ...", accesses the settings for configuring the PPDU of frame
blocks. See Chapter 3.4, "PPDU configuration", on page 31.
Remote command: 
n.a.

Data Rate /Mbps
Indicates the PPDU data rate.
Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:DATA:RATE? on page 157
[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:DATA:RATE? on page 164

State
Enables the corresponding frame block for transmission.
Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:STATe on page 158

Append
Adds a default frame block behind the selected frame block.
Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock:APPend on page 153

Insert
Adds a default frame block before the selected frame block.
Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:INSert on page 154

Delete
Deletes the selected frame block.
Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:DELete on page 154

Copy
Copies the selected frame block.
Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:COPY on page 153

Paste
Pastes the copied frame block behind the selected frame block.
Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:PASTe on page 154

Frame block configuration
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3.4  PPDU configuration

This chapter describes the physical protocol data unit (PPDU) settings.

Access:

► Select "Frame Blocks > PPDU > Conf...".

The dialog provides settings to configure PPDU parameters.

Available settings depend on the WLAN 802.11 standard, frame type, physical mode
and Tx mode. Detailed information is provided in the description of the parameter.

Settings

● General settings......................................................................................................31
● HE settings..............................................................................................................37
● EHT settings............................................................................................................45
● User configuration settings......................................................................................52
● Data settings........................................................................................................... 57

3.4.1  General settings

Access:

1. Select "Frame Blocks > PPDU > Conf...".

2. Select "General".

This dialog provides settings to configure stream settings, modulation settings and
coding scheme settings and the PSDU bit rate.

Available settings depend on the WLAN 802.11 standard, frame type, physical mode
and Tx mode. Detailed information is provided in the description of the parameter.

Settings

● Stream settings....................................................................................................... 31
● User settings........................................................................................................... 33
● MCS configuration settings..................................................................................... 34
● CCK/PBCC settings................................................................................................ 36

3.4.1.1  Stream settings

Access:

1. Select "Frame Blocks > PPDU > Conf...".

2. Select the side-tab "General > Stream Settings".

PPDU configuration
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This dialog provides settings to configure spatial streams.

Settings

Spatial Streams.............................................................................................................32
Space Time Streams.....................................................................................................32
Extended Spatial Streams.............................................................................................32
Multi User MIMO........................................................................................................... 32
Segment........................................................................................................................33
Space Time Block Coding.............................................................................................33

Spatial Streams
Displays or sets the number of spatial streams.
Setting the parameter requires, that the number of transmit antennas is higher than
one, see Chapter 3.2, "Transmit antenna setup", on page 22. The maximum number of
configurable spatial streams equals the number of transmit antennas.
For "Physical Mode > Legacy" and/or for "Tx Mode > HT-Duplicate", there is only one
spatial stream.
Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:SSTReam on page 174

Space Time Streams
Sets the number of space time streams.
This value depends on the setting in the "Spatial Streams" field. Changing the number
of the spatial streams immediately changes the value of the "Space Time Streams" to
the same value.
Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:STSTream on page 175

Extended Spatial Streams
Sets the value of the extended spatial streams.
This field is active for "Type > Sounding" only to probe additional dimensions of the
channel.
Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:ESSTream on page 165

Multi User MIMO
Requires "Std. > 11ac", see "Std." on page 24.
Activates multi user MIMO. Activation requires to "Spatial Streams > 1".
Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:MUMimo:STATe on page 167

PPDU configuration
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Segment
Requires a two segment channel, e.g. "Tx Mode > HE-80+80MHz".

Example: To set segments for fixed transmission bandwidth
For "Transmission Bandwidth > 80 MHz" and "Tx Mode > VHT-80+80MHz", you can
select one of the two segments. But you cannot select both segments.
To select both segments increase the transmission bandwidth to 160 MHz.

Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:SEGMent on page 173

Space Time Block Coding
Displays the status of the space time block coding.
Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:STBC:STATe? on page 174

3.4.1.2  User settings

Access:

1. Select "Std. > 11ac".

2. Select the "Frame Blocks > PPDU > Conf...".

3. Select the side tab "General > Stream Settings".

4. Select "Spatial Streams ≠ 1".

5. Select "Multi User MIMO > On".

6. Select the side tab "User Settings".

This tab provides user settings for WLAN standard IEEE 802.11ac. The settings
comprise parameters to select and configure signal generation of multiple users.

Settings:

User Index.....................................................................................................................34
Multi User MIMO Settings Table....................................................................................34

PPDU configuration
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User Index
Defines the currently generated user. For "Multi User MIMO > Active", only one user
can be generated at a time. This parameter selects the generated one out of four avail-
able users.
Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:UINDex on page 176

Multi User MIMO Settings Table
Sets the user-defined parameters for all available users.
● User index

A maximum of four users are supported
● N_STS

Number of space time streams for each user
● Group ID

Group ID for each user
Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:MU<st0>:NSTS on page 168
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:MU<st0>:GID on page 168

3.4.1.3  MCS configuration settings

Access:

1. Select "Frame Blocks > PPDU > Conf...".

2. Select "General > MCS Configuration".

Settings:

MCS.............................................................................................................................. 34
Data Rate /Mbps........................................................................................................... 35
Data Bits Per Symbol.................................................................................................... 35
Stream n........................................................................................................................35
Channel Coding............................................................................................................ 35
Encoders....................................................................................................................... 35
Cod Rate....................................................................................................................... 36
Guard............................................................................................................................ 36
DCM.............................................................................................................................. 36

MCS
Selects the modulation and coding scheme for all spatial streams.

PPDU configuration
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Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:MCS on page 166
[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:MCS on page 166

Data Rate /Mbps
Indicates the PPDU data rate.
Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:DATA:RATE? on page 157
[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:DATA:RATE? on page 164

Data Bits Per Symbol
Displays the number of data bits sent by an OFDM symbol on all spatial streams.
Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:DATA:BPSymbol? on page 162
[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:DATA:BPSymbol?
on page 162

Stream n
Selects the modulation used for the selected spatial stream.
"4096QAM" Requires "MCS 12/13".
Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:MODulation<st> on page 167
[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:MODulation<st>
on page 167

Channel Coding
Selects the channel coding.
"Off" No channel coding is used.
"BCC" Binary convolution code
"LDPC" Requires "Tx Mode > HT.../VHT...".

Low density parity check is an optional coding for the IEEE 802.11ac
and IEEE 802.11n standards.

Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:CODing:TYPE on page 162
[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:CODing:TYPE
on page 162

Encoders
Displays the number of encoders to be used. This value depends on the data rate. For
data rates smaller or equal 300 Mbit/s, this value is 1. Otherwise, the number of encod-
ers is 2.
Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:CODing:ENCoder? on page 161
[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:CODing:ENCoder?
on page 161
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Cod Rate
Selects the coding rate.
Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:CODing:RATE on page 161
[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:CODing:RATE
on page 161

Guard
Selects which guard interval is used for the OFDM guard.
For "Physical Mode > Green Field/Legacy", the field is read-only, since the modes
have long guard intervals only.
Guard intervals 0.8 µs, 1.6 µs and 3.2 µs require "Std. > 11ax/11be/User".
Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:GUARd on page 166

DCM
Requires "MCS > 0/1/3/4".
Indicates the use of dual carrier modulation (DCM) for a HE data field.
Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:USER<di>:DCM on page 162

3.4.1.4  CCK/PBCC settings

Access:

1. Select "Frame Blocks > Physical Mode > Legacy".

2. Select "Tx Mode > CCK/PBCC".

3. Select "PPDU > Conf...".

In this dialog, the "PSDU Bit Rate" can be set.

Settings

PSDU Bit Rate.............................................................................................................. 36
PSDU Modulation..........................................................................................................37
Barker Spreading.......................................................................................................... 37

PSDU Bit Rate
Requires "Tx Mode > CCK/PBCC".
Selects the bit rate of the PSDU.
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The data rates available are 1 Mbps, 2 Mbps, 5.5 Mbps, 11 Mbps and 22 Mbps. The
1 Mbps data rate is only available if the long PLCP format has been selected. The
selection of the data rate also determines the possible modulation modes.
The following table shows the correlation between data rate and modulation.

Data rate Possible modulation mode

1 Mbps Barker sequence (DBPSK)

The information data sequence is spread with an 11-chip Barker sequence, the chip
rate is 11 Mcps.

2 Mbps Barker sequence (DQPSK)

The information data sequence is spread with an 11-chip Barker sequence, the chip
rate is 11 Mcps.

5.5 Mbps CCK (DQPSK) or PBCC (BPSK)

11 Mbps CCK (DQPSK) or PBCC (QPSK)

22 Mbps PBCC (8PSK)

Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:PSDU:BRATe on page 170

PSDU Modulation
Requires "Tx Mode" > "CCK/PBCC".
Indicates the modulation type. The modulation type is determined by the selected
PSDU "Bit Rate".
Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:PSDU:MODulation? on page 171

Barker Spreading
Requires "Tx Mode > CCK/PBCC" and "PSDU Bit Rate > 1 Mbps/2 Mbps".
Activates barker spreading.
Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:PSDU:BSPReading:STATe on page 171

3.4.2  HE settings

This chapter describes settings of high efficiency (HE) frames that are available for
WLAN standard IEEE 802.11ax.

Access:

1. Select "IEEE 802.11..." > "Frame Blocks".

2. Select "Std" > "11ax" or "Std" > "User".

3. Select "Tx Mode" > "HE-x".
"x" represents the bandwidth and type of HE frame, e.g. "x" = "80+80MHz".
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4. Select "PPDU" > "Conf...".

The dialog provides settings to configure high efficiency (HE) frames that are avail-
able for WLAN standard IEEE 802.11ax.

For settings that are shared by more IEEE 802.11 standards, see Chapter 3.4, "PPDU
configuration", on page 31.

Settings:

● HE general settings.................................................................................................38
● Additional HE-SIG-A settings..................................................................................42
● Logging................................................................................................................... 45

3.4.2.1  HE general settings

Access:

1. Select "PPDU" > "Conf..." > "General".

2. Select the side tab "HE General".

This tab provides general settings to configure HE frames.

About preamble puncturing

You can puncture preambles of HE frames with channel bandwidths 80 MHz,
80+80 MHz and 160 MHz. Puncturing the preambles implies puncturing subchannels
within the HE frames. The baseband signal does not include punctured subchannels.

In the HE-SIG-A field of an HE MU PPDU, the bits of the Bandwidth field specify punc-
tured subchannels. Theses subchannels have a length of 20 MHz and are part of pri-
mary and secondary channels with a length of 20 MHz to 80 MHz.

The table Table 3-8 provides default settings of the bandwidth field bits (BW), affected
HE frames, punctured subchannels (SubCh# > On) and unpunctured subchannels
(SubCh# > Off). Also, you can enable or disable puncturing for individual subchannels
or pairs of subchannels. For details, see the specification IEEE Std 802.11ax™-2021.
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Table 3-8: Preamble puncturing subchannels SubCh# (default settings)

BW HE frame SubCh0 SubCh1 SubCh2 SubCh3 SubCh4 SubCh5 SubCh6 SubCh7

4 80 MHz Off On Off Off - - - -

5 80 MHz Off Off On Off - - - -

6 80+80 MHz

160 MHz

Off On Off Off Off Off Off Off

7 80+80 MHz

160 MHz

Off Off On Off Off Off Off Off

Preamble puncturing in HE MU PPDUs

This step-by-step instruction provides an example how to puncture preambles in HE
MU PPDUs. Use preamble puncturing, when you want to simulate channel allocation in
highly deployed access point or station scenarios.

1. To specify the channel bandwidth of your HE frame, select, for example, "Tx Mode"
> "HE-160MHz".

2. Activate preamble puncturing:

a) Select "PPDU" > "Conf..." > "General".
b) Select "HE General" > "Preamble Puncturing" > "On".

3. Specify punctured subchannels:

a) Select, for example, "Additional HE-SIG-A" > "Preamble Puncturing Bandwidth"
> "7".

b) Check the default settings for punctured and unpuctured 20 MHz subchannels
in Figure 3-1.

1 2 3

Figure 3-1: Bandwidth bit 7: Punctured and unpuctured 20 MHz

1 = Unpunctured subchannels (read-only)
2 = Punctured subchannels
3 = Unpunctured subchannels (configurable)

The third subchannel "SubCh2" is punctured. All other subchannels are
unpunctured.
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c) Optionally, puncture additional subchannels, for example, the fifth subchannel
"SubCh4" and the sixth subchannel "SubCh5".

You can change puncturing but there are specified combinations of punctured sub-
channels that are part of primary and secondary channels. For detailed information
on these combinations, see the specification IEEE Std 802.11ax™-2021.

4. Select "General" > "State" > "On", to activate baseband signal generation.

Settings:

Link Direction................................................................................................................ 40
Guard............................................................................................................................ 40
Max PE Duration........................................................................................................... 40
Time Domain Windowing Active....................................................................................41
Beam Change............................................................................................................... 41
PPDU Format................................................................................................................41
EHT-LTF Symb Duration/HE-LTF Symb Duration.........................................................41
Cur PE Duration............................................................................................................ 41
Right 106-Tone RU........................................................................................................42
Transition Time..............................................................................................................42
SIG-B DCM................................................................................................................... 42
SIG-B MCS................................................................................................................... 42
Preamble Puncturing.....................................................................................................42

Link Direction
Selects the link direction for HE/EHT frames.
Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:LINK on page 180

Guard
Selects which guard interval is used for the OFDM guard.
For "Physical Mode > Green Field/Legacy", the field is read-only, since the modes
have long guard intervals only.
Guard intervals 0.8 µs, 1.6 µs and 3.2 µs require "Std. > 11ax/11be/User".
Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:GUARd on page 166

Max PE Duration
Selects the maximum packet extension (PE) duration.
Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:MAXPe on page 181
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Time Domain Windowing Active
Activates time domain windowing.
Time domain windowing is a method to influence the spectral characteristics of the sig-
nal, which is not stipulated by the standard. However, it does not replace oversampling
and subsequent signal filtering.
Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:TDWindowing:STATe on page 175

Beam Change
Requires "PPDU Format" > "HE SU"/"HE SU EXT".
If enabled, the beam is changed between pre-HE and HE modulated fields. The pre-
HE fields are: L-STF, L-LTF, L-SIG, RL-SIG, HE-SIG-A, HE-SIG-A-R, and HE-SIG-B
fields. The HE modulated fields are: HE-STF, HE-LTF and data fields.
Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:BCHG on page 176

PPDU Format
Selects the PPDU format for EHT/HE frames.
"HE SU" HE SU (single-user) carries a single PSDU. The HE signal A (HE-

SIG-A) field is not repeated.
"EHT MU/HE MU"

EHT MU/HE MU (multi-user) carries multiple PSDUs to one or more
users.

"HE SU EXT" Carries a single PSDU. The HE-SIG-A field is repeated.
This format is only transmitted in 20 MHz channel bandwidths. It is
intended for a user who is further away from the access point (AP).

"EHT TRIG/HE TRIG"
Requires "Link Direction > Uplink".
Carries a single PSDU. It is sent as a response to a PPDU that con-
tains a trigger frame.

Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:PFORmat on page 182

EHT-LTF Symb Duration/HE-LTF Symb Duration
Selects the duration of the EHT/HE Long Training Field (LTF) symbol. The duration
does not include the length of the guard interval.
Available values are multiples of a single LTF symbol duration:
3.2 μs (1x LTF), 6.4 μs (2x LTF) and 12.8 μs (4x LTF)
Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:SYMDuration on page 184

Cur PE Duration
Displays the current packet extension (PE) duration of HE/EHT frames for all users.
The duration can be equal or lower than the maximum PE duration, "Max PE Duration"
on page 40.
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Available values are 0 μs, 4 μs, 8 μs, 12 μs and 16 μs.
Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:CURPe? on page 179

Right 106-Tone RU
Requires "Tx Mode" > "HE-20MHz" and "PPDU Format" > "HE SU EXT".
If enabled, indicates that the right 106-tone RU is within the primary 20 MHz.
Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:RIGHt106tone on page 173

Transition Time
Sets the transition time when "Time Domain Windowing > Active".
The transition time defines the overlap range of two OFDM symbols. At a setting of 100
ns and if BW = 20 MHz, one sample overlaps.
Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:TTIMe on page 175

SIG-B DCM
Requires "PPDU Format" > "HE MU".
Enables the use of dual carrier modulation (DCM) in a signal B field.
Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:BDCM on page 177

SIG-B MCS
Requires "PPDU Format" > "HE MU".
Selects the modulation and coding scheme (MCS) for the signal B field.
Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:BMCS on page 177

Preamble Puncturing
Requires "Tx Mode" > "HE-80MHz"/"HE-80+80MHz"/"HE-160MHz" and "PPDU For-
mat" > "HE MU".
Enables preamble puncturing of the HE MU PPDU in 80 MHz, 80+80 MHz or 160 MHz
channels. If enabled, specific 20 MHz subchannels are not transmitted, see Table 3-8.
How to: "Preamble puncturing in HE MU PPDUs" on page 39
Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:PPUNcturing:STATe on page 183

3.4.2.2  Additional HE-SIG-A settings

Access:

1. Select "PPDU" > "Conf..." > "General".
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2. Select the side tab "Additional HE-SIG-A".

This tab provides additional settings to configure the HE signal A field. The field
provides information about how to interpret the HE PPDUs.

Settings:

BSS Color..................................................................................................................... 43
TXOP Duration..............................................................................................................43
Spatial Reuse 1/2..........................................................................................................43
Doppler..........................................................................................................................44
pre-FEC Padding Factor............................................................................................... 44
PE Disambiguity............................................................................................................44
Preamble Puncturing Bandwidth...................................................................................44
SubChan#..................................................................................................................... 44

BSS Color
Sets the BSS color, that is an identifier of the basic service sets (BSS) field. This
parameter helps to check if a detected frame is coming from an overlapping station.
If a WLAN station detects an 802.11ax/802.11be frame, it checks the BSS color. The
station compares the color result to the color that was announced by the access point
(AP). If the BSS colors match, the frame is treated as intra-BSS. If the BSS colors mis-
match, the wireless station considers the frame as inter-BSS.
Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:BSSColor on page 178

TXOP Duration
If transmission opportunity (TXOP) is set to 127, it indicates no duration information. If
it is set to any other value, it indicates duration information for network allocation vector
(NAV) parameter and that the TXOP is protected.
Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:TXOPduration on page 184

Spatial Reuse 1/2
Requires "PPDU Format > EHT TRIG/HE TRIG".
Specifies, if spatial reuse is allowed ("Spatial Reuse ≠ 0") or not ("Spatial Reuse = 0").
You can specify spatial reuse for four trigger PPDUs.
Spatial reuse is a method of the IEEE802.11ax/be standard, that aims to improve net-
work performance in dense deployments.
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Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:SPAReuse<st> on page 183

Doppler
If enabled, signals a doppler shift in the EHT/HE signal fields.
Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:DOPPler on page 180

pre-FEC Padding Factor
Displays the pre forward error condition (FEC) padding factor used in the trigger
PPDU.
Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:PFPFactor? on page 182

PE Disambiguity
Displays the disambiguity in the number of symbols occurring due to the packet exten-
sion.
Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:PED? on page 182

Preamble Puncturing Bandwidth
Requires "Preamble Puncturing" > "On".
Sets the bits of the bandwidth field for preamble puncturing of subchannels. These bits
determine punctured or unpunctured 20 MHz subchannels. See also Table 3-8.
By default, the panel "Preamble Puncture 20MHz Subchannels" displays the specified
setup of punctured subchannels ("SubChan#") that are related to the bit value of the
bandwidth field. Also, you can puncture additional subchannels or change the default
setting.
How to: "Preamble puncturing in HE MU PPDUs" on page 39
"4"/"5" Sets the bandwidth mode for "Tx Mode" > "HE-80MHz" channels.
"6"/"7" Sets the bandwidth mode for "Tx Mode" >

"HE-80+80MHz"/"HE-160MHz" channels.
Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:PPUNcturing:STATe on page 183

SubChan#
Requires "Preamble Puncturing" > "On".
Selects or indicates the 20 MHz subchannel that is punctured in the preamble. If
enabled, this subchannel is not transmitted.
How to: "Preamble puncturing in HE MU PPDUs" on page 39
Remote command: 
n.a.
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3.4.2.3  Logging

Access:

1. Select "PPDU > Conf... > General".

2. Select the side tab "Logging".

The tab provides settings to configure logging for EHT/HE frames.

Settings:

Logging State................................................................................................................ 45
Output File.....................................................................................................................45

Logging State
If enabled, the contents of EHT/HE SIG fields and the payload are written into a file in
text form.
When the 802.11 standard is active ("General > State > On"), the file is saved into the
file path as specified in "Output File".
Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:LOGGing on page 181

Output File
Displays the fixed file path including the file name, in that the log file is saved.
The file name consists of the digital standard "wlan" and the selected frame block. For
example, the file wlan_fb7 has logging data of frame block 7.

Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:LOGFile? on page 181

3.4.3  EHT settings

This chapter describes settings of Extremely High Throughput (EHT) frames that are
available for WLAN standard IEEE 802.11be.

Access:

1. Select "IEEE 802.11... > Frame Blocks".
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2. Select "Std > 11be" or "Std > User".

3. Select "Tx Mode > EHT-x".
"x" represents the bandwidth and type of EHT frame, e.g. "x" = "160MHz".

4. Select "PPDU > Conf...".

The dialog provides settings to configure EHT frames that are available for WLAN
standard IEEE 802.11be.

For settings that are shared by more IEEE 802.11 standards, see Chapter 3.4, "PPDU
configuration", on page 31.

● EHT general settings...............................................................................................46
● U-SIG settings.........................................................................................................47
● EHT-SIG settings.................................................................................................... 49
● Logging................................................................................................................... 51

3.4.3.1  EHT general settings

Access:

1. Select "PPDU > Conf... > General".

2. Select the side tab "General > EHT General".

This tab provides general settings to configure EHT frames.

Settings:

Max PE Duration........................................................................................................... 46
PE Disambiguity............................................................................................................47
Time Domain Windowing Active....................................................................................47
Transition Time..............................................................................................................47

Max PE Duration
Selects the maximum packet extension (PE) duration.
Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:MAXPe on page 181
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PE Disambiguity
Displays the disambiguity in the number of symbols occurring due to the packet exten-
sion.
Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:PED? on page 182

Time Domain Windowing Active
Activates time domain windowing.
Time domain windowing is a method to influence the spectral characteristics of the sig-
nal, which is not stipulated by the standard. However, it does not replace oversampling
and subsequent signal filtering.
Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:TDWindowing:STATe on page 175

Transition Time
Sets the transition time when "Time Domain Windowing > Active".
The transition time defines the overlap range of two OFDM symbols. At a setting of 100
ns and if BW = 20 MHz, one sample overlaps.
Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:TTIMe on page 175

3.4.3.2  U-SIG settings

Access:

1. Select "PPDU > Conf... > General".

2. Select the side tab "U-SIG".

This dialog provides additional settings to configure the Universal SIGNAL field.

Settings:

Link Direction................................................................................................................ 48
PPDU Format................................................................................................................48
Spatial Reuse 1/2..........................................................................................................48
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OFDMA Mode............................................................................................................... 48
PHY Version Identifier................................................................................................... 48
BSS Color..................................................................................................................... 49
TXOP Duration..............................................................................................................49
EHT-SIG MCS...............................................................................................................49
320MHz Type................................................................................................................ 49

Link Direction
Selects the link direction for HE/EHT frames.
Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:LINK on page 180

PPDU Format
Selects the PPDU format for EHT/HE frames.
"HE SU" HE SU (single-user) carries a single PSDU. The HE signal A (HE-

SIG-A) field is not repeated.
"EHT MU/HE MU"

EHT MU/HE MU (multi-user) carries multiple PSDUs to one or more
users.

"HE SU EXT" Carries a single PSDU. The HE-SIG-A field is repeated.
This format is only transmitted in 20 MHz channel bandwidths. It is
intended for a user who is further away from the access point (AP).

"EHT TRIG/HE TRIG"
Requires "Link Direction > Uplink".
Carries a single PSDU. It is sent as a response to a PPDU that con-
tains a trigger frame.

Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:PFORmat on page 182

Spatial Reuse 1/2
Requires "PPDU Format > EHT TRIG/HE TRIG".
Specifies, if spatial reuse is allowed ("Spatial Reuse ≠ 0") or not ("Spatial Reuse = 0").
You can specify spatial reuse for four trigger PPDUs.
Spatial reuse is a method of the IEEE802.11ax/be standard, that aims to improve net-
work performance in dense deployments.
Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:SPAReuse<st> on page 183

OFDMA Mode
Activates OFDMA mode.
Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:POFDma on page 182

PHY Version Identifier
Displays the PHY version identifier for EHT frames.
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Remote command: 
n.a.

BSS Color
Sets the BSS color, that is an identifier of the basic service sets (BSS) field. This
parameter helps to check if a detected frame is coming from an overlapping station.
If a WLAN station detects an 802.11ax/802.11be frame, it checks the BSS color. The
station compares the color result to the color that was announced by the access point
(AP). If the BSS colors match, the frame is treated as intra-BSS. If the BSS colors mis-
match, the wireless station considers the frame as inter-BSS.
Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:BSSColor on page 178

TXOP Duration
If transmission opportunity (TXOP) is set to 127, it indicates no duration information. If
it is set to any other value, it indicates duration information for network allocation vector
(NAV) parameter and that the TXOP is protected.
Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:TXOPduration on page 184

EHT-SIG MCS
Sets the modulation coding scheme for modulation of the EHT-SIG bits.
Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:EMCS on page 180

320MHz Type
Sets the type of channelization of 320 MHz channels in the bandwidth (BW) field of the
U-SIG-1 field.
The channelization affects two adjacent 160 MHz channels of a 320 MHz channel in
the 6 GHz band. Table 3-9 shows the two types of channelization, the BW field value
and the channel center frequency number.
Table 3-9: 320 MHz channelization

Channelization /
"320MHz Type"

BW field value BW field bits Channel center fre-
quency number

"320MHz-1" 4 100 31, 95, 159

"320MHz-2" 5 101 63, 127, 191

Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:BWINd on page 178

3.4.3.3  EHT-SIG settings

Access:

1. Select "PPDU > Conf... > General".
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2. Select the side tab "EHT-SIG".

This dialog provides additional settings to configure the EHT Signal field. The field
provides information about how to interpret the EHT PPDUs.

Settings:

pre-FEC Padding Factor............................................................................................... 50
PE Disambiguity............................................................................................................50
Guard............................................................................................................................ 50
EHT-LTF Symb Duration/HE-LTF Symb Duration.........................................................50
Non-OFDMA Users....................................................................................................... 51
EHT-SIG Diff per 80MHz...............................................................................................51

pre-FEC Padding Factor
Displays the pre forward error condition (FEC) padding factor used in the trigger
PPDU.
Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:PFPFactor? on page 182

PE Disambiguity
Displays the disambiguity in the number of symbols occurring due to the packet exten-
sion.
Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:PED? on page 182

Guard
Selects which guard interval is used for the OFDM guard.
For "Physical Mode > Green Field/Legacy", the field is read-only, since the modes
have long guard intervals only.
Guard intervals 0.8 µs, 1.6 µs and 3.2 µs require "Std. > 11ax/11be/User".
Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:GUARd on page 166

EHT-LTF Symb Duration/HE-LTF Symb Duration
Selects the duration of the EHT/HE Long Training Field (LTF) symbol. The duration
does not include the length of the guard interval.
Available values are multiples of a single LTF symbol duration:
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3.2 μs (1x LTF), 6.4 μs (2x LTF) and 12.8 μs (4x LTF)
Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:SYMDuration on page 184

Non-OFDMA Users
Requires "U-SIG > OFDMA Mode > Off".
Sets the number of non-OFDMA users
Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:NONOfdmaUser on page 181

EHT-SIG Diff per 80MHz
Requires "Tx Mode > EHT-160MHz/EHT-320MHz".
For EHT-160MHz/EHT-320MHz frames, activates different EHT-SIG fields for every 80
MHz channel.
Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:ESDiffer on page 180

3.4.3.4  Logging

Access:

1. Select "PPDU > Conf... > General".

2. Select the side tab "Logging".

The tab provides settings to configure logging for EHT/HE frames.

Settings:

Logging State................................................................................................................ 51
Output File.....................................................................................................................52

Logging State
If enabled, the contents of EHT/HE SIG fields and the payload are written into a file in
text form.
When the 802.11 standard is active ("General > State > On"), the file is saved into the
file path as specified in "Output File".
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Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:LOGGing on page 181

Output File
Displays the fixed file path including the file name, in that the log file is saved.
The file name consists of the digital standard "wlan" and the selected frame block. For
example, the file wlan_fb7 has logging data of frame block 7.

Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:LOGFile? on page 181

3.4.4  User configuration settings

This chapter describes the user configuration settings for WLAN standards IEEE
802.11ax and IEEE 802.11be.

Multiple users for 802.11ax

Since multiple users are intended recipients in the OFDMA downlink, the AP needs to
tell the STAs which resource unit belongs to them. In 802.11ax, the AP uses the HE
SIG-B field in the HE_MU_PPDU for this purpose.

The SIG-B contains two fields:
● Common field, where RU allocation info is included.
● User-specific field, where per-STA info belongs.

In the "User Configuration" dialog, you can define the different settings of the SIG-B
fields.

To access multiple user settings

1. Select "IEEE 802.11 > Frame Blocks".

2. Select "Std > User", "Std > 11ax" or "Std > 11be".

3. Select "Type > Data/Trigger"

4. Select the "Tx Mode":

● For EHT frames: "Tx Mode > EHT-x".
"x" represents the bandwidth and type of EHT frame, e.g. "x" = "160MHz".

● For HE frames: "Tx Mode > HE-x".
"x" represents the bandwidth and type of HE frame, e.g. "x" = "80+80MHz".

5. Select "PPDU > Conf...".

6. Select "User Configuration".

The dialog provides settings to configure user settings of EHT/HE frames.
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Settings:

● Content channel settings.........................................................................................53
● User config settings.................................................................................................54

3.4.4.1  Content channel settings

Access:

1. To display the tab "Content Channel", choose one of the following:

● For HE frames: Select "PPDU Format > HE MU/HE TRIG".
● For EHT frames: Select "OFDMA Mode > On".

2. To access the content channel settings, select "User Configuration" > "Content
Channel" side tab.

The tab provides the settings for first and second content channel.

Settings

1st/2nd Content Channel.............................................................................................. 53
└ RU Selection...................................................................................................53
└ RU Allocation.................................................................................................. 54
└ Number of MU-MIMO users............................................................................54
└ Center 26-tone RU..........................................................................................54

1st/2nd Content Channel
Defines the settings of the common field and user-specific field of an EHT-SIG content
channel or an HE-SIG-B content channel.
For "Tx Mode > HE-20MHz/EHT-20MHz", only the 1st content channel settings are
available.

RU Selection ← 1st/2nd Content Channel
For HE frames. Requires "PPDU Format > HE MU/HE TRIG".
Selects the RU allocation subfield of the HE-SIG-B common block field.
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Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:CCH1:RUSelection<st> on page 185
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:CCH2:RUSelection<st> on page 185

RU Allocation ← 1st/2nd Content Channel
For EHT frames. Requires "OFDMA > On".
Selects the RU allocation subfield of the EHT-SIG user-specific field.
Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:CCH1:RUALlocation<st> on page 178
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:CCH2:RUALlocation<st> on page 179

Number of MU-MIMO users ← 1st/2nd Content Channel
Sets the number of MU-MIMO users. This value depends on the RU selection and the
number of spatial streams. It configures the yyy/zzz value of the RU allocation subfield.
Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:CCH1:MUNum<st> on page 185
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:CCH2:MUNum<st> on page 185

Center 26-tone RU ← 1st/2nd Content Channel
For HE frames. Requires "PPDU Format > HE MU/HE TRIG".
For full bandwidth 80 MHz: if enabled, indicates that center 26 -tone RU is allocated
in the common block fields of both SIGB content channels with same value.
For full bandwidth 160/80+80 MHz: if enabled, indicates that center 26 -tone RU is
allocated for one individual 80 MHz in common block fields of both SIGB content chan-
nels.
Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:CENRu<st> on page 186

3.4.4.2  User config settings

Access:

► Select the side tab "User Configuration > User Config".

In this table, you can define settings of the user-specific part of the EHT-SIG field
and HE-SIG-B field.
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Settings

User x............................................................................................................................55
STA Id............................................................................................................................55
Nsts............................................................................................................................... 55
RU Size......................................................................................................................... 55
MRU Index.................................................................................................................... 55
MU MIMO......................................................................................................................56
Gain (dB).......................................................................................................................56
TxBF..............................................................................................................................56
PPDU............................................................................................................................ 56
State..............................................................................................................................56

User x
Displays the user number.
The number indicates the configuration for the individual user.
Remote command: 
For EHT[:SOURce<hw>]:BB:WLNN:FBLock<ch>:BEUL? on page 177

STA Id
Sets the station ID, the 11 least significant bits of the association identifier (AID).
Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:USER<di>:STAid on page 187

Nsts
Sets the number of space time streams allocated to a particular user.
If "Space time stream" is greater than 1 and "Number of MU-MIMO users" is also
greater than 1, RUs of size 106 subcarriers or larger can accommodate more than one
user. The "Nsts" setting allocates a portion of the available space time streams to a
particular user.
Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:USER<di>:NSTS on page 187

RU Size
Sets size of the resource unit for each user.
Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:USER<di>:RUTYpe on page 187

MRU Index
For EHT frames. Requires "OFDMA > Off".
Sets the index of the multi-resource unit (MRU). The index constitutes position of the
MRU in the resource allocation.
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Example: MRU index 2 in an RU size of 996+484

Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:USER<di>:MRUindex on page 186

MU MIMO
Displays if the multi-user MIMO is used for current user.
All MU-MIMO users share one resource unit (RU) using different space time streams.
Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:USER<di>:MUMimo:STATe?
on page 186

Gain (dB)
Sets the additional gain that can be applied to the RU allocated by a particular user.
Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:USER<di>:GAIN on page 186

TxBF
If enabled, indicates that the beamforming matrix is applied to the waveform.
Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:USER<di>:TXBF on page 188

PPDU
Opens a dialog for configuring the PPDU of respective user.
For related settings, see the following sections:
● Chapter 3.4.1.3, "MCS configuration settings", on page 34
● Chapter 3.5, "A-MPDU settings", on page 63
● Chapter 3.4.5, "Data settings", on page 57
● Chapter 3.6, "MAC header and FCS configuration for frame block", on page 64

State
Sets the state of the respective user.
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Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:USER<di>:STATe on page 187

3.4.5  Data settings

Access:

1. Select "Frame Blocks > PPDU > Config...".

2. Select "Data".

The "Data" dialog comprises the settings for the configuration of the data and the
header. The parameters available for configuration depend on the selected "Type",
"Physical Layer" and "Tx Mode".

Settings

● Data settings........................................................................................................... 57
● Header settings.......................................................................................................62

3.4.5.1  Data settings

Access:

1. Select "Frame Blocks > PPDU > Config...".

2. Select "Data > Data Settings".

The dialog comprises the settings for the configuration of the data.
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Settings

Data Length...................................................................................................................58
Frame Duration............................................................................................................. 58
Frame Delay..................................................................................................................58
Scrambler......................................................................................................................59
Ch. Bandwidth in Non HT..............................................................................................59
Interleaver Active.......................................................................................................... 59
Time Domain Windowing Active....................................................................................60
Default PN Seed........................................................................................................... 60
Number Of Data Symbols............................................................................................. 60
Duty Cycle.....................................................................................................................60
Scrambler Init (hex).......................................................................................................60
Dyn. Bandwidth in Non HT............................................................................................60
Service Field (hex)........................................................................................................ 61
Transition Time..............................................................................................................61
Service Field Clock Bit.................................................................................................. 61
PLCP P+H Format........................................................................................................ 61
PN Seed........................................................................................................................61

Data Length
Sets the size of the data field in bytes.
For "Data Length" = 0, no data field is generated for the case of a sounding frame.
The maximum data length depends on the physical mode:
● In "Physical Mode > Legacy", the maximum value is 4061 bytes.
● In "Physical Mode > Mixed Mode" and "Physical Mode > Green Field", the maxi-

mum value is 1048575 bytes.
The data length is related to the number of data symbols. Whenever the data length
changes, the number of data symbols is updated and vice versa.
Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:DATA:LENGth on page 164
[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:DATA:LENGth
on page 164

Frame Duration
Displays the duration of the frame, i.e. the WLAN burst length.
Frame duration and duty cycle are related to data length and number of data symbols.
Whenever one of them changes, the frame duration and duty cycle are updated.
Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:DATA:FDURation? on page 163

Frame Delay
Shifts the frame in time by the specified frame delay value.
The idle time after the frame is reduced by the specified value and inserted before the
frame. The waveform sequence length remains unchanged. This parameter works in
the sample domain. Also it can be useful when generating time-shifted waveform files
before further processing. Further processing applies, for example, when using them in
a multi-segment waveform.
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Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:DATA:FDELay on page 163

Scrambler
Selects the different options for the scrambler.
"OFF" The scrambler is deactivated.
"On (Random Init)"

(not available for "Tx Mode > CCK/PBCC"
The scrambler is activated.
The initialization value of the scrambler is selected at random. Each
frame has a different random initialization value. This value is also dif-
ferent if there is successive recalculations with the same setting
parameters so that different signals are generated for each calcula-
tion.

"On (User Init)" (not available for "Tx Mode > CCK/PBCC")
The scrambler is activated.
The initialization value of the scrambler is set to a fixed value that is
entered in the "Scrambler Init (hex)". This value is then identical in
each generated frame.

"ON" (available only for "Tx Mode > CCK/PBCC")
The scrambler is activated.

"Preamble
Only"

(available only for "Tx Mode > CCK/PBCC")
The scrambler is activated.
Only the preamble is scrambled.

Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:SCRambler:MODE on page 172
[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:SCRambler:MODE
on page 172

Ch. Bandwidth in Non HT
(available only for "Tx Mode > VHT")
This parameter is used to modify the first 7 bits of the scrambling sequence to indicate
the duplicated bandwidth of the PPDU.
"NON_HT20 | 40 | 80 | 160"

Indicates 20 MHz, 40MHz, 80MHz or 160 (80+80) MHz channel
bandwidth of the transmitted packet.

"Not present" Channel bandwidth in non HT is not present.
Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:CBINonht on page 161

Interleaver Active
Activates/deactivates the interleaver of the data field.
Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:ILEaver:STATe on page 166
[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:ILEaver:STATe
on page 166
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Time Domain Windowing Active
Activates time domain windowing.
Time domain windowing is a method to influence the spectral characteristics of the sig-
nal, which is not stipulated by the standard. However, it does not replace oversampling
and subsequent signal filtering.
Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:TDWindowing:STATe on page 175

Default PN Seed
Requires "Data > PNxx" set as the data source.
Activates the default PN seed. The seed is used initially to generate the pseudo-ran-
dom noise sequence.
Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:DPNSeed:STATe
on page 165

Number Of Data Symbols
Sets the number of data symbols per frame block.
If the number of OFDM data symbols is changed, the generator calculates the data
field length as a function of the set PPDU bit rate. This value is displayed at "Data
Length".
Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:DATA:SYMBols on page 164

Duty Cycle
Displays the duty cycle, i.e. the ratio of frame duration and total signal length.
Frame duration and duty cycle are related to data length and number of data symbols.
Whenever one of them changes, the frame duration and duty cycle are updated.
Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:DATA:DCYCle? on page 162

Scrambler Init (hex)
Enters the initialization value for "Scrambler >User". This value is then identical in each
generated frame.
Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:SCRambler:PATTern on page 173
[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:SCRambler:PATTern
on page 173

Dyn. Bandwidth in Non HT
(available only for "Tx Mode > VHT")
If present, this parameter is used to modify the first 7 bits of the scrambling sequence
to indicate if the transmitter supports "Static" or "Dynamic" bandwidth operation.
"Not present" Dynamic bandwidth in non HT is not present.
"Static" The transmitter supports static bandwidth operation.
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"Dynamic" The transmitter supports dynamic bandwidth operation.
Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:DBINonht on page 165

Service Field (hex)
Enters the value of the service field. The standard specifies a default value of 0. Other
values can be entered in hexadecimal form for test purposes or future extensions.
Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:SERVice:PATTern on page 173
[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:SERVice:PATTern
on page 173

Transition Time
Sets the transition time when "Time Domain Windowing > Active".
The transition time defines the overlap range of two OFDM symbols. At a setting of 100
ns and if BW = 20 MHz, one sample overlaps.
Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:TTIMe on page 175

Service Field Clock Bit
(available only for "Tx Mode > CCK/PBCC")
Sets the locked clock bit in service field of the PLCP header.
Via this flag (bit), the transmitter indicates whether transmission frequency and symbol
rate have been derived from the same oscillator. If so (locked), the bit is set to 1, other-
wise (not locked) to 0.
Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:PLCP:LCBit:STATe on page 169

PLCP P+H Format
(available only for "Tx Mode > CCK/PBCC")
Selects the packet type (PPDU format) with long or short PLCP (physical layer conver-
gence protocol).
Depending on the selected format, the structure, modulation and data rate of the PLCP
the preamble and the header are modified.
Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:PLCP:FORMat on page 169

PN Seed
Requires "Default PN Seed > Off".
Sets the PN seed, a 24-bit value in hexadecimal representation. Use this setting, if you
do not use the default PN seed.
The maximum PN seed value is internally limited by the length of the used shift regis-
ter. E.g., "Data > PN 9" has 9-bit resolution for and limits the PN seed to 1FF.
Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:PNSeed on page 170
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3.4.5.2  Header settings

Access:

1. Select "Frame Blocks > PPDU > Config...".

2. Select "Data > Header Settings".

This dialog provides settings to configure header settings.

Settings:

Preamble/Header Active............................................................................................... 62
Smoothing..................................................................................................................... 62
Partial AID (hex)............................................................................................................62
No TXOP PS................................................................................................................. 63

Preamble/Header Active
Activates preamble and signal fields of the frames in the current frame block.
For "Type > Sounding", the preamble and signal field are always activated and cannot
be deactivated.
Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:PREamble:STATe on page 170

Smoothing
Requires "Tx Mode > VHT".
Indicates to the receiver whether frequency-domain smoothing is recommended as
part of channel estimation.
"On" Indicates that channel estimate smoothing is recommended.
"Off" Indicates that only per-carrier independent channel (unsmoothed)

estimate is recommended.
Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:SMOothing on page 174

Partial AID (hex)
Requires "Tx Mode > VHT".
Provides an abbreviated indication of one or more intended recipients of the frame.

PPDU configuration



WLAN configuration and settingsR&S®SMW-K54/-K86/-K142/-K147

63User Manual 1175.6749.02 ─ 28

Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:PAID:PATTern on page 169

No TXOP PS
Requires "Tx Mode > VHT".
Indicates whether the VHT access point (AP) allows VHT non-AP stations (STAs) in
transmit opportunity (TXOP) power save mode to enter during TXOP.
"On" Indicates that the VHT AP allows VHT non-AP STAs to enter doze

mode during a TXOP.
"Off" Indicates that the VHT AP does not allow VHT non-AP STAs to enter

doze mode during a TXOP.
Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:NTPS on page 168

3.5  A-MPDU settings

This chapter describes the aggregate MAC protocol data unit (A-MPDU) settings.

Access:

1. Select "IEEE 802.11... > Frame Blocks".

2. Select "Type > Data".

3. Select "Data > A-MPDU".

4. Select "DList/Pattern > Config".

5. Select "A-MPDU".

The dialog comprises the A-MPDU settings.

Settings:

Number of MPDUs........................................................................................................ 63
A-MPDU Length............................................................................................................ 64
Data Length / bytes....................................................................................................... 64
Data...............................................................................................................................64
DList / Pattern............................................................................................................... 64

Number of MPDUs
Determines the number of MPDUs in the frame.
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Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:MPDU:COUNt on page 188
[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:MPDU:COUNt on page 188

A-MPDU Length
Indicates the overall A-MPDUs length, resulting from the "Data Length / bytes" settings
of all MPDUs.
Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:DATA:LENGth on page 164

Data Length / bytes
Determines the size of the data field in bytes.
Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:MPDU<st>:DATA:LENGth on page 189
[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:MPDU<st>:DATA:LENGth
on page 189

Data
Selects the data source.
Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:MPDU<st>:DATA:SOURce on page 190
[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:MPDU<st>:DATA:SOURce
on page 190

DList / Pattern
Depending on the selected data source, selects a data list or allows entering a user-
defined bit pattern.
Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:MPDU<st>:DATA:DSELection
on page 188
[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:MPDU<st>:DATA:
DSELection on page 188
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:MPDU<st>:DATA:PATTern on page 189
[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:MPDU<st>:DATA:
PATTern on page 189

3.6  MAC header and FCS configuration for frame block

In the real IEEE 802.11 system, a MAC (medium access control) header is transmitted
in the PPDU before the actual data section. This header provides the control informa-
tion of the MAC layer. It is also possible to protect the PPDU by a frame checksum.
These two functions can be controlled in the dialog.

Access:

1. Select "IEEE 802.11" > "Frame Blocks".
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2. Select "PPDU" > "Config...".

3. Select "MAC Header & FCS".

The dialog provides MAC Header settings and MAC Frame Control Field settings.

Settings:

● MAC header and FCS common settings.................................................................65
● MAC header and frame control settings..................................................................66
● MAC HT/VHT/HE control settings...........................................................................70
● Beacon frame settings............................................................................................ 80
● Trigger frame settings............................................................................................. 87

3.6.1  MAC header and FCS common settings

Access:

► Select "MAC Header & FCS" > "MAC Header"/"FCS (checksum)".

The settings activate the MAC header and frame check sequence (FCS).

Settings:

MAC Header
Activates the generation of the MAC header for the PPDU. If the MAC header is activa-
ted, all MAC header fields are enabled for operation.
The individual fields of the MAC header are described in the following.
All values of the MAC fields (except addresses) are entered in hexadecimal form with
least significant bit (LSB) in right notation. In the data stream, the values are output
standard-conformal with the LSB coming first.
Note: IEEE 802.11ac requires an A-MPDU frame aggregation. When generating IEEE
802.11ac signals, select "Frame Blocks" > "Data" > "A-MPDU".
Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:MAC:STATe on page 197
[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:MAC:STATe on page 197
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FCS (checksum)
Activates the calculation of the FCS (frame check sequence). The standard defines a
32-bit (4-byte) checksum to protect the MAC header and the user data (frame body).
Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:MAC:FCS:STATe on page 194
[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:MAC:FCS:STATe
on page 194

3.6.2  MAC header and frame control settings

Access:

► Select "MAC Header & FCS" > "Frame Control (hex)".

The panel provides settings to configure the MAC Frame Control field.

Frame Control (hex)
Sets the bits in Frame Control field in the MAC header.
The field has a length of 2 bytes or 16 bits and relates to the bits in the Frame Control
subfields. Alternatively, configure subfield bits and the Frame Control field adjusts auto-
matically.

Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:MAC:FCONtrol on page 193

MAC Frame Control Field
Sets the subfield bits of the MAC Frame Control field.
The subfields have a length of 2 bytes or 16 bits and relate to the bits in the Frame
Control field. Alternatively, configure the Frame Control field and the subfield bits adjust
automatically. For a description of the subfields, see the IEEE
Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:MAC:FCONtrol:PVERsion on page 193
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:MAC:FCONtrol:TYPE on page 194
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:MAC:FCONtrol:SUBType on page 194
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:MAC:FCONtrol:TDS on page 194
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:MAC:FCONtrol:FDS on page 193
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:MAC:FCONtrol:MFRagments
on page 193
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:MAC:FCONtrol:RETRy on page 194
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[:SOURce<hw>]:BB:WLNN:FBLock<ch>:MAC:FCONtrol:PMANagement
on page 193
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:MAC:FCONtrol:MDATa on page 193
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:MAC:FCONtrol:WEP on page 194
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:MAC:FCONtrol:ORDer on page 193
[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:MAC:FCONtrol
on page 193
[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:MAC:FCONtrol:
PVERsion on page 193
[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:MAC:FCONtrol:TYPE
on page 194
[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:MAC:FCONtrol:SUBType
on page 194
[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:MAC:FCONtrol:TDS
on page 194
[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:MAC:FCONtrol:FDS
on page 193
[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:MAC:FCONtrol:
MFRagments on page 193
[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:MAC:FCONtrol:RETRy
on page 193
[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:MAC:FCONtrol:
PMANagement on page 193
[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:MAC:FCONtrol:MDATa
on page 193
[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:MAC:FCONtrol:WEP
on page 194
[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:MAC:FCONtrol:ORDer
on page 193

Duration ID (hex)
Enters the value of the duration ID field.
Depending on the frame type, the 2-byte field "Duration/ID" is used to transmit the
association identity of the station transmitting the frame. Or it indicates the duration
assigned to the frame type.
Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:MAC:DID on page 192
[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:MAC:DID on page 192

MAC Address
Enters the value of the address field 1 to address field 4.
The MAC header can contain up to four address fields, but not all must be available.
Each of the 4 address fields can be activated or deactivated. The fields are used for
transmitting the basic service set identifier, the destination address, the source
address, the receiver address and the transmitter address. Each address is 6 bytes (48
bit) long. The addresses can be entered in hexadecimal form in the entry field of each
address field. The LSB is in left notation.
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Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:MAC:ADDRess<st>:STATe on page 192
[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:MAC:ADDRess<st>:
STATe on page 192

SA (hex)
Requires PPDU "Type" > "Beacon".
Enters the value of the source address (SA) field.
Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:MAC:SA on page 194

BSSID (hex)
Requires "Physical Mode > Beacon".
Enters the value of the basic service set identification (BSSID) field.
Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:MAC:BSSid on page 193

Sequence Control
Activates the sequence control field.
The sequence control field has a length of 2 bytes and is divided in two parts, the frag-
ment number (4 bits) and the sequence number (12 bits) field. A long user data stream
to be transmitted is first split up into MSDUs (MAC service data units). The MSDUs can
either be transmitted as PSDU frames or further divided into fragments.
The sequence number and the fragment number are then used to number the individ-
ual subpackets of the user data stream to be transmitted. Thus, all PSDUs are
assigned a consecutive number. The assignment allows the receiver to arrange the
data packets in the correct order. It also allows the receiver to determine whether an
incorrectly transmitted packet was retransmitted and to find out whether packets are
missing.
The sequence number is incremented by 1 for each packet. The sequence control field
is 0 at the latest after a count of 4095. For the receiver, the following applies:
● The receiver can detect a packet without an error.
● The receiver does not request a retransmission.
The fragment number field is incremented by 1 when another fragment of the current
MPDU is transmitted. The start count for the transmission (normally 0) and the number
of packets required to increment the corresponding counter can be defined for both
numbers. Defining is done with the parameters "Start Number" and "Incremented
every ... packet(s)".
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Example: 
An error-free transmission of 50 packets (no packet retransmission) is to be simulated.
The sequence number is incremented by 1 for each packet. Since no packet is frag-
mented, the fragment counter can always remain at 0. In this case, the following values
have to be set:

If you want to simulate, that a receiver receives some packets incorrectly, set "Incre-
mented Every" > "2 packets" or higher. The R&S SMW sends each packet with identi-
cal data twice.

Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:MAC:SCONtrol:STATe on page 197
[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:MAC:SCONtrol:STATe
on page 197

Start Number (hex) ← Sequence Control
Sets the start number of the fragment bits or the sequence bits of the sequence con-
trol.
Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:MAC:SCONtrol:FRAGment:STARt
on page 196
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:MAC:SCONtrol:SEQuence:STARt
on page 196
[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:MAC:SCONtrol:
FRAGment:STARt on page 196
[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:MAC:SCONtrol:
SEQuence:STARt on page 196
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Increment Every ← Sequence Control
Defines the number of packets required to increment the counter of the fragment bits
or the sequence bits of the sequence control.
Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:MAC:SCONtrol:FRAGment:INCRement
on page 195
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:MAC:SCONtrol:SEQuence:INCRement
on page 196
[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:MAC:SCONtrol:
FRAGment:INCRement on page 195
[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:MAC:SCONtrol:
SEQuence:INCRement on page 196

HT Config/VHT Config/HE Config
Accesses settings to configure the HT/VHT/HE Control field. See Chapter 3.6.3, "MAC
HT/VHT/HE control settings", on page 70.
Note: Only the"Physical Modes > Mixed Mode" or "Physical Modes > Green Field"
(QoS data frames) provide the HT or VHT transmission technology. For "Physical
Modes > Legacy", this configuration field is not indicated.
Remote command: 
n.a.

Frame Body
Indicates the length of the user data (frame body).
Remote command: 
n.a.

FCS
Indicates the length of the check sum.
Remote command: 
n.a.

3.6.3  MAC HT/VHT/HE control settings

Access:

1. Select "Frame Blocks" > "PPDU" > "Config...".

2. Access the control settings related to the configured "Tx Mode":

● "Tx Mode" > "HT-x": Select "MAC Header & FCS" > "HT Config".
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Figure 3-2: MAC HT control

● "Tx Mode" > "VHT-x": Select "MAC Header & FCS" > "VHT Config".

Figure 3-3: MAC VHT control

● "Tx Mode" > "HE-x"/"EHT-x": Select "MAC Header & FCS" > "HE Config".

Figure 3-4: MAC HE/EHT control

See Chapter 3.6.3.4, "MAC HE control settings", on page 79.

The dialog provides settings to configure HT/VHT/HE Control Field settings like the
mode, the time shifts and the transmit parameters.

The "HT/VHT Control Field" can be included in any frame except a non-QoS Data
frame. The presence of the HT/VHT control field in frames carried in a HT/VHT PPDU
is indicated by setting the order bit in the MAC header. The HT/VHT Control Field
appears last in the MAC header, excluding any security fields.

Settings:

● Common settings.................................................................................................... 72
● MAC HT control settings......................................................................................... 72
● MAC VHT control settings.......................................................................................75
● MAC HE control settings.........................................................................................79
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3.6.3.1  Common settings

Provided are the following settings for enabling the "MAC HT/VHT Control Field":

QoS Control.................................................................................................................. 72
HT/VHT/HE Control.......................................................................................................72

QoS Control
Control field (2 bytes) with an embedded checkbox for activating the control mecha-
nism of Quality of Service (QoS) data frames.
The QoS solicits an acknowledgement policy from the receiver, according to specific
feedback rules. QoS control ensures a high level of transmission performance like high
bit rate, low latency or low bit error probability.
Information on contents of the QoS Control Data frame is, for example, duration
request field, TXOP limit, and AP Buffer State or queue size.
Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:MAC:QSControl:STATe on page 195
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:MAC:QSControl on page 195
[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:MAC:QSControl
on page 195
[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:MAC:QSControl:STATe
on page 195

HT/VHT/HE Control
Enables HT/VHT/HE control and sets the HT/VHT/HE control field as hex value.
Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:MAC:HTControl on page 197
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:MAC:VHTControl on page 203
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:MAC:HTControl:STATe on page 202
[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:MAC:HTControl:STATe
on page 202
[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:MAC:HEControl
on page 207

3.6.3.2  MAC HT control settings

The following functions describe the control field of the MAC HT configuration:

Settings:

RDG/More PPDU.......................................................................................................... 73
AC Constraint................................................................................................................73
Reserved.......................................................................................................................73
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NDP Announcement..................................................................................................... 73
CSI Steering..................................................................................................................74
Reserved.......................................................................................................................74
Calibration Sequence....................................................................................................74
Calibration Position....................................................................................................... 74
Link Adaption Control....................................................................................................74
HT/VHT......................................................................................................................... 75

RDG/More PPDU
The RDG/More signal field (LSB, 1 bit) issues the reverse direction grant. When trans-
mitted by an initiator or a responder, this field is interpreted differently.
Transmitted by initiator
0 = No reverse grant.
1 = A reverse grant is present, as defined by the Duration/ID field.
Transmitted by responder
0 = The PPDU carrying the MPDU is the last transmission by the responder.
1 = The PPDU carrying the frame is followed by another PPDU.
Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:MAC:HTControl:RDGMore on page 201

AC Constraint
Indicates the access point of the responder (1 bit).
0 = The response can contain data from any traffic identifier (TID)
1 = The response can contain data only from the same AC as the last data received
from the initiator.
Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:MAC:HTControl:ACConstraint
on page 198

Reserved
This signal field (5 bit) is defined, but not used. It is set to zero by the transmitter and
ignored by the receiver.
Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:MAC:HTControl:REServed
on page 201

NDP Announcement
The NDP announcement (1 bit) indicates that a null data packet (NDP) will be transmit-
ted after the frame.
0 = no NDP follows
1 = NDP follows
Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:MAC:HTControl:NDP on page 201
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:MAC:HTControl:ZLF on page 202
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CSI Steering
Sets the position of the CSI feedback (2 bit)
00 = CSI
01 = uncompressed steering matrix
10 = compressed steering matrix
11 = reserved
Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:MAC:HTControl:CSISteering
on page 199

Reserved
This signal field (2 bit) is defined, but not used.
Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:MAC:HTControl:SREServed
on page 202
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:MAC:HTControl:FREQuest
on page 199

Calibration Sequence
Identifies the calibration sequence (2 bit). The field is included in each frame within the
calibration procedure. Its value remains unchanged during one calibration procedure
and is incremented each time a new calibration procedure starts.
Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:MAC:HTControl:CALibration:
SEQuence on page 199

Calibration Position
Sets the position in the Calibration Sounding Exchange sequence (2 bit):
00 = not a calibration frame (Default setting)
01 = calibration start
10 = sounding response
11 = sounding complete
Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:MAC:HTControl:CALibration:
POSition on page 198

Link Adaption Control
Sets the parameters of the link adaption control field. The following subfields enable
configuring the response signal of the link adaption.
B0 (1bit) MA - MA payload
When the MA (Management Action) field is set to 1, the payload of the QoS Null Data
MPDU (Medium Access Controller Protocol Data Unit) is interpreted as a payload of
the management action frame.
B1 (1bit) TRQ - sounding request
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1 = request to the responder to transmit a sounding PPDU (Physical layer Protocol
Data Unit).
B2 (1bit) MRQ - MCS request
1 = request for feedback of MCS (Modulation Coding Scheme).
B3-B5 (3bit) MRS - MRQ sequence identifier
Set by sender to any value in the range '000'-'110' to identify MRQ. = invalid if MRQ = 0
B6-B8 (3bit) MFS - MFB sequence identifier
Set to the received value of MRS. Set to '111' for unsolicited MFB.
B9-B15 (7bit) MFB - MCS feedback
Link adaptation feedback containing the recommended MCS. When a responder is
unable to provide MCS feedback or the feedback is not available, the MFB is set to 'all-
ones' (default value) and also MFS is set to '1'.
Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:MAC:HTControl:LAControl
on page 200

HT/VHT
The subfield indicates the used format (HT or VHT).
0 = indicates use of the HT format.
1 = indicates use of the VHT format.
Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:MAC:HTControl:HVINdicator?
on page 200

3.6.3.3  MAC VHT control settings

Access:

1. Select "Frame Blocks > Tx Mode" to
"VHT-20MHz","VHT-40MHz","VHT-80MHz","VHT-80 + 80MHz" or "VHT-160MHz".

2. Select "Frame Blocks >PPDU > Config..."

3. Select "MAC Header & FCS > VHT Config"

The following functions describe the control field of the MAC VHT configuration:
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Settings:

RDG/More PPDU.......................................................................................................... 76
AC Constraint................................................................................................................76
Unsolicited MFB............................................................................................................ 76
FB Tx Type....................................................................................................................76
Coding Type.................................................................................................................. 77
GID-H............................................................................................................................ 77
MFB...............................................................................................................................77
MFSI/GID-L................................................................................................................... 78
MSI................................................................................................................................78
MRQ..............................................................................................................................78
Rsv................................................................................................................................ 79
HT/VHT......................................................................................................................... 79

RDG/More PPDU
The RDG/More signal field (LSB, 1 bit) issues the reverse direction grant. When trans-
mitted by an initiator or a responder, this field is interpreted differently.
Transmitted by initiator
0 = No reverse grant.
1 = A reverse grant is present, as defined by the Duration/ID field.
Transmitted by responder
0 = The PPDU carrying the MPDU is the last transmission by the responder.
1 = The PPDU carrying the frame is followed by another PPDU.
Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:MAC:VHTControl:RDGMore
on page 206

AC Constraint
Indicates the access point of the responder (1 bit).
0 = The response can contain data from any TID (Traffic Identifier).
1 = The response can contain data only from the same AC as the last data received
from the initiator.
Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:MAC:VHTControl:ACConstraint
on page 203

Unsolicited MFB
0 = if the MFB is a response to an MRQ.
1 = if the MFB is not a response to an MRQ.
Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:MAC:VHTControl:UMFB on page 206

FB Tx Type
0 = If the Unsolicited MFB subfield is set to 1 and FB Tx Type subfield is set to 0, the
Unsolicited MFB refers to one of the following:

MAC header and FCS configuration for frame block



WLAN configuration and settingsR&S®SMW-K54/-K86/-K142/-K147

77User Manual 1175.6749.02 ─ 28

Unbeamformed VHT PPDU or transmit diversity using an STBC VHT PPDU.
1 = If the Unsolicited MFB subfield is set to 1 and the FB Tx Type subfield is set to 1,
the unsolicited MFB refers to a beamformed SU-MIMO VHT PPDU.
Otherwise this subfield is reserved.
Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:MAC:VHTControl:FTTYpe on page 204

Coding Type
If the Unsolicited MFB subfield is set to 1, the "Coding Type" subfield contains the cod-
ing information (set to 0 for BCC and set to 1 for LDPC) to which the unsolicited MFB
refers.
0 = for BCC
1 = for LDPC
Otherwise this subfield is reserved.
Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:MAC:VHTControl:CTYPe on page 203

GID-H
If the Unsolicited MFB subfield is set to 1, the GID-H subfield contains the highest 3
bits of group ID of the PPDU to which the unsolicited MFB refers.
Otherwise this subfield is reserved.
Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:MAC:VHTControl:GIDH on page 204

MFB
MFB subfield is interpreted as defined in Table 3-10. This subfield contains the recom-
mended MFB. The value of MCS=15 and VHT N_STS=7 indicates that no feedback is
present.
Table 3-10: MFB subfield in the VHT format HT control field

Subfield Meaning Definition

VHT
N_STS

Recommended VHT
NSTS

Indicates the recommended VHT NSTS (Link adaption using the
VHT format of the "HT Control" field).

MCS Recommended MCS
feedback

Indicates the recommended VHT MCS (Link adaption using the
VHT format of the "HT Control" field).

MAC header and FCS configuration for frame block



WLAN configuration and settingsR&S®SMW-K54/-K86/-K142/-K147

78User Manual 1175.6749.02 ─ 28

Subfield Meaning Definition

BW Bandwidth of the recom-
mended MCS

MFB = 1
If the unsolicited MFB subfield is set to 1, the BW subfield con-
tains the bandwidth of which the recommended MCS is intended
for (Link adaption using the VHT format of the "HT Control" field).
The BW subfield is set as follows:
● 0 for 20 MHz
● 1 for 40 MHz
● 2 for 80 MHz
● 3 for 160 MHz and 80+80 MHz

MFB = 1
If the Unsolicited MFB subfield is set to 0, the BW subfield is
reserved and set to 0.

SNR Average SNR Indicates the average SNR, which is an SNR averaged over data
subcarriers and spatial streams (Link adaption using the VHT for-
mat of the "HT Control" field).

Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:MAC:VHTControl:MFB on page 205

MFSI/GID-L
MFB = 0
If the Unsolicited MFB subfield is set to 0, the MFSI/GID-L subfield contains the
received value of MSI contained in the frame to which the MFB information refers.
MFB = 1
The MFSI/GID-L subfield contains the lowest 3 bits of group ID of the PPDU to which
the unsolicited MFB refers.
Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:MAC:VHTControl:MGL on page 205

MSI
MRQ = 0
When the MRQ subfield is set to 0, the MSI subfield is reserved.
MRQ = 1
When the MRQ subfield is set to 1, the MSI subfield contains a sequence number in
the range 0 to 6 that identifies the specific request.
Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:MAC:VHTControl:MSI on page 206

MRQ
0 = to request MCS feedback (solicited MFB).
1 = otherwise.
Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:MAC:VHTControl:MRQ on page 205
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Rsv
This signal field (1 bit) is defined, but not used. It is set to zero by the transmitter and
ignored by the receiver.
Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:MAC:VHTControl:VREServed
on page 207

HT/VHT
The subfield indicates the used format (HT or VHT).
0 = indicates use of the HT format.
1 = indicates use of the VHT or HE format, depending on the value of the HE field.
Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:MAC:VHTControl:HVINdicator?
on page 204
[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:MAC:VHTControl:
HVINdicator? on page 200

3.6.3.4  MAC HE control settings

Access:

1. Select "Frame Blocks > Type > Data".

2. Select "Tx Mode" > "HE-20MHz"/"HE-40MHz"/"HE-80MHz"/"HE-80 +
80MHz"/"HE-160MHz".

3. Select "Frame Blocks" > "PPDU" > "Config...".

4. Select "User Configuration" > "PPDU" > "Config...".

5. Select "MAC Header & FCS > HE Config"

The panel provides settings to configure the control field of the MAC HE configuration.

Settings:

Aggregated control........................................................................................................79
HE................................................................................................................................. 80
HT/VHT......................................................................................................................... 80

Aggregated control
Enters the value of the aggregated control (A-Control) field. This field consists of a
sequence of one or more control subfields.
A control subfield consists of a 4-bit control ID subfield and a control information of a
variable size. The values are as defined in the 802.11ax amendment.
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Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:MAC:HEControl:
ACONtrol on page 207

HE
Indicates the use of the HE format, if you set "HT/VHT" > "1".
"0" Uses the VHT format.
"1" Uses the HE format.
Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:MAC:HEControl:
HEINdicator? on page 207

HT/VHT
The subfield indicates the used format (HT or VHT).
0 = indicates use of the HT format.
1 = indicates use of the VHT or HE format, depending on the value of the HE field.
Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:MAC:VHTControl:HVINdicator?
on page 204
[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:MAC:VHTControl:
HVINdicator? on page 200

3.6.4  Beacon frame settings

A beacon frame is a management frame that contains all the information about a net-
work. The beacon settings are used to define the timestamp, the beacon interval, the
SSID, the supported rate etc. They also comprise the capability information and the
ERP parameters.

Settings:

● General beacon settings......................................................................................... 80
● Capability information parameters.......................................................................... 82
● ERP parameters......................................................................................................85
● HT capability information.........................................................................................86

3.6.4.1  General beacon settings

Access:

1. Select "IEEE 802.11 > Frame Blocks".

2. Select "Type > Beacon".

3. Select "PPDU > Config...".
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4. Select "MAC Header & FCS > Beacon General".

The dialog provides general beacon settings.

Settings:

Timestamp (hex)........................................................................................................... 81
Beacon Interval............................................................................................................. 81
SSID..............................................................................................................................81
Supported Rates........................................................................................................... 82
DSSS(Current Channel)................................................................................................82
IBSS(ATIM Window) (hex)............................................................................................ 82

Timestamp (hex)
Updates the local clock of a station (the timing synchronization function (TSF) of a fra-
mes' source) after receiving a beacon frame.
Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:BFConfiguration:TSTamp
on page 213

Beacon Interval
Defines the time interval between two beacon transmissions in ms.
Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:BFConfiguration:BINTerval
on page 212

SSID
Specifies the desired service set identifier (SSID) or the wildcard SSID. The maximum
allowed length is 32 characters.
Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:BFConfiguration:SSID on page 213
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Supported Rates
Contains the set of data rates supported by the AP, including indication which rates are
part of the BSSBasicRateSet.
Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:BFConfiguration:SRATe on page 213

DSSS(Current Channel)
Indicates the current channel of this direct sequence spread spectrum (DSSS) net-
work.
Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:BFConfiguration:DCCHannel?
on page 212

IBSS(ATIM Window) (hex)
Contains the set of parameters necessary to support an independent basic service set
(IBSS). The information field contains the announcement traffic indication message
(ATIM) window parameter.
Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:BFConfiguration:IAWindow
on page 212

3.6.4.2  Capability information parameters

Access:

1. Select "IEEE 802.11 > Frame Blocks".

2. Select "Type > Beacon".

3. Select "PPDU > Config...".
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4. Select "MAC Header & FCS >Capability Info".

The dialog displays the capability info parameters.

The capability info parameters indicate, if requested optional capabilities and services
are allowed, supported or in use.

For example if "DSSS-OFDM" is enabled the associated stations in the network is
informed that use of direct sequence spread spectrum - OFDM modulation (DSSS-
OFDM) is allowed.

Settings:

Capability Information Parameters................................................................................83

Capability Information Parameters
Table 3-11: Functions of capability information parameters

Function
name

If enabled this function indicates that: SCPI command

"Immediate
Block Ack"

Immediate block Ack is allowed (suitable for high-
bandwidth, low latency traffic).

[:SOURce<hw>]:BB:WLNN:
FBLock<ch>:
BFConfiguration:
CAPability:IBACk on page 215

"Delayed
Block Ack"

Delayed block Ack is allowed (delayed block Ack is
suitable for applications that tolerate moderate
latency).

[:SOURce<hw>]:BB:WLNN:
FBLock<ch>:
BFConfiguration:
CAPability:DBACk on page 216

"DSSS-
OFDM"

Direct sequence spread spectrum - OFDM is allowed
(encodes packet data using the DSSS headers and
OFDM encoding of the payload).

[:SOURce<hw>]:BB:WLNN:
FBLock<ch>:
BFConfiguration:
CAPability:DOFDm on page 216
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Function
name

If enabled this function indicates that: SCPI command

"Radio Mea-
surement"

Radio measurement is supported (for example
requests, performs and reports radio measurements
in supported channels and provides information
about neighbor APs).

[:SOURce<hw>]:BB:WLNN:
FBLock<ch>:
BFConfiguration:
CAPability:RMEasurement
on page 217

"APSD" Automatic power save delivery (APSD) is supported
(energy-saving function).

[:SOURce<hw>]:BB:WLNN:
FBLock<ch>:
BFConfiguration:
CAPability:APSD on page 214

"Short Slot
Time"

Short slot time is supported (reduces the slot time
resulting in higher throughput (used at IEEE802.11g).
The AP only uses short slot time when all clients
support short slot time).

[:SOURce<hw>]:BB:WLNN:
FBLock<ch>:
BFConfiguration:
CAPability:SSTime
on page 218

"QoS" Quality of service (QoS) is supported (takes care that
important applications always get enough band-
width).

[:SOURce<hw>]:BB:WLNN:
FBLock<ch>:
BFConfiguration:
CAPability:QOS on page 217

"Spectrum
Mgmt"

Spectrum management is enabled (the process of
regulating the use of radio frequencies).

[:SOURce<hw>]:BB:WLNN:
FBLock<ch>:
BFConfiguration:
CAPability:SMGMt on page 217

"Channel Agil-
ity"

Channel agility is enabled (overcomes some inherent
difficulty with a tone jammer).

[:SOURce<hw>]:BB:WLNN:
FBLock<ch>:
BFConfiguration:
CAPability:CAGility
on page 214

"PBCC" Packet binary convolutional coding (PBCC) is
allowed (a modulation mode for IEEE 802.11g).

[:SOURce<hw>]:BB:WLNN:
FBLock<ch>:
BFConfiguration:
CAPability:PBCC on page 216

"Short Pream-
ble"

Short preamble is allowed (uses 56 instead of 128
bits for the "sync" field. Created to improve WLAN
efficiency).

[:SOURce<hw>]:BB:WLNN:
FBLock<ch>:
BFConfiguration:
CAPability:SPReamble
on page 217

"Privacy" Privacy mode is enabled (thus encryption is required
for all data frames).

[:SOURce<hw>]:BB:WLNN:
FBLock<ch>:
BFConfiguration:
CAPability:PRIVacy
on page 216

"CF-Poll
Request"

Contention-free poll is requested (indicates how the
AP handles poll requests).

[:SOURce<hw>]:BB:WLNN:
FBLock<ch>:
BFConfiguration:
CAPability:CPRequest
on page 215
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Function
name

If enabled this function indicates that: SCPI command

"CF Pollable" The node can use the point coordination function
(PCF), as opposed to the distributed coordination
function (DCF). PCF is a method of coordinating
wireless transmissions in which one station notifies
other stations when they can broadcast.

[:SOURce<hw>]:BB:WLNN:
FBLock<ch>:
BFConfiguration:
CAPability:CPOLlable
on page 214

"IBSS" The network is an independent basic service set
(IBSS) type network. IBSS is an operation mode of a
WLAN. An IBSS does not need an AP. The wireless
clients directly connect with each other. This mode is
also named ad hoc mode.

[:SOURce<hw>]:BB:WLNN:
FBLock<ch>:
BFConfiguration:
CAPability:IBSS on page 215

"ESS" The network is an extended service set (ESS) type
network (ESS is a set of connected BSSs. APs in an
ESS are connected by a distribution system. Each
ESS has an ID called the SSID which is a 32-byte
(maximum) character string).

[:SOURce<hw>]:BB:WLNN:
FBLock<ch>:
BFConfiguration:
CAPability:ESS on page 215

3.6.4.3  ERP parameters

Access:

1. Select "IEEE 802.11 > Frame Blocks".

2. Select "Type > Beacon".

3. Select "PPDU > Config...".

4. Select "MAC Header & FCS > ERP".

The dialog provides extended rate PHY (ERP) settings.
The ERP parameters indicate special features/modes.

Settings:

ERP Parameters........................................................................................................... 86
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ERP Parameters

Function
name

If enabled this function indicates that: SCPI command

"Barker Pre-
amble Mode"

Associated stations have to use the long preamble (in
IEEE802.11g networks). If all stations can receive
short preambles, disable "Barker Preamble Mode"
and all stations use short preambles for efficiency.

[:SOURce<hw>]:BB:WLNN:
FBLock<ch>:
BFConfiguration:ERP:
BPMode on page 218

"Use Protec-
tion"

A station not IEEE802.11g-capable (usually stations
equipped with IEEE802.11b or IEEE802.11) is associ-
ated to the network and thus all stations have to
enable use protection.

You can activate "Use Protection", if "NonERP Pres-
ent" is activated.

[:SOURce<hw>]:BB:WLNN:
FBLock<ch>:
BFConfiguration:ERP:
UPRotection on page 219

"NonERP
Present"

A non-ERP station is present in the network. [:SOURce<hw>]:BB:WLNN:
FBLock<ch>:
BFConfiguration:ERP:
NEPResent on page 219

3.6.4.4  HT capability information

Access:

1. Select "IEEE 802.11 > Frame Blocks".

2. Select "Type > Beacon".

3. Select "PPDU > Config...".

4. Select "MAC Header & FCS > HT Capability".

The dialog provides HT capability information.
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Settings:

State..............................................................................................................................87
Green Field................................................................................................................... 87

State
Activates/ deactivates the HT capability information element.
Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:BFConfiguration:HTCapability:
STATe on page 218

Green Field
If enabled, the function indicates that the reception of PPDUs with HT Greenfield for-
mat is supported.
Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:BFConfiguration:HTCapability:
GFIeld on page 218

3.6.5  Trigger frame settings

Access:

1. Select "IEEE 802.11 > Frame Blocks".

2. Set "Type > Trigger"

3. Select "PPDU > Config...".

4. Select "MAC Header & FCS".

The dialog provides the trigger frame settings, including settings for the common
info field, user info field and additional info settings.

Common Info field and User Info field variants

Common info field bits B54 and B55 specify User Info field variants (HE or EHT) in trig-
ger based (TB) PPDU types. For the EHT variant of the User Info field you can define
the presence of the Special User Info field, see the table below.

Common Info
field B54

Common Info
field B55

User Info field
B39

Special User
Info field

User Info field TB PPDU type

1 1 0 Not present HE variant HE

0 0 0 Present EHT variant EHT

0 0 1 Present EHT variant EHT

1 0 1 Present EHT variant EHT

1 0 0 Not present HE variant HE
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For details, see the specifications of the WLAN standards IEEE Std 802.11be™-2023
and IEEE Std 802.11ax™-2021.

Settings:

● Common info field................................................................................................... 88
● User info field.......................................................................................................... 92
● Additional info settings............................................................................................ 95

3.6.5.1  Common info field

Access:

1. Select "IEEE 802.11 > Frame Blocks".

2. Set "Type > Trigger"

3. Select "PPDU > Config...".

4. Select "MAC Header & FCS" > "Common Info".

This dialog provides common info field settings of the trigger frame settings.

Settings:

Trigger Frame Type.......................................................................................................89
Trigger Type.................................................................................................................. 89
Length........................................................................................................................... 89
Cascade Indication........................................................................................................89
CS Required..................................................................................................................89
BW................................................................................................................................ 89
GI LTF........................................................................................................................... 90
MU-MIMO LTF Mode.....................................................................................................90
Num HE-LTF Symbols...................................................................................................90
STBC.............................................................................................................................90
LDPC Ext Symb Seg.....................................................................................................90
AP Tx Power................................................................................................................. 90
Packet Extension.......................................................................................................... 91
Spatial Reuse................................................................................................................91
Doppler..........................................................................................................................91
HE-SIG-A Reserved......................................................................................................91
HE/EHT P160................................................................................................................91
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Special User Info Field Present.....................................................................................91
Rsv................................................................................................................................ 92
Trigger Dependent Common Info..................................................................................92

Trigger Frame Type
Sets the trigger frame type and the bits in the trigger type subfield as described in
Table 3-12.
Table 3-12: Trigger frame type and trigger type subfield values

Trigger frame type 4-bit "Trigger Type" subfield

BASIC 0000

MU-RTS 0011

BSRP (Buffer Status Report Poll) 0100

Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:TFConfig:CINFo:
TFTYpe on page 209

Trigger Type
Specifies the type of trigger frame.
Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:TFConfig:CINFo:
TTYPe? on page 209

Length
Specifies the value of the L-SIG length field.
Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:TFConfig:CINFo:LEN
on page 209

Cascade Indication
If set to 1, then there is a subsequent trigger frame.
Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:TFConfig:CINFo:
CINDication on page 209

CS Required
If set to 1, the stations identified in the user field can sense the medium state and con-
sider the nav in determining if to respond or not.
Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:TFConfig:CINFo:
CSRequired on page 209

BW
Specifies the bandwidth. It can have the following values:
● 0: corresponds to a bandwidth of 20 MHz
● 1: corresponds to a bandwidth of 40 MHz
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● 2: corresponds to a bandwidth of 80 MHz
● 3: corresponds to a bandwidth of 80+80 MHz or 160 MHz
Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:TFConfig:CINFo:BW
on page 209

GI LTF
Specifies the GI and HE-LTF. It can have the following values:
● 0: corresponds to a value of 1xLTF + 1.6µs GI
● 1: corresponds to a value of 2xLTF + 0.8µs GI
● 2: corresponds to a value of 2xLTF + 1.6µs GI
● 3: corresponds to a value of 4xLTF + 3.2µs GI
Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:TFConfig:CINFo:GILTf
on page 209

MU-MIMO LTF Mode
Specifies the LTF mode of the UL MU-MIMO.
Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:TFConfig:CINFo:
MLTFmode on page 209

Num HE-LTF Symbols
Specifies the number of HE-LTF symbols present.
Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:TFConfig:CINFo:
NHLSym on page 209

STBC
If set to 1, STBC encoding is used for the HE trigger-based PPDU response. Other-
wise the value is set to 0.
Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:TFConfig:CINFo:STBC
on page 209

LDPC Ext Symb Seg
If set to 1, LDPC extra symbol is present. Otherwise the value is set to 0.
Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:TFConfig:CINFo:
LESSeg on page 209

AP Tx Power
Specifies the combined average power per 20 MHz bandwidth of all antennas that
transmitted the trigger frame.
Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:TFConfig:CINFo:TXPow
on page 209

MAC header and FCS configuration for frame block



WLAN configuration and settingsR&S®SMW-K54/-K86/-K142/-K147

91User Manual 1175.6749.02 ─ 28

Packet Extension
Specifies the packet extension duration.
Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:TFConfig:CINFo:
PEXTension on page 209

Spatial Reuse
Specifies the value of the spatial reuse of the HE trigger-based PPDU transmitted as a
response to a trigger frame.
Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:TFConfig:CINFo:
SPAReuse on page 209

Doppler
Specifies a high Doppler mode of transmission.
Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:TFConfig:CINFo:
DOPPler on page 209

HE-SIG-A Reserved
Requires HE frames: "Tx Mode" > "HE-x"
Specifies the value of the reserved bits in the HE-SIG-A field.
Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:TFConfig:CINFo:
HREServed on page 209

HE/EHT P160
Requires EHT frames: "Tx Mode" > "EHT-x"
Sets the 1-bit value of the HE/EHT P160 field.
Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:TFConfig:CINFo:HEEHt
on page 209

Special User Info Field Present
Specifies if the Special User Info field is present in the trigger frame or not.
The presence of this field affects the subfield settings in the User Info field, see the
table below.

Special User Info field Affected User Info subfields

Present "PS160"

Not present "PHY Version ID", "UL Band Extension", "Spatial Reuse1"/"Spatial
Reuse2", "U-SIG Disregard And Validate"

For related settings, see Chapter 3.6.5.2, "User info field", on page 92.
"1" Special User Info field is present.
"0" Special User Info field is not present.
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Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:TFConfig:CINFo:
SUIPresent on page 209

Rsv
Specifies the value of the reserved bits in the "Rsv" field.
For EHT frames, configure up to 8-bit values for the reserved bits.
Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:TFConfig:CINFo:RSV
on page 209
[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:TFConfig:CINFo:
EREServed on page 209

Trigger Dependent Common Info
The value of this field depends on the trigger variant. It is present for MU-BAR frame
formats.
Remote command: 
n.a.

3.6.5.2  User info field

Access:

1. Select "IEEE 802.11 > Frame Blocks".

2. Set "Type > Trigger"

3. Select "PPDU > Config...".

4. Select "MAC Header & FCS > User Info".

This dialog provides user info field settings of the trigger frame settings.

Settings:

No. Of User Info............................................................................................................ 93
User Info........................................................................................................................93
AID12............................................................................................................................ 93
RU Allocation................................................................................................................ 93
Coding Type.................................................................................................................. 93
MCS.............................................................................................................................. 93
DCM.............................................................................................................................. 94
SS Allocation.................................................................................................................94
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Target RSSI...................................................................................................................94
PS160........................................................................................................................... 94
PHY Version ID............................................................................................................. 94
UL Band Extension....................................................................................................... 94
Spatial Reuse1/Spatial Reuse2.................................................................................... 94
U-SIG Disregard And Validate.......................................................................................95
Rsv................................................................................................................................ 95
Trigger Dependent User Info.........................................................................................95

No. Of User Info
Sets the number of "User Info" fields in the trigger frame.
You can set up to 37 fields.
Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:TFConfig:NUINfo
on page 209

User Info
"No. Of User Info = 1": Displays the "User Info = 0" field.
"No. Of User Info > 1": Selects the "User Info x" field, where "x = 1 to 36".
Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:TFConfig:NUINfo
on page 209

AID12
Carries the least significant 12 of the AID of the STA.
Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:TFConfig:UINFo<st0>:
AID on page 209

RU Allocation
Specifies the RU used by the HE trigger-based PPDU of the STA, which is identified by
the "AID12" field value.
Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:TFConfig:UINFo<st0>:
RUALlocation on page 210

Coding Type
Specifies the code type. The value 0 indicates a BCC coding and 1 LDPC.
Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:TFConfig:UINFo<st0>:
CODType on page 210

MCS
Specifies the MCS.
Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:TFConfig:UINFo<st0>:
MCS on page 210
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DCM
Specifies the dual carrier modulation. If the value is 0, then no DCM is used.
Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:TFConfig:UINFo<st0>:
DCM on page 210

SS Allocation
Specifies the spatial streams. This field contains 3 bits that specify the starting spatial
stream and 3 bits that specify the number of spatial streams.
Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:TFConfig:UINFo<st0>:
SSALlocation on page 210

Target RSSI
Specifies the target received signal power.
Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:TFConfig:UINFo<st0>:
TRSSi on page 210

PS160
Requires "Special User Info Field Present" > "1", see "Special User Info Field Present"
on page 91.
Sets the 1-bit value of the PS160 field.
Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:TFConfig:UINFo<st0>:
PS160 on page 210

PHY Version ID
Requires "Special User Info Field Present" > "0", see "Special User Info Field Present"
on page 91.
Specifies the 3-bit value of the PHY Version ID field.
Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:TFConfig:UINFo<st0>:
PVI on page 210

UL Band Extension
Requires "Special User Info Field Present" > "0", see "Special User Info Field Present"
on page 91.
Specifies the 2-bit value of the UL Band Extension field.
Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:TFConfig:UINFo<st0>:
UBEXtension on page 210

Spatial Reuse1/Spatial Reuse2
Requires "Special User Info Field Present" > "0", see "Special User Info Field Present"
on page 91.
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Specifies the 4-bit values of the Spatial Reuse1 and Spatial Reuse2 fields.
Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:TFConfig:UINFo<st0>:
SPRFirst on page 210
[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:TFConfig:UINFo<st0>:
SPRSecond on page 210

U-SIG Disregard And Validate
Requires "Special User Info Field Present" > "0", see "Special User Info Field Present"
on page 91.
Specifies the 12-bit value of the U-SIG Disregard And Validate field.
Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:TFConfig:UINFo<st0>:
UDV on page 210

Rsv
Specifies the value of reserved bits in the "Rsv" field.
Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:TFConfig:UINFo<st0>:
RSV on page 210
[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:TFConfig:UINFo<st0>:
UREServed on page 210

Trigger Dependent User Info
The value of this field depends on the trigger variant.
Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:TFConfig:UINFo<st0>:
TDUSerinfo on page 210

3.6.5.3  Additional info settings

Access:

1. Select "IEEE 802.11" > "Frame Blocks".

2. Set "Type" > "Trigger"

3. Select "PPDU" > "Config...".

4. Select "MAC Header & FCS" > "Additional Info".

This dialog provides additional info settings of the trigger frame settings.
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Settings:

MPDU EOF................................................................................................................... 96
Min Trigger Process Time............................................................................................. 96
Padding Length............................................................................................................. 96

MPDU EOF
Selects the end of frame (EOF) tag.
Tagged/untagged indication is set in the 1-bit EOF/Tag field of an MPDU.
"EOF 0" End of frame is untagged.
"EOF 1" End of frame is tagged.
Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:TFConfig:EOF
on page 210

Min Trigger Process Time
Sets minimum time to process the trigger frame in microseconds.
Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:TFConfig:TPTime
on page 211

Padding Length
Displays the padding length of a trigger frame in bytes.
Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:TFConfig:PADLength
on page 211

3.7  Spatial mapping

Access:

1. Select "Frame Blocks > PPDU > Config".
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2. Select "Spatial Mapping".

The dialog provides settings to configure the spatial mapping mode, the time shifts
and the transmit parameters.

The WLAN standard IEEE 802.11 builds upon previous 802.11 standards by adding
MIMO (multiple-input multiple-output). MIMO uses multiple transmitter and receiver
antennas for increased data throughput via spatial multiplexing and increased range by
exploiting the spatial diversity. Mode, time shifts and transmit parameters are defined in
the "Spatial Mapping for Frame Block" dialog.

When loaded, the spatial mapping dialog shows the frame block number for which this
spatial mapping dialog is loaded. The transmit matrix corresponding to index k has NTX

rows (representing the number of transmit antennas) and NSTS columns (representing
the space time streams). The text label shows the spatial mapping mode selected in
the dialog which is updated whenever the mode changes. For "Physical Layer" >
"Sounding", a second submatrix horizontally sided to the transmit matrix with NTX rows
and NESS columns is used as a transmit matrix for the extended long training fields
(ELTF). The values displayed for the transmit matrices are also normalized (internally)
so that the expectation of IQ sum-power of all antennas is 0 dBr. Also for "OFF",
"Direct", and "Spatial Expansion", the expected IQ power is the same for all antennas
and hence these modes can be intermixed without caring about any power regulation
issue. Relative RMS levels are displayed in the dialog for each antenna.

Settings:

Mode............................................................................................................................. 98
Index k...........................................................................................................................98
Time Shift...................................................................................................................... 98
I (Transmit Matrix)......................................................................................................... 98
Q (Transmit Matrix)....................................................................................................... 99
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Mode
Selects the spatial mapping mode for the selected frame block. The matrix element
values are loaded using Info Class Methods.
"Off" (available only for "Physical Mode > Legacy" frame)

The spatial mapping mode is switched off automatically.
"Direct" (available only for "Physical Mode > Mixed Mode" or "Physical Mode

> Green Field" when NTX = NSTS)
Sets the spatial mapping to "Direct" mode.
The transmit matrix is a CSD matrix, that is, a diagonal matrix of unit
magnitude and complex values that represent cyclic shifts in the time
domain.

"Indirect" (available only for "Physical Mode > Mixed Mode" or "Physical Mode
> Green Field" )
In indirect mode, the transmit matrix is the product of a CSD matrix
and the Hadamard unitary matrix.

"Expansion" Requires "Physical Mode > Mixed Mode" or "Physical Mode > Green
Field".
In expansion mode, the transmit matrix is the product of a CSD matrix
and a square matrix formed of orthogonal columns, as defined in the
IEEE 802.11 specification.

Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:SMAPping:MODE on page 219

Index k
Sets the index of the subcarrier. A matrix is mapped to each subcarrier.
Except for k = 0, the index can be set in the following ranges:
● 20 MHz channel, e.g. HT-20 MHz: -32 ... 31
● 40 MHz channel, e.g. VHT-40 MHz: -64 ... 63
● 80 MHz channel, e.g. VHT-80 MHz: -128 ... 127
● 160 MHz channel, e.g. VHT-160 MHz: -256 ... 255
Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:SMAPping:INDex on page 220

Time Shift
Sets the spatial mapping time shift. This value is relevant for spatial mapping mode
"Direct" and "Spatial Expansion" only.
Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:SMAPping:TSHift<st> on page 220

I (Transmit Matrix)
Displays the time shift value of element I of the selected row and column of the spatial
transmit matrix.
Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:SMAPping:ROW<st>:COL<dir>:I?
on page 221

Spatial mapping



WLAN configuration and settingsR&S®SMW-K54/-K86/-K142/-K147

99User Manual 1175.6749.02 ─ 28

Q (Transmit Matrix)
Displays the time shift value of element Q of the selected row and column of the spatial
transmit matrix.
Remote command: 
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:SMAPping:ROW<st>:COL<dir>:Q?
on page 221

Spatial mapping
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4  How to work with the IEEE 802.11 WLAN
option
The R&S SMW equipped with the option digital standard IEEE 802.11 WLAN allows
you to generate signals for different transmitter and receiver tests scenarios.

The following step-by-step instructions provide examples of some typical generic work-
flows and setups for working with this options.

4.1  Generating a 160 MHz 2x2 WLAN 802.11ax signal

The IEEE 802.11ac/ax uses MIMO technology, up to 160 MHz bandwidth and special
coding for increased throughput. The following options are required for the generation
of such a signal:
● Option standard baseband generator (R&S SMW-B10)
● Option R&S SMW-B13T
● Frequency option (e.g. R&S SMW-B1003 and R&S SMW-B2003)
● 2x option baseband extension to 160 MHz RF bandwith (R&S SMW-K522)
● 2x option WLAN IEEE802.11ac/ax (R&S SMW-K86/142)
● Optional, 2x option fading simulator (R&S SMW-B14)
● Optional, option fading MIMO (R&S SMW-K74)
● Optional, option AWGN (R&S SMW-K62)

The following step-by step instruction describes how to configure the instrument for
generating a 160 MHz 2x2 WLAN 802.11ac signal.

To configure the R&S SMW for a 160 MHz 2x2 MIMO WLAN 802.11ac/ax signal
generation

1. Configure the basebands in the "System Configuration > Fading/Baseband Config"
dialog to generate a 1x2x2 coupled sources signal.
For a detailed description of how to do that, refer to the R&S SMW user manual.

2. Configure the reference oscillator settings, depending on whether an external refer-
ence source is provided.
Select "External Reference Frequency Source" and configure the "Synchronization
Bandwidth" and the "External Reference Frequency" accordingly.

3. Set the power level and the frequency in the header display of the instrument.

4. Select an "IEEE 802.11 WLAN > Trigger in > Source > External Global Trigger".

5. In the "IEEE 802.11 WLAN > General > Transmit Antenna Setup" dialog set the
transmit antennas:

a) Set "Antennas > = 2".
b) Set "Output > O1 > Baseband A" and "Output > O2 > Baseband B".

Generating a 160 MHz 2x2 WLAN 802.11ax signal



How to work with the IEEE 802.11 WLAN optionR&S®SMW-K54/-K86/-K142/-K147

101User Manual 1175.6749.02 ─ 28

6. Set "IEEE 802.11 WLAN > General > Transmission Bandwith > 160 MHz".

7. Set the frame block in the "IEEE 802.11 WLAN > Frame Block Configuration" dia-
log:

a) Set "Std.> 11ac/ax".
b) Set the required "Type" and "Physical Mode" of the frame block.
c) Set "Tx Mode > VHT-160 MHz"/"Tx Mode > HE-160 MHz".
d) For "Type > Data" and "Physical Mode > Mixed Mode" set "Data > A-MPDU".
e) Set "State > ON".
f) Use the default "IEEE 802.11 WLAN > Frame Block Configuration > PPDU

Configuration" settings or adjust them if necessary to, for instance, add redun-
dancy.

8. Enable the WLAN 802.11ac/ax signal generation.

9. (optional)
The signal can be additionally fed to a fading simulator.
An example of how to configure the fading simulator is given below. For a detailed
description, refer to the R&S SMW user manual.

a) In the "Fading" configuration dialog select "General > Standard > 802.11ac-
MIMO > Modell A".

b) Set "State > On".

10. (optional)
In the block diagram select "AWGN > On".
For a detailed description of how to do that, refer to the R&S SMW user manual.

11. In the block diagram select "RF A > On" and "RF B > On".
For a detailed description of how to do that, refer to the R&S SMW user manual.

4.2  Generating a 3x3 MIMO WLAN 802.11n signal with a
R&S SMW for transmitter tests

This example shows the connection and configuration of the instrument for the genera-
tion of a 3x3 MIMO WLAN 802.11n signal for transmitter tests.

The 3x3 MIMO WLAN 802.11n signal generation scenario requires one two-path
instrument and a signal generator that provides the third RF Path, like the R&S SGS.

● Option standard baseband generator (R&S SMW-B10)
● Option R&S SMW-B13T
● Frequency option (e.g. R&S SMW-B1003 and R&S SMW-B2003)
● 2x option baseband extension to 160 MHz RF bandwith (R&S SMW-K522)
● 2x option WLAN IEEE802.11n (R&S SMW-K54)
● Optional, 4x option fading simulator (R&S SMW-B14)
● Optional, option fading MIMO (R&S SMW-K74)

Generating a 3x3 MIMO WLAN 802.11n signal with a R&S SMW for transmitter tests
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● Optional, option AWGN (R&S SMW-K62)

The instruments have to be configured and connected as described in the following
section.

Connecting a R&S SGS and a R&S SMW for 3x3 MIMO WLAN 802.11n signal gen-
eration

Connect the instruments as described below:

1. Connect the [I OUT 1/Q OUT 1] connectors of the R&S SMW to the [I IN / Q IN]
connectors of the R&S SGS.

2. To provide the R&S SGS with reference frequency, connect the input [REF IN] of
the instrument to the "REF OUT" connector of the R&S SMW.

3. Provide an external trigger signal to the input [USER 3] of the R&S SMW.

4. Avoid unnecessary cable lengths and branching points.

The figure below shows the cabling of a two-path R&S SMW and a R&S SGS for
the generation of a 3x3 MIMO WLAN 802.11n signal.

Figure 4-1: Setup for tests with three antennas (Example of R&S SMW and a R&S SGS)

Configure the R&S SMW for 3x3 MIMO WLAN 802.11n signal generation

1. Connect the R&S SGS in the "System Configuration > External RF and I/Q > I/Q
OUT 1 > External Instrument > Config...".
For a detailed description of how to do that, refer to the R&S SMW user manual.

2. Configure the basebands in the "System Configuration > Fading/Baseband Config"
dialog to generate a 1x3x3 coupled source signal.
For a detailed description of how to do that, refer to the R&S SMW user manual.

3. Configure the reference oscillator settings, depending on whether an external refer-
ence source is provided.

Generating a 3x3 MIMO WLAN 802.11n signal with a R&S SMW for transmitter tests
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Select "External Reference Frequency Source" and configure the "Synchronization
Bandwidth" and the "External Reference Frequency" accordingly.
For a detailed description of how to do that, refer to the R&S SMW user manual.

4. Set the power level and the frequency in the header display of the instrument.

5. Select an "IEEE 802.11 WLAN > Trigger in > Source > External Global Trigger 1".

6. In the "IEEE 802.11 WLAN > General > Transmit Antenna Setup" dialog set the
transmit antenna:

a) Set "Antennas > =3".
b) Set "Output > O1 > Baseband A", "Output > O2 > Baseband B" and "Output >

O3 > Baseband C".

7. To enable the R&S SMW to generate a WLAN 802.11n/802.11ac signal of anten-
nas with different power level, set the power level of the corresponding path to the
desired level in the header display of the instrument.

8. Set the frame block in the "IEEE 802.11 WLAN > Frame Block Configuration" dia-
log:

a) Set "Std.> 11n".
b) Set the required "Type" and "Physical Mode" of the frame block.
c) Set "State > ON".
d) Use the default "IEEE 802.11 WLAN > Frame Block Configuration > PPDU

Configuration" settings or adjust them if necessary to, for instance, add redun-
dancy.

9. Enable the WLAN 802.11n signal generation.

10. (optional)
The signal can be additionally fed to a fading simulator.
An example of how to configure the fading simulator is given below. For a detailed
description, refer to the R&S SMW user manual.

a) In the "Fading" configuration dialog select "General > Standard > 802.11n-
MIMO > Modell A".

b) Set "State > On".

11. (optional)
In the block diagram select "AWGN > On".
For a detailed description of how to do that, refer to the R&S SMW user manual.

12. In the block diagram select "I/Q Analog A > On", "RF A > On" and "RF B > On".
For a detailed description, refer to the R&S SMW user manual.

Generating a 3x3 MIMO WLAN 802.11n signal with a R&S SMW for transmitter tests
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4.3  Generating a realistic MxN MIMO WLAN 802.11n/ac/p
signal for receiver test under static conditions

This example shows you how to enable the R&S SMW to generate a WLAN 802.11n/
802.11ac/802.11p signal for simple diversity and simulation of frequency flat MIMO
channel conditions. No additional channel simulator is necessary for this test applica-
tion.

The figure below shows an example of a simple diversity scenario with three transmis-
sion antennas Tx1..Tx3 and one receiving antenna Rx1. The channel is represented by
the weight coefficients w1 .. w3.

The R&S SMW provides the possibility to weight, sum and map the generated Tx
antenna signals to the output(s) of the signal generator, i.e. to simulate a frequency flat
MIMO channel conditions for single carrier analysis e.g. BER tests.

To generate a realistic WLAN 802.11n/802.11ac/802.11p MIMO signal under static con-
ditions, configure the instrument(s) as follows:

1. In the "Frame Block Configuration" dialog set the "Std." for the required standard.

2. Use the default "Frame Block Configuration" settings or adjust them as required.

3. Use the default "PPDU Configuration" settings or adjust them if necessary to, for
instance, add redundancy.

Generating a realistic MxN MIMO WLAN 802.11n/ac/p signal for receiver test under static conditions
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4. In the "Transmit Antenna Setup" dialog, select the number of "Tx Antennas" to be
simulated. The number of the Tx Antennas determines the value M in the MxN
MIMO system and the number of the transmission chains.

5. Configure the subcarrier to be analyzed, i.e. configure the "Spatial Mapping Mode"
and set the "Time Shifts".

1

7 6 5 4

2

3

1, 2, 3 = Transmission antennas Tx1 to Tx3
4 = Extended spatial stream
5, 6, 7 = Space time stream 3 to 1

6. In the Tx Antenna Setup dialog, enable the Baseband to generate the Rx1 signal.

7. Select the mapping coordinates and adjust the weights of the Tx signals in the
Transmission Chain Matrix.

w1 w2 w3

31 2

7 6 5 4

+ +

Generating a realistic MxN MIMO WLAN 802.11n/ac/p signal for receiver test under static conditions
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1, 2, 3 = Transmission antennas Tx1 to Tx3
4, 5, 6 = Weigthing factors w1 to w3
7 = Baseband output for receiving antenna Rx1

8. To enable the R&S SMW to generate a WLAN 802.11n/802.11ac/802.11p signal of
antennas with different power level, set the power level of the corresponding path
to the desired level in the header display of the instrument.

9. Enable signal generation.

The Baseband of the R&S SMW will generate the Rx signal as a sum of the three Tx
signals, weighted with the selected coefficients.

4.4  Generating a realistic MxN MIMO WLAN 802.11n/ac/p
signal for receiver test under real word conditions

The simulation of real-time MIMO channel condition requires instruments equipped
with the fading options R&S SMW-K74/-B14.

The instruments have to be configured as follows:

1. Enable the instrument to generate a 2xN, 3xN or 4xN MIMO WLAN 802.11n/
802.11ac/802.11p signal as described in Chapter 4.2, "Generating a 3x3 MIMO
WLAN 802.11n signal with a R&S SMW for transmitter tests", on page 101.

2. Enable the instrument to generate 2xN, 3xN or 4xN MIMO fading signal. Refer to
section "Multiple Input Multiple Output" in the description of the Fading Simulator.

Generating a realistic MxN MIMO WLAN 802.11n/ac/p signal for receiver test under real word conditions
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5  Signal control and signal characteristics
This section lists settings provided for configuring the baseband filter, for defining the
signal generation start and for generating signals necessary for synchronization with
other instruments.

Settings:

● Filter/clipping settings............................................................................................107
● Trigger settings......................................................................................................112
● Marker settings......................................................................................................117
● Clock settings........................................................................................................121
● Local and global connectors settings....................................................................123

5.1  Filter/clipping settings

Access:

► Select "IEEE 802.11 > General > Filter/Clipping Settings".

This dialog provides settings to configure the baseband filter and clipping.

5.1.1  Filter settings

Access:

► Select "Filter/Clipping Settings > Filter".

The dialog comprises the settings, necessary to configure the baseband filter.

Filter/clipping settings
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Settings

Use Default Wlan Filter............................................................................................... 108
Filter............................................................................................................................ 108
Roll Off Factor or BxT..................................................................................................108
Cut Off Frequency Factor............................................................................................109
Cut Off Frequency Shift...............................................................................................109
Sample Rate Variation.................................................................................................109
IFFT Upsampling.........................................................................................................109

Use Default Wlan Filter
Requires "Transmission Bandwidth > 40 MHz" or higher.
Activates the WLAN default filter. The default filter setting is optimized to achieve best
possible EVM results while complying with the spectrum emission mask.
Remote command: 
[:SOURce<hw>]:BB:WLNN:FILTer:DEFSetting:STATe on page 132

Filter
Selects the baseband filter.
Remote command: 
[:SOURce<hw>]:BB:WLNN:FILTer:TYPE on page 136

Roll Off Factor or BxT
Sets the roll-off factor
The rolloff factor affects the steepness of the filter slopes. A "Rolloff Factor = 0" results
in the steepest slopes; values near to 1 make the slopes more flat.

Figure 5-1: Example of the frequency response of a filter with different roll off factors

For the default cosine filter, a roll-off factor of 0.10 is used.
Remote command: 
[:SOURce<hw>]:BB:WLNN:FILTer:PARameter:APCO25 on page 133
[:SOURce<hw>]:BB:WLNN:FILTer:PARameter:COSine on page 133
[:SOURce<hw>]:BB:WLNN:FILTer:PARameter:GAUSs on page 134
[:SOURce<hw>]:BB:WLNN:FILTer:PARameter:PGAuss on page 135
[:SOURce<hw>]:BB:WLNN:FILTer:PARameter:RCOSine on page 135
[:SOURce<hw>]:BB:WLNN:FILTer:PARameter:SPHase on page 135

Filter/clipping settings



Signal control and signal characteristicsR&S®SMW-K54/-K86/-K142/-K147

109User Manual 1175.6749.02 ─ 28

Cut Off Frequency Factor
Sets the value for the cutoff frequency factor. The cutoff frequency of the filter can be
adjusted to reach spectrum mask requirements.
Remote command: 
[:SOURce<hw>]:BB:WLNN:FILTer:PARameter:LPASs on page 134
[:SOURce<hw>]:BB:WLNN:FILTer:PARameter:LPASSEVM on page 134

Cut Off Frequency Shift
Requires "Filter > Cosine".
The cutoff frequency is a filter characteristic that defines the frequency at the 3 dB
down point. The "Cut Off Frequency Shift" affects this frequency in the way that the fil-
ter flanks are "moved" and the transition band increases by "Cut Off Frequency
Shift"*"Sample Rate".
● A "Cut Off Frequency Shift" = -1 results in a very narrow-band filter
● Increasing the value up to 1 makes the filter more broad-band
● By "Cut Off Frequency Shift" = 0, the -3 dB point is at the frequency determined by

the half of the selected "Sample Rate".
Tip: Use this parameter to adjust the cutoff frequency and reach spectrum mask
requirements.

Figure 5-2: Example of the frequency response of a filter with different cutoff frequency shift

Remote command: 
[:SOURce<hw>]:BB:WLNN:FILTer:PARameter:COSine:COFS on page 133

Sample Rate Variation
Sets the sample rate of the signal.
A variation of this parameter only affects the ARB clock rate; all other signal parame-
ters remain unchanged. If the sampling rate in the frame configuration menu is
changed, this parameter is reset to the chosen sampling rate.
Remote command: 
[:SOURce<hw>]:BB:WLNN:SRATe:VARiation on page 136

IFFT Upsampling
Activates inverted Fast Fourier Transformation (IFFT) upsampling.

Filter/clipping settings
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Remote command: 
[:SOURce<hw>]:BB:WLNN:FILTer:IUPSampling on page 133

5.1.2  Clipping settings

Access:

► Select "Filter/Clipping Settings > Clipping".

The dialog comprises the settings, necessary to configure the clipping.

Settings

Clipping State.............................................................................................................. 110
Clipping Level.............................................................................................................. 111
Clipping Mode..............................................................................................................111
Clip Signal Fields to Payload Max Peak......................................................................111

Clipping State
Switches baseband clipping on and off.
Baseband clipping is a simple and effective way of reducing the crest factor of the sig-
nal. Since clipping is done before to filtering, the procedure does not influence the
spectrum. The EVM however increases.
WLAN signals can have high crest factors. High crest factors entail two basic prob-
lems:
● The nonlinearity of the power amplifier (compression) causes intermodulation

which expands the spectrum (spectral regrowth).
● Since the level in the D/A converter is relative to the maximum value, the average

value is converted with a relatively low resolution. Low resolution conversion
results in a high quantization noise.

Both effects increase the adjacent-channel power.
With baseband clipping, all the levels are limited to a settable value ("Clipping Level").
This level is specified as a percentage of the highest peak value. Since clipping is done
before filtering, the procedure does not influence the spectrum. The EVM however
increases.

Filter/clipping settings
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Since clipping the signal not only changes the peak value but also the average value,
the effect on the crest factor is unpredictable. The following table shows the effect of
the "Clipping" on the crest factor for typical scenarios.
Remote command: 
[:SOURce<hw>]:BB:WLNN:CLIPping:STATe on page 132

Clipping Level
Sets the limit for clipping.
This value indicates at what point the signal is clipped. It is specified as a percentage,
relative to the highest level. 100% indicates that clipping does not take place.
Remote command: 
[:SOURce<hw>]:BB:WLNN:CLIPping:LEVel on page 131

Clipping Mode
Selects the clipping method. The dialog displays a graphical illustration on how this two
methods work.
● "Vector | i + jq |"

The limit is related to the amplitude | i + q |. The I and Q components are mapped
together, the angle is retained.

● "Scalar | i | , | q |"
The limit is related to the absolute maximum of all the I and Q values | i | + | q |.
The I and Q components are mapped separately, the angle changes.

Remote command: 
[:SOURce<hw>]:BB:WLNN:CLIPping:MODE on page 131

Clip Signal Fields to Payload Max Peak
Applies vector clipping to fields L-SIG, RL-SIG, U-SIG and EHT-SIG.
Vector clipping is applied, so that the maximum peak of these fields does not exceed
the maximum peak of the payload field.
The method can be useful to reduce the overall crest factor. The signal quality is
mostly not affected because the signal fields are robustly encoded and the EVM mea-
surement at the receiver is only carried out on payload symbols. Low-pass filtering is
applied after clipping, to avoid spectral regrowth.
Remote command: 
[:SOURce<hw>]:BB:WLNN:CLIPping:SPPState on page 132

Filter/clipping settings
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5.2  Trigger settings

Access:

► Select "Baseband" > "IEEE 802.11" > "Trigger In".

This tab provides settings to select and configure the trigger, like trigger source,
trigger mode and trigger delays, and to arm or trigger an internal trigger manually.
The header of the tab displays the status of the trigger signal and trigger mode. As
in the tabs "Marker" and "Clock", this tab provides also access to the settings of the
related connectors.

Routing and activating a trigger signal

1. Define the effect of a trigger event and the trigger signal source.

a) Select "Trigger In" > "Mode".
b) Select "Trigger In" > "Source".

2. For external trigger signals, define the connector for signal input. See Chapter 5.5,
"Local and global connectors settings", on page 123.
You can map trigger signals to one or more USER x or T/M connectors.

Local and global connectors settings allow you to configure the signal mapping, the
polarity, the trigger threshold and the input impedance of the input connectors.

3. Activate baseband signal generation. In the block diagram, set "Baseband" > "On".

The R&S SMW starts baseband signal generation after the configured trigger
event.

About baseband trigger signals

This section focuses on the available settings.

For information on how these settings affect the signal, refer to section "Basics on ..."
in the R&S SMW user manual.

Settings:

Trigger settings common to all basebands..................................................................113
Mode............................................................................................................................113
Signal Duration Unit.....................................................................................................113
Signal Duration............................................................................................................114
Running/Stopped.........................................................................................................114
Time Based Trigger..................................................................................................... 114
Trigger Time................................................................................................................ 114

Trigger settings
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Arm..............................................................................................................................114
Execute Trigger........................................................................................................... 115
Trigger Source.............................................................................................................115
Sync. Output to External Trigger/Sync. Output to Trigger........................................... 115
External Trigger Inhibit................................................................................................ 116
Trigger Delay............................................................................................................... 116

Trigger settings common to all basebands
To enable simultaneous signal generation in all basebands, the R&S SMW couples the
trigger settings in the available basebands in any instrument's configuration involving
signal routing with signal addition. For example, in MIMO configuration, routing and
summing of basebands or of streams.
The icon  indicates that common trigger settings are applied.
You can access and configure the common trigger source and trigger mode settings in
any of the basebands. An arm or a restart trigger event applies to all basebands, too.
You can still apply different delay to each of the triggers individually.

Mode
Selects trigger mode, i.e. determines the effect of a trigger event on the signal genera-
tion.
For more information, refer to chapter "Basics" in the R&S SMW user manual.
● "Auto"

The signal is generated continuously.
● "Retrigger"

The signal is generated continuously. A trigger event (internal or external) causes a
restart.

● "Armed Auto"
The signal is generated only when a trigger event occurs. Then the signal is gener-
ated continuously.
An "Arm" stops the signal generation. A subsequent trigger event (internal or exter-
nal) causes a restart.

● "Armed Retrigger"
The signal is generated only when a trigger event occurs. Then the signal is gener-
ated continuously. Every subsequent trigger event causes a restart.
An "Arm" stops signal generation. A subsequent trigger event (internal or external)
causes a restart.

● "Single"
The signal is generated only when a trigger event occurs. Then the signal is gener-
ated once to the length specified at "Signal Duration".
Every subsequent trigger event (internal or external) causes a restart.

Remote command: 
[:SOURce<hw>]:BB:WLNN[:TRIGger]:SEQuence on page 142

Signal Duration Unit
Defines the unit for describing the length of the signal sequence to be output in the
"Single" trigger mode.
Remote command: 
[:SOURce<hw>]:BB:WLNN:TRIGger:SLUNit on page 140

Trigger settings
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Signal Duration
Requires trigger "Mode" > "Single".
Enters the length of the trigger signal sequence.
Use this parameter, for example, for the following applications:
● To output the trigger signal partly.
● To output a predefined sequence of the trigger signal.
Remote command: 
[:SOURce<hw>]:BB:WLNN:TRIGger:SLENgth on page 140

Running/Stopped
With enabled modulation, displays the status of signal generation for all trigger modes.
● "Running"

The signal is generated; a trigger was (internally or externally) initiated in triggered
mode.

● "Stopped"
The signal is not generated and the instrument waits for a trigger event.

Remote command: 
[:SOURce<hw>]:BB:WLNN:TRIGger:RMODe? on page 139

Time Based Trigger
Requires trigger "Mode" > "Armed Auto"/"Single".
Activates time-based triggering with a fixed time reference.
The R&S SMW triggers signal generation when its operating system time ("Current
Time") matches a specified time trigger ("Trigger Time"). As trigger source, you can
use an internal trigger or an external global trigger.
How to: Chapter "Time-based triggering" in the R&S SMW user manual.
Remote command: 
[SOURce<hw>]:BB:<DigStandard>:TRIGger:TIME[:STATe]

Trigger Time
Requires trigger "Mode" > "Armed Auto"/"Single".
Sets date and time for a time-based trigger signal.
Set a trigger time that is later than the "Current Time". The current time is the operating
system time of the R&S SMW. If you set an earlier trigger time than the current time,
time-based triggering is not possible.
How to: Chapter "Time-based triggering" in the R&S SMW user manual.

"Date" Sets the date of the time-based trigger in format YYYY-MM-DD.
Remote command: 
[SOURce<hw>]:BB:<DigStandard>:TRIGger:TIME:DATE

"Time" Sets the time of the time-based trigger in format hh:mm:ss.
Remote command: 
[SOURce<hw>]:BB:<DigStandard>:TRIGger:TIME:TIME

Arm
Stops the signal generation until subsequent trigger event occurs.

Trigger settings
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Remote command: 
[:SOURce<hw>]:BB:WLNN:TRIGger:ARM:EXECute on page 138

Execute Trigger
For internal trigger source, executes trigger manually.
Remote command: 
[:SOURce<hw>]:BB:WLNN:TRIGger:EXECute on page 138

Trigger Source
The following sources of the trigger signal are available:
● "Internal"

The trigger event is executed manually by the "Execute Trigger".
● "Internal (Baseband A/B)"

The trigger event is provided by the trigger signal from the other basebands.
If common trigger settings are applied, this trigger source is disabled.

● "External Global Trigger"
The trigger event is the active edge of an external trigger signal provided and con-
figured at the USER x connectors.

● "External Local Trigger"
The trigger event is the active edge of an external trigger signal provided and con-
figured at the local T/M/C connector.
With coupled trigger settings, the signal has to be provided at the T/M/C1/2/3 con-
nectors.

● "External Local Clock"
The trigger event is the active edge of an external local clock signal provided and
configured at the local T/M/C connector.
With coupled trigger settings, the signal has to be provided at the T/M/C1 connec-
tor.

● "Baseband Sync In"
Option: R&S SMW-B9
In primary-secondary instrument mode, secondary instruments are triggered by the
active edge of the synchronization signal.

"External Local Clock/Trigger" require R&S SMW-B10.
Remote command: 
[:SOURce<hw>]:BB:WLNN:TRIGger:SOURce on page 141

Sync. Output to External Trigger/Sync. Output to Trigger
Enables signal output synchronous to the trigger event.
● "On"

Corresponds to the default state of this parameter.
The signal calculation starts simultaneously with the trigger event. Because of the
processing time of the instrument, the first samples are cut off and no signal is out-
put. After elapsing of the internal processing time, the output signal is synchronous
to the trigger event.

Trigger settings
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● "Off"
The signal output begins after elapsing of the processing time. Signal output starts
with sample 0. The complete signal is output.
This mode is recommended for triggering of short signal sequences. Short sequen-
ces are sequences with signal duration comparable with the processing time of the
instrument.

In primary-secondary instrument mode, this setting ensures that once achieved, syn-
chronization is not lost if the baseband signal sampling rate changes.
Remote command: 
[:SOURce<hw>]:BB:WLNN:TRIGger:EXTernal:SYNChronize:OUTPut
on page 138

External Trigger Inhibit
Applies for external trigger signal or trigger signal from the other path.
Sets the duration with that any following trigger event is suppressed. In "Retrigger"
mode, for example, a new trigger event does not cause a restart of the signal genera-
tion until the specified inhibit duration does not expire.
For more information, see chapter "Basics" in the R&S SMW user manual.
Remote command: 
[:SOURce<hw>]:BB:WLNN:TRIGger[:EXTernal]:INHibit on page 142
[:SOURce<hw>]:BB:WLNN:TRIGger:OBASeband:INHibit on page 139

Trigger Delay
Delays the trigger event of the signal from:
● The external trigger source
● The other path

Trigger settings
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● The other basebands (internal trigger), if common trigger settings are used.
Use this setting to:
● Synchronize the instrument with the device under test (DUT) or other external devi-

ces
● Postpone the signal generation start in the basebands compared to each other
● Compensate delays and align the signal generation start in multi-instrument setup
For more information, see chapter "Basics on ..." in the R&S SMW user manual.
Remote command: 
[:SOURce<hw>]:BB:WLNN:TRIGger[:EXTernal]:DELay on page 142
[:SOURce<hw>]:BB:WLNN:TRIGger:OBASeband:DELay on page 139

5.3  Marker settings

Access:

► Select "Baseband > IEEE 802.11 > Marker".

The tab provides access to the settings necessary to select and configure the
marker output signal, like the marker mode or marker delay settings.

This section focuses on the available settings.
For information on how these settings affect the signal, refer to section "Basics on ..."
in the R&S SMW user manual.

Routing and enabling a marker
The provided marker signals are not dedicated to a particular connector. They can be
mapped to one or more USER x or T/M connectors.
To route and enable a marker signal, perform the following general steps:
● Define the shape of the generated marker, i.e. select the "Marker > Mode".
● Define the connector where the selected signal is provided.

Use the Local and global connectors settings.

Marker settings
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Settings

Marker Mode............................................................................................................... 118
Marker x Delay............................................................................................................ 121

Marker Mode
Marker configuration for up to 3 markers. The settings are used to select the marker
mode defining the shape and periodicity of the markers. The contents of the dialog
change with the selected marker mode.
"Restart" A marker signal is generated at the start of each signal sequence

(period = all frame blocks).
"Frame Block" "Number of Frame Blocks" = 1, that is, a marker signal is generated

at the start of each frame block. Otherwise a specific frame block
index is given and the whole frame block is marked.
Remote command: 
[:SOURce<hw>]:BB:WLNN:TRIGger:OUTPut<ch>:FBINdex
on page 146

"Frame" "Number of Frame Blocks" = 1, that is, a marker signal is generated
at the start of each frame in the single frame block. Otherwise, the
frame block and frame index are entered and the specific frame is
masked.
Remote command: 
[:SOURce<hw>]:BB:WLNN:TRIGger:OUTPut<ch>:FINDex
on page 146

Marker settings
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"Frame Active Part / Frame Inactive Part"
A marker signal is generated to mark every active part of each frame.
The active data transfer part (PPDU) of a frame period is marked with
high, the inactive part (idle time) with low. This marker can be used to

Marker settings
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decrease the carrier leakage during inactive signal parts by feeding it
into the pulse modulator.
Otherwise, the frame block and frame index are entered and the
active part of the specific frame is masked.
The parameters "Rising Edge Shift / Falling Edge Shift" open when
"Frame Active Part" or "Frame Inactive Part" is selected.
They shift the rising/falling edge of the marker the specified number
of samples. Negative values result in a shift back of the marker edge.

Figure 5-3: "Frame active Part" marker and shifting of its rising/falling edges

1 = Marker shift rising edge
2 = Marker shift falling edge

Figure 5-4: "Frame Inactive Part" marker and shifting of its rising/falling edges

1 = Marker shift rising edge
2 = Marker shift falling edge

Remote command: 
[:SOURce<hw>]:BB:WLNN:TRIGger:OUTPut<ch>:FESHift
on page 146
[:SOURce<hw>]:BB:WLNN:TRIGger:OUTPut<ch>:RESHift
on page 147

Marker settings
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"Pulse" A regular marker signal is generated. The clock frequency is defined
by entering a divider. The frequency is derived by dividing the chip
rate by the divider. The input box for the divider opens when "Pulse"
is selected, and the resulting pulse frequency is displayed below it.
Remote command: 
[:SOURce<hw>]:BB:WLNN:TRIGger:OUTPut<ch>:PULSe:
DIVider on page 147
[:SOURce<hw>]:BB:WLNN:TRIGger:OUTPut<ch>:PULSe:
FREQuency? on page 148

"Pattern" A marker signal that is defined by a bit pattern is generated. The pat-
tern has a maximum length of 32 bits.
Remote command: 
[:SOURce<hw>]:BB:WLNN:TRIGger:OUTPut<ch>:PATTern
on page 147

"On/Off Ratio"
A regular marker signal that is defined by an On/Off ratio is gener-
ated. A period lasts one On and Off cycle.

Remote command: 
[:SOURce<hw>]:BB:WLNN:TRIGger:OUTPut<ch>:ONTime
on page 145
[:SOURce<hw>]:BB:WLNN:TRIGger:OUTPut<ch>:OFFTime
on page 145

Remote command: 
[:SOURce<hw>]:BB:WLNN:TRIGger:OUTPut<ch>:MODE on page 144

Marker x Delay
Delays the marker signal at the marker output relative to the signal generation start.
Variation of the parameter "Marker x" > "Delay" causes signal recalculation.
Remote command: 
[:SOURce<hw>]:BB:WLNN:TRIGger:OUTPut<ch>:DELay on page 148

5.4  Clock settings

Access:

► Select "Baseband > IEEE 802.11 > Clock".

Clock settings
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This tab provides access to the settings necessary to select and configure the
clock signal, like the clock source and clock mode.

This section focuses on the available settings.
For information on how these settings affect the signal, refer to section "Basics on ..."
in the R&S SMW user manual.

Defining the clock
The provided clock signals are not dedicated to a particular connector. They can be
mapped to one or more USER x and T/M/C connectors.
Use the Local and global connectors settings to configure the signal mapping, the
polarity, the trigger threshold, and the input impedance of the input connectors.
To route and enable a trigger signal, perform the following general steps:
● Define the signal source, that is select the "Clock > Source".
● Define the connector where the selected signal is provided.

Use the Local and global connectors settings.

Settings

Clock Source...............................................................................................................122
Clock Mode................................................................................................................. 122
Measured External Clock............................................................................................ 123

Clock Source
Selects the clock source.
● "Internal"

The instrument uses its internal clock reference.
● "External Local Clock"

Option: R&S SMW-B10
The instrument expects an external clock reference at the local T/M/C connector.

"External Local Clock" requires R&S SMW-B10.
Remote command: 
[:SOURce<hw>]:BB:WLNN:CLOCk:SOURce on page 149

Clock Mode
Option: R&S SMW-B10
Sets the type of externally supplied clock.
Remote command: 
[:SOURce<hw>]:BB:WLNN:CLOCk:MODE on page 149

Clock settings



Signal control and signal characteristicsR&S®SMW-K54/-K86/-K142/-K147

123User Manual 1175.6749.02 ─ 28

Measured External Clock
Provided for permanent monitoring of the enabled and externally supplied clock signal.
Remote command: 
CLOCk:INPut:FREQuency?

5.5  Local and global connectors settings

Accesses a dialog to configure local connectors or global connectors.

The button is available in the following dialogs or tabs:
● "Trigger / Marker / Clock" dialog that is accessible via the "TMC" block in the block

diagram.
● "Trigger In", "Marker" and "Clock" tabs that are accessible via the "Baseband"

block in the block diagram.

See also chapter "Local and global connectors settings" in the user manual.

Local and global connectors settings
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6  Remote-control commands
The following commands are required to perform signal generation with the IEEE
802.11 WLAN options in a remote environment. We assume that the R&S SMW has
already been set up for remote operation in a network as described in the R&S SMW
documentation. A knowledge about the remote control operation and the SCPI com-
mand syntax is assumed.

Conventions used in SCPI command descriptions
For a description of the conventions used in the remote command descriptions, see
section "Remote Control Commands" in the R&S SMW user manual.

The SOURce:BB:WLNN subsystem contains commands for the primary and general
settings of the IEEE 802.11 WLAN standard. With these settings, you can activate the
standard, set the transmission direction, filter, clock, trigger and clipping settings and
do a preset.

The commands for defining the frame configuration for physical layer modes OFDM
and CCK/PBCC are described in the next section. The commands are divided up in
this way to make the comprehensive SOURce:BB:WLNN subsystem clearer.

Common suffixes

The following common suffixes are used in remote commands:

Suffix Value range Description

ENTity<ch> 1 to 4 Entity in a multiple entity configuration

ENTity3|4 require option R&S SMW-K76

SOURce<hw> [1] to 4 Available baseband signals

OUTPut<ch> 1 to 3 Available markers

FBLock<ch> [1]...100 Available frame blocks

MPDU<st> 1...10 Available MPDUs

USER<di> 1...9 Available users

UINFo<st0> 1...37 Available trigger frame users

Using SCPI command aliases for advanced mode with multiple entities
You can address multiple entities configurations by using the SCPI commands starting
with the keyword SOURce or the alias commands starting with the keyword ENTity.
Note that the meaning of the keyword SOURce<hw> changes in the second case.
For details, see section "SCPI Command Aliases for Advanced Mode with Multiple
Entities" in the R&S SMW user manual.
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The following commands specific to options of the WLAN standards IEEE
802.11a/b/g/n/j/p/ac/ax/be are described here:

● Programming examples........................................................................................ 125
● General commands...............................................................................................128
● Filter/clipping settings............................................................................................131
● Trigger settings..................................................................................................... 137
● Marker settings......................................................................................................144
● Clock settings........................................................................................................149
● Antenna configuration settings..............................................................................149
● Frame block configuration.....................................................................................153
● Frame configuration settings.................................................................................159

6.1  Programming examples

The following sections provide programming examples for the IEEE 802.11 Wlan
options.

The purpose of the examples is to present all commands for a given task. In real appli-
cations, one would rather reduce the examples to an appropriate subset of commands.

The programming examples have been tested with a software tool which provides an
environment for the development and execution of remote tests. To keep the example
as simple as possible, only the "clean" SCPI syntax elements are reported. Non-exe-
cutable command lines (e.g. comments) start with two // characters.

At the beginning of the most remote control program, an instrument reset is recom-
mended to set the instrument to a definite state. The commands *RST and
SYSTem:PRESet are equivalent for this purpose. *CLS also resets the status registers
and clears the output buffer.

6.1.1  Trigger settings

// ******************************************************************
// Configure trigger in automatic mode. 
// ******************************************************************
SOURce1:BB:WLNN:TRIGger:SEQuence AUTo

/ ******************************************************************
// Alternatively configure trigger in retrigger mode, source
// internal. Start signal generation via executing the trigger.
// ******************************************************************
SOURce1:BB:WLNN:TRIGger:SEQuence RETR
SOURce1:BB:WLNN:TRIGger:SOURce INTernal
SOURce1:BB:WLNN:TRIGger:EXEcute

 ******************************************************************
// Alternatively configure trigger in retrigger mode, use 
// the internal trigger signal from the other path. 

Programming examples
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// Set inhibit duration, specify delay in samples
// ******************************************************************
SOURce1:BB:WLNN:TRIGger:SEQuence RETR
SOURce1:BB:WLNN:TRIGger:SOURce INTB
SOURce1:BB:WLNN:TRIGger:OBASeband:INHibit 10
SOURce1:BB:WLNN:TRIGger:DELay:UNIT SAMP
SOURce1:BB:WLNN:TRIGger:OBASeband:DELay 25

/ ******************************************************************
// Alternatively set and query delay in seconds.
// ******************************************************************
SOURce1:BB:WLNN:TRIGger:DELay:UNIT TIME
SOURce1:BB:WLNN:TRIGger:OBASeband:TDELay 0.00001
SOURce1:BB:WLNN:TRIGger:OBASeband:RDELay?

 ******************************************************************
// Alternatively configure trigger in armed retrigger mode, use 
// external global trigger. Enable synchronization output.
// Set inhibit duration, specify delay in samples.
// ******************************************************************
SOURce1:BB:WLNN:TRIGger:SEQuence ARET
SOURce1:BB:WLNN:TRIGger:SOURce EGT1
SOURce1:BB:WLNN:TRIGger:EXTernal:SYNChronize:OUTPut 1
SOURce1:BB:WLNN:TRIGger:EXTernal:INHibit 10
SOURce1:BB:WLNN:TRIGger:DELay:UNIT SAMP
SOURce1:BB:WLNN:TRIGger:EXTernal:DELay 25

/ ******************************************************************
// Alternatively set and query delay in seconds.
// ******************************************************************
SOURce1:BB:WLNN:TRIGger:DELay:UNIT TIME
SOURce1:BB:WLNN:TRIGger:EXTernal:TDELay 0.00001
SOURce1:BB:WLNN:TRIGger:EXTernal:RDELay?

// ******************************************************************
// Configure trigger in single mode. Set the output of
// the current waveform to the first sample after 
// the next trigger event. Execute the trigger.
// ******************************************************************
SOURce1:BB:WLNN:TRIGger:SEQuence SINGle
SOURce1:BB:WLNN:TRIGger:SLUNit SAMP
SOURce1:BB:WLNN:TRIGger:SLENgth 1
SOURce1:BB:WLNN:TRIGger:EXEcute

/ ******************************************************************
// Alternatively configure internal trigger in armed retrigger
// mode. Start signal generation via executing the trigger.
// Stop signal generation via arming the trigger.
// Execute the trigger again to restarts signal generation.

Programming examples
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// ******************************************************************
SOURce1:BB:WLNN:TRIGger:SEQuence ARETrigger
SOURce1:BB:WLNN:TRIGger:SOURce INTernal
SOURce1:BB:WLNN:TRIGger:EXEcute
SOURce1:BB:WLNN:TRIGger:ARM:EXECute
SOURce1:BB:WLNN:TRIGger:EXEcute

// ******************************************************************
// Query trigger signal generation status.
// ******************************************************************
SOURce1:BB:WLNN:TRIGger:RMODe?

6.1.2  Marker settings

Example: Marker configuration
// ******************************************************************
// Query marker mode, set rising and falling offsets.
// ******************************************************************
SOURce:BB:WLNN:TRIGger:OUTPut2:MODE?
// RESTart
SOURce:BB:WLNN:TRIGger:OUTPut2:FOFFset 10
SOURce:BB:WLNN:TRIGger:OUTPut2:ROFFset 20

// ******************************************************************
// Set delay.
// ******************************************************************
SOURce:BB:WLNN:TRIGger:OUTPut3:DELay 16

6.1.3  Clock settings

This section is not relevant for R&S WinIQSIM2.

Example: Clock configuration
// ******************************************************************
// Select internal clock. 
// ******************************************************************
SOURce1:BB:WLNN:CLOCk:SOURce INTernal

// ******************************************************************
// Alternatively select external clock. Set its mode and query 
// input frequency.
// ******************************************************************
SOURce:BB:WLNN:CLOCk:SOURce EXT
SOURce:BB:WLNN:CLOCk:MODE SAMP
CLOCk:INPUt:FREQuency?

Programming examples
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6.2  General commands

[:SOURce<hw>]:BB:WLNN:BWidth..................................................................................128
[:SOURce<hw>]:BB:WLNN:PRESet.................................................................................128
[:SOURce<hw>]:BB:WLNN:SETTing:CATalog?................................................................. 128
[:SOURce<hw>]:BB:WLNN:SETTing:DELete.................................................................... 129
[:SOURce<hw>]:BB:WLNN:SETTing:LOAD...................................................................... 129
[:SOURce<hw>]:BB:WLNN:SETTing:STORe.................................................................... 129
[:SOURce<hw>]:BB:WLNN:STATe................................................................................... 130
[:SOURce<hw>]:BB:WLNN:VERSion?............................................................................. 130
[:SOURce<hw>]:BB:WLNN:WAVeform:CREate.................................................................130

[:SOURce<hw>]:BB:WLNN:BWidth <BWidth>

The command selects the transmission bandwidth. Whenever the bandwidth changes
from a higher to a lower one, the frame blocks are validated because some of them
could be invalid in the lower bandwidth (invalid TX Mode).

Parameters:
<BWidth> BW20 | BW40 | BW80 | BW160 | BW320

*RST: BW20
Default unit: MHz

Example: BB:WLNN:BW BW40
sets the transmission bandwidth to 40 MHz.

Manual operation: See "Transmission Bandwidth" on page 21

[:SOURce<hw>]:BB:WLNN:PRESet

Sets the parameters of the digital standard to their default values (*RST values speci-
fied for the commands).

Not affected is the state set with the command SOURce<hw>:BB:WLNN:STATe.

Example: SOURce:BB:WLNN:PRESet
Usage: Event

Manual operation: See "Set to Default" on page 19

[:SOURce<hw>]:BB:WLNN:SETTing:CATalog?

Reads out the files with IEEE 802.11a/b/g/n/ac settings in the default directory. The
default directory is set using command MMEM:CDIRectory. Only files with the file
extension *.wlann will be listed.

Return values: 
<Catalog> string

General commands
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Example: MMEM:CDIR '/var/user/temp/wlann'
Sets the default directory to /var/user/temp/wlann.
BB:WLNN:SETT:CAT?
Reads out all the files with IEEE 802.11 settings in the default
directory.
Response: 'wlann_1','wlann_2'
The files ''wlann1' and 'wlann2'' are available.

Usage: Query only

Manual operation: See "Save/Recall" on page 20

[:SOURce<hw>]:BB:WLNN:SETTing:DELete <Filename>

Deletes the selected file with IIEEE 802.11a/b/g/n/ac settings. The directory is set
using command MMEM:CDIRectory. A path can also be specified, in which case the
files in the specified directory are read. The file extension may be omitted. Only files
with the file extension *.wlann are listed and can be deleted.

Setting parameters: 
<Filename> string

Example: BB:WLNN:SETT:DEL 'wlann_1'
Deletes file 'wlann_1'.

Usage: Setting only

Manual operation: See "Save/Recall" on page 20

[:SOURce<hw>]:BB:WLNN:SETTing:LOAD <Filename>

Loads the selected file with IEEE 802.11 WLAN settings. The directory is set using
command MMEM:CDIRectory. A path can also be specified, in which case the files in
the specified directory are read. The file extension may be omitted. Only files with the
file extension *.wlann will be loaded.

Setting parameters: 
<Filename> string

Example: BB:WLNN:SETT:LOAD 'wlann_1'
Loads file 'wlann_1'.

Usage: Setting only

Manual operation: See "Save/Recall" on page 20

[:SOURce<hw>]:BB:WLNN:SETTing:STORe <Filename>

Saves the current IEEE 802.11a/b/g/n/ac settings into the selected file. The directory is
set using command MMEM:CDIRectory. A path can also be specified, in which case
the files in the specified directory are read. Only the file name has to be entered. IEEE
802.11a/b/g/n/ac/ax settings are saved as files with file extension *.wlann.

General commands
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Setting parameters: 
<Filename> string

Example: :SOURce1:BB:WLNN:SETT:STOR 'wlann_1'
Saves the current settings into file 'wlann_1'.

Usage: Setting only

Manual operation: See "Save/Recall" on page 20

[:SOURce<hw>]:BB:WLNN:STATe <State>

Activates the standard and deactivates all the other digital standards and digital modu-
lation modes in the same path.

Parameters:
<State> 1 | ON | 0 | OFF

*RST: 0

Example: SOURce1:BB:WLNN:STATe ON
Activates the standard.

Manual operation: See "State" on page 19

[:SOURce<hw>]:BB:WLNN:VERSion?

Queries the version of the IEEE 802.11 WLAN standard underlying the definitions.

Return values: 
<Version> string

Example: BB:WLNN:VERS?
"Release D11.0"
Queries the IEEE 802.11 WLAN version.

Usage: Query only

[:SOURce<hw>]:BB:WLNN:WAVeform:CREate <Filename>

Creates a waveform using the current settings of the "WLAN" menu. The file name is
entered with the command. The file is saved with the predefined file extension *.wv.
The file name and the directory it is saved in are user-definable.

Setting parameters: 
<Filename> string

Example: MMEM:CDIR '/var/user/temp/waveform'
Sets the default directory to /var/user/temp/waveform.
BB:WLNN:WAV:CRE 'wlann_1'
Creates the waveform file wlann_1.wv in the default directory.

Usage: Setting only

Manual operation: See "Generate Waveform File" on page 21

General commands
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6.3  Filter/clipping settings

[:SOURce<hw>]:BB:WLNN:CLIPping:LEVel......................................................................131
[:SOURce<hw>]:BB:WLNN:CLIPping:MODE.................................................................... 131
[:SOURce<hw>]:BB:WLNN:CLIPping:SPPState................................................................ 132
[:SOURce<hw>]:BB:WLNN:CLIPping:STATe.....................................................................132
[:SOURce<hw>]:BB:WLNN:FILTer:DEFSetting:STATe........................................................132
[:SOURce<hw>]:BB:WLNN:FILTer:IUPSampling................................................................133
[:SOURce<hw>]:BB:WLNN:FILTer:PARameter:APCO25.................................................... 133
[:SOURce<hw>]:BB:WLNN:FILTer:PARameter:COSine......................................................133
[:SOURce<hw>]:BB:WLNN:FILTer:PARameter:COSine:COFS............................................133
[:SOURce<hw>]:BB:WLNN:FILTer:PARameter:GAUSs...................................................... 134
[:SOURce<hw>]:BB:WLNN:FILTer:PARameter:LPASs....................................................... 134
[:SOURce<hw>]:BB:WLNN:FILTer:PARameter:LPASSEVM................................................134
[:SOURce<hw>]:BB:WLNN:FILTer:PARameter:PGAuss..................................................... 135
[:SOURce<hw>]:BB:WLNN:FILTer:PARameter:RCOSine................................................... 135
[:SOURce<hw>]:BB:WLNN:FILTer:PARameter:SPHase..................................................... 135
[:SOURce<hw>]:BB:WLNN:FILTer:TYPE..........................................................................136
[:SOURce<hw>]:BB:WLNN:SRATe?.................................................................................136
[:SOURce<hw>]:BB:WLNN:SRATe:VARiation................................................................... 136

[:SOURce<hw>]:BB:WLNN:CLIPping:LEVel <Level>

Sets the limit for level clipping. This value indicates at what point the signal is clipped.
It is specified as a percentage, relative to the highest level. 100% indicates that clip-
ping does not take place.

Level clipping is activated if [:SOURce<hw>]:BB:WLNN:CLIPping:STATe is set to
ON.

Parameters:
<Level> integer

Range: 1 PCT  to  100 PCT
Increment: 1 PCT
*RST: 100 PCT

Example: BB:WLNN:CLIP:LEV 80PCT
Sets the limit for level clipping to 80% of the maximum level.
BB:WLNN:CLIP:STAT ON
Activates level clipping.

Manual operation: See "Clipping Level" on page 111

[:SOURce<hw>]:BB:WLNN:CLIPping:MODE <Mode>

Sets the method for level clipping.

Parameters:
<Mode> VECTor | SCALar

VECTor
The reference level is the amplitude | i+jq |.

Filter/clipping settings
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SCALar
The reference level is the absolute maximum of the I and Q val-
ues.
*RST: VECTor

Example: BB:WLNN:CLIP:MODE SCAL
Selects the absolute maximum of all the I and Q values as the
reference level.
BB:WLNN:CLIP:LEV 80PCT
Sets the limit for level clipping to 80% of this maximum level.
BB:WLNN:CLIP:STAT ON
Activates level clipping.

Manual operation: See "Clipping Mode" on page 111

[:SOURce<hw>]:BB:WLNN:CLIPping:SPPState <State>

Applies vector clipping to fields L-SIG, RL-SIG, U-SIG and EHT-SIG.

Parameters:
<State> 1 | ON | 0 | OFF

*RST: 0

Example: BB:WLNN:FBLock1:STANdard WBE
BB:WLNN:CLIPping:SPPState 1
// Clips the EHT-SIG field.

Manual operation: See "Clip Signal Fields to Payload Max Peak" on page 111

[:SOURce<hw>]:BB:WLNN:CLIPping:STATe <State>

Activates level clipping (Clipping). The value is defined with [:SOURce<hw>]:BB:
WLNN:CLIPping:LEVel, the mode of calculation with [:SOURce<hw>]:BB:WLNN:
CLIPping:MODE.

Parameters:
<State> 1 | ON | 0 | OFF

*RST: 0

Example: BB:WLNN:CLIP:STAT ON
Activates level clipping.

Manual operation: See "Clipping State" on page 110

[:SOURce<hw>]:BB:WLNN:FILTer:DEFSetting:STATe <UseDefaultFilte>

Activates the WLAN default filter settings.

Parameters:
<UseDefaultFilte> 1 | ON | 0 | OFF

*RST: 1

Filter/clipping settings
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Example: SOURce1:BB:WLNN:FILTer:DEFSetting:STATe 1
Activates the WLAN default filter settings.

Manual operation: See "Use Default Wlan Filter" on page 108

[:SOURce<hw>]:BB:WLNN:FILTer:IUPSampling <IFFTUpsampling>

Activates inverted Fast Fourier Transformation (IFFT) upsampling.

Parameters:
<IFFTUpsampling> 1 | ON | 0 | OFF

*RST: 1

Example: SOURce1:BB:WLNN:FILTer:IUPSampling ON
Activates IFFT upsampling.

Manual operation: See "IFFT Upsampling" on page 109

[:SOURce<hw>]:BB:WLNN:FILTer:PARameter:APCO25 <Apco25>

Sets the roll-off factor for filter type APCO25.

Parameters:
<Apco25> float

Range: 0.05  to  0.99
Increment: 0.01
*RST: 0.2

Example: BB:WLNN:PAR:APCO25 0.2
Sets the roll-off factor to 0.2 for filter type APCO25.

Manual operation: See "Roll Off Factor or BxT" on page 108

[:SOURce<hw>]:BB:WLNN:FILTer:PARameter:COSine <Cosine>

Sets the roll-off factor for the cosine filter type.

Parameters:
<Cosine> float

Range: 0  to  1
Increment: 0.01
*RST: 0.1

Example: BB:WLNN:PAR:COS 0.35
Sets the roll-off factor to 0.35 for filter type cosine.

Manual operation: See "Roll Off Factor or BxT" on page 108

[:SOURce<hw>]:BB:WLNN:FILTer:PARameter:COSine:COFS <CoFs>

The command sets the "cut of frequency shift' value for the Cosine filter type.
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Parameters:
<CoFs> float

Range: -1  to  1
Increment: 0.01
*RST: 0

Example: BB:WLNN:FILT:PAR:COS:COFS 0.04
the "cut of frequency shift" value is set to 0.04.

Manual operation: See "Cut Off Frequency Shift" on page 109

[:SOURce<hw>]:BB:WLNN:FILTer:PARameter:GAUSs <Gauss>

Sets the roll-off factor for the Gauss filter type.

Parameters:
<Gauss> float

Range: 0.15  to  2.5
Increment: 0.01
*RST: 0.5

Example: BB:WLNN:PAR:GAUS 0.5
Sets B x T to 0.5 for the Gauss filter type.

Manual operation: See "Roll Off Factor or BxT" on page 108

[:SOURce<hw>]:BB:WLNN:FILTer:PARameter:LPASs <LPass>

Sets the cut off frequency factor for the Lowpass (ACP optimization) filter type.

Parameters:
<LPass> float

Range: 0.05  to  2
Increment: 0.01
*RST: 0.5

Example: BB:WLNN:FILT:PAR:LPAS 0.5
The cut of frequency factor is set to 0.5.

Manual operation: See "Cut Off Frequency Factor" on page 109

[:SOURce<hw>]:BB:WLNN:FILTer:PARameter:LPASSEVM <LPassevm>

Sets the cut off frequency factor for the Lowpass (EVM optimization) filter type.

Parameters:
<LPassevm> float

Range: 0.05  to  2
Increment: 0.01
*RST: 0.5
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Example: BB:WLNN:FILT:PAR:LPASSEVM 0.5
The cut of frequency factor is set to 0.5.

Manual operation: See "Cut Off Frequency Factor" on page 109

[:SOURce<hw>]:BB:WLNN:FILTer:PARameter:PGAuss <PGauss>

Sets the roll-off factor for the pure gauss filter type.

Parameters:
<PGauss> float

Range: 0.15  to  2.5
Increment: 0.01
*RST: 0.5

Example: BB:WLLN:FILT:PAR:PGAUS 0.5
Sets B x T to 0.5 for the pure gauss filter type.

Manual operation: See "Roll Off Factor or BxT" on page 108

[:SOURce<hw>]:BB:WLNN:FILTer:PARameter:RCOSine <RCosine>

Sets the roll-off factor for the root cosine filter type.

Parameters:
<RCosine> float

Range: 0  to  1
Increment: 0.01
*RST: 0.22

Example: BB:WLNN:PAR:RCOS 0.22
Sets the roll-off factor to 0. 22 for filter type root cosine.

Manual operation: See "Roll Off Factor or BxT" on page 108

[:SOURce<hw>]:BB:WLNN:FILTer:PARameter:SPHase <SPhase>

Sets B x T for the Split Phase filter type.

Parameters:
<SPhase> float

Range: 0.15  to  2.5
Increment: 0.01
*RST: 2

Example: BB:WLNN:PAR:SPH 0.5
Sets B x T to 0.5 for the Split Phase filter type.

Manual operation: See "Roll Off Factor or BxT" on page 108
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[:SOURce<hw>]:BB:WLNN:FILTer:TYPE <Type>

The command selects the filter type.

Parameters:
<Type> RCOSine | COSine | GAUSs | LGAuss | CONE | COF705 |

COEQualizer | COFequalizer | C2K3x | APCO25 | SPHase |
RECTangle | PGAuss | LPASs | DIRac | ENPShape |
EWPShape | LPASSEVM
*RST: Depends on layer mode

Example: BB:WLNN:FILT:TYPE COS
sets the filter type COSine.

Manual operation: See "Filter" on page 108

[:SOURce<hw>]:BB:WLNN:SRATe?

Displays the sample rate specific for the selected bandwidth ([:SOURce<hw>]:BB:
WLNN:BWidth).

Return values: 
<SampRate> float

20MHz for BW20, 60MHz for BW40.

Usage: Query only

Manual operation: See "Sample Rate" on page 21

[:SOURce<hw>]:BB:WLNN:SRATe:VARiation <Variation>

Sets the sample rate of the signal.

Parameters:
<Variation> float

Range: 400  to  40000000
Increment: 0.001
*RST: 20000000
Default unit: Hz (c/s)

Example: BB:WLNN:SRAT:VAR 4000000
Sets the output sample rate to 4 MHz.

Manual operation: See "Sample Rate Variation" on page 109
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6.4  Trigger settings

Example: Configure and enable triggering
SOURce1:BB:WLNN:TRIGger:SEQuence SINGle
SOURce1:BB:WLNN:TRIGger:SLENgth 200
// the first 200 samples of the current waveform will be output after 
// the next trigger event

SOURce1:BB:WLNN:TRIGger:SOURce INTB
// the internal trigger signal from the other path must be used
SOURce1:BB:WLNN:TRIGger:OBASeband:DELay 25
SOURce1:BB:WLNN:TRIGger:OBASeband:INHibit 10

SOURce1:BB:WLNN:TRIGger:SOURce INT
SOURce1:BB:WLNN:TRIGger:SEQuence ARETrigger
SOURce1:BB:WLNN:STAT ON
SOURce1:BB:WLNN:TRIGger:EXEcute
// executes a trigger, signal generation starts
SOURce1:BB:WLNN:TRIGger:ARM:EXECute
// signal generation stops
SOURce1:BB:WLNN:TRIGger:EXEcute
// executes a trigger, signal generation starts again

Example: Specifying delay and inhibit values in time units
SOURce1:BB:WLNN:CLOCk 1000000
SOURce1:BB:WLNN:TRIGger:SEQuence AAUT
SOURce1:BB:WLNN:TRIGger:SOURce EGT1
// external trigger signal must be provided at the USER connector
// SOURce1:BB:WLNN:TRIGger:EXTernal:SYNChronize:OUTPut 1
SOURce1:BB:WLNN:TRIGger:DELay:UNIT SAMP
SOURce1:BB:WLNN:TRIGger:EXTernal:DELay 100
SOURce1:BB:WLNN:TRIGger:EXTernal:RDELay?
// Response: 100

SOURce1:BB:WLNN:TRIGger:DELay:UNIT TIME
SOURce1:BB:WLNN:TRIGger:EXTernal:TDELay 0.00001
SOURce1:BB:WLNN:TRIGger:EXTernal:RDELay?
// Response: 0.00001

SOURce1:BB:WLNN:TRIGger:DELay:UNIT SAMP
SOURce1:BB:WLNN:TRIGger:EXTernal:DELay 10

[:SOURce<hw>]:BB:WLNN:TRIGger:ARM:EXECute..........................................................138
[:SOURce<hw>]:BB:WLNN:TRIGger:EXECute..................................................................138
[:SOURce<hw>]:BB:WLNN:TRIGger:EXTernal:SYNChronize:OUTPut.................................138
[:SOURce<hw>]:BB:WLNN:TRIGger:OBASeband:DELay.................................................. 139
[:SOURce<hw>]:BB:WLNN:TRIGger:OBASeband:INHibit.................................................. 139
[:SOURce<hw>]:BB:WLNN:TRIGger:RMODe?................................................................. 139
[:SOURce<hw>]:BB:WLNN:TRIGger:SLENgth.................................................................. 140
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[:SOURce<hw>]:BB:WLNN:TRIGger:SLUNit.....................................................................140
[:SOURce<hw>]:BB:WLNN:TRIGger:SOURce.................................................................. 141
[:SOURce<hw>]:BB:WLNN:TRIGger[:EXTernal]:DELay..................................................... 142
[:SOURce<hw>]:BB:WLNN:TRIGger[:EXTernal]:INHibit..................................................... 142
[:SOURce<hw>]:BB:WLNN[:TRIGger]:SEQuence..............................................................142
[:SOURce<hw>]:BB:WLNN:TRIGger:TIME:DATE..............................................................143
[:SOURce<hw>]:BB:WLNN:TRIGger:TIME:TIME...............................................................143
[:SOURce<hw>]:BB:WLNN:TRIGger:TIME[:STATe]........................................................... 143

[:SOURce<hw>]:BB:WLNN:TRIGger:ARM:EXECute

Stops signal generation for trigger modes armed auto and armed retrigger. A subse-
quent internal or external trigger event restart signal generation.

Example: See Example"Configure and enable triggering" on page 137

Usage: Event

Manual operation: See "Arm" on page 114

[:SOURce<hw>]:BB:WLNN:TRIGger:EXECute

Executes a trigger. The internal trigger source must be selected using the command
BB:WLNN:TRIG:SOUR INT and a trigger mode other than AUTO must be selected
using the command [:SOURce<hw>]:BB:WLNN[:TRIGger]:SEQuence.

Example: BB:WLNN:TRIG:SOUR INT
Sets internal triggering.
BB:WLNN:TRIG:SEQ RETR
Sets retrigger mode, i.e. every trigger event causes signal gen-
eration to restart.
BB:WLNN:TRIG:EXEC
Executes a trigger.

Usage: Event

Manual operation: See "Execute Trigger" on page 115

[:SOURce<hw>]:BB:WLNN:TRIGger:EXTernal:SYNChronize:OUTPut <Output>

Enables signal output synchronous to the trigger event.

Parameters:
<Output> 1 | ON | 0 | OFF

OFF
*RST: 1

Example: BB:WLNN:TRIG:SOUR EGT1
Sets external triggering.
BB:WLNN:TRIG:EXT:SYNC:OUTP ON
Enables synchronous output to external trigger.
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Manual operation: See "Sync. Output to External Trigger/Sync. Output to Trigger"
on page 115

[:SOURce<hw>]:BB:WLNN:TRIGger:OBASeband:DELay <Delay>

Specifies the trigger delay (expressed as a number of samples) for triggering by the
trigger signal from the second path.

Parameters:
<Delay> float

Range: 0  to  2147483647
Increment: 0.01
*RST: 0

Example: BB:WLNN:TRIG:SOUR INTB
The internal trigger signal from the other path must be used
BB:WLNN:TRIG:INH 200
Sets a restart inhibit for 200 samples following a trigger event.

Manual operation: See "Trigger Delay" on page 116

[:SOURce<hw>]:BB:WLNN:TRIGger:OBASeband:INHibit <Inhibit>

Specifies the number of samples by which a restart is to be inhibited following a trigger
event. This command applies only for triggering by the second path.

Parameters:
<Inhibit> integer

Range: 0  to  67108863
*RST: 0

Example: BB:WLNN:TRIG:SOUR INTB
the internal trigger signal from the other path must be used.
BB:WLNN:TRIG:OBAS:INH 200
sets a restart inhibit for 200 samples following a trigger event.

Manual operation: See "External Trigger Inhibit" on page 116

[:SOURce<hw>]:BB:WLNN:TRIGger:RMODe?

The command queries the current status of signal generation for all trigger modes with
IEEE 802.11 WLAN modulation on.

Return values: 
<RMode> RUN | STOP

RUN
the signal is generated. A trigger event occurred in the triggered
mode.
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STOP
the signal is not generated. A trigger event did not occur in the
triggered modes, or signal generation was stopped by the com-
mand :BB:WLNN:TRIG:ARM:EXECute (armed trigger modes
only).

Example: BB:WLNN:TRIG:SOUR EGT1
sets external triggering.
BB:WLNN:TRIG:MODE ARET
selects the Armed_Retrigger mode.
BB:WLNN:TRIG:RMOD?
queries the current status of signal generation.
Response: RUN
the signal is generated, an external trigger was executed.

Usage: Query only

Manual operation: See "Running/Stopped" on page 114

[:SOURce<hw>]:BB:WLNN:TRIGger:SLENgth <Slength>

The command defines the length of the signal sequence to be output in the "Single"
trigger mode ([:SOURce<hw>]:BB:WLNN[:TRIGger]:SEQuence is set to SING).
The input is made in terms of samples.

It is possible to output deliberately just part of the frame, an exact sequence of the
frame, or a defined number of repetitions of the frame.

Parameters:
<Slength> integer

Range: 1  to  (2^32) - 1
*RST: 1
Default unit: sample

Example: BB:WLNN:SEQ SING
Sets trigger mode single.
BB:WLNN:TRIG:SLEN 200
Sets a sequence length of 200 samples. The first 200 samples
of the current frame will be output after the next trigger event.

Manual operation: See "Signal Duration" on page 114

[:SOURce<hw>]:BB:WLNN:TRIGger:SLUNit <Slunit>

Defines the unit for the entry of the length of the signal sequence ([:SOURce<hw>]:
BB:WLNN:TRIGger:SLENgth) to be output in the single trigger mode ([:
SOURce<hw>]:BB:WLNN[:TRIGger]:SEQuence is set to SINGle).

Parameters:
<Slunit> SAMPle | SEQuence

SAMPle
Unit Sample. A single sample is generated after a trigger event.
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SEQuence
Unit Sequence Length. A single sequence is generated after a
trigger event.
*RST: SEQuence

Example: BB:WLNN:SEQ SING
Sets trigger mode single.
BB:WLNN:TRIG:SLUN SEQ
Sets unit sequence for the entry of sequence length.
BB:WLNN:TRIG:SLEN 2
Sets a sequence length of 2 sequences. Two sequences will be
output after the next trigger event.

Manual operation: See "Signal Duration Unit" on page 113

[:SOURce<hw>]:BB:WLNN:TRIGger:SOURce <Source>

Selects the trigger signal source and determines the way the triggering is executed.
Provided are:
● Internal triggering by a command (INTernal)
● External trigger signal via one of the local or global connectors

– EGT1|EGT2: External global trigger
– EGC1|EGC2: External global clock
– ELTRigger: External local trigger
– ELCLock: External local clock

● Internal triggering by a signal from the other basebands (INTA|INTB)
● In primary-secondary instrument mode, the external baseband synchronization sig-

nal (BBSY)
● OBASeband|BEXTernal|EXTernal: Setting only

Provided only for backward compatibility with other Rohde & Schwarz signal gener-
ators.
The R&S SMW accepts these values and maps them automatically as follows:
EXTernal = EGT1, BEXTernal = EGT2, OBASeband = INTA or INTB
(depending on the current baseband)

Parameters:
<Source> INTB|INTernal|OBASeband|EGT1|EGT2|EGC1|EGC2|ELTRig-

ger|INTA|ELCLock|BEXTernal|EXTernal | BBSY
*RST: INTernal

Example: See Example"Configure and enable triggering" on page 137.

Options: ELTRigger|ELCLock require R&S SMW-B10
BBSY require R&S SMW-B9

Manual operation: See "Trigger Source" on page 115
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[:SOURce<hw>]:BB:WLNN:TRIGger[:EXTernal]:DELay <Delay>

Sets the trigger delay.

Parameters:
<Delay> float

Range: 0  to  2147483647
Increment: 0.01
*RST: 0
Default unit: samples

Example: See Example"Configure and enable triggering" on page 137.

Manual operation: See "Trigger Delay" on page 116

[:SOURce<hw>]:BB:WLNN:TRIGger[:EXTernal]:INHibit <Inhibit>

Specifies the number of samples by which a restart is to be inhibited following an exter-
nal trigger event.

Parameters:
<Inhibit> integer

Range: 0  to  21.47*sampRate
*RST: 0

Example: See Example"Configure and enable triggering" on page 137.

Manual operation: See "External Trigger Inhibit" on page 116

[:SOURce<hw>]:BB:WLNN[:TRIGger]:SEQuence <Sequence>

Selects the trigger mode:
● AUTO = auto
● RETRigger = retrigger
● AAUTo = armed auto
● ARETrigger = armed retrigger
● SINGle = single

Parameters:
<Sequence> AUTO | RETRigger | AAUTo | ARETrigger | SINGle

*RST: AUTO

Example: BB:WLNN:SEQ AAUT
Sets the Armed_auto trigger mode; the device waits for the first
trigger (e.g. with *TRG) and then generates the signal continu-
ously.

Manual operation: See "Mode" on page 113

Trigger settings



Remote-control commandsR&S®SMW-K54/-K86/-K142/-K147

143User Manual 1175.6749.02 ─ 28

[:SOURce<hw>]:BB:WLNN:TRIGger:TIME:DATE <Year>, <Month>, <Day>

Sets the date for a time-based trigger signal. For trigger modes single or armed auto,
you can activate triggering at this date via the following command:

SOURce<hw>:BB:<DigStd>:TRIGger:TIME:STATe
<DigStd> is the mnemonic for the digital standard, for example, ARB. Time-based trig-
gering behaves analogously for all digital standards that support this feature.

Parameters:
<Year> integer

Range: 1980  to  9999

<Month> integer
Range: 1  to  12

<Day> integer
Range: 1  to  31

Example: See example "Configure a time-based trigger signal" in the sub-
chapter "Trigger Commands" of the chapter "SOURce:BB:ARB
subsystem" in the R&S SMW user manual.

[:SOURce<hw>]:BB:WLNN:TRIGger:TIME:TIME <Hour>, <Minute>, <Second>

Sets the time for a time-based trigger signal. For trigger modes single or armed auto,
you can activate triggering at this time via the following command:

SOURce<hw>:BB:<DigStd>:TRIGger:TIME:STATe
<DigStd> is the mnemonic for the digital standard, for example, ARB. Time-based trig-
gering behaves analogously for all digital standards that support this feature.

Parameters:
<Hour> integer

Range: 0  to  23

<Minute> integer
Range: 0  to  59

<Second> integer
Range: 0  to  59

Example: See example "Configure a time-based trigger signal" in the sub-
chapter "Trigger Commands" of the chapter "SOURce:BB:ARB
subsystem" in the R&S SMW user manual.

[:SOURce<hw>]:BB:WLNN:TRIGger:TIME[:STATe] <State>

Activates time-based triggering with a fixed time reference. If activated, the R&S SMW
triggers signal generation when its operating system time matches a specified time.

Specify the trigger date and trigger time with the following commands:
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SOURce<hw>:BB:<DigStd>:TRIGger:TIME:DATE
SOURce<hw>:BB:<DigStd>:TRIGger:TIME:TIME
<DigStd> is the mnemonic for the digital standard, for example, ARB. Time-based trig-
gering behaves analogously for all digital standards that support this feature.

Parameters:
<State> 1 | ON | 0 | OFF

*RST: 0

Example: See example "Configure a time-based trigger signal" in the sub-
chapter "Trigger Commands" of the chapter "SOURce:BB:ARB
subsystem" in the R&S SMW user manual.

6.5  Marker settings

[:SOURce<hw>]:BB:WLNN:TRIGger:OUTPut<ch>:MODE................................................. 144
[:SOURce<hw>]:BB:WLNN:TRIGger:OUTPut<ch>:ONTime............................................... 145
[:SOURce<hw>]:BB:WLNN:TRIGger:OUTPut<ch>:OFFTime..............................................145
[:SOURce<hw>]:BB:WLNN:TRIGger:OUTPut<ch>:FBINdex...............................................146
[:SOURce<hw>]:BB:WLNN:TRIGger:OUTPut<ch>:FINDex................................................ 146
[:SOURce<hw>]:BB:WLNN:TRIGger:OUTPut<ch>:FESHift................................................ 146
[:SOURce<hw>]:BB:WLNN:TRIGger:OUTPut<ch>:RESHift................................................147
[:SOURce<hw>]:BB:WLNN:TRIGger:OUTPut<ch>:PATTern............................................... 147
[:SOURce<hw>]:BB:WLNN:TRIGger:OUTPut<ch>:PULSe:DIVider..................................... 147
[:SOURce<hw>]:BB:WLNN:TRIGger:OUTPut<ch>:PULSe:FREQuency?.............................148
[:SOURce<hw>]:BB:WLNN:TRIGger:OUTPut<ch>:DELay................................................. 148

[:SOURce<hw>]:BB:WLNN:TRIGger:OUTPut<ch>:MODE <Mode>

Defines the signal for the selected marker output.

Parameters:
<Mode> RESTart | FBLock | FRAMe | FAPart | PULSe | PATTern | RATio |

FIPart
RESTart
A marker signal is generated at the start of each signal
sequence (period = all frame blocks).
FRAMe
Number of Frame Blocks = 1, that is, a marker signal is gener-
ated at the start of each frame in the single frame block. Other-
wise, the frame block and frame index are entered and the spe-
cific frame is masked.
FBLock
Number of Frame Blocks = 1, that is, a marker signal is gener-
ated at the start of each frame block. Otherwise, a specific frame
block index is given and the whole frame block is marked.
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FAPart
Number of Frame Blocks = 1, that is, a marker signal is gener-
ated to mark every active part of each frame.
The active data transfer part (PPDU) of a frame period is
marked with high, the inactive part (idle time) with low. This
marker can be used to decrease the carrier leakage during inac-
tive signal parts by feeding it into the pulse modulator.
Otherwise, the frame block and frame index are entered and the
active part of the specific frame is masked.
PATTern
A marker signal is generated according to the user defined pat-
tern (command
SOURce:BB:WLNN:TRIGger:OUTPut:PATTern).
PULSe
A pulsed marker signal is generated. The pulse frequency
(= symbol rate/divider) is defined with the
SOUR:BB:WLNN:TRIG:OUTP:PULSe:DIVider command and
can be queried with the
SOUR:BB:WLNN:TRIG:OUTP:PULSe:FREQuency? command.
RATio
A marker signal corresponding to the Time Off / Time On specifi-
cations in the commands
SOURce:BB:WLNN:TRIGger:OUTPut:OFFT and
"SOURce:BB:WLNN:TRIGger:OUTPut:ONT" is generated.
*RST: RESTart

Example: BB:WLNN:TRIG:OUTP:MODE FRAM
selects the frame marker for the corresponding marker signal.

Manual operation: See "Marker Mode" on page 118

[:SOURce<hw>]:BB:WLNN:TRIGger:OUTPut<ch>:ONTime <OnTime>
[:SOURce<hw>]:BB:WLNN:TRIGger:OUTPut<ch>:OFFTime <OffTime>
Sets the duration during which the marker output is on or off.
*) If R&S SMW-B9 is installed, the minimum marker duration depends on the sample/
symbol rate.

See chapter "Basics on ..." in the R&S SMW user manual.

Parameters:
<OffTime> integer

Range: 1 (R&S SMW-B10) / 1* (R&S SMW-B9)  to 
16777215

*RST: 1

Example: BB:WLNN:TRIG:OUTP:OFFT 200
Manual operation: See "Marker Mode" on page 118
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[:SOURce<hw>]:BB:WLNN:TRIGger:OUTPut<ch>:FBINdex <FbIndex>

Sets the frame block index. For this/these frame block(s), a marker signal is generated.
The maximum value depends on the number of the currently active frame blocks (max
= 100).

Parameters:
<FbIndex> integer

Range: 0  to  100
Increment: 1
*RST: 1

Example: BB:WLNN:TRIG:OUTP1:FBIN 5
Sets the frame block index to 5.

Manual operation: See "Marker Mode" on page 118

[:SOURce<hw>]:BB:WLNN:TRIGger:OUTPut<ch>:FINDex <FIndex>

Sets the frame index, that is, the frame to be marked in the frame block marked with
[:SOURce<hw>]:BB:WLNN:TRIGger:OUTPut<ch>:FBINdex. The maximum value
depends on the number of frames set with command [:SOURce<hw>]:BB:WLNN:
FBLock<ch>:FCOunt . The maximum value is 1024.

Parameters:
<FIndex> integer

Range: 1  to  1024
Increment: 1
*RST: 1

Example: BB:WLNN:TRIG:OUTP1:FIND 100
Sets the frame index to 100.

Manual operation: See "Marker Mode" on page 118

[:SOURce<hw>]:BB:WLNN:TRIGger:OUTPut<ch>:FESHift <Shift>

Shifts the falling edge of the marker the specified number of samples. Negative values
result in a shift back of the marker edge.

Parameters:
<Shift> integer

Range: -1000  to  1000
*RST: 0

Example: BB:WLNN:TRIG:OUTP2:FESH 75
shifts the falling edge of the marker 2 about 75 samples.

Manual operation: See "Marker Mode" on page 118
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[:SOURce<hw>]:BB:WLNN:TRIGger:OUTPut<ch>:RESHift <Shift>

Shifts the rising edge of the marker the specified number of samples. Negative values
result in a shift back of the marker edge.

Parameters:
<Shift> integer

Range: -1000  to  1000
*RST: 0

Example: BB:WLNN:TRIG:OUTP2:RESH -20
shifts back the rising edge of marker 2 about 20 samples.

Manual operation: See "Marker Mode" on page 118

[:SOURce<hw>]:BB:WLNN:TRIGger:OUTPut<ch>:PATTern <Pattern>

Defines the bit pattern used to generate the marker signal if [:SOURce<hw>]:BB:
WLNN:TRIGger:OUTPut<ch>:MODEis set to PATTern.

Parameters:
<Pattern> 64 bits

0 = marker off, 1 = marker on
*RST: #H2,2

Example: BB:WLNN:TRIG:OUTP2:PATT #B000000011111111,15
Sets a bit pattern.
BB:WLNN:TRIG:OUTP:MODE PATT
Activates the marker signal according to a bit pattern for the cor-
responding marker signal.

Manual operation: See "Marker Mode" on page 118

[:SOURce<hw>]:BB:WLNN:TRIGger:OUTPut<ch>:PULSe:DIVider <Divider>

Sets the divider for the pulsed marker signal.
*) If R&S SMW-B9 is installed, the minimum marker duration depends on the sample/
symbol rate.

See chapter "Basics on ..." in the R&S SMW user manual.

Parameters:
<Divider> integer

Range: 2 (R&S SMW-B10) / 2* (R&S SMW-B9)  to  1024
Increment: 1
*RST: 2
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Example: BB:WLNN:TRIG:OUTP:PULS:DIV 2
Sets the divider to 2 for the corresponding marker signal.
BB:WLNN:TRIG:OUTP2:FREQ?
Queries the resulting pulse frequency of the marker signal.
Response: 66 000
The resulting pulse frequency is 66 kHz.

Manual operation: See "Marker Mode" on page 118

[:SOURce<hw>]:BB:WLNN:TRIGger:OUTPut<ch>:PULSe:FREQuency?

Queries the pulse frequency of the pulsed marker signal ([:SOURce<hw>]:BB:
WLNN:TRIGger:OUTPut<ch>:MODEPULSe). The pulse frequency is derived by divid-
ing the symbol rate by the divider.

Return values: 
<Frequency> float

Range: 0.0  to  max

Example: BB:WLNN:TRIG:OUTP:PULS:DIV 2
Sets the divider marker signal of the corresponding marker sig-
nal to the value 2.
BB:WLNN:TRIG:OUTP:MODE PULS
Enables the pulsed marker signal.
BB:WLNN:TRIG:OUTP:PULS:FREQ?
Queries the pulse frequency of the marker signal.
Response: 33 000
The resulting pulse frequency is 33 kHz.

Usage: Query only

Manual operation: See "Marker Mode" on page 118

[:SOURce<hw>]:BB:WLNN:TRIGger:OUTPut<ch>:DELay <Delay>

Defines the delay between the signal on the marker outputs and the start of the sig-
nals.

Parameters:
<Delay> float

Range: 0  to  16777215
Increment: 0.001
*RST: 0

Example: BB:WLNN:TRIG:OUTP:DEL 1600
Sets a delay of 1600 samples for the corresponding marker sig-
nal.

Manual operation: See "Marker x Delay" on page 121
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6.6  Clock settings

[:SOURce<hw>]:BB:WLNN:CLOCk:MODE....................................................................... 149
[:SOURce<hw>]:BB:WLNN:CLOCk:SOURce....................................................................149

[:SOURce<hw>]:BB:WLNN:CLOCk:MODE <Mode>

Sets the type of externally supplied clock.

Parameters:
<Mode> SAMPle | MSAMple

*RST: SAMPle

Example: SOURce1:BB:WLNN:CLOCk:MODE SAMPle
Selects clock type

Options: R&S SMW-B10

Manual operation: See "Clock Mode" on page 122

[:SOURce<hw>]:BB:WLNN:CLOCk:SOURce <Source>

Selects the clock source.

Parameters:
<Source> INTernal|ELCLock|EXTernal

*RST: INTernal

Example: BB:WLNN:CLOC:SOUR INT
Selects an internal clock reference.

Options: ELCLock requires R&S SMW-B10

Manual operation: See "Clock Source" on page 122

6.7  Antenna configuration settings

[:SOURce<hw>]:BB:WLNN:ANTenna:CMODe?.................................................................150
[:SOURce<hw>]:BB:WLNN:ANTenna:MODE.................................................................... 150
[:SOURce<hw>]:BB:WLNN:ANTenna:NOBB?................................................................... 150
[:SOURce<hw>]:BB:WLNN:ANTenna:SYSTem................................................................. 150
[:SOURce<hw>]:BB:WLNN:ANTenna:TCHain<ch>:OUTPut:DESTination............................ 151
[:SOURce<hw>]:BB:WLNN:ANTenna:TCHain<ch>:OUTPut:FSELect..................................151
[:SOURce<hw>]:BB:WLNN:ANTenna:TCHain<ch>:TX<dir>:REAL...................................... 151
[:SOURce<hw>]:BB:WLNN:ANTenna:TCHain<ch>:TX<dir>:IMAGinary............................... 152
[:SOURce<hw>]:BB:WLNN:ANTenna:TCHain<ch>:TX<dir>:PHASe....................................152
[:SOURce<hw>]:BB:WLNN:ANTenna:TCHain<ch>:TX<dir>:MAGNitude..............................152
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[:SOURce<hw>]:BB:WLNN:ANTenna:CMODe?

Queries the coupling state of transmit antennas.

If enabled, the transmit antennas are coupled, i.e. they transmit the same frame blocks
data.

Return values: 
<CMODe> 1 | ON | 0 | OFF

*RST: 0

Usage: Query only

[:SOURce<hw>]:BB:WLNN:ANTenna:MODE <Mode>

The command selects the number of transmit antennas to be used.

Parameters:
<Mode> A1 | A2 | A3 | A4 | A5 | A6 | A7 | A8

*RST: A1

Example: BB:WLNN:ANT:MODE A1
one antenna is used for transmission.

Manual operation: See "Antennas" on page 22

[:SOURce<hw>]:BB:WLNN:ANTenna:NOBB?

Queries the number of basebands required for the transmit antenna setup.

Return values: 
<NOBB> NBB1 | NBB2 | NBB4 | NBB3 | NBB8

*RST: NBB1

Usage: Query only

[:SOURce<hw>]:BB:WLNN:ANTenna:SYSTem <System>

Selects the coordinate system of the transmission chain matrix.

Parameters:
<System> CARTesian | CYLindrical

*RST: CARTesian

Example: BB:WLNN:ANT:SYST CART
Sets the coordinate system of the transmission chain matrix to
Cartesian.

Manual operation: See "Mapping Coordinates" on page 22
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[:SOURce<hw>]:BB:WLNN:ANTenna:TCHain<ch>:OUTPut:DESTination
<Destination>

Selects the destination of the calculated IQ chains.

Parameters:
<Destination> OFF | BB | BB_B | FILE

OFF
No mapping takes place.
BB
The IQ chain is output to the baseband A. Exactly one output
stream can be mapped as "Baseband A".
BB_B
The IQ chain is output to the baseband B. Exactly one output
stream can be mapped as "Baseband B".
FILE
The IQ chain is saved in a file.
*RST: OFF (for antenna 2 .. 8); Baseband (for antenna 1)

Example: BB:WLNN:ANT:TCH1:OUTP:DEST BB
The IQ chain is saved in a file.

Manual operation: See "Output" on page 23

[:SOURce<hw>]:BB:WLNN:ANTenna:TCHain<ch>:OUTPut:FSELect <FSelect>

The command saves the IQ chain in a file.

Parameters:
<FSelect> string

Example: BB:WLNN:ANT:TCH1:OUTP:FSEL
'/var/user/temp/wlnn_1.wv'
saves the IQ chain in the selected file.

Manual operation: See "Output" on page 23

[:SOURce<hw>]:BB:WLNN:ANTenna:TCHain<ch>:TX<dir>:REAL <Real>

Sets the value for the Real coordinate.

Parameters:
<Real> float

Range: -1000  to  1000
Increment: 0.01

Example: BB:WLNN:ANT:TCH1:TX2:REAL 500
sets the real coordinate for the selected transmission chain to
500.

Manual operation: See "Real/Magnitude" on page 23
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[:SOURce<hw>]:BB:WLNN:ANTenna:TCHain<ch>:TX<dir>:IMAGinary
<Imaginary>

Sets the value for the Imaginary coordinate.

Parameters:
<Imaginary> float

Range: -999.99  to  999.99
Increment: 0.01
*RST: 0

Example: BB:WLNN:ANT:TCH1:TX2:IMAG 500
sets the imaginary coordinate for the selected transmission
chain to 500.

Manual operation: See "Imaginary/Phase" on page 23

[:SOURce<hw>]:BB:WLNN:ANTenna:TCHain<ch>:TX<dir>:PHASe <Phase>

Sets the phase when cylindrical mapping coordinates are selected.

Parameters:
<Phase> float

Range: 0  to  359.99
Increment: 0.01
*RST: 0

Example: :BB:WLNN:ANT:TCH1:TX1:PHAS 10
Sets the phase to 10°.

Manual operation: See "Imaginary/Phase" on page 23

[:SOURce<hw>]:BB:WLNN:ANTenna:TCHain<ch>:TX<dir>:MAGNitude
<Magnitude>

Sets the magnitude when cylindrical mapping coordinates are selected.

Parameters:
<Magnitude> float

Range: 0  to  999.99
Increment: 0.01
*RST: 0

Example: :BB:WLNN:ANT:TCH1:TX1:MAGN 100
Sets the magnitude to 100.

Manual operation: See "Real/Magnitude" on page 23
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6.8  Frame block configuration

[:SOURce<hw>]:BB:WLNN:FBLock:APPend.....................................................................153
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:COPY................................................................ 153
[:SOURce<hw>]:BB:WLNN:CFBLock...............................................................................153
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:DELete.............................................................. 154
[:SOURce<hw>]:BB:WLNN:DFBLock...............................................................................154
[:SOURce<hw>]:BB:WLNN:IFBLock................................................................................ 154
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:INSert................................................................ 154
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:PASTe................................................................154
[:SOURce<hw>]:BB:WLNN:PFBLock............................................................................... 154
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:BCSMoothing..................................................... 154
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:BOOSt...............................................................155
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:FCOunt..............................................................155
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:DATA................................................................. 155
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:DATA:DSELection............................................... 156
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:DATA:PATTern.................................................... 156
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:DATA:RATE?......................................................157
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:ITIMe.................................................................157
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:PMODe..............................................................157
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:STANdard.......................................................... 158
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:STATe................................................................158
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:TMODe..............................................................158
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:TYPE.................................................................159

[:SOURce<hw>]:BB:WLNN:FBLock:APPend

Appends a frame block to the end of the frame blocks list.

Example: BB:WLNN:FBL:APP
Usage: Event

Manual operation: See "Append" on page 30

[:SOURce<hw>]:BB:WLNN:FBLock<ch>:COPY
[:SOURce<hw>]:BB:WLNN:CFBLock <CfBlock>
Copies the selected frame block.

Setting parameters: 
<CfBlock> integer

Range: 1  to  100

Example: BB:WLNN:CFBL 5
copies frame block 5 for later insertion.

Usage: Setting only
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[:SOURce<hw>]:BB:WLNN:FBLock<ch>:DELete
[:SOURce<hw>]:BB:WLNN:DFBLock <DfBlock>
Deletes the selected frame block.

Setting parameters: 
<DfBlock> integer

Range: 1  to  100

Example: BB:WLNN:DFBL 10
deletes the selected frame block.

Usage: Setting only

[:SOURce<hw>]:BB:WLNN:IFBLock <IfBlock>
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:INSert
The command adds a default frame block before the selected frame block.

Example: BB:WLNN:FBL2:INS
inserts a default frame block before the selected frame block.

Usage: Event

Manual operation: See "Insert" on page 30

[:SOURce<hw>]:BB:WLNN:FBLock<ch>:PASTe
[:SOURce<hw>]:BB:WLNN:PFBLock <PfBlock>
Pastes the selected frame block.

Setting parameters: 
<PfBlock> integer

Range: 1  to  99

Example: BB:WLNN:PFBL 20
pastes the frame block to row 20.

Usage: Setting only

[:SOURce<hw>]:BB:WLNN:FBLock<ch>:BCSMoothing <BCSmoothing>

Activates beam change and smoothing.

Parameters:
<BCSmoothing> 1 | ON | 0 | OFF

*RST: 1

Example: SOURce1:BB:WLNN:FBL1:BCSMoothing 1
Example: Beam change and smoothing is activated.
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[:SOURce<hw>]:BB:WLNN:FBLock<ch>:BOOSt <Boost>

Assigns a specific RMS power boost/attenuation to the corresponding frame block
modulation.

The power level of a frame block modulation is calculated as sum of the power boost
and the power level set in the header of the instrument.

Note: At least one frame block should have a power boost set to 0 dB value for this
gated power mode functionality to work properly.

Parameters:
<Boost> float

Range: -80  to  0
Increment: 0.01
*RST: 0
Default unit: dB

Example: BB:WLNN:FBL5:BOOS -10.0
Sets the power boost

Manual operation: See "Boost /dB" on page 29

[:SOURce<hw>]:BB:WLNN:FBLock<ch>:FCOunt <FCount>

Sets the number of frames to be transmitted in the current frame block.

Parameters:
<FCount> integer

Range: 1  to  20 000
Increment: 1
*RST: 1

Example: BB:WLNN:FBL5:FCO 1
Sets the number of transmitted frames in the current frame block
to 1.

Manual operation: See "Frames" on page 29

[:SOURce<hw>]:BB:WLNN:FBLock<ch>:DATA <Data>

Selects the data source.

Parameters:
<Data> ZERO | ONE | PATTern | PN9 | PN11 | PN15 | PN16 | PN20 |

PN21 | PN23 | DLISt | AMPDU
PNxx
The pseudo-random sequence generator is used as the data
source. Different random sequence lengths can be selected.
DLISt
A data list is used. The data list is selected with the command
BB:WLNN:FBLocks:DATA:DSEL
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ZERO | ONE
Internal 0 and 1 data is used.
PATTern
Internal data is used. The bit pattern for the data is defined by
the command BB:WLNN:FBLocks:DATA:PATTern.
AMPDU
Aggregated mac protocol data unit (A-MPDU) data is used as
configured with the commands in Chapter 6.9.4, "MPDU config-
uration", on page 188
*RST: PN9

Example: BB:WLNN:FBL5:DATA PN9
sets PN9 as the data source.

Manual operation: See "Data" on page 29

[:SOURce<hw>]:BB:WLNN:FBLock<ch>:DATA:DSELection <DSelection>

Selects the data list for the DLISt data source selection.

The lists are saved as files with the fixed file extensions *.dm_iqd in a directory of the
user's choice. The directory applicable to the following commands is defined with the
command MMEMory:CDIR. To access the files in this directory, you only have to give
the file name without the path and the file extension.

Parameters:
<DSelection> string

Example: BB:WLNN:FBL5:DATA DLIS
Selects the data lists data source.
MMEM:CDIR '/var/user/temp/Lists_DM'
Selects the directory for the data lists.
BB:WLNN:FBL5:DATA:DSEL 'dlist1'
Selects file 'dlist1' as the data source. This file must be in the
directory /var/user/temp/Lists_DM and have the file exten-
sion *.dm_iqd.

Manual operation: See "Data" on page 29

[:SOURce<hw>]:BB:WLNN:FBLock<ch>:DATA:PATTern <Pattern>

Determines the bit pattern for the PATTern selection. The maximum length is 64 bits.

Parameters:
<Pattern> 64 bits

*RST: #H0,1

Example: BB:WLNN:FBL5:DATA:PATT #H3F,8
Sets the bit pattern.

Manual operation: See "Data" on page 29
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[:SOURce<hw>]:BB:WLNN:FBLock<ch>:DATA:RATE?

The command queries the PPDU data rate.

Return values: 
<Rate> float

Example: BB:WLNN:FBL5:DATA:RATE?
queries the data rate.

Usage: Query only

Manual operation: See "Data Rate /Mbps" on page 30

[:SOURce<hw>]:BB:WLNN:FBLock<ch>:ITIMe <ITime>

Sets the time interval separating two frames in this frame block. The default unit for the
time interval are seconds. However, the time interval can be set in milliseconds. In this
case the unit has to be set.

Parameters:
<ITime> float

Range: 0  to  1
Increment: 100E-6
*RST: 100E-6

Example: BB:WLNN:FBL5:ITIMe 0.0025
sets the idle time to 2.5 msec.

Manual operation: See "Idle Time /ms" on page 29

[:SOURce<hw>]:BB:WLNN:FBLock<ch>:PMODe <PMode>

Selects the preamble design.

For physical type SOUNDING, only GREEN FIELD is available.

Parameters:
<PMode> LEGacy | MIXed | GFIeld

LEGacy
Compatible with 802.11 a/g OFDM devices.
MIXed
For High Throughput (HT) and 802.11a/g OFDM devices.
GFIeld
For HT only networks.
*RST: MIXed

Example: BB:WLNN:FBL5:PMOD LEG
Sets the physical mode to LEGACY.

Manual operation: See "Physical Mode" on page 26
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[:SOURce<hw>]:BB:WLNN:FBLock<ch>:STANdard <Standard>

Sets the IEEE 802.11 WLAN standard.

Parameters:
<Standard> USER | WAG | WBG | WPJ | WN | WAC | WAX | WBE

USER
Sets a user defined standard.
WAG
Sets the IEEE 802.11a/g standard.
WBG
Sets the IEEE 802.11b/g standard.
WPJ
Sets the IEEE 802.11p/j standard.
WN
Sets the IEEE 802.11n standard.
WAC
Sets the IEEE 802.11a/c standard.
WAX
Sets the IEEE 802.11ax standard.
WBE
Sets the IEEE 802.11be standard.
*RST: USER

Example: :SOURce1:BB:WLNN:FBL1:STAN WN
Sets the IEEE 802.11n standard

Manual operation: See "Std." on page 24

[:SOURce<hw>]:BB:WLNN:FBLock<ch>:STATe <State>

Enables the corresponding frame block for transmission.

Parameters:
<State> 1 | ON | 0 | OFF

*RST: ON

Example: BB:WLNN:FBL5:STAT ON
Enables frame block 5 for transmission.

Manual operation: See "State" on page 30

[:SOURce<hw>]:BB:WLNN:FBLock<ch>:TMODe <TMode>

Sets the Tx mode. The available Tx modes are dependent on the physical mode.
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Parameters:
<TMode> L20 | LDUP | LUP | LLOW | HT20 | HT40 | HTDup | HTUP |

HTLow | CCK | PBCC | V20 | V40 | V80 | V160 | V8080 | L10 |
S1 | S2 | S4 | S16 | HE20 | HE40 | HE80 | HE8080 | HE160 |
EHT320 | EHT20 | EHT40 | EHT80 | EHT160 | EHT320
*RST: HT20

Example: SOURce1:BB:WLNN:FBL5:TMOD HT40
Sets the Tx mode to HT 40 MHz.

Manual operation: See "Tx Mode" on page 26

[:SOURce<hw>]:BB:WLNN:FBLock<ch>:TYPE <Type>

The command selects the PPDU type.

Parameters:
<Type> DATA | SOUNding | BEACon | TRIGger

DATA
Only Data Long Training Fields are used to probe the channel.
SOUNding
Staggered preambles are used to probe additional dimension of
the MIMO channel. Only Physical Layer Mode GREEN FIELD is
available.
BEACon
Frame type "Beacon" is used to probe the channel.
*RST: DATA

Example: BB:WLNN:FBL5:TYPE DATA
sets the PPDU type data.

Manual operation: See "Type" on page 25

6.9  Frame configuration settings

● Frame block PPDU configuration..........................................................................159
● EHT/HE configuration........................................................................................... 176
● User configuration.................................................................................................184
● MPDU configuration..............................................................................................188
● MAC header configuration.................................................................................... 190
● Beacon configuration............................................................................................ 212
● Spatial mapping configuration...............................................................................219

6.9.1  Frame block PPDU configuration
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[:SOURce<hw>]:BB:WLNN:FBLock<ch>:CBINonht <CBINonht>

(Available only for VHT Tx mode)

The command is used to modify the first 7 bits of the scrambling sequence to indicate
the duplicated bandwidth of the PPDU.

Parameters:
<CBINonht> B20 | B40 | B80 | B160 | OFF

B20|B40|B80|B160
Indicates 20 MHz, 40MHz, 80MHz or 160 (80+80) MHz channel
bandwidth of the transmitted packet.
OFF
Channel bandwidth in Non HT is not present.
*RST: OFF
Default unit: MHz

Example: BB:WLNN:FBL1:CBIN B80
Selects 80 MHz channel bandwidth of the transmitted packet.

Manual operation: See "Ch. Bandwidth in Non HT" on page 59

[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:CODing:ENCoder?
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:CODing:ENCoder?
Queries the number of encoders to be used. This value depends on the data rate. For
data rate ≤ 300 Mps, this value is 1. Otherwise the number of encoders is 2.

Return values: 
<Encoder> E1 | E2 | E3 | E6 | E7 | E8 | E9 | E12 | E4 | E5 | E10 | E11

Example: BB:WLNN:FBL5:COD:ENC?
queries the number of encoders to be used.

Usage: Query only

Manual operation: See "Encoders" on page 35

[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:CODing:RATE <Rate>
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:CODing:RATE <Rate>
This command selects the coding rate.

Parameters:
<Rate> CR1D2 | CR2D3 | CR3D4 | CR5D6

*RST: CR1D2

Example: BB:WLNN:FBL5:COD:RATE CR1D2
sets the coding rate to CR1D2.
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Manual operation: See "Cod Rate" on page 36

[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:CODing:TYPE <Type>
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:CODing:TYPE <Type>
Selects the channel coding.

Parameters:
<Type> OFF | BCC | LDPC

*RST: BCC

Example: BB:WLNN:FBL5:COD:TYPE OFF
no channel coding is used.

Manual operation: See "Channel Coding" on page 35

[:SOURce<hw>]:BB:WLNN:FBLock<ch>:USER<di>:DCM <DCM>

Enables dual carrier modulation.

Parameters:
<DCM> 1 | ON | 0 | OFF

*RST: 0

Manual operation: See "DCM" on page 36

[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:DATA:BPSymbol?
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:DATA:BPSymbol?
Queries the number of data bits sent by an OFDM symbol on all spatial streams.

Return values: 
<BpSymbol> integer

*RST: 0

Example: BB:WLNN:FBL5:DATA:BPS?
queries the number of data bits sent by an OFDM symbol on all
spatial streams.

Usage: Query only

Manual operation: See "Data Bits Per Symbol" on page 35

[:SOURce<hw>]:BB:WLNN:FBLock<ch>:DATA:DCYCle?

Queries the duty cycle, i.e. the ratio of frame duration and total signal length.

Frame duration and duty cycle are related to data length and number of data symbols.
Whenever one of them changes, the frame duration and duty cycle are updated.
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Return values: 
<DutyCycle> float

Range: 0.1  to  1
Increment: 0.0001
*RST: 0.1

Example: SOURce1:BB:WLNN:FBLock1:DATA:DCYCle?
Response: 1
The frame duration and the total signal length are equal.

Usage: Query only

Manual operation: See "Duty Cycle" on page 60

[:SOURce<hw>]:BB:WLNN:FBLock<ch>:DATA:FDELay <FrameDelay>

Shifts the frame in time by the specified frame delay value.

Parameters:
<FrameDelay> float

Range: 0  to  1000000
Increment: 1
*RST: 0

Example: SOURce1:BB:WLNN:FBLock1:DATA:FDELay 100
Shifts the frame in time by 100 microseconds.

Manual operation: See "Frame Delay" on page 58

[:SOURce<hw>]:BB:WLNN:FBLock<ch>:DATA:FDURation?

Queries the duration of the frame in milliseconds, i.e. the WLAN burst length.

Frame duration and duty cycle are related to data length and number of data symbols.
Whenever one of them changes, the frame duration and duty cycle are updated.

Return values: 
<FrameDuration> float

Range: 0  to  1000
Increment: 0.0001
*RST: 0.1

Example: SOURce1:BB:WLNN:FBLock1:DATA:FDURation?
Response: 0.676
The WLAN burst has a length of 0.676 ms.

Usage: Query only

Manual operation: See "Frame Duration" on page 58
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[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:DATA:LENGth <Length>
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:DATA:LENGth <Length>
The command enters the size of the data field in bytes.

For Data Length = 0, no data field will be generated for the case of a sounding frame.

The maximum data length depends on the physical mode: In LEGACY mode, the max-
imum value is 4061 Bytes. In MIXED MODE and GREEN FIELD, the maximum value
is 65495 Bytes.

The data length is related to the number of data symbols. Whenever the data length
changes, the number of data symbols is updated and vice versa.

Parameters:
<Length> integer

Range: 0  to  Max
*RST: 1024 (for LEGACY); 1048575 (for GREEN FIELD

or MIXED MODE)

Example: BB:WLNN:FBL5:DATA:LENG 500
sets the data length to 500 Bytes.

Manual operation: See "Data Length" on page 58
See "A-MPDU Length" on page 64

[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:DATA:RATE?
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:DATA:RATE?
The command queries the PPDU data rate.

Return values: 
<Rate> float

Example: BB:WLNN:FBL5:DATA:RATE?
queries the data rate.

Usage: Query only

Manual operation: See "Data Rate /Mbps" on page 30

[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:DATA:SYMBols <Symbols>
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:DATA:SYMBols <Symbols>
Sets the number of data symbols per frame block.

If the number of OFDM data symbols is changed, the generator calculates the data
field length as a function of the set PPDU bit rate and displays it at Data Length.

Parameters:
<Symbols> integer

Range: 1  to  Max
*RST: 158

Example: BB:WLNN:FBL5:DATA:SYMB 1
sets the number of data symbols per frame block to 1.

Frame configuration settings



Remote-control commandsR&S®SMW-K54/-K86/-K142/-K147

165User Manual 1175.6749.02 ─ 28

Manual operation: See "Number Of Data Symbols" on page 60

[:SOURce<hw>]:BB:WLNN:FBLock<ch>:DBINonht <DBINonht>

(available only for VHT Tx mode)

Modifys the first 7 bits of the scrambling sequence to indicate if the transmitter is capa-
ble of "Static" or "Dynamic" bandwidth operation.

Parameters:
<DBINonht> STAT | DYN | OFF

STAT
The transmitter is capable of static bandwidth operation.
DYN
The transmitter is capable of dynamic bandwidth operation.
OFF
Dynamic bandwidth in Non HT is not present.
*RST: OFF

Example: BB:WLNN:FBL1:DBIN DYN
The transmitter is capable of dynamic bandwidth operation.

Manual operation: See "Dyn. Bandwidth in Non HT" on page 60

[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:DPNSeed:STATe
<DefaultPNSeed>

Activates the default PN seed. The seed is used initially to generate the pseudo-ran-
dom noise sequence.

Parameters:
<DefaultPNSeed> 1 | ON | 0 | OFF

*RST: 1

Example: See [:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:
PNSeed on page 170.

Manual operation: See "Default PN Seed" on page 60

[:SOURce<hw>]:BB:WLNN:FBLock<ch>:ESSTream <EsStream>

Sets the value of the extended spatial streams. This field is active for frame block type
sounding only to probe additional dimensions to the channel.

Parameters:
<EsStream> integer

Range: 1  to  dynamic
Increment: 1
*RST: 1
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Example: BB:WLNN:FBL5:ESSTR 4
Sets the number of the extended spatial streams to 4.

Manual operation: See "Extended Spatial Streams" on page 32

[:SOURce<hw>]:BB:WLNN:FBLock<ch>:GUARd <Guard>

Selects which guard interval is used for the OFDM guard.

In physical mode green field or legacy, only long guard intervals are possible. In this
case, the field is read-only.

GD08, GD16 and GD32 are available only for the IEEE 802.11ax standard.

Parameters:
<Guard> SHORt | LONG | GD08 | GD16 | GD32

*RST: LONG

Example: BB:WLNN:FBL5:GUAR LONG
Sets a long guard interval.

Manual operation: See "Guard" on page 36

[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:ILEaver:STATe <State>
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:ILEaver:STATe <State>
The command activates/deactivates the interleaver of the data field.

Parameters:
<State> 0 | 1 | OFF | ON

*RST: ON

Example: BB:WLNN:FBL5:ILE:STAT ON
activates the interleaver.

Manual operation: See "Interleaver Active" on page 59

[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:MCS <MCS>
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:MCS <MCS>
Selects the modulation and coding scheme for the spatial streams.
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Parameters:
<MCS> MCS0 | MCS1 | MCS2 | MCS3 | MCS4 | MCS5 | MCS6 | MCS7 |

MCS8 | MCS9 | MCS10 | MCS11 | MCS12 | MCS13 | MCS14 |
MCS15 | MCS16 | MCS17 | MCS18 | MCS19 | MCS20 |
MCS21 | MCS22 | MCS23 | MCS24 | MCS25 | MCS26 |
MCS27 | MCS28 | MCS29 | MCS30 | MCS31 | MCS32 |
MCS33 | MCS34 | MCS35 | MCS36 | MCS37 | MCS38 |
MCS39 | MCS40 | MCS41 | MCS42 | MCS43 | MCS44 |
MCS45 | MCS46 | MCS47 | MCS48 | MCS49 | MCS50 |
MCS51 | MCS52 | MCS53 | MCS54 | MCS55 | MCS56 |
MCS57 | MCS58 | MCS59 | MCS60 | MCS61 | MCS62 |
MCS63 | MCS64 | MCS65 | MCS66 | MCS67 | MCS68 |
MCS69 | MCS70 | MCS71 | MCS72 | MCS73 | MCS74 |
MCS75 | MCS76
*RST: MCS1

Example: BB:WLNN:FBL1:MCS MCS8
selects MCS8 as the coding scheme used for the spatial stream.

Manual operation: See "MCS" on page 34

[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:MODulation<st>
<Modulation>

[:SOURce<hw>]:BB:WLNN:FBLock<ch>:MODulation<st> <Modulation>
Selects the modulation used for the spatial stream.

Parameters:
<Modulation> BPSK | QPSK | QAM16 | QAM64 | QAM256 | QAM1024 |

QAM4096
*RST: QPSK; BPSK for Tx Mode > HT-Duplicate

Example: BB:WLNN:FBL5:MOD1 BPSK
sets BPSK as the modulation mode used for the spatial stream.

Options: QAM256|QAM1024|QAM4096 require R&S SMW-K86

Manual operation: See "Stream n" on page 35

[:SOURce<hw>]:BB:WLNN:FBLock<ch>:MUMimo:STATe <MUMimo>

Activates Multi User MIMO. This function applies to "Spatial Streams">1.

Parameters:
<MUMimo> 1 | ON | 0 | OFF

*RST: 0

Example: BB:WLNN:BB:WLNN:FBL1:MUM:STAT ON
activates Multi User MIMO.

Manual operation: See "Multi User MIMO" on page 32
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[:SOURce<hw>]:BB:WLNN:FBLock<ch>:MU<st0>:GID <GID>

Sets the group ID for all available users.

Parameters:
<GID> integer

Range: 1  to  62
*RST: 1

Example: BB:WLNN:BB:WLNN:FBL1:MU1:GID 1.0
assigns group ID 1.0 to user 1.

Manual operation: See "Multi User MIMO Settings Table" on page 34

[:SOURce<hw>]:BB:WLNN:FBLock<ch>:MU<st0>:NSTS <NSTS>

Sets the number of space time streams for each user.

Parameters:
<NSTS> integer

Range: 0  to  Max
*RST: 1

Example: BB:WLNN:BB:WLNN:FBL1:MU2:NSTS 8.0
sets 8 space time streams for user 2.

Manual operation: See "Multi User MIMO Settings Table" on page 34

[:SOURce<hw>]:BB:WLNN:FBLock<ch>:NTPS <NTPS>

(Available only for VHT Tx mode)

Indicates whether VHT AP allows VHT non-AP STAs in TXOP power save mode to
enter during TXOP.

Parameters:
<NTPS> OFF | ON

ON
Indicates that the VHT AP allows VHT non-AP STAs to enter
doze mode during a TXOP.
OFF
Indicates that the VHT AP does not allow VHT non-AP STAs to
enter doze mode during a TXOP.
*RST: 1

Example: BB:WLNN:FBL1:NTPS ON
Activates NTPS.

Manual operation: See "No TXOP PS" on page 63
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[:SOURce<hw>]:BB:WLNN:FBLock<ch>:PAID:PATTern <Pattern>

(avaliable only for VHT Tx mode)

The command provides an abbreviated indication of the intended recipient(s) of the
frame.

Parameters:
<Pattern> 9 bits

Range: #H000,9  to  #H1FF,9
*RST: #H000,9

Example: BB:WLNN:FBL1:PAID:PAT #H1FB,9
Sets the 9 bits pattern 1FB.

Manual operation: See "Partial AID (hex)" on page 62

[:SOURce<hw>]:BB:WLNN:FBLock<ch>:PLCP:FORMat <Format>

(available only for CCK and PBCC transport modes)

Selects the packet type (PPDU format) with long or short PLCP (physical layer conver-
gence protocol).

Depending on the format selected, the structure, modulation and data rate of the PLCP
preamble and header are modified.

Parameters:
<Format> LONG | SHORt

*RST: LONG

Example: BB:WLNN:FBL5:PMOD LEG
sets the physical mode to LEGACY.
BB:WLNN:FBL5:TMOD CCK
sets the transport mode
BB:WLNN:FBL5:PLCP:FORM SHOR
sets the PLCP Format

Manual operation: See "PLCP P+H Format" on page 61

[:SOURce<hw>]:BB:WLNN:FBLock<ch>:PLCP:LCBit:STATe <State>

(available only for CCK and PBCC transport modes)

Sets the Locked Clock Bit in Service Field of the PLCP Header.

Parameters:
<State> 1 | ON | 0 | OFF

*RST: ON
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Example: BB:WLNN:FBL5:PMOD LEG
sets the physical mode to LEGACY.
BB:WLNN:FBL5:TMOD CCK
sets the transport mode
BB:WLNN:FBL5:PLCP:LCB:STAT OFF
sets the Locked Clock Bit

Manual operation: See "Service Field Clock Bit" on page 61

[:SOURce<hw>]:BB:WLNN:FBLock<ch>:PREamble:STATe <State>

Activates/deactivates the preamble and signal fields of the frames in the current frame
block. For data type = SOUNDING, the preamble and signal field are always activated
and cannot be deactivated.

Parameters:
<State> 1 | ON | 0 | OFF

*RST: 1

Example: BB:WLNN:FBL5:PRE:STAT ON
Activates the preamble and signal fields of the frames in the cur-
rent frame block.

Manual operation: See "Preamble/Header Active" on page 62

[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:PNSeed <PNSeed>

Sets the PN seed. Use this setting, if you don't use the default PN seed.

Parameters:
<PNSeed> 24 bits | 24 bit

Range: #H000001,24  to  #H7FFFFF,24
*RST: #H000001,24

Example: SOURce1:BB:WLNN:FBL5:DATA PN9
Sets "PN9" as the data source.
BB:WLNN:FBL5:DPNSeed:STATe 0
Deactivates the default PN seed.
BB:WLNN:FBL5:PNSeed #H47FFFF,24
Sets a PN seed value of 47FFFF. The value is internally correc-
ted to the maximum 9 bit PN seed value of 1FF.

Manual operation: See "PN Seed" on page 61

[:SOURce<hw>]:BB:WLNN:FBLock<ch>:PSDU:BRATe <BRate>

(available only for CCK and PBCC transport modes)

Sets the PSDU bit rate.
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Parameters:
<BRate> integer

Range: 0  to  22E6
*RST: 11E6

Example: BB:WLNN:FBL5:PMOD LEG
sets the physical mode to LEGACY
BB:WLNN:FBL5:TMOD CCK
sets the transport mode
BB:WLNN:FBL5:PSDU:BRAT 2E6
sets the PSDU bit rate of 2 Mbps

Manual operation: See "PSDU Bit Rate" on page 36

[:SOURce<hw>]:BB:WLNN:FBLock<ch>:PSDU:BSPReading:STATe <State>

(available only for CCK and PBCC transport modes)

Enables/disables Barker spreading.

Parameters:
<State> 1 | ON | 0 | OFF

*RST: 1

Example: BB:WLNN:FBL5:PMOD LEG
sets the physical mode to LEGACY.
BB:WLNN:FBL5:TMOD CCK
sets the transport mode
BB:WLNN:FBL5:PSDU:BRAT 2MBPS
sets the PSDU bit rate
BB:WLNN:FBL5:PSDU:BSPR:STAT ON
enables spreading

Manual operation: See "Barker Spreading" on page 37

[:SOURce<hw>]:BB:WLNN:FBLock<ch>:PSDU:MODulation?

(available only for CCK and PBCC Tx modes)

Queries the modulation type. The modulation mode depends on the selected PSDU bit
rate which depends on the selected physical layer mode (SOUR:BB:WLNN:MODE).

Return values: 
<Modulation> BPSK | QPSK | DBPSK | DQPSK | CCK | PBCC

*RST: CCK
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Example: BB:WLNN:FBL5:PMOD LEG
Sets the physical mode to legacy.
BB:WLNN:FBL5:TMOD CCK
Sets the transport mode to CCK.
BB:WLNN:FBL5:PSDU:BRAT P2MBPS
Sets the PSDU bit rate to 2 mbps.
BB:WLNN:PSDU:MOD?
Queries the modulation mode.
Response: "DQPSK"

Usage: Query only

Manual operation: See "PSDU Modulation" on page 37

[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:SCRambler:MODE <Mode>
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:SCRambler:MODE <Mode>
The command selects the different options for the scrambler.

Parameters:
<Mode> OFF | RANDom | USER | ON | PREamble

OFF
The scrambler is deactivated.
RANDom
(not for CCK/PBCC)
The scrambler is activated.
The initialization value of the scrambler is selected at random.
Each frame has a different random initialization value. This value
is also different in case of successive recalculations with the
same setting parameters so that different signals are generated
for each calculation.
USER
(not for CCK/PBCC)
The scrambler is activated.
The initialization value of the scrambler is set to a fixed value
that is set using the command BB:WLNN:FBL5:SCR:PATT. This
value is then identical in each generated frame.
ON
(CCK/PBCC only)
The scrambler is activated.
PREamble
(CCK/PBCC only)
The scrambler is activated. Only the preamble is scrambled.
*RST: USER

Example: BB:WLNN:FBL5:SCR:MODE RAND
activates the scrambler with an random initialization value.

Manual operation: See "Scrambler" on page 59
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[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:SCRambler:PATTern
<Pattern>

[:SOURce<hw>]:BB:WLNN:FBLock<ch>:SCRambler:PATTern <Pattern>
The command sets the initialization value for scrambling mode User. This value is then
identical in each generated frame.

Parameters:
<Pattern> 8 bits

*RST: #H01,8

Example: BB:WLNN:FBL5:SCR:PATT #H3F,8
sets the user defined initialization value for the scrambler.

Manual operation: See "Scrambler Init (hex)" on page 60

[:SOURce<hw>]:BB:WLNN:FBLock<ch>:RIGHt106tone <Right106toneRu>

If enabled, indicates that the right 106-tone RU is within the primary 20 MHz.

Parameters:
<Right106toneRu> 1 | ON | 0 | OFF

*RST: 0

Manual operation: See "Right 106-Tone RU" on page 42

[:SOURce<hw>]:BB:WLNN:FBLock<ch>:SEGMent <SEGMent>

Selects one of the two segments in VHT-80+80 MHz mode with transmission band-
width 80 MHz or 160 MHz. Both segments can only be generated with bandwidth 160
MHz.

This parameter applies to VHT-80+80 MHz Tx mode only.

Parameters:
<SEGMent> SEG0 | SEG1 | BOTH

*RST: SEG0

Example: BB:WLNN:FBL1:SEGM BOTH
Selects both segments.

Manual operation: See "Segment" on page 33

[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:SERVice:PATTern <Pattern>
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:SERVice:PATTern <Pattern>
The command sets the value of the service field. The standard specifies a default
value of 0. Other values can be entered in hexadecimal form for test purposes or future
extensions.

Parameters:
<Pattern> 16 bits

*RST: #H0000,16
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Example: BB:WLNN:FBL5:SERV:PATT #H3F,16
sets the value for the service field.

Manual operation: See "Service Field (hex)" on page 61

[:SOURce<hw>]:BB:WLNN:FBLock<ch>:SMOothing <SMOothing>

(available for all Tx modes, except VHT)

This command indicates to the receiver whether frequency-domain smoothing is rec-
ommended as part of channel estimation.

Parameters:
<SMOothing> OFF | ON

ON
Indicates that channel estimate smoothing is recommended.
OFF
Indicates that only per-carrier independent channel
(unsmoothed) estimate is recommended.
*RST: 1

Example: BB:WLNN:FBL:SMO ON
switches on smoothing.

Manual operation: See "Smoothing" on page 62

[:SOURce<hw>]:BB:WLNN:FBLock<ch>:SSTReam <SStream>

Sets the number of the spatial streams. For physical mode LEGACY, only value 1 is
valid. For Tx Mode "HT-Duplicate", only value 1 is valid. In all other cases, the number
of spatial streams depends on the number of antennas configured with command
SOURce:BB:WLNN:ANTenna:MODE.

Parameters:
<SStream> integer

Range: 1  to  8
*RST: 1

Example: BB:WLNN:FBL5:SSTR 4
Sets the number of spatial streams to 4.

Manual operation: See "Spatial Streams" on page 32

[:SOURce<hw>]:BB:WLNN:FBLock<ch>:STBC:STATe?

Queries the status of the space time block coding.

Return values: 
<State> INACtive | ACTive

Example: BB:WLNN:FBL5:STBC:STAT?
Queries the status of the space time block coding.
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Usage: Query only

Manual operation: See "Space Time Block Coding" on page 33

[:SOURce<hw>]:BB:WLNN:FBLock<ch>:STSTream <Ststream>

Sets the number of the space time streams. This value depends on the number of spa-
tial streams defined with command SOURce:BB:WLNN:FBLock:SSTReam. Changing
the number of the Spatial Streams immediately changes the value of the Space Time
Streams to the same value.

Parameters:
<Ststream> integer

Range: 1  to  dynamic
*RST: 1

Example: BB:WLNN:FBL5:STBC:STAT?
Queries the status of the space time block coding.

Manual operation: See "Space Time Streams" on page 32

[:SOURce<hw>]:BB:WLNN:FBLock<ch>:TDWindowing:STATe <State>

Activates/deactivates the time domain windowing. Time domain windowing is a method
to influence the spectral characteristics of the signal, which is not stipulated by the
standard. However, it does not replace oversampling and subsequent signal filtering.

Parameters:
<State> 1 | ON | 0 | OFF

*RST: 0

Example: BB:WLNN:FBL5:TDW:STAT ON
Activates the time domain windowing.

Manual operation: See "Time Domain Windowing Active" on page 41

[:SOURce<hw>]:BB:WLNN:FBLock<ch>:TTIMe <TTime>

Sets the transition time when time domain windowing is active.

The transition time defines the overlap range of two OFDM symbols. At a setting of 100
ns and if BW = 20 MHz, one sample overlaps.

Parameters:
<TTime> float

Range: 0  to  1000 ns
Increment: 1 ns
*RST: 100 ns

Example: BB:WLNN:FBL5:TTIM 100
Sets the transition time to 100 ns.

Manual operation: See "Transition Time" on page 42
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[:SOURce<hw>]:BB:WLNN:FBLock<ch>:UINDex <UIND>

Defines the currently generated user. In activated Multi User MIMO only, one user can
be generated at a time. This parameter selects the generated one out of four available
users.

Parameters:
<UIND> UIDX0 | UIDX1 | UIDX2 | UIDX3

*RST: UIDX0

Example: BB:WLNN:BB:WLNN:FBL1:UIND UIDX1
Selects the generated user with index 1.

Manual operation: See "User Index" on page 34

6.9.2  EHT/HE configuration

[:SOURce<hw>]:BB:WLNN:FBLock<ch>:BCHG................................................................176
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:BDCM................................................................177
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:BEUL?...............................................................177
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:BMCS................................................................177
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:BSSColor...........................................................178
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[:SOURce<hw>]:BB:WLNN:FBLock<ch>:DOPPler............................................................ 180
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:EMCS................................................................180
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:ESDiffer............................................................. 180
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[:SOURce<hw>]:BB:WLNN:FBLock<ch>:LOGGing............................................................181
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:MAXPe.............................................................. 181
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:NONOfdmaUser................................................. 181
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:PED?.................................................................182
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:PFORmat...........................................................182
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[:SOURce<hw>]:BB:WLNN:FBLock<ch>:PPUNcturing:BW................................................ 183
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[:SOURce<hw>]:BB:WLNN:FBLock<ch>:SPAReuse<st>................................................... 183
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[:SOURce<hw>]:BB:WLNN:FBLock<ch>:BCHG <BeamChange>

If enabled, the beam is changed between pre-HE and HE modulated fields.

Parameters:
<BeamChange> OFF | ON | 1 | 0
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Example: :BB:WLNN:FBL1 BCHG ON
Enables that the beam is changed between the pre-HE and HE
modulated fields.

Manual operation: See "Beam Change" on page 41

[:SOURce<hw>]:BB:WLNN:FBLock<ch>:BDCM <SIGBDCM>

Enables the use of dual carrier modulation (DCM) in a signal B field.

Parameters:
<SIGBDCM> OFF | ON | 1 | 0

Example: :BB:WLNN:FBL1:BDCM OFF
Disables DCM in the signal B field.

Manual operation: See "SIG-B DCM" on page 42

[:SOURce<hw>]:BB:WLNN:FBLock<ch>:BEUL?

Queries the total number of users for each 802.11be frame block.

Return values: 
<UserLength> integer

*RST: 1

Example: BB:WLNN:FBLock2:BEUL?
// Response: "8"
// Frame block two has eight users.

Usage: Query only

Manual operation: See "User x" on page 55

[:SOURce<hw>]:BB:WLNN:FBLock<ch>:BMCS <SIGBMCS>

Sets the modulation and coding scheme (MCS) for the signal B field.

Parameters:
<SIGBMCS> MCS0 | MCS1 | MCS2 | MCS3 | MCS4 | MCS5 | MCS6 | MCS7 |

MCS8 | MCS9 | MCS10 | MCS11 | MCS12 | MCS13 | MCS14 |
MCS15 | MCS16 | MCS17 | MCS18 | MCS19 | MCS20 |
MCS21 | MCS22 | MCS23 | MCS24 | MCS25 | MCS26 |
MCS27 | MCS28 | MCS29 | MCS30 | MCS31 | MCS32 |
MCS33 | MCS34 | MCS35 | MCS36 | MCS37 | MCS38 |
MCS39 | MCS40 | MCS41 | MCS42 | MCS43 | MCS44 |
MCS45 | MCS46 | MCS47 | MCS48 | MCS49 | MCS50 |
MCS51 | MCS52 | MCS53 | MCS54 | MCS55 | MCS56 |
MCS57 | MCS58 | MCS59 | MCS60 | MCS61 | MCS62 |
MCS63 | MCS64 | MCS65 | MCS66 | MCS67 | MCS68 |
MCS69 | MCS70 | MCS71 | MCS72 | MCS73 | MCS74 |
MCS75 | MCS76
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Example: :BB:WLNN:FBL1:BMCS MCS1
Sets the SIG-B MCSs to modulation scheme 1.

Manual operation: See "SIG-B MCS" on page 42

[:SOURce<hw>]:BB:WLNN:FBLock<ch>:BSSColor <BSSColor>

Sets the BSS color, an identifier of the basic service sets (BSS) field. This parameter
helps to check if a detected frame is coming form an overlapping station.

Parameters:
<BSSColor> integer

Range: 0  to  63
*RST: 0

Example: BB:WLNN:FBL1:BSSC 5
Sets the BSS color to 5.

Manual operation: See "BSS Color" on page 43

[:SOURce<hw>]:BB:WLNN:FBLock<ch>:BWINd <BwType>

Sets the type of channelization of 320 MHz channels in the BW field of the U-SIG-1
field.

The channelization affects two adjacent 160 MHz of a 320 MHz in the 6 GHz band.

Parameters:
<BwType> T1_320 | T2_320

T1_320
320MHz-1 channelization with channel center frequency num-
bers 31, 95 and 159.
T2_320
320MHz-2 channelization with channel center frequency num-
bers 63, 127 and 191.
*RST: T1_320

Example: :BB:WLNN:FBL1BWINd T1_320
Sets 320 MHz channel type "320MHz-1".

Manual operation: See "320MHz Type" on page 49

[:SOURce<hw>]:BB:WLNN:FBLock<ch>:CCH1:RUALlocation<st> <RuAllocation>

For EHT frames.

Sets the resource unit allocation of the first content channel for the respective channel
and station.
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Parameters:
<RuAllocation> RU0 | RU1 | RU2 | RU3 | RU4 | RU5 | RU6 | RU7 | RU8 | RU9 |

RU10 | RU11 | RU12 | RU13 | RU14 | RU15 | RU16 | RU17 |
RU18 | RU19 | RU20 | RU21 | RU22 | RU23 | RU24 | RU25 |
RU26 | RU27 | RU28 | RU29 | RU30 | RU31 | RU32 | RU33 |
RU34 | RU35 | RU36 | RU37 | RU38 | RU39 | RU40 | RU41 |
RU42 | RU43 | RU44 | RU45 | RU46 | RU47 | RU48 | RU49 |
RU50 | RU51 | RU52 | RU53 | RU54 | RU55 | RU56 | RU57 |
RU58 | RU59 | RU60 | RU61 | RU62 | RU63 | RU64 | RU65 |
RU66 | RU67 | RU68 | RU69 | RU70 | RU71 | RU72 | RU73 |
RU74 | RU75 | RU76 | RU77 | RU78 | RU79 | RU80 | RU81 |
RU82 | RU83 | RU84 | RU85 | RU86
*RST: RU57

Manual operation: See "RU Allocation" on page 54

[:SOURce<hw>]:BB:WLNN:FBLock<ch>:CCH2:RUALlocation<st> <RuAllocation>

For EHT frames.

Sets the resource unit allocation of the second content channel for the respective
channel and station.

Parameters:
<RuAllocation> RU0 | RU1 | RU2 | RU3 | RU4 | RU5 | RU6 | RU7 | RU8 | RU9 |

RU10 | RU11 | RU12 | RU13 | RU14 | RU15 | RU16 | RU17 |
RU18 | RU19 | RU20 | RU21 | RU22 | RU23 | RU24 | RU25 |
RU26 | RU27 | RU28 | RU29 | RU30 | RU31 | RU32 | RU33 |
RU34 | RU35 | RU36 | RU37 | RU38 | RU39 | RU40 | RU41 |
RU42 | RU43 | RU44 | RU45 | RU46 | RU47 | RU48 | RU49 |
RU50 | RU51 | RU52 | RU53 | RU54 | RU55 | RU56 | RU57 |
RU58 | RU59 | RU60 | RU61 | RU62 | RU63 | RU64 | RU65 |
RU66 | RU67 | RU68 | RU69 | RU70 | RU71 | RU72 | RU73 |
RU74 | RU75 | RU76 | RU77 | RU78 | RU79 | RU80 | RU81 |
RU82 | RU83 | RU84 | RU85 | RU86
*RST: RU57

Manual operation: See "RU Allocation" on page 54

[:SOURce<hw>]:BB:WLNN:FBLock<ch>:CURPe?

Queries the current PE duration for all users.

Return values: 
<CurrentPe> integer

Range: 0  to  16
*RST: 0

Usage: Query only

Manual operation: See "Cur PE Duration" on page 41
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[:SOURce<hw>]:BB:WLNN:FBLock<ch>:DOPPler <DOPPLER>

If switched on, the Doppler effect is used for the PPDU.

Parameters:
<DOPPLER> OFF | ON | 1 | 0

Example: :BB:WLNN:FBLock1:DOPP ON
Enables the Doppler effect to be used for the PPDU.

Manual operation: See "Doppler" on page 44

[:SOURce<hw>]:BB:WLNN:FBLock<ch>:EMCS <EhtSigMcs>

Sets the modulation coding scheme for modulation of the EHT-SIG bits.

Parameters:
<EhtSigMcs> MCS0 | MCS1 | MCS3 | MCS15

*RST: MCS0

Example: BB:WLNN:FBLock1:EMCS MCS1
// Sets modulation coding scheme MCS1.

Manual operation: See "EHT-SIG MCS" on page 49

[:SOURce<hw>]:BB:WLNN:FBLock<ch>:ESDiffer <EHTSIGDiffer>

For EHT-160MHz/EHT-320MHz frames, activates different EHT-SIG fields for every 80
MHz channel.

Parameters:
<EHTSIGDiffer> 1 | ON | 0 | OFF

*RST: 0

Example: BB:WLNN:BW BW160
BB:WLNN:FBL1:TMODe EHT160
BB:WLNN:FBL1:ESDiffer 1

Manual operation: See "EHT-SIG Diff per 80MHz" on page 51

[:SOURce<hw>]:BB:WLNN:FBLock<ch>:LINK <LinkDirection>

Sets the link direction.

Parameters:
<LinkDirection> DOWN | UP

*RST: DOWN

Example: :BB:WLNN:FBL1:LINK DOWN
Set the downlink link direction.

Manual operation: See "Link Direction" on page 40
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[:SOURce<hw>]:BB:WLNN:FBLock<ch>:LOGFile?

Queries the fixed file path used for logging the contents of HE-SIG-A and HE-SIG-B
fields, if [:SOURce<hw>]:BB:WLNN:FBLock<ch>:LOGGing is set to ON.

Return values: 
<LogFile> string

Usage: Query only

Manual operation: See "Output File" on page 45

[:SOURce<hw>]:BB:WLNN:FBLock<ch>:LOGGing <LoggingState>

If enabled (ON), the contents of HE-SIG-A and HE-SIG-B fields are written to a file in a
text form. The location of the file can be queried with [:SOURce<hw>]:BB:WLNN:
FBLock<ch>:LOGGing.

Parameters:
<LoggingState> 1 | ON | 0 | OFF

Manual operation: See "Logging State" on page 45

[:SOURce<hw>]:BB:WLNN:FBLock<ch>:MAXPe <MaxPeDuration>

Sets the maximum packet extension (PE) duration.

Parameters:
<MaxPeDuration> PE0 | PE8 | PE16 | PE20

PE0|PE8|PE16|PE20
0/8/16/20 us
*RST: PE0

Example: SOURce1:BB:WLNN:FBL1:MAXP PE0
Sets the maximum packet extension of 0 us.

Manual operation: See "Max PE Duration" on page 40

[:SOURce<hw>]:BB:WLNN:FBLock<ch>:NONOfdmaUser <NonOfdmaUser>

Sets the number of non-OFDMA users.

Parameters:
<NonOfdmaUser> integer

Range: 1  to  8
*RST: 1

Example: BB:WLNN:FBL1:NONOfdmaUser 2
Sets two non-OFDMA users.

Manual operation: See "Non-OFDMA Users" on page 51
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[:SOURce<hw>]:BB:WLNN:FBLock<ch>:PED?

Queries the disambiguity in the number of sybmbols occuring due to the packet exten-
sion.

Return values: 
<PEDisambiguity> integer

Range: 0  to  1
*RST: 0

Usage: Query only

Manual operation: See "PE Disambiguity" on page 44

[:SOURce<hw>]:BB:WLNN:FBLock<ch>:PFORmat <PpduFormat>

Sets the PPDU format.

Parameters:
<PpduFormat> SU | MU | SUEXt | TRIG

SU
HE SU (single-user) carries a single PSDU. The HE Signal A
(HE-SIG-A) field is not repeated.
MU
HE MU (multi-user) carries multiple PSDUs to one or more
users.
SUEXt
Carries a single PSDU. The HE-SIG-A field is repeated.
TRIG
Carries a single PSDU. It is send as a response to a PPDU that
contains a trigger frame.
*RST: SU

Example: :BB:WLNN:FBL1:PFOR SU
Sets the PPDU format to HE single user.

Manual operation: See "PPDU Format" on page 41

[:SOURce<hw>]:BB:WLNN:FBLock<ch>:POFDma <OfdmaMode>

Queries, if OFDMA mode is active for EHT frames.

Parameters:
<OfdmaMode> 1 | ON | 0 | OFF

*RST: 0

Manual operation: See "OFDMA Mode" on page 48

[:SOURce<hw>]:BB:WLNN:FBLock<ch>:PFPFactor?

Queries the pre-FEC padding factor.
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Return values: 
<PreFECPadding> integer

Range: 0  to  3
*RST: 0

Usage: Query only

Manual operation: See "pre-FEC Padding Factor" on page 44

[:SOURce<hw>]:BB:WLNN:FBLock<ch>:PPUNcturing:BW <PreamblePuncBw>

Sets the bandwidth mode of preamble puncturing.

Parameters:
<PreamblePuncBw> 4 | 5 | 6 | 7

4|5
Sets the bandwidth mode for HE80 channels.
6|7
Sets the bandwidth mode for HE8080 channels.
*RST: 4

Example: See [:SOURce<hw>]:BB:WLNN:FBLock<ch>:
PPUNcturing:STATe on page 183.

[:SOURce<hw>]:BB:WLNN:FBLock<ch>:PPUNcturing:STATe <PreamblePunc>

Enables preamble puncturing of the HE MU PPDU in 80 MHz or (80+80)/160 MHz
channels.

Parameters:
<PreamblePunc> 1 | ON | 0 | OFF

*RST: 0

Example: BB:WLNN:FBL1:TMODe HE8080
BB:WLNN:FBL1:PPUNcturing:STATe 1
BB:WLNN:FBL1:PPUNcturing:BW 6

Manual operation: See "Preamble Puncturing" on page 42
See "Preamble Puncturing Bandwidth" on page 44

[:SOURce<hw>]:BB:WLNN:FBLock<ch>:SPAReuse<st> <SpatialReuse>

Indicates if the spatial reuse is allowed (value is ≠0) or not (value is 0).

Parameters:
<SpatialReuse> integer

Range: 0  to  15
*RST: 0
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Example: SOURce1:BB:WLNN:FBLock1:SPAReuse1 0
// Spatial reuse is not allowed for frame block 1.
SOURce1:BB:WLNN:FBLock1:SPAReuse1 1
// Spatial reuse is not allowed for frame block 1.

Manual operation: See "Spatial Reuse 1/2" on page 43

[:SOURce<hw>]:BB:WLNN:FBLock<ch>:SYMDuration <HeLtfSymDur>

Selects the duration of the HE long training field (LTF).The symbol duration value does
not include the guard interval.

Parameters:
<HeLtfSymDur> SD32 | SD64 | SD128

*RST: SD64

Manual operation: See "EHT-LTF Symb Duration/HE-LTF Symb Duration"
on page 41

[:SOURce<hw>]:BB:WLNN:FBLock<ch>:TXOPduration <TXOPDuraion>

If transmission opportunity (TXOP) is set to 127, it indicates no duration information. If
it is set to any other value, it indicates duration information for network allocation vector
(NAV) parameter and that the TXOP is protected.

Parameters:
<TXOPDuraion> integer

Range: 0  to  127
*RST: 127

Example: :BB:WLNN:FBL1:TXOP 127
Sets the transmission opportunity duration to 127.

Manual operation: See "TXOP Duration" on page 43

6.9.3  User configuration
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[:SOURce<hw>]:BB:WLNN:FBLock<ch>:CCH1:RUSelection<st> <RuSelCh1>

For HE frames.

Sets the resource unit allocation of the first content channel for the respective channel
and station.

Parameters:
<RuSelCh1> RU0 | RU1 | RU2 | RU3 | RU4 | RU5 | RU6 | RU7 | RU8 | RU9 |

RU10 | RU11 | RU12 | RU13 | RU14 | RU15 | RU18 | RU19 |
RU20 | RU21 | RU22 | RU23 | RU24 | RU25 | RU34 | RU35 |
RU36 | RU37 | RU38 | RU16 | RU17 | RU26 | RU27 | RU28 |
RU29 | RU30 | RU31 | RU32 | RU33
*RST: RU34

Manual operation: See "RU Selection" on page 53

[:SOURce<hw>]:BB:WLNN:FBLock<ch>:CCH2:RUSelection<st> <RuSelCh2>

For HE frames.

Sets the resource unit allocation of the second content channel for the respective
channel and station.

Parameters:
<RuSelCh2> RU0 | RU1 | RU2 | RU3 | RU4 | RU5 | RU6 | RU7 | RU8 | RU9 |

RU10 | RU11 | RU12 | RU13 | RU14 | RU15 | RU18 | RU19 |
RU20 | RU21 | RU22 | RU23 | RU24 | RU25 | RU34 | RU35 |
RU36 | RU37 | RU38 | RU16 | RU17 | RU26 | RU27 | RU28 |
RU29 | RU30 | RU31 | RU32 | RU33
*RST: RU34

Manual operation: See "RU Selection" on page 53

[:SOURce<hw>]:BB:WLNN:FBLock<ch>:CCH2:MUNum<st> <MuNumCh2>

Sets the number of MU-MIMO users for each RU and station of the second content
channel.

Parameters:
<MuNumCh2> integer

Range: 0  to  8
*RST: 1

Manual operation: See "Number of MU-MIMO users" on page 54

[:SOURce<hw>]:BB:WLNN:FBLock<ch>:CCH1:MUNum<st> <MuNumCh1>

Sets the number of MU-MIMO users for each RU and station of the first content chan-
nel.
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Parameters:
<MuNumCh1> integer

Range: 0  to  8
*RST: 1

Manual operation: See "Number of MU-MIMO users" on page 54

[:SOURce<hw>]:BB:WLNN:FBLock<ch>:CENRu<st> <Center26toneRU>

For full bandwidth 80 MHz: if enabled, indicates that center 26 -tone RU is allocated
in the common block fields of both SIGB content channels with same value.

For full bandwidth 160/80+80 MHz: if enabled, indicates that center 26 -tone RU is
allocated for one individual 80 MHz in Common Block fields of both SIGB content
channels.

Parameters:
<Center26toneRU> OFF | ON | 1 | 0

Manual operation: See "Center 26-tone RU" on page 54

[:SOURce<hw>]:BB:WLNN:FBLock<ch>:USER<di>:GAIN <Gain>

Sets the user gain.

Parameters:
<Gain> float

Range: -80  to  0
Increment: 0.01
*RST: 0

Manual operation: See "Gain (dB)" on page 56

[:SOURce<hw>]:BB:WLNN:FBLock<ch>:USER<di>:MRUindex <MruIndex>

Sets the multi resource unit index.

Parameters:
<MruIndex> MRU1 | MRU2 | MRU3 | MRU4 | MRU5 | MRU6 | MRU7 |

MRU8 | MRU9 | MRU10 | MRU11 | MRU12
*RST: MRU1

Manual operation: See "MRU Index" on page 55

[:SOURce<hw>]:BB:WLNN:FBLock<ch>:USER<di>:MUMimo:STATe?

Queries if the MU-MIMO is used for current user.

Return values: 
<MuMimoState> 1 | ON | 0 | OFF

*RST: 0
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Usage: Query only

Manual operation: See "MU MIMO" on page 56

[:SOURce<hw>]:BB:WLNN:FBLock<ch>:USER<di>:NSTS <UserNsts>

Sets the number of spatial streams, the number of space time streams minus 1.

Parameters:
<UserNsts> integer

Range: 1  to  8
*RST: 1

Manual operation: See "Nsts" on page 55

[:SOURce<hw>]:BB:WLNN:FBLock<ch>:USER<di>:RUTYpe <RuType>

Queries the resource unit type for the current user.

Parameters:
<RuType> RU26 | RU52 | RU106 | RU242 | RU484 | RU996 | RU2996 |

RUC26 | RU4996 | RU484_242 | RU996_484 |
RU996_484_242 | RU2996_484 | RU3996 | RU3996_484
RU26|RU52|RU106|RU242|RU484|RU996|RU2996|RUC26
Require WLAN standard IEEE 802.11ax or IEEE 802.11be:
SOURce1:BB:WLNN:FBLock1:STANdard WAX
RU26|RU52|RU106|RU242|RU484|RU996|RU2996|RUC26|
RU4996|RU484_242|RU996_484|RU996_484_242|
RU2996_484|RU3996|RU3996_484
Require WLAN standard IEEE 802.11be:
SOURce1:BB:WLNN:FBLock1:STANdard WBE
*RST: RU242

Manual operation: See "RU Size" on page 55

[:SOURce<hw>]:BB:WLNN:FBLock<ch>:USER<di>:STAid <StaId>

Sets the station ID for the current user, the 11 least significant bits of the association
identifier (AID).

Parameters:
<StaId> integer

Range: 0  to  2047
*RST: 1

Manual operation: See "STA Id" on page 55

[:SOURce<hw>]:BB:WLNN:FBLock<ch>:USER<di>:STATe <UserState>

Switches the current user on and off.
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Parameters:
<UserState> 1 | ON | 0 | OFF

*RST: 1

Manual operation: See "State" on page 56

[:SOURce<hw>]:BB:WLNN:FBLock<ch>:USER<di>:TXBF <TXBF>

If switched on, indicates that the beamforming matrix is applied to the waveform.

Parameters:
<TXBF> 1 | ON | 0 | OFF

Manual operation: See "TxBF" on page 56

6.9.4  MPDU configuration

[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:MPDU:COUNt.................................. 188
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:MPDU:COUNt.................................................... 188
[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:MPDU<st>:DATA:DSELection............ 188
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:MPDU<st>:DATA:DSELection.............................. 188
[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:MPDU<st>:DATA:LENGth..................189
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:MPDU<st>:DATA:LENGth....................................189
[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:MPDU<st>:DATA:PATTern................. 189
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:MPDU<st>:DATA:PATTern................................... 189
[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:MPDU<st>:DATA:SOURce.................190
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:MPDU<st>:DATA:SOURce...................................190
[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:MPDU:EOF...................................... 190
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:MPDU:EOF........................................................ 190

[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:MPDU:COUNt <Count>
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:MPDU:COUNt <Count>
Determines the number of MPDUs in the frame.

Parameters:
<Count> integer

Range: 1  to  64
*RST: 1

Example: BB:WLNN:FBL1:MPDU:COUN 3
Determines the number of MPDUs in the frame.

Manual operation: See "Number of MPDUs" on page 63

[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:MPDU<st>:DATA:
DSELection <Filename>

[:SOURce<hw>]:BB:WLNN:FBLock<ch>:MPDU<st>:DATA:DSELection
<Filename>

Selects the data list for the DLISt data source selection.
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The lists are saved as files with the fixed file extensions *.dm_iqd in a directory of the
user's choice.

Parameters:
<Filename> string

Example: BB:WLNN:FBL1:MPDU1:DATA DLIS
Selects the Data Lists data source.
MMEM:CDIR '/var/user/temp/Lists'
Selects the directory for the data lists.
BB:WLNN:FBL1:MPDU1:DATA:DSEL 'dlist1'
Selects the 'dlist1' as the data source. This file must be in the
directory specified above. It must have the file extension
*.dm_iqd.

Manual operation: See "DList / Pattern" on page 64

[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:MPDU<st>:DATA:LENGth
<Length>

[:SOURce<hw>]:BB:WLNN:FBLock<ch>:MPDU<st>:DATA:LENGth <Length>
Determines the size of the data field in bytes.

Parameters:
<Length> integer

Range: 0  to  16384
*RST: 1024

Example: BB:WLNN:FBL1:MPDU1:DATA:LENG 1024
Determines the size of the data field.

Manual operation: See "Data Length / bytes" on page 64

[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:MPDU<st>:DATA:PATTern
<Pattern>

[:SOURce<hw>]:BB:WLNN:FBLock<ch>:MPDU<st>:DATA:PATTern <Pattern>
Determines the bit pattern for the PATTern selection.

Parameters:
<Pattern> 64 bits

*RST: #H0,1

Example: BB:WLNN:FBL1:MPDU1:DATA:PATT #B0101,4
Sets the bit pattern.

Manual operation: See "DList / Pattern" on page 64
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[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:MPDU<st>:DATA:SOURce
<Source>

[:SOURce<hw>]:BB:WLNN:FBLock<ch>:MPDU<st>:DATA:SOURce <Source>
Selects the data source.

Parameters:
<Source> ZERO | ONE | PATTern | PN9 | PN11 | PN15 | PN16 | PN20 |

PN21 | PN23 | DLISt
PNxx
The pseudo-random sequence generator is used as the data
source. Different random sequence lengths can be selected.
DLISt
A data list is used. The data list is selected with the command
BB:WLNN:FBL<ch>:MPDU<st>:DATA:DSEL
ZERO | ONE
Internal 0 or 1 data is used.
PATTern
Internal data is used. The bit pattern for the data is defined by
the command BB:WLNN:FBL<ch>:MPDU<st>:DATA:PATT.
*RST: PN9

Example: BB:WLNN:FBL1:MPDU1:DATA:SOUR PATT
Selects the data source.

Manual operation: See "Data" on page 64

[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:MPDU:EOF <EOF>
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:MPDU:EOF <EOF>
Sets the EOF value for the A-MPDU.

Parameters:
<EOF> DEFault | E0 | E1

*RST: DEFault

6.9.5  MAC header configuration

6.9.5.1  Common fields commands

[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:MAC:ADDRess<st>...........................192
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:MAC:ADDRess<st>.............................................192
[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:MAC:ADDRess<st>:STATe................ 192
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:MAC:ADDRess<st>:STATe.................................. 192
[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:MAC:DID..........................................192
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:MAC:DID............................................................192
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:MAC:BSSid........................................................ 193
[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:MAC:FCONtrol................................. 193

Frame configuration settings



Remote-control commandsR&S®SMW-K54/-K86/-K142/-K147

191User Manual 1175.6749.02 ─ 28

[:SOURce<hw>]:BB:WLNN:FBLock<ch>:MAC:FCONtrol................................................... 193
[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:MAC:FCONtrol:FDS.......................... 193
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:MAC:FCONtrol:FDS............................................ 193
[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:MAC:FCONtrol:MDATa...................... 193
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:MAC:FCONtrol:MDATa........................................ 193
[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:MAC:FCONtrol:MFRagments............. 193
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:MAC:FCONtrol:MFRagments............................... 193
[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:MAC:FCONtrol:ORDer...................... 193
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:MAC:FCONtrol:ORDer........................................ 193
[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:MAC:FCONtrol:PMANagement...........193
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:MAC:FCONtrol:PMANagement.............................193
[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:MAC:FCONtrol:PVERsion..................193
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:MAC:FCONtrol:PVERsion....................................193
[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:MAC:FCONtrol:RETRy...................... 193
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:MAC:FCONtrol:RETRy........................................ 194
[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:MAC:FCONtrol:SUBType...................194
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:MAC:FCONtrol:SUBType.....................................194
[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:MAC:FCONtrol:TDS.......................... 194
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:MAC:FCONtrol:TDS............................................ 194
[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:MAC:FCONtrol:TYPE........................ 194
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:MAC:FCONtrol:TYPE.......................................... 194
[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:MAC:FCONtrol:WEP......................... 194
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:MAC:FCONtrol:WEP........................................... 194
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:MAC:SA.............................................................194
[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:MAC:FCS:STATe.............................. 194
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:MAC:FCS:STATe................................................ 194
[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:MAC:QSControl................................ 195
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:MAC:QSControl..................................................195
[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:MAC:QSControl:STATe......................195
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:MAC:QSControl:STATe........................................195
[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:MAC:SCONtrol:FRAGment:

INCRement......................................................................................................... 195
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:MAC:SCONtrol:FRAGment:INCRement................ 195
[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:MAC:SCONtrol:FRAGment:STARt......196
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:MAC:SCONtrol:FRAGment:STARt........................196
[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:MAC:SCONtrol:SEQuence:

INCRement......................................................................................................... 196
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:MAC:SCONtrol:SEQuence:INCRement.................196
[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:MAC:SCONtrol:SEQuence:STARt...... 196
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:MAC:SCONtrol:SEQuence:STARt........................ 196
[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:MAC:SCONtrol:STATe....................... 197
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:MAC:SCONtrol:STATe......................................... 197
[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:MAC:STATe......................................197
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:MAC:STATe........................................................197
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[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:MAC:ADDRess<st>
<Address>

[:SOURce<hw>]:BB:WLNN:FBLock<ch>:MAC:ADDRess<st> <Address>
The command enters the value of the address fields 1 ... 4. Exactly 48 bits must be
entered. Each address is 6 bytes (48 bit) long. The addresses can be entered in hexa-
decimal form in the entry field of each address field. The least significant byte (LSB) is
in left notation.

Parameters:
<Address> integer

Range: #H000000000000,48  to  #HFFFFFFFFFFFF,48
*RST: #H000000000000,48

Example: BB:WLNN:FBL1:MAC:ADDR2 #H124836C7EA54,48
set the value for address field 2.

[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:MAC:ADDRess<st>:STATe
<State>

[:SOURce<hw>]:BB:WLNN:FBLock<ch>:MAC:ADDRess<st>:STATe <State>
The command activates/deactivates the selected address field.

Parameters:
<State> 0 | 1 | OFF | ON

*RST: OFF

Example: BB:WLNN:FBL1:MAC:ADDR2:STAT ON
activates generation of address field 2.

Manual operation: See "MAC Address" on page 67

[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:MAC:DID <Did>
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:MAC:DID <Did>
The command enters the value of the duration ID field. Depending on the frame type,
the 2-byte field Duration/ID is used to transmit the association identity of the station
transmitting the frame or it indicates the duration assigned to the frame type. Exactly
16 bit must be entered.

Parameters:
<Did> integer

Range: #H0000,16  to  #HFFFF,16
*RST: #H0000,16

Example: BB:WLNN:FBL1:MAC:DID #HA5A5,16
sets the value of the duration ID field.

Manual operation: See "Duration ID (hex)" on page 67
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[:SOURce<hw>]:BB:WLNN:FBLock<ch>:MAC:BSSid <Bssid>

Sets the value of the basic service set identification (BSSID) field.

Parameters:
<Bssid> integer

Example: BB:WLNN:FBL1:MAC:BSS #H124836C7EA54,48
Sets the value of the BSSID field to 124836C7EA54

Manual operation: See "BSSID (hex)" on page 68

[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:MAC:FCONtrol <FControl>
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:MAC:FCONtrol <FControl>
The command enters the value of the frame control field. The frame control field has a
length of 2 bytes (16 bits) and is used to define the protocol version, the frame type,
and its function, etc.. As an alternative, the individual bits can be set with the following
commands.

Parameters:
<FControl> integer

Range: #H0000,16  to  #HFFFF,16
*RST: #H0000,16

Example: BB:WLNN:FBL1:MAC:FCON #H100A,16
sets the value of the frame control field.

Manual operation: See "Frame Control (hex)" on page 66

[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:MAC:FCONtrol:FDS <Fds>
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:MAC:FCONtrol:FDS <Fds>
[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:MAC:FCONtrol:MDATa

<MData>
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:MAC:FCONtrol:MDATa <MData>
[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:MAC:FCONtrol:

MFRagments <MFragments>
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:MAC:FCONtrol:MFRagments

<MFragments>
[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:MAC:FCONtrol:ORDer

<Order>
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:MAC:FCONtrol:ORDer <Order>
[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:MAC:FCONtrol:

PMANagement <PManagement>
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:MAC:FCONtrol:PMANagement

<PManagement>
[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:MAC:FCONtrol:PVERsion

<PVersion>
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:MAC:FCONtrol:PVERsion <PVersion>
[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:MAC:FCONtrol:RETRy

<Retry>
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[:SOURce<hw>]:BB:WLNN:FBLock<ch>:MAC:FCONtrol:RETRy <Retry>
[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:MAC:FCONtrol:SUBType

<Subtype>
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:MAC:FCONtrol:SUBType <Subtype>
[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:MAC:FCONtrol:TDS <Tds>
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:MAC:FCONtrol:TDS <Tds>
[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:MAC:FCONtrol:TYPE

<Type>
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:MAC:FCONtrol:TYPE <Type>
[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:MAC:FCONtrol:WEP <Wep>
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:MAC:FCONtrol:WEP <Wep>
The command enters the value of the individual bits of the frame control field.

Parameters:
<Wep> integer

Range: #H0,1  to  #H1,1
*RST: #H0,1

Example: BB:WLNN:FBL1:MAC:FCON:MDAT #H1,1
sets the value of the More Data bit.

Manual operation: See "MAC Frame Control Field" on page 66

[:SOURce<hw>]:BB:WLNN:FBLock<ch>:MAC:SA <Sa>

Sets the value of the source address (SA) field.

Parameters:
<Sa> integer

Example: BB:WLNN:FBL1:MAC:SA #HFFFFFFFFFFFF,48
Sets the value of the SA field to FFFFFFFFFFFF.

Manual operation: See "SA (hex)" on page 68

[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:MAC:FCS:STATe <State>
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:MAC:FCS:STATe <State>
Activates/deactivates the calculation of the FCS (frame check sequence). The stan-
dard defines a 32-bit (4-byte) checksum to protect the MAC header and the user data
(frame body).

Parameters:
<State> 0 | 1 | OFF | ON

*RST: OFF

Example: BB:WLNN:FBL1:MAC:FCS:STAT ON
activates the calculation of the FCS.

Manual operation: See "FCS (checksum)" on page 66
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[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:MAC:QSControl
<QsControl>

[:SOURce<hw>]:BB:WLNN:FBLock<ch>:MAC:QSControl <QsControl>
Sets the value for the QoS control field.

Parameters:
<QsControl> integer

Range: #H0000,16  to  #HFFFF,16

Example: BB:WLNN:FBL1:MAC:QSC #H5A5A,16
Sets the value for the QoS field to#H5A5A,16.

Manual operation: See "QoS Control" on page 72

[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:MAC:QSControl:STATe
<State>

[:SOURce<hw>]:BB:WLNN:FBLock<ch>:MAC:QSControl:STATe <State>
The command enables/disables the QoS control.

Parameters:
<State> 0 | 1 | OFF | ON

*RST: ON

Example: BB:WLNN:FBL1:MAC:QSC:STAT ON
enables the QoS control.

Manual operation: See "QoS Control" on page 72

[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:MAC:SCONtrol:FRAGment:
INCRement <Increment>

[:SOURce<hw>]:BB:WLNN:FBLock<ch>:MAC:SCONtrol:FRAGment:INCRement
<Increment>

Defines the number of packets required to increment the counter of the fragment bits of
the sequence control.

Parameters:
<Increment> integer

Range: 0  to  1024
*RST: 1

Example: BB:WLNN:FBL1:MAC:SCON:FRAG:INCR 2
two packets are required to increment the counter of the frag-
ment bits.

Manual operation: See "Increment Every" on page 70
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[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:MAC:SCONtrol:FRAGment:
STARt <Start>

[:SOURce<hw>]:BB:WLNN:FBLock<ch>:MAC:SCONtrol:FRAGment:STARt
<Start>

The command enters the start number of the fragment bits of the sequence control.

Parameters:
<Start> integer

Range: #H0,4  to  #HF,4
*RST: #H0,4

Example: BB:WLNN:FBL1:MAC:SCON:FRAG:STAR #H4,4
sets the start value of the fragment bits of the sequence control.

Manual operation: See "Start Number (hex)" on page 69

[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:MAC:SCONtrol:SEQuence:
INCRement <Increment>

[:SOURce<hw>]:BB:WLNN:FBLock<ch>:MAC:SCONtrol:SEQuence:INCRement
<Increment>

Defines the number of packets required to increment the counter of the sequence bits
of the sequence control.

Parameters:
<Increment> integer

Range: 0  to  1024
*RST: 1

Example: BB:WLNN:FBL1:MAC:SCON:FRAG:INCR 2
two packets are required to increment the counter of the
sequence bits.

Manual operation: See "Increment Every" on page 70

[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:MAC:SCONtrol:SEQuence:
STARt <Start>

[:SOURce<hw>]:BB:WLNN:FBLock<ch>:MAC:SCONtrol:SEQuence:STARt
<Start>

The command enters the start number of the fragment bits of the sequence control.

Parameters:
<Start> integer

Range: #H000,12  to  #HFFF,12
*RST: #H000,12

Example: BB:WLNN:FBL1:MAC:SCON:SEQ:STAR #H444,12
sets the start value of the sequence bits of the sequence control.

Manual operation: See "Start Number (hex)" on page 69
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[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:MAC:SCONtrol:STATe
<State>

[:SOURce<hw>]:BB:WLNN:FBLock<ch>:MAC:SCONtrol:STATe <State>
The command activates/deactivates the sequence control.

Parameters:
<State> 0 | 1 | OFF | ON

*RST: OFF

Example: BB:WLNN:FBL1:MAC:SCON:STAT ON
activates the sequence control field.

Manual operation: See "Sequence Control" on page 68

[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:MAC:STATe <State>
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:MAC:STATe <State>
The command activates/deactivates the generation of the MAC Header.

Parameters:
<State> 0 | 1 | OFF | ON

*RST: 0

Example: BB:WLNN:FBL1:MAC:STAT ON
activates the generation of the MAC Header.

Manual operation: See "MAC Header" on page 65

6.9.5.2  MAC header HT configuration

[:SOURce<hw>]:BB:WLNN:FBLock<ch>:MAC:HTControl.................................................. 197
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:MAC:HTControl:ACConstraint.............................. 198
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:MAC:HTControl:CALibration:POSition...................198
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:MAC:HTControl:CALibration:SEQuence................199
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:MAC:HTControl:CSISteering................................ 199
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:MAC:HTControl:FREQuest.................................. 199
[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:MAC:VHTControl:HVINdicator?.......... 200
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:MAC:HTControl:HVINdicator?.............................. 200
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:MAC:HTControl:LAControl................................... 200
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:MAC:HTControl:NDP...........................................201
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:MAC:HTControl:RDGMore...................................201
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:MAC:HTControl:REServed...................................201
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:MAC:HTControl:SREServed.................................202
[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:MAC:HTControl:STATe...................... 202
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:MAC:HTControl:STATe........................................ 202
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:MAC:HTControl:ZLF............................................202

[:SOURce<hw>]:BB:WLNN:FBLock<ch>:MAC:HTControl <HtControl>

Sets the value for the HT control field.
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Parameters:
<HtControl> integer

Range: #H00000000,32  to  #HFFFFFFFF,32
*RST: #H00000000,32

Example: BB:WLNN:FBL1:MAC:HTC #H5a5a5a5a,32
Sets the value for the HT control field to #H5a5a5a5a,32.

Manual operation: See "HT/VHT/HE Control" on page 72

[:SOURce<hw>]:BB:WLNN:FBLock<ch>:MAC:HTControl:ACConstraint
<AcConstraint>

Sets the value for the AC signal field.

0 = The response may contain data from any TID (Traffic Identifier).

1 = The response may contain data only from the same AC as the last Data received
from the initiator.

Parameters:
<AcConstraint> integer

Range: #H0,1  to  #H1,1
*RST: 0

Example: BB:WLNN:FBL1:MAC:HTC:ACC #H0,1
Sets the AC signal field to 0 (The response may contain data
from any TID)

Manual operation: See "AC Constraint" on page 73

[:SOURce<hw>]:BB:WLNN:FBLock<ch>:MAC:HTControl:CALibration:POSition
<Position>

Sets the value for the calibration position.

00 = Not a calibration frame (Default setting)

01 = Calibration Start

10 = Sounding Response

11 = Sounding Complete

Parameters:
<Position> integer

Range: #H0,2  to  #H3,2

Example: BB:WLNN:FBL1:MAC:HTC:CAL:POS #H0,2
Sets the calibration position signal field to 00 (not a calibration
frame).

Manual operation: See "Calibration Position" on page 74
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[:SOURce<hw>]:BB:WLNN:FBLock<ch>:MAC:HTControl:CALibration:SEQuence
<Sequence>

Sets the value for the calibration sequence.

Parameters:
<Sequence> integer

Range: #H0,2  to  #H3,2

Example: BB:WLNN:FBL1:MAC:HTC:CAL:SEQ #H3,2
Sets the value for the calibration sequence.

Manual operation: See "Calibration Sequence" on page 74

[:SOURce<hw>]:BB:WLNN:FBLock<ch>:MAC:HTControl:CSISteering
<CsiSteering>

Sets the value for the CSI steering.

00 = CSI

01 = uncompressed Steering Matrix

10 = compressed Steering Matrix

11 = Reserved

Parameters:
<CsiSteering> integer

Range: #H0,2  to  #H3,2

Example: BB:WLNN:FBL1:MAC:HTC:CSIS #H1,2
Sets the value for the CSI steering to 01 (uncompressed Steer-
ing Matrix).

Manual operation: See "CSI Steering" on page 74

[:SOURce<hw>]:BB:WLNN:FBLock<ch>:MAC:HTControl:FREQuest <FRequest>

Sets the value for the feedback request.

00 = no request

01 = unsolicited feedback only

10 = immediate feedback

11 = aggregated feedback

Parameters:
<FRequest> integer

Range: #H0,2  to  #H3,2

Example: BB:WLNN:FBL1:MAC:HTC:FREQ #H2,2
Sets the value for the feedback request to 10 (immediate feed-
back).
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Manual operation: See "Reserved" on page 74

[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:MAC:VHTControl:
HVINdicator?

[:SOURce<hw>]:BB:WLNN:FBLock<ch>:MAC:HTControl:HVINdicator?
The command queries the used format (HT or VHT).

Return values: 
<HTVHT> integer

Example: BB:WLNN:FBL:MAC:HTC:HVIN?
Response: 1
HT format is used.

Usage: Query only

Manual operation: See "HT/VHT" on page 75

[:SOURce<hw>]:BB:WLNN:FBLock<ch>:MAC:HTControl:LAControl <LaControl>

Sets the value for the link adaption control.

B0 (1bit) MA - MA payload

When the MA field is set to 1, the payload of the QoS Null Data MPDU is interpreted as
a payload of the management action frame.

B1 (1bit) TRQ - Sounding Request

1 = Request to the responder to transmit a sounding PPDU.

B2 (1bit) MRQ - MCS Request

1 = Request for feedback of MCS.

B3-B5 (3bit) MRS - MRQ Sequence Identifier

Set by sender to any value in the range '000'-'110' to identify MRQ. = Invalid if MRQ =
0

B6-B8 (3bit) MFS - MFB Sequence Identifier

Set to the received value of MRS. Set to '111' for unsolicited MFB.

B9-B15 (7bit) MFB - MCS Feedback

Link adaptation feedback containing the recommended MCS. When a responder is
unable to provide MCS feedback or the feedback is not available, the MFB is set to 'all-
ones' (default value) and also MFS is set to '1'.

Parameters:
<LaControl> integer

Range: #H0000,16  to  #HFFFF, 16

Example: BB:WLNN:FBL1:MAC:HTC:LAC #H5A5A,16
Sets the value for the link adaption control to #H5A5A,16.
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Manual operation: See "Link Adaption Control" on page 74

[:SOURce<hw>]:BB:WLNN:FBLock<ch>:MAC:HTControl:NDP <Ndp>

Sets the value of the Null Data Packet (NDP) announcement.

0 = no NDP will follow

1 = NDP will follow

Parameters:
<Ndp> integer

Example: BB:WLNN:FBL1:MAC:HTC:NDP #H1,1
Sets the value for the NDP announcement to 1 (NDP will follow).

Manual operation: See "NDP Announcement" on page 73

[:SOURce<hw>]:BB:WLNN:FBLock<ch>:MAC:HTControl:RDGMore <RdgMore>

Sets the value for the RDG/More PPDU.

Transmitted by Initiator

0 = No reverse grant.

1 = A reverse grant is present, as defined by the Duration/ID field.

Transmitted by Responder

0 = The PPDU carrying the MPDU is the last transmission by the responder.

1 = The PPDU carrying the frame is followed by another PPDU.

Parameters:
<RdgMore> integer

Range: #H0,1  to  #H1,1

Example: BB:WLNN:FBL1:MAC:HTC:RDGM #H0,1
Sets the value for the RDG/More PPDU to #H0,1.

Manual operation: See "RDG/More PPDU" on page 73

[:SOURce<hw>]:BB:WLNN:FBLock<ch>:MAC:HTControl:REServed <Reserved>

This signal field is currently defined, but not used. It is set to zero by the transmitter
and ignored by the receiver.

Parameters:
<Reserved> integer

Range: #H0,5  to  #H5,2

Manual operation: See "Reserved" on page 73
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[:SOURce<hw>]:BB:WLNN:FBLock<ch>:MAC:HTControl:SREServed <Reserved>

This signal field is currently defined, but not used.

Parameters:
<Reserved> integer

Manual operation: See "Reserved" on page 74

[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:MAC:HTControl:STATe
<State>

[:SOURce<hw>]:BB:WLNN:FBLock<ch>:MAC:HTControl:STATe <State>
The command enables/disables HT Control.

Parameters:
<State> 0 | 1 | OFF | ON

*RST: OFF

Example: BB:WLNN:FBL1:MAC:HTC:STAT ON
enables HT Control.

Manual operation: See "HT/VHT/HE Control" on page 72

[:SOURce<hw>]:BB:WLNN:FBLock<ch>:MAC:HTControl:ZLF <Zlf>

Sets the value for the ZLF announcement.

0 = no ZLF will follow

1 = ZLF will follow

Parameters:
<Zlf> integer

Range: #H0,1  to  #H1,1

Example: BB:WLNN:FBL1:MAC:HTC:ZLF #H1,1
Sets the value for the ZLF announcement to 1 (ZLF will follow).

Manual operation: See "NDP Announcement" on page 73

6.9.5.3  MAC header VHT configuration

[:SOURce<hw>]:BB:WLNN:FBLock<ch>:MAC:VHTControl................................................ 203
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:MAC:VHTControl:ACConstraint............................ 203
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:MAC:VHTControl:CTYPe.....................................203
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:MAC:VHTControl:FTTYpe....................................204
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:MAC:VHTControl:GIDH....................................... 204
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:MAC:VHTControl:HVINdicator?............................ 204
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:MAC:VHTControl:MFB........................................ 205
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:MAC:VHTControl:MGL........................................ 205
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:MAC:VHTControl:MRQ........................................205
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:MAC:VHTControl:MSI..........................................206
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[:SOURce<hw>]:BB:WLNN:FBLock<ch>:MAC:VHTControl:RDGMore.................................206
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:MAC:VHTControl:UMFB...................................... 206
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:MAC:VHTControl:VREServed.............................. 207

[:SOURce<hw>]:BB:WLNN:FBLock<ch>:MAC:VHTControl <VHTContol>

The command sets the value for the VHT control field.

Parameters:
<VHTContol> integer

Range: #H00000000,32  to  #HFFFFFFFF,32
*RST: #H00000000,32

Example: BB:WLNN:FBL1:MAC:VHTC #H5a5a5a5a,32
sets the value for the VHT control field.

Manual operation: See "HT/VHT/HE Control" on page 72

[:SOURce<hw>]:BB:WLNN:FBLock<ch>:MAC:VHTControl:ACConstraint
<VhtAcConstraint>

The command sets the value for the AC signal field. It indicates the access point of the
responder (1 bit).

Parameters:
<VhtAcConstraint> integer

0
The response may contain data from any TID (Traffic Identifier)
1
The response may contain data only from the same AC as the
last data received from the initiator.

Example: BB:WLNN:FBL:MAC:VHTC:ACC 0
the response may contain data from any TID.

Manual operation: See "AC Constraint" on page 76

[:SOURce<hw>]:BB:WLNN:FBLock<ch>:MAC:VHTControl:CTYPe <CTYPe>

The command sets the coding information. If the Unsolicited MFB subfield is set to 1,
the Coding Type subfield contains the Coding information (set to 0 for BCC and set to
1 for LDPC) to which the unsolicited MFB refers.

Parameters:
<CTYPe> integer

0
BCC
1
LDPC

Example: BB:WLNN:FBL:MAC:VHTC:CTYP 1
sets the coding information for LPDC.
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Manual operation: See "Coding Type" on page 77

[:SOURce<hw>]:BB:WLNN:FBLock<ch>:MAC:VHTControl:FTTYpe <FbTxType>

The command sets the FB Tx Type subfield.

0 = If the Unsolicited MFB subfield is set to 1 and FB Tx Type subfield is set to 0, the
unsolicited MFB refers to either an unbeamformed VHT PPDU or transmit diversity
using an STBC VHT PPDU.

1 = If the Unsolicited MFB subfield is set to 1 and the FB Tx Type subfield is set to 1,
the unsolicited MFB refers to a beamformed SU-MIMO VHT PPDU.

Otherwise this subfield is reserved.

Parameters:
<FbTxType> integer

Example: BB:WLNN:FBL1:PAID:FTTY #B1,1
sets the FTTY subfield.

Manual operation: See "FB Tx Type" on page 76

[:SOURce<hw>]:BB:WLNN:FBLock<ch>:MAC:VHTControl:GIDH <GIDH>

Sets GID-H subfield. If the Unsolicited MFB subfield is set to 1, the GID-H subfield con-
tains the highest 3 bits of Group ID of the PPDU to which the unsolicited MFB refers.

Otherwise this subfield is reserved.

Parameters:
<GIDH> integer

*RST: #H0

Example: BB:WLNN:FBL:MAC:VHTC:GIDH #B111,3
sets the coding information for GID-H.

Manual operation: See "GID-H" on page 77

[:SOURce<hw>]:BB:WLNN:FBLock<ch>:MAC:VHTControl:HVINdicator?

Queries the used format (HT or VHT). The command returns 0 for the HT format and 1
for the VHT format.

Return values: 
<HtVhtIndicator> integer

Example: BB:WLNN:FBL:MAC:VHTC:HVIN?
Response: 1
VHT format is used.

Usage: Query only

Manual operation: See "HT/VHT" on page 79

Frame configuration settings



Remote-control commandsR&S®SMW-K54/-K86/-K142/-K147

205User Manual 1175.6749.02 ─ 28

[:SOURce<hw>]:BB:WLNN:FBLock<ch>:MAC:VHTControl:MFB <Mfb>

The command sets the MFB subfield. This subfield contains the recommended MFB.
The value of MCS=15 and VHT N_STS=7 indicates that no feedback is present.

See also Table 3-10 for definition of the MFB subfield.

Parameters:
<Mfb> integer

Example: BB:WLNN:FBL:MAC:VHTC:MFB #B111111111111111,15
sets the information for the MFB subfield.

Manual operation: See "MFB" on page 77

[:SOURce<hw>]:BB:WLNN:FBLock<ch>:MAC:VHTControl:MGL <MfsiGidL>

The command determines the information of the MFSI/GID-L subfield.

MFB = 0

If the Unsolicited MFB subfield is set to 0, the MFSI/GID-L subfield contains the
received value of MSI contained in the frame to which the MFB information refers.

MFB = 1

The MFSI/GID-L subfield contains the lowest 3 bits of Group ID of the PPDU to which
the unsolicited MFB refers.

Parameters:
<MfsiGidL> integer

Example: BB:WLNN:FBL:MAC:VHTC:MGL #B111,3
sets the information for the MFSI/GID-L subfield.

Manual operation: See "MFSI/GID-L" on page 78

[:SOURce<hw>]:BB:WLNN:FBLock<ch>:MAC:VHTControl:MRQ <Mrq>

The command determines the information of the MRQ subfield.

Parameters:
<Mrq> integer

0
requests MCS feedback (solicited MFB).
1
otherwise

Example: BB:WLNN:FBL:MAC:VHTC:MRQ #B1,1
sets the information for the MRQ subfield.

Manual operation: See "MRQ" on page 78
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[:SOURce<hw>]:BB:WLNN:FBLock<ch>:MAC:VHTControl:MSI <Msi>

The command sets the MSI subfield.

MRQ = 0

When the MRQ subfield is set to 0, the MSI subfield is reserved.

MRQ = 1

When the MRQ subfield is set to 1, the MSI subfield contains a sequence number in
the range 0 to 6 that identifies the specific request.

Parameters:
<Msi> integer

Example: BB:WLNN:FBL:MAC:VHTC:MSI #B111,3
sets the information for the MFSI/GID-L subfield.

Manual operation: See "MSI" on page 78

[:SOURce<hw>]:BB:WLNN:FBLock<ch>:MAC:VHTControl:RDGMore
<VhtRdgMore>

The command issues the reverse direction grant. When transmitted by an initiator or a
responder, this field is interpreted differently.

Transmitted by Initiator

0 = No reverse grant.

1 = A reverse grant is present, as defined by the Duration/ID field.

Transmitted by Responder

0 = The PPDU carrying the MPDU is the last transmission by the responder.

1 = The PPDU carrying the frame is followed by another PPDU.

Parameters:
<VhtRdgMore> integer

Example: BB:WLNN:FBL:MAC:HTC #H80000000,32
BB:WLNN:FBL:MAC:VHTC:RDGM #B1,1
sets the value for the RDG/More PPDU.

Manual operation: See "RDG/More PPDU" on page 76

[:SOURce<hw>]:BB:WLNN:FBLock<ch>:MAC:VHTControl:UMFB
<UnsolicitedMfb>

The command sets the Unsolicited MFB subfield.

Parameters:
<UnsolicitedMfb> integer

0
if the MFB is a response to an MRQ.
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1
if the MFB is not a response to an MRQ.

Example: BB:WLNN:FBL:MAC:VHTC:UMFB #B1,1
sets the information for the UMFB subfield.

Manual operation: See "Unsolicited MFB" on page 76

[:SOURce<hw>]:BB:WLNN:FBLock<ch>:MAC:VHTControl:VREServed
<VhtReserved>

This signal field is currently defined, but not used. It is set to zero by the transmitter
and ignored by the receiver.

Parameters:
<VhtReserved> integer

Manual operation: See "Rsv" on page 79

6.9.5.4  MAC header HE configuration

[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:MAC:HEControl................................ 207
[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:MAC:HEControl:ACONtrol................. 207
[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:MAC:HEControl:HEINdicator?............ 207

[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:MAC:HEControl
<HEControl>

Sets the value with the length of 4 bytes of the HE control field.

Parameters:
<HEControl> integer

Manual operation: See "HT/VHT/HE Control" on page 72

[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:MAC:HEControl:ACONtrol
<AggregatedCtrl>

Sets the value for the aggregated control field. The length of this value may vary
according to the selected control ID subfield.

Parameters:
<AggregatedCtrl> integer

Manual operation: See "Aggregated control" on page 79

[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:MAC:HEControl:
HEINdicator?

Indicates the use of the HE format, if [:SOURce<hw>]:BB:WLNN:FBLock<ch>[:
USER<di>]:MAC:VHTControl:HVINdicator? is set to 1. The command returns 1
if the HE format is used and 0 if not.
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Return values: 
<HEIndicator> integer

Usage: Query only

Manual operation: See "HE" on page 80

6.9.5.5  Trigger frame settings

[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:TFConfig:CINFo:BW......................... 209
[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:TFConfig:CINFo:CINDication............. 209
[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:TFConfig:CINFo:CSRequired............. 209
[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:TFConfig:CINFo:DOPPler..................209
[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:TFConfig:CINFo:EREServed..............209
[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:TFConfig:CINFo:GILTf.......................209
[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:TFConfig:CINFo:HEEHt.....................209
[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:TFConfig:CINFo:HREServed..............209
[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:TFConfig:CINFo:LEN........................ 209
[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:TFConfig:CINFo:LESSeg...................209
[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:TFConfig:CINFo:MLTFmode.............. 209
[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:TFConfig:CINFo:NHLSym..................209
[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:TFConfig:CINFo:PEXTension............. 209
[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:TFConfig:CINFo:RSV........................ 209
[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:TFConfig:CINFo:SPAReuse............... 209
[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:TFConfig:CINFo:STBC...................... 209
[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:TFConfig:CINFo:SUIPresent.............. 209
[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:TFConfig:CINFo:TFTYpe................... 209
[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:TFConfig:CINFo:TTYPe?...................209
[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:TFConfig:CINFo:TXPow.................... 209
[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:TFConfig:NUINfo.............................. 209
[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:TFConfig:UINFo<st0>:AID................. 209
[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:TFConfig:UINFo<st0>:CODType........ 210
[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:TFConfig:UINFo<st0>:DCM............... 210
[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:TFConfig:UINFo<st0>:MCS............... 210
[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:TFConfig:UINFo<st0>:PS160.............210
[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:TFConfig:UINFo<st0>:PVI................. 210
[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:TFConfig:UINFo<st0>:RSV................210
[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:TFConfig:UINFo<st0>:RUALlocation...210
[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:TFConfig:UINFo<st0>:SPRFirst..........210
[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:TFConfig:UINFo<st0>:SPRSecond..... 210
[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:TFConfig:UINFo<st0>:SSALlocation... 210
[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:TFConfig:UINFo<st0>:TDUSerinfo......210
[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:TFConfig:UINFo<st0>:TRSSi............. 210
[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:TFConfig:UINFo<st0>:UBEXtension... 210
[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:TFConfig:UINFo<st0>:UDV................210
[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:TFConfig:UINFo<st0>:UREServed......210
[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:TFConfig:EOF.................................. 210
[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:TFConfig:PADLength.........................211
[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:TFConfig:TPTime.............................. 211

Frame configuration settings



Remote-control commandsR&S®SMW-K54/-K86/-K142/-K147

209User Manual 1175.6749.02 ─ 28

[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:TFConfig:CINFo:BW <BW>
[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:TFConfig:CINFo:

CINDication <CascadeInd>
[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:TFConfig:CINFo:

CSRequired <CSRequired>
[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:TFConfig:CINFo:DOPPler

<Doppler>
[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:TFConfig:CINFo:

EREServed <EhtReserved>
[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:TFConfig:CINFo:GILTf

<GILTF>
[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:TFConfig:CINFo:HEEHt

<HeEhtP160>
[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:TFConfig:CINFo:

HREServed <HESIGAReserved>
[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:TFConfig:CINFo:LEN

<Length>
[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:TFConfig:CINFo:LESSeg

<LDPCExtSymSeg>
[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:TFConfig:CINFo:MLTFmode

<MUMIMOLTFMode>
[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:TFConfig:CINFo:NHLSym

<NumHeLtfSym>
[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:TFConfig:CINFo:

PEXTension <PacketExtension>
[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:TFConfig:CINFo:RSV

<Reserved>
[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:TFConfig:CINFo:SPAReuse

<SpatialReuse>
[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:TFConfig:CINFo:STBC

<STBC>
[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:TFConfig:CINFo:SUIPresent

<SpeUserInfoPres>
[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:TFConfig:CINFo:TFTYpe

<TrigFrmType>
[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:TFConfig:CINFo:TTYPe?
[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:TFConfig:CINFo:TXPow

<APTxPower>
Sets the value bits of the common info field.

Parameters:
<APTxPower> 6 bits

Manual operation: See "AP Tx Power" on page 90

[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:TFConfig:NUINfo
<NoUserInfo>

[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:TFConfig:UINFo<st0>:AID
<AID12>
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[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:TFConfig:UINFo<st0>:
CODType <CodingType>

[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:TFConfig:UINFo<st0>:DCM
<DCM>

[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:TFConfig:UINFo<st0>:MCS
<MCS>

[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:TFConfig:UINFo<st0>:
PS160 <PS160>

[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:TFConfig:UINFo<st0>:PVI
<PhyVerId>

[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:TFConfig:UINFo<st0>:RSV
<Reserved>

[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:TFConfig:UINFo<st0>:
RUALlocation <RUAllocation>

[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:TFConfig:UINFo<st0>:
SPRFirst <SpatialReuse1>

[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:TFConfig:UINFo<st0>:
SPRSecond <SpatialReuse2>

[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:TFConfig:UINFo<st0>:
SSALlocation <SSAllocation>

[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:TFConfig:UINFo<st0>:
TDUSerinfo <TrigDepUserInfo>

[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:TFConfig:UINFo<st0>:
TRSSi <TargetRssi>

[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:TFConfig:UINFo<st0>:
UBEXtension <UlBandExt>

[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:TFConfig:UINFo<st0>:UDV
<UsigDisVal>

[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:TFConfig:UINFo<st0>:
UREServed <UserInfoReserve>

Sets the value bits of the user info field.

You can configure the user info for up to 37 users with the following command:

[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:TFConfig:NUINfo
on page 209.

Parameters:
<UserInfoReserve> 3 bits

Manual operation: See "Rsv" on page 95

[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:TFConfig:EOF <MpduEof>

Selects the end of frame (EOF) tag.

Tagged/untagged indication is set in the 1-bit EOF/Tag field of an MPDU.

Parameters:
<MpduEof> E0 | E1

E0
End of frame is untagged.
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E1
End of frame is tagged.
*RST: E0

Example: SOURce1:BB:WLNN:FBLock1:TFConfig:EOF E1
The end of the trigger frame in the first frame block is tagged.

Manual operation: See "MPDU EOF" on page 96

[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:TFConfig:PADLength
<PaddingLength>

Queries the length of the padding field in the trigger frame. The length is returned in
bytes.

Parameters:
<PaddingLength> integer

Range: 0  to  47040
*RST: 0
Default unit: byte

Example: SOURce1:BB:WLNN:FBLock1:TFConfig:PADLength?
// Response in bytes: "200"
The padding length is 200 bytes.

Manual operation: See "Padding Length" on page 96

[:SOURce<hw>]:BB:WLNN:FBLock<ch>[:USER<di>]:TFConfig:TPTime
<TrigProcTime>

Sets minimum time to process the trigger frame in microseconds.

Parameters:
<TrigProcTime> TPT0 | TPT8 | TPT16

TPT0|TPT8|TPT16
0/8/16 us
*RST: TPT0

Example: SOURce1:BB:WLNN:FBLock1:TFConfig:TPTime?
// Response in microseconds: "8"
The minimum time to process the trigger frame is 8 microsec-
onds.

Manual operation: See "Min Trigger Process Time" on page 96
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6.9.6  Beacon configuration

6.9.6.1  General beacon functions

[:SOURce<hw>]:BB:WLNN:FBLock<ch>:BFConfiguration:BINTerval...................................212
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:BFConfiguration:DCCHannel?..............................212
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:BFConfiguration:IAWindow.................................. 212
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:BFConfiguration:SRATe....................................... 213
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:BFConfiguration:SSID......................................... 213
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:BFConfiguration:TSTamp.....................................213

[:SOURce<hw>]:BB:WLNN:FBLock<ch>:BFConfiguration:BINTerval <BInterval>

Defines the time interval between two beacon transmissions.

Parameters:
<BInterval> float

Range: 0  to  65
Increment: 1E-9
*RST: 0.1
Default unit: s

Example: BB:WLNN:FBL1:BFC:BINT 200ms
Sets the time interval between two beacon transmissions to 200
ms.

Manual operation: See "Beacon Interval" on page 81

[:SOURce<hw>]:BB:WLNN:FBLock<ch>:BFConfiguration:DCCHannel?

Queries the current channel of the DSSS network.

Return values: 
<DCCHannel> integer

Example: BB:WLNN:FBL1:BFC:DCCH?
Usage: Query only

Manual operation: See "DSSS(Current Channel)" on page 82

[:SOURce<hw>]:BB:WLNN:FBLock<ch>:BFConfiguration:IAWindow <IAWindow>

Sets the parameters necessary to support an IBSS (2 bytes). The Information field
contains the ATIM Window parameter.

Parameters:
<IAWindow> integer

*RST: #H0000

Example: BB:WLNN:FBL1:BFC:IAW #HFFFF,16

Frame configuration settings



Remote-control commandsR&S®SMW-K54/-K86/-K142/-K147

213User Manual 1175.6749.02 ─ 28

Manual operation: See "IBSS(ATIM Window) (hex)" on page 82

[:SOURce<hw>]:BB:WLNN:FBLock<ch>:BFConfiguration:SRATe <SRATe>

Determines a set of data rates that are supported by the access point (Supported
Rates field).

Parameters:
<SRATe> integer

Example: BB:WLNN:FBL1:BFC:SRAT #H06090C1218243036,64
Determines the following set of supported data rates: Hex num-
bers 06 09 0C 12 18 24 30 36.
This means: 6 Mbps, 9 Mbps, 12 Mbps, 18 Mbps, 24 Mbps, 36
Mbps, 48 Mbps and 54 Mbps are supported by the access point.

Manual operation: See "Supported Rates" on page 82

[:SOURce<hw>]:BB:WLNN:FBLock<ch>:BFConfiguration:SSID <Ssid>

Specifies the desired SSID or the wildcard SSID.

Parameters:
<Ssid> string

Range: 0 char  to  32 char

Example: BB:WLNN:FBL1:BFC:SSID "Rohde&Schwarz"
Sets the SSID to "Rohde&Schwarz".

Manual operation: See "SSID" on page 81

[:SOURce<hw>]:BB:WLNN:FBLock<ch>:BFConfiguration:TSTamp <TStamp>

Sets the value of the TSF timer (Timing Synchronization Function of a frame’s source).

Parameters:
<TStamp> integer

Example: BB:WLNN:FBL1:BFC:TST #H1414AFAE891254BC, 64
Sets the value of the TSF timer to 1414AFAE891254BC.

Manual operation: See "Timestamp (hex)" on page 81

6.9.6.2  Capability information parameters

[:SOURce<hw>]:BB:WLNN:FBLock<ch>:BFConfiguration:CAPability:APSD........................ 214
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:BFConfiguration:CAPability:CAGility..................... 214
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:BFConfiguration:CAPability:CPOLlable................. 214
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:BFConfiguration:CAPability:CPRequest................ 215
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:BFConfiguration:CAPability:ESS...........................215
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:BFConfiguration:CAPability:IBACk........................215
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:BFConfiguration:CAPability:IBSS..........................215
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[:SOURce<hw>]:BB:WLNN:FBLock<ch>:BFConfiguration:CAPability:DBACk...................... 216
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:BFConfiguration:CAPability:DOFDm..................... 216
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:BFConfiguration:CAPability:PBCC........................ 216
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:BFConfiguration:CAPability:PRIVacy.....................216
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:BFConfiguration:CAPability:QOS..........................217
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:BFConfiguration:CAPability:RMEasurement...........217
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:BFConfiguration:CAPability:SMGMt...................... 217
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:BFConfiguration:CAPability:SPReamble................217
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:BFConfiguration:CAPability:SSTime......................218
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:BFConfiguration:HTCapability:GFIeld....................218
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:BFConfiguration:HTCapability:STATe.................... 218

[:SOURce<hw>]:BB:WLNN:FBLock<ch>:BFConfiguration:CAPability:APSD
<CAPSd>

Informs the associated stations if automatic power save delivery (APSD, energy saving
function) is supported.

Parameters:
<CAPSd> 1 | ON | 0 | OFF

*RST: 0

Example: BB:WLNN:FBLock1:BFC:CAP:APSD ON
Informs the associated stations that automatic power save deliv-
ery (APSD, energy saving function) is supported.

[:SOURce<hw>]:BB:WLNN:FBLock<ch>:BFConfiguration:CAPability:CAGility
<CCAGility>

Informs the associated stations if channel agility is used.

Parameters:
<CCAGility> 1 | ON | 0 | OFF

*RST: 0

Example: BB:WLNN:FBL1:BFC:CAP:CAG ON

Informs the associated stations that channel agility is used.

[:SOURce<hw>]:BB:WLNN:FBLock<ch>:BFConfiguration:CAPability:CPOLlable
<CCPollable>

Informs the associated stations if contention free is pollable.

Parameters:
<CCPollable> 1 | ON | 0 | OFF

*RST: 0

Example: BB:WLNN:FBL1:BFC:CAP:CPOL ON
Informs the associated stations that contention free is pollable.
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[:SOURce<hw>]:BB:WLNN:FBLock<ch>:BFConfiguration:CAPability:CPRequest
<CCPRequest>

Indicates if contention free poll (CF-poll) is requested.

Parameters:
<CCPRequest> 1 | ON | 0 | OFF

*RST: 0

Example: BB:WLNN:FBL1:BFC:CAP:CPR ON
Tells the associated stations that contention free poll (CF-poll) is
requested.

[:SOURce<hw>]:BB:WLNN:FBLock<ch>:BFConfiguration:CAPability:ESS
<CESS>

Informs the associated stations if the network is an ESS type network.

Parameters:
<CESS> 1 | ON | 0 | OFF

*RST: 1

Example: BB:WLNN:FBL1:BFC:CAP:ESS ON
Informs the associated stations that the network is an ESS type
network.

[:SOURce<hw>]:BB:WLNN:FBLock<ch>:BFConfiguration:CAPability:IBACk
<IBACk>

Informs the associated stations if immediate block Ack is allowed.

Parameters:
<IBACk> 1 | ON | 0 | OFF

*RST: 0

Example: BB:WLNN:FBL1:BFC:CAP:IBACk ON
Informs the associated stations that immediate block Ack is
allowed.

[:SOURce<hw>]:BB:WLNN:FBLock<ch>:BFConfiguration:CAPability:IBSS
<CIBSs>

Informs the associated stations if the network is an IBSS type network.

Parameters:
<CIBSs> 1 | ON | 0 | OFF

*RST: 0

Example: BB:WLNN:FBL1:BFC:CAP:IBSS ON
Informs the associated stations that the network is an IBSS type
network.
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[:SOURce<hw>]:BB:WLNN:FBLock<ch>:BFConfiguration:CAPability:DBACk
<CDBAck>

Informs the associated stations if delayed block Ack is allowed.

Parameters:
<CDBAck> 1 | ON | 0 | OFF

*RST: 0

Example: BB:WLNN:FBL1:BFC:CAP:DBAC ON
Informs the associated stations that delayed block Ack is
allowed.

[:SOURce<hw>]:BB:WLNN:FBLock<ch>:BFConfiguration:CAPability:DOFDm
<CDOFdm>

Indicates if Direct Sequence Spread Spectrum - OFDM is allowed.

Parameters:
<CDOFdm> 1 | ON | 0 | OFF

*RST: 0

Example: BB:WLNN:FBL1:BFC:CAP:DOFD

Informs the associated stations that Direct Sequence Spread Spectrum - OFDM is
allowed.

[:SOURce<hw>]:BB:WLNN:FBLock<ch>:BFConfiguration:CAPability:PBCC
<PBCC>

Informs the associated stations if PBCC is allowed.

Parameters:
<PBCC> 1 | ON | 0 | OFF

*RST: 0

Example: BB:WLNN:FBL1:BFC:CAP:PBCC ON

Informs the associated stations that PBCC is allowed.

[:SOURce<hw>]:BB:WLNN:FBLock<ch>:BFConfiguration:CAPability:PRIVacy
<PRIVacy>

Informs the associated stations if encryption is required for all data frames.

Parameters:
<PRIVacy> 1 | ON | 0 | OFF

*RST: 0

Example: BB:WLNN:FBL1:BFC:CAP:PRIV ON

Informs the associated stations that encryption is required for all data frames.
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[:SOURce<hw>]:BB:WLNN:FBLock<ch>:BFConfiguration:CAPability:QOS
<QOS>

Informs the associated stations if quality of service (QoS) is supported.

Parameters:
<QOS> 1 | ON | 0 | OFF

*RST: 0

Example: SOUR:BB:WLNN:FBL1:BFC:CAP:QOS ON
Informs the associated stations that quality of service (QoS) is
supported.

[:SOURce<hw>]:BB:WLNN:FBLock<ch>:BFConfiguration:CAPability:
RMEasurement <RMEasurement>

Informs the associated stations if radio measurement is supported.

Parameters:
<RMEasurement> 1 | ON | 0 | OFF

*RST: 0

Example: SOUR:BB:WLNN:FBL1:BFC:CAP:RME ON

Informs the associated stations that radio measurement is supported.

[:SOURce<hw>]:BB:WLNN:FBLock<ch>:BFConfiguration:CAPability:SMGMt
<SMGMt>

Informs the associated stations if spectrum management is enabled.

Parameters:
<SMGMt> 1 | ON | 0 | OFF

*RST: 0

Example: SOUR:BB:WLNN:FBL1:BFC:CAP:SMGM ON
Informs the associated stations that spectrum management is
enabled.

[:SOURce<hw>]:BB:WLNN:FBLock<ch>:BFConfiguration:CAPability:SPReamble
<SPReamble>

Informs the associated stations if short preamble is allowed.

Parameters:
<SPReamble> 1 | ON | 0 | OFF

*RST: 0

Example: BB:WLNN:FBL1:BFC:CAP:SPR ON

Informs the associated stations that short preamble is allowed.
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[:SOURce<hw>]:BB:WLNN:FBLock<ch>:BFConfiguration:CAPability:SSTime
<SSTime>

Informs the associated stations if short slot time is supported.

Parameters:
<SSTime> 1 | ON | 0 | OFF

*RST: 0

Example: BB:WLNN:FBL1:BFC:CAPability:SST ON
Informs the associated stations that short slot time is supported.

[:SOURce<hw>]:BB:WLNN:FBLock<ch>:BFConfiguration:HTCapability:GFIeld
<GreenField>

Enables/disables the support for the reception of PPDUs with HT Greenfield format.

Parameters:
<GreenField> 1 | ON | 0 | OFF

*RST: 0

Manual operation: See "Green Field" on page 87

[:SOURce<hw>]:BB:WLNN:FBLock<ch>:BFConfiguration:HTCapability:STATe
<State>

Activates/ deactivates the HT capability information element.

Parameters:
<State> 1 | ON | 0 | OFF

*RST: 0

Manual operation: See "State" on page 87

6.9.6.3  ERP parameters

[:SOURce<hw>]:BB:WLNN:FBLock<ch>:BFConfiguration:ERP:BPMode.............................218
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:BFConfiguration:ERP:NEPResent........................ 219
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:BFConfiguration:ERP:UPRotection....................... 219

[:SOURce<hw>]:BB:WLNN:FBLock<ch>:BFConfiguration:ERP:BPMode
<EBPMode>

Informs associated stations whether to use the long or the short preamble.

Parameters:
<EBPMode> 1 | ON | 0 | OFF

*RST: 0
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Example: BB:WLNN:FBL1:BFC:ERP:BPM ON
Informs associated stations that they should use the long pream-
ble.

[:SOURce<hw>]:BB:WLNN:FBLock<ch>:BFConfiguration:ERP:NEPResent
<ENEPresent>

Sets Non-ERP Present on. This is needed if there is a non-ERP MU associated to the
AP.

Parameters:
<ENEPresent> 1 | ON | 0 | OFF

*RST: 0

Example: BB:WLNN:FBL1:BFC:ERP:NEPR ON
Sets on Non-ERP Present.

[:SOURce<hw>]:BB:WLNN:FBLock<ch>:BFConfiguration:ERP:UPRotection
<EUPRotection>

Informs associated stations if they have to use protection.

Parameters:
<EUPRotection> 1 | ON | 0 | OFF

*RST: 0

Example: BB:WLNN:FBL1:BFC:ERP:UPR ON
Informs associated stations that they have to use protection.

6.9.7  Spatial mapping configuration

[:SOURce<hw>]:BB:WLNN:FBLock<ch>:SMAPping:MODE............................................... 219
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:SMAPping:TSHift<st>..........................................220
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:SMAPping:INDex................................................ 220
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:SMAPping:ROW<st>:COL<dir>:I?........................ 221
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:SMAPping:ROW<st>:COL<dir>:Q?.......................221

[:SOURce<hw>]:BB:WLNN:FBLock<ch>:SMAPping:MODE <Mode>

Selects the spatial mapping mode for the selected frame block. Except of the beam-
forming mode, the matrix element values are loaded by using info class methods.

Parameters:
<Mode> OFF | DIRect | EXPansion | BEAMforming | INDirect

OFF
(only "LEGACY" mode)
The spatial mapping mode is switched off automatically.
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DIRect
(only active with physical modes MIXED MODE or GREEN
FIELD when NTX = NSTS)
The transmit matrix is a CSD matrix, that is, diagonal matrix of
unit magnitude and complex values that represent cyclic shifts in
the time domain.
EXPansion
(only active with physical modes MIXED MODE or GREEN
FIELD)
The transmit matrix is the product of a CSD matrix and a square
matrix formed of orthogonal columns, as defined in the IEEE
802.11n specification.
INDirect
(only active with physical modes MIXED MODE or GREEN
FIELD)
The transmit matrix is the product of a CSD matrix and the
Hadamard unitary matrix.
*RST: EXPansion

Example: BB:WLNN:FBL1:SMAP:MODE OFF
Sets the spatial mapping mode to OFF, that is, the spatial map-
ping mode is switched off automatically.

Manual operation: See "Mode" on page 98

[:SOURce<hw>]:BB:WLNN:FBLock<ch>:SMAPping:TSHift<st> <TShift>

Sets the spatial mapping time shift. This value is relevant for spatial mapping mode
direct and spatial expansion only.

Parameters:
<TShift> float

Range: -32000 ns  to  32000 ns
Increment: 1 ns
*RST: 0 ns

Example: BB:WLNN:FBL1:SMAP:MODE TSH 1000
Sets the spatial mapping time shift to 1000 ns.

Manual operation: See "Time Shift" on page 98

[:SOURce<hw>]:BB:WLNN:FBLock<ch>:SMAPping:INDex <Index>

Sets the index of the subcarrier. A matrix is mapped to each subcarrier. Except for k=0,
the index can be set in the value range of -64 to 63

Parameters:
<Index> integer

Range: depends on TxMode  to  depends on TxMode
*RST: 20
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Example: BB:WLNN:FBL1:SMAP:IND 30
Sets the index of the subcarrier to k = 30.

Manual operation: See "Index k" on page 98

[:SOURce<hw>]:BB:WLNN:FBLock<ch>:SMAPping:ROW<st>:COL<dir>:I?

Queries the time shift value of element I of the selected row and column of the spatial
transmit matrix.

Return values: 
<I> float

Example: BB:WLNN:FBL1:SMAP:ROW2:COL2:I?
queries the time shift value of element I for row 2, column 2.

Usage: Query only

Manual operation: See "I (Transmit Matrix)" on page 98

[:SOURce<hw>]:BB:WLNN:FBLock<ch>:SMAPping:ROW<st>:COL<dir>:Q?

Queries the time shift value of element Q of the selected row and column of the spatial
transmit matrix.

Return values: 
<Q> float

Example: BB:WLNN:FBL1:SMAP:ROW2:COL2:Q?
queries the time shift value of element Q for row 2, column 2.

Usage: Query only

Manual operation: See "Q (Transmit Matrix)" on page 99

Frame configuration settings
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Glossary: Specifications and references
Symbols

1GP56: Rohde & Schwarz application note "802.11 Packet Error Rate Testing":
https://www.rohde-schwarz.com/appnote/1GP56.html

1GP94: Rohde & Schwarz application note "Generating Signals for WLAN 802.11ac":
https://www.rohde-schwarz.com/appnote/1GP94.html

1GP115: Rohde & Schwarz application note "Generating WLAN IEEE 802.11ax Sig-
nals":
https://www.rohde-schwarz.com/appnote/1GP115.html

1MA69: Rohde & Schwarz application note "WLAN Tests According to Standard
802.11a/b/g":
https://www.rohde-schwarz.com/appnote/1MA69.html

1MA152: Rohde & Schwarz application note "Intelligent Transportation Systems Using
IEEE 802.11p":
https://www.rohde-schwarz.com/appnote/1MA152.html

1MA179: Rohde & Schwarz application note "WLAN 802.11n: From SISO to MIMO":
https://www.rohde-schwarz.com/appnote/1MA179.html

1MA192: Rohde & Schwarz white paper "802.11ac Technology Introduction":
https://www.rohde-schwarz.com/appnote/1MA192.html

1MA222: Rohde & Schwarz white paper "IEEE 802.11ax Technology Introduction":
https://www.rohde-schwarz.com/appnote/1MA222.html

I
IEEE Std 802.11ax™-2021: "Part 11: Wireless LAN Medium Access Control (MAC)
and Physical Layer (PHY) Specifications"
Amendment 1: Enhancements for High-Efficiency WLAN

IEEE Std 802.11be™-2023: "Part 11: Wireless LAN Medium Access Control (MAC)
and Physical Layer (PHY) Specifications
Amendment: Enhancements for Extremely High Throughput (EHT)"

IEEE Std 802.11™: "Part 11: Wireless LAN Medium Access Control (MAC) and Physi-
cal Layer (PHY) Specifications"
Related amendments covering all IEEE 802.11 standards

 

https://www.rohde-schwarz.com/appnote/1GP56.html
https://www.rohde-schwarz.com/appnote/1GP94.html
https://www.rohde-schwarz.com/appnote/1GP115.html
https://www.rohde-schwarz.com/appnote/1MA69.html
https://www.rohde-schwarz.com/appnote/1MA152.html
https://www.rohde-schwarz.com/appnote/1MA179.html
https://www.rohde-schwarz.com/appnote/1MA192.html
https://www.rohde-schwarz.com/appnote/1MA222.html
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List of commands
[:SOURce<hw>]:BB:WLNN:ANTenna:CMODe?............................................................................................150
[:SOURce<hw>]:BB:WLNN:ANTenna:MODE................................................................................................150
[:SOURce<hw>]:BB:WLNN:ANTenna:NOBB?...............................................................................................150
[:SOURce<hw>]:BB:WLNN:ANTenna:SYSTem.............................................................................................150
[:SOURce<hw>]:BB:WLNN:ANTenna:TCHain<ch>:OUTPut:DESTination................................................... 151
[:SOURce<hw>]:BB:WLNN:ANTenna:TCHain<ch>:OUTPut:FSELect..........................................................151
[:SOURce<hw>]:BB:WLNN:ANTenna:TCHain<ch>:TX<dir>:IMAGinary.......................................................152
[:SOURce<hw>]:BB:WLNN:ANTenna:TCHain<ch>:TX<dir>:MAGNitude..................................................... 152
[:SOURce<hw>]:BB:WLNN:ANTenna:TCHain<ch>:TX<dir>:PHASe............................................................152
[:SOURce<hw>]:BB:WLNN:ANTenna:TCHain<ch>:TX<dir>:REAL.............................................................. 151
[:SOURce<hw>]:BB:WLNN:BWidth...............................................................................................................128
[:SOURce<hw>]:BB:WLNN:CFBLock............................................................................................................153
[:SOURce<hw>]:BB:WLNN:CLIPping:LEVel................................................................................................. 131
[:SOURce<hw>]:BB:WLNN:CLIPping:MODE................................................................................................131
[:SOURce<hw>]:BB:WLNN:CLIPping:SPPState........................................................................................... 132
[:SOURce<hw>]:BB:WLNN:CLIPping:STATe................................................................................................ 132
[:SOURce<hw>]:BB:WLNN:CLOCk:MODE...................................................................................................149
[:SOURce<hw>]:BB:WLNN:CLOCk:SOURce................................................................................................149
[:SOURce<hw>]:BB:WLNN:DFBLock............................................................................................................154
[:SOURce<hw>]:BB:WLNN:FBLock:APPend................................................................................................ 153
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:BCHG...........................................................................................176
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:BCSMoothing............................................................................... 154
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:BDCM...........................................................................................177
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:BEUL?..........................................................................................177
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:BFConfiguration:BINTerval...........................................................212
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:BFConfiguration:CAPability:APSD...............................................214
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:BFConfiguration:CAPability:CAGility............................................214
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:BFConfiguration:CAPability:CPOLlable....................................... 214
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:BFConfiguration:CAPability:CPRequest...................................... 215
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:BFConfiguration:CAPability:DBACk.............................................216
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:BFConfiguration:CAPability:DOFDm............................................216
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:BFConfiguration:CAPability:ESS..................................................215
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:BFConfiguration:CAPability:IBACk...............................................215
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:BFConfiguration:CAPability:IBSS.................................................215
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:BFConfiguration:CAPability:PBCC...............................................216
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:BFConfiguration:CAPability:PRIVacy........................................... 216
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:BFConfiguration:CAPability:QOS.................................................217
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:BFConfiguration:CAPability:RMEasurement................................217
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:BFConfiguration:CAPability:SMGMt.............................................217
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:BFConfiguration:CAPability:SPReamble......................................217
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:BFConfiguration:CAPability:SSTime............................................ 218
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:BFConfiguration:DCCHannel?..................................................... 212
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:BFConfiguration:ERP:BPMode.................................................... 218
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:BFConfiguration:ERP:NEPResent............................................... 219
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:BFConfiguration:ERP:UPRotection..............................................219
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:BFConfiguration:HTCapability:GFIeld..........................................218
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:BFConfiguration:HTCapability:STATe.......................................... 218
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[:SOURce<hw>]:BB:WLNN:FBLock<ch>:BFConfiguration:IAWindow.......................................................... 212
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:BFConfiguration:SRATe............................................................... 213
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:BFConfiguration:SSID..................................................................213
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[:SOURce<hw>]:BB:WLNN:FBLock<ch>:BOOSt..........................................................................................155
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:BSSColor......................................................................................178
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:BWINd..........................................................................................178
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[:SOURce<hw>]:BB:WLNN:FBLock<ch>:CCH1:MUNum<st>...................................................................... 185
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[:SOURce<hw>]:BB:WLNN:FBLock<ch>:CCH1:RUSelection<st>................................................................185
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[:SOURce<hw>]:BB:WLNN:FBLock<ch>:CODing:RATE.............................................................................. 161
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[:SOURce<hw>]:BB:WLNN:FBLock<ch>:DATA:BPSymbol?........................................................................ 162
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[:SOURce<hw>]:BB:WLNN:FBLock<ch>:DATA:RATE?................................................................................164
[:SOURce<hw>]:BB:WLNN:FBLock<ch>:DATA:SYMBols............................................................................ 164
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[:SOURce<hw>]:BB:WLNN:FBLock<ch>:LINK............................................................................................. 180
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