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1 Welcome to the R&S SMBVB-K54x options

The R&S SMBVB-K540 is a software option that allows you to generate an envelope
tracking signal, that follows the envelope variation of the RF signal.

R&S SMBVB-K540 key features

® Baseband signal, RF signal, and envelope signal generation out of one instrument
® Envelope signal derived directly and in real time from the baseband signal

® Fully synchronous envelope and RF signal with optional delay compensation for
time alignment of the envelope signal

® Simultaneous output of envelope and inverted envelope signal

® Flexible envelope shaping based on different algorithms incl. a build-in table shap-
ing editor

® Import/export interface for files describing shaping functions
® Real-time display of the characteristics of the envelope signal

The R&S SMBVB-K541 is a software option that adds functionality to define and apply
AM/AM and AM/PM predistortions.

R&S SMBVB-K541 key features
® Applying user-defined AM/AM and AM/PM digital predistortions directly on the digi-
tal baseband signal

® Digital predistortions are applied directly and in real time to the baseband signal,
i.e. to any Digital Standard signal or with ARB waveforms

® Separate or superimposed AM/AM or AM/PM predistortion also with variable order
in the processing flow

® Flexible shaping of the predistortion functions based on a polynomial function and
a build-in table editor

® Import/export interface for files describing the predistortion functions, i.e. load of
AM/AM and AM/PM tables directly from characterization software

® Real-time display of the correction functions

® |ninstruments equipped with the option R&S SMBVB-K540, digitally predistorted
baseband signal, RF signal, and envelope signal generation out of one instrument

This user manual contains a description of the functionality that the application pro-
vides, including remote control operation.

All functions not discussed in this manual are the same as in the base unit and are
described in the R&S SMBV100B user manual. The latest version is available at:

www.rohde-schwarz.com/manual/SMBV100B

Installation

You can find detailed installation instructions in the delivery of the option or in the
R&S SMBV100B service manual.
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Documentation overview

1.1 Accessing the required settings

To open the dialog with Envelope Tracking settings

1. In the block diagram of the R&S SMBV100B, select the "I/Q OUT" connector to
unfold the "I/Q Analog" block.

A dialog box opens that displays the provided general settings.
2. Select "I/Q Analog > 1/Q Analog Outputs > General".
3. Select "RF Envelope > On".

To open the dialog with DPD settings

» In the block diagram of the R&S SMBV100B, select "I/Q Mod > Digital Predistortion
> AM/AM AM/PM".

A dialog box opens that displays the provided settings.

The signal generation is not started immediately. To start signal generation with the
default settings, select "State > On".

1.2 What's new

This manual describes firmware version FW 5.30.047.xx and later of the
R&S®SMBV100B.

Compared to the previous version there are editorial changes only.

1.3 Documentation overview

This section provides an overview of the R&S SMBV100B user documentation. Unless
specified otherwise, you find the documents at:

www.rohde-schwarz.com/manual/smbv100b

1.3.1 Getting started manual
Introduces the R&S SMBV100B and describes how to set up and start working with the

product. Includes basic operations, typical measurement examples, and general infor-
mation, e.g. safety instructions, etc. A printed version is delivered with the instrument.
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Documentation overview

1.3.2 User manuals and help

Separate manuals for the base unit and the software options are provided for down-
load:

® Base unit manual
Contains the description of all instrument modes and functions. It also provides an
introduction to remote control, a complete description of the remote control com-
mands with programming examples, and information on maintenance, instrument
interfaces and error messages. Includes the contents of the getting started manual.

® Software option manual
Contains the description of the specific functions of an option. Basic information on
operating the R&S SMBV100B is not included.

The contents of the user manuals are available as help in the R&S SMBV100B. The
help offers quick, context-sensitive access to the complete information for the base unit
and the software options.

All user manuals are also available for download or for immediate display on the Inter-
net.

1.3.3 Service manual

Describes the performance test for checking compliance with rated specifications, firm-
ware update, troubleshooting, adjustments, installing options and maintenance.

The service manual is available for registered users on the global Rohde & Schwarz
information system (GLORIS):

https://gloris.rohde-schwarz.com

1.3.4 Instrument security procedures

Deals with security issues when working with the R&S SMBV100B in secure areas. It
is available for download on the internet.

1.3.5 Printed safety instructions

Provides safety information in many languages. The printed document is delivered with
the product.

1.3.6 Data sheets and brochures

The data sheet contains the technical specifications of the R&S SMBV100B. It also
lists the options and their order numbers and optional accessories.

The brochure provides an overview of the instrument and deals with the specific char-
acteristics.

User Manual 1178.8165.02 — 08 7


https://gloris.rohde-schwarz.com

R&S®SMBVB-K540, R&S®SMBVB-K541 Welcome to the R&S SMBVB-K54x options

Documentation overview
See www.rohde-schwarz.com/brochure-datasheet/smbv100b

1.3.7 Release notes and open source acknowledgment (OSA)
The release notes list new features, improvements and known issues of the current
firmware version, and describe the firmware installation.

The software makes use of several valuable open source software packages. An open-
source acknowledgment document provides verbatim license texts of the used open
source software.

See www.rohde-schwarz.com/firmware/smbv100b

1.3.8 Application notes, application cards, white papers, etc.

These documents deal with special applications or background information on particu-
lar topics.

See www.rohde-schwarz.com/application/smbv100b

1.3.9 Videos

Find various videos on Rohde & Schwarz products and test and measurement topics
on YouTube: https://www.youtube.com/@RohdeundSchwarz

O On the menu bar, search for your product to find related videos.

HOME VIDEOS SHORTS PLAYLISTS COMMUNITY CHANNELS ABOUT ':)\ <product>

Figure 1-1: Product search on YouTube
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Notes on screenshots
1.4 Scope

Tasks (in manual or remote operation) that are also performed in the base unit in the
same way are not described here.

In particular, it includes:

® Managing settings and data lists, like saving and loading settings, creating and
accessing data lists, or accessing files in a particular directory.

® [nformation on regular trigger, marker and clock signals and filter settings, if appro-
priate.

® General instrument configuration, such as checking the system configuration, con-
figuring networks and remote operation

® Using the common status registers

For a description of such tasks, see the R&S SMBV100B user manual.

1.5 Notes on screenshots

When describing the functions of the product, we use sample screenshots. These
screenshots are meant to illustrate as many as possible of the provided functions and
possible interdependencies between parameters. The shown values may not represent
realistic usage scenarios.

The screenshots usually show a fully equipped product, that is: with all options instal-
led. Thus, some functions shown in the screenshots may not be available in your par-
ticular product configuration.
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2.1

2.2

About the envelope tracking

Generation of envelope tracking signals

Envelope tracking (ET) is a method used by modern power amplifiers (PA) to improve
their efficiency, especially when amplifying RF signals with a high peak to average
power (PAPR). An envelope tracking detector "tracks" the power variations in the input
signal of the PA. The PA then varies synchronously to this variation the supply voltage
V¢ at its end-amplifying stage.

This section introduces the concept of the envelope tracking functionality and the way
that it is implemented in the R&S SMBV100B.

Refer to Chapter 4, "How to generate a control signal for power amplifier envelope
tracking tests", on page 68 for step-by-step instruction on how to use the provided
function.

Required options

The equipment layout for generation and output of envelope tracking signal includes:
® Base unit

® Option differential analog 1/Q outputs (R&S SMBVB-K17)

® Option envelope tracking (R&S SMBVB-K540)

® Optional option AM/AM AM/PM predistortion (R&S SMBVB-K541)

For more information, see data sheet.

About the envelope tracking

The R&S SMBV100B allows you to generate an envelope tracking signal, that follows
the envelope variation of the RF signal.

Principle of the envelope tracking

The Figure 2-1 shows a simplified test setup for testing of a PA with an envelope track-
ing. This illustration is intended to explain the principle in general, not all connections
and required equipment are considered.
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RF PCL[
RF Signal =i PA
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N\ -
et Modulator

Envelope Signal ()’ Vip

Inverted Envelope Signal (& )

Figure 2-1: Simplified test setup for power amplifier envelope tracking tests

The R&S SMBV100B in this setup is configured to generate both, an RF signal with
complex modulation scheme and an envelope signal, that follows the envelope varia-
tion of this RF signal. A suitable test signal is, for example, an EUTRA/LTE DL signal.

The R&S SMBV100B generates the envelope signal directly from the baseband signal.
The envelope signal is a voltage signal, with voltage level V. proportional to the

power of the RF signal (+]I(t)?>+Q(t)?]) of the corresponding path. If you do not apply a
shaping function, the envelope signal linear dependent follows the variation of the RF
signal's envelope.

The envelope signal is output at the | out and | Bar out rear panel connectors. This
envelope signal is then further fed to an external DC modulator.

The PA receives the RF input signal and the dynamically adapted supply voltage v..
Ideally, the PA gain stays constant.

Suitable baseband signal to observe the effect of the envelope tracking settings

To simplify the explanation in the following sections, we use a simple ramp function as
a baseband signal modulated on the RF carrier.

Other suitable baseband signals are signals with relative constant envelope. You find a
choice of predefined signals in the "Baseband > Custom Digital Mod > Set according to
standard" dialog. With the default settings in this dialog, you can observe the gener-
ated envelope signal and the effects of enabled shaping.

2.2.1 Envelope voltage adaptation modes

In the R&S SMBV100B, you define the voltage of the generated envelope signal using
one of the following modes:

® Auto Power/Normilized Envelope Voltage Adaptation:
In this mode, you define the desired input characteristics of the power amplifier.

Based on these values and depending on the crest factor of the generated signal,
the R&S SMBV100B calculates:

— The voltage on the | out/l Bar out connectors (V, Min/Max) and a bias (Bias),

User Manual 1178.8165.02 — 08 11
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Generation of envelope tracking signals

About the envelope tracking

— The RMS level of the RF signal

The auto voltage adaptation mode is a suitable choice, if you have knowledge on
the power amplifier components and characteristics. Common PA characteristics
are the supply voltage V., the input power PEP;, required for working in the linear
range and the gain characteristics of the external DC modulator.

You find the required values in the documentation of your power amplifier, for
example in its data sheet.

® Manual Envelope Voltage Adaptation:
In this mode, you can also define the operating range of the power amplifier based
on a pre-gain and a post-gain range. Based on these values, the instrument calcu-
lates the supply voltage V..

All modes support envelope shaping.

Signal parameters for testing according to the eTrak® specification

In the R&S SMBV100B, you can select one of the predefined eTrak® interface types so

that the generated signal is conformed with the MIPI®Alliance specification "Analog
Reference Interface for Envelope Tracking Specification".

Table 2-1: Default parameters per eTrak® Interface Type

Parameter 1.2 Vpp 1.5 Vpp 2 Vpp

1/Q output Type Differential Differential Differential
Bias 500 mV 600 mV 900 mV
Vpp Max 1.2V 1.5V 2V

Vpp Max 1.2V 1.5V 2V
Bipolar Input On On On

Envelope shaping and shaping methods

Envelope shaping is a method that uses functions to describe the relationship between
supply voltage and RF input power. An envelope-shaping function is a trade-off
between effectivity and improved linearity of the PA.

In the R&S SMBV100B, you can select the way you define the shaping function. You
can choose between:

® 2 predefined simple linear functions
(see Chapter 2.2.3.1, "About the linear functions", on page 13)

e 3 detroughing functions with a configurable factor
(see Chapter 2.2.3.2, "About the detroughing function", on page 14)

® A polynomial function with up to 10 polynomial coefficients

(see Chapter 2.2.3.3, "About the polynomial function", on page 14)
® A shaping function defined as a shaping table

(see Chapter 2.2.3.4, "About the shaping table", on page 15)
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® To set the correction values in raw format with a single remote control command
(see Chapter 2.2.3.5, "Shaping function in raw data format", on page 16)

The linear, the detroughing and the polynomial shaping functions are mathematical
expressions that are described as function of the variable x, see Table 2-2.

Table 2-2: Definition of the variable x depending on the envelope voltage adaptation mode

"Envelope Voltage Adaptation™ X

Auto Power X = Viq = Vin min
x=0

Auto Normalized X = VinVin max

Manual X = Ven/Venymax

2.2.3.1

The mathematical expressions and further information on the shaping functions are
provided in the corresponding sections.

See also Chapter 2.2.3.6, "Converting shaping functions and understanding the dis-
played values", on page 16.

o About the linear fFUNCHONS. ..... ..o e 13
e About the detroughing fUNCHON......cooii i 14
e About the polynomial fUNCON..........oiiiiiiii e 14
o About the shaping table........coooi e 15
e Shaping function in raw data format............ccccceeeeiiei s 16
e Converting shaping functions and understanding the displayed values................. 16

About the linear functions

The linear shaping can be used for less demanding applications, simple analysis, and
the first interactions by designing the optimum envelope shape. Because the shaping
gain of the linear function is 0 dB, in "Envelope Voltage Adaptation > Manual" mode
this function is suitable for determining the "Pre-/Post-Gain" values (see Example"Cal-
culating the current V¢ in "Manual" mode" on page 20).

Provided are two linear functions, where each of them depends on the "Envelope Volt-
age Adaptation" mode:
® Linear (Voltage)
— f(x) = x in "Auto Normalized/Manual"
- f(x) = b*xX + V¢ min in "Auto Power”
® Linear (Power)
— f(x) = x? in "Auto Normalized/Manual"

= f(x) = b**x2 + V¢ min in "Auto Power”

Where:

® The variable x depends on the "Envelope Voltage Adaptation" mode, see
Table 2-2.

® The constant b is calculated as:
b= (Vcc,max - Vcc,min)/(vin,max - Vin,min)
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See also Chapter 2.2.3.6, "Converting shaping functions and understanding the dis-
played values", on page 16.

2.2.3.2 About the detroughing function

Detroughing functions are well defined mathematical functions that prevent that the
supply voltage V. drops down to zero or falls under specified limits. That is, they pre-
vent that the signal is clipped.

Provided are the following functions:

® f(x)=x+d*e

e f(x)=1-(1-d)"cos(x*pi/2)

® f(x)=d+(1-d)*x®

Where:
® X is avariable, that depends on the "Envelope Voltage Adaptation" mode, see
Table 2-2

® aisthe Exponent (a).

® dis the Detroughing Factor (d), that limits the supply voltage V. in the low-power
region and controls the shaping.
The detroughing factor (d) can be set manually or derived from the selected V,
value. In the latter case, it is calculated as follows:
d= Vcc,min/Vcc,max
See Couple Detroughing Factor with Vcc.
A "Detroughing Factor = 0" defines a linear function.

See also Chapter 2.2.3.6, "Converting shaping functions and understanding the dis-
played values", on page 16.

2.2.3.3 About the polynomial function

The polynomial function is an analytical method to describe a shaping function. The
polynomial function is defined as follows:

f(x) = ag + 2(a,*x"), where n £10 and:
® Depending on the "Envelope Voltage Adaptation" mode, f(x) is:
—  f(x) = V(x) in "Auto Power"
- f(X) = Vee/ Ve max(X) in "Auto Normalized/Manual”
® The polynomial order n, the polynomial constant a,, and polynomial coefficients a,
to a,, are user-definable, see Chapter 2.7, "Polynomial coefficients settings",
on page 43
® x depends on the "Envelope Voltage Adaptation" mode, see Table 2-2
The default polynomial function with n = 1, a5 = 0 and ay = 1 describes a linear func-
tion.
See also:
® Figure 2-13
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About the envelope tracking

® Chapter 2.2.3.6, "Converting shaping functions and understanding the displayed
values", on page 16.

File format of the polynomial function file

You can store a polynomial function in a file or even define the polynomial coefficients,
store them as a file and load this file into the instrument. The polynomial files are files
with extension *.iq poly.

The file contains an optional header # Rohde & Schwarz - IQ Output
Envelope Polynomial Coefficients # a0,al,a2, ... and a list of comma-
separated coefficient values.

Example: Polynomial function file content

# Rohde & Schwarz - IQ Output Envelope Shaping Table
# a0,al,a2,...

0.135,0.91,0.34,-0.59,-0.11

About the shaping table

The envelope-shaping table is a widely used method to define the shaping function.
This kind of definition is suitable if you have knowledge on or aim to achieve an exact
relation between supply voltage and RF input power. For example, with suitable set-
tings, the shaping table can precisely describe the transition region of the PA.

You can receive information on suitable envelope-shaping values form the power
amplifier manufacturer.

In the R&S SMBV100B, there are two ways to define a shaping table function:

® Externally
Create a shaping table file as a CSV file with Microsoft Excel, with a Notepad or a
similar tool. Save it with the predefined extension, transfer it to and load it into the
instrument.
See also "File format of the shaping table file" on page 15.

® [nternally
Use the built-in editor table editor, see Chapter 2.6, "Edit I/Q envelope shape set-
tings", on page 40.

File format of the shaping table file

The shaping table files are files with predefined extension and simple file format, see
Table 2-3.
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Table 2-3: Shaping table files: format and extensions

"Envelope Voltage Adaptation" | File extension Header (optional)

Auto Power *.ig lutpv # Rohde & Schwarz - IQ Output
Envelope Shaping Table

# Power [dBm],Vcc[V]

Auto Normalized/Manual *.ig lut # Rohde & Schwarz - IQ Output
Envelope Shaping Table

# Vin/Vmax,Vcc/Vmax

The header is optional. The file content is list of up to 4000 comma-separated value
pairs; a new line indicator separates the pairs.

Example: Shaping table file content (*.iq_lut file)

Rohde & Schwarz - IQ Output Envelope Shaping Table
Vin/Vmax,Vcc/Vmax

.3,0.4

.35,0.45

.56,0.55

.4,0.5

.6,0.65

0,0.135

O O O O O I H*

2.2.3.5 Shaping function in raw data format

The shaping values are defined directly, with a single remote control command. You
define up to 4000 comma-separated value pairs, describing the vin/vVmax, Vcc/Vmax
or Power [dBm] ,Vcc[V].

Example:

SOURcel :OUTPut:ANALog:ENVelope:SHAPing:PV:FILE:DATA 0,0, 0.1,0.2, 1,1

See:

® [:SOURce<hw>]:IQ:0UTPut|[:ANALog] :ENVelope:SHAPing:FILE:DATA
on page 92

® [:SOURce<hw>]:IQ:0UTPut[:ANALog] :ENVelope:SHAPing:PV:FILE:
DATA on page 92

® [:SOURce<hw>]:IQ:0UTPut[:ANALog] :ENVelope:SHAPing:FILE:NEW
on page 92

® [:SOURce<hw>]:IQ:0UTPut|[:ANALog] :ENVelope:SHAPing:PV:FILE:NEW
on page 92

2.2.3.6 Converting shaping functions and understanding the displayed values

If an envelope function is defined, the "Shaping" dialog displays the diagram of the
resulting envelope shape.

See for example Figure 2-7.
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Several parameters influence the displayed information:

® The selected "Envelope Voltage Adaptation" determines whether the x-axis uses
normalized or linear values

® The selected "Graphic Configuration > Scale" sets the x-axis units

® The selected V Min/Max and PEP;,Min/Max values set the borders of the clipping
areas

® The selected "Shaping" function and the parameters influence the envelope shape.

The illustration on Figure 2-2 shows how these parameters influence a linear shaping
function.

Vcha}( —‘

VchOFm .
VecPowy T
VecPowg )

Vchin—-

VC(_;Min =0

VinMin Vin VinMax
(PEP;Min) (PEPin)  (PEP;,Max)

Figure 2-2: Understanding the displayed values ("Shaping > Linear (Voltage)")

Shaded area = Area where the signal is clipped and the envelope signal is held constant.
1a, 1b, 2a, 2b = V¢ min/Veemax @and PEP;,Min/Max values that set the borders of the clipping areas

Shaping = Linear (Voltage)

3a = Linear function (dashed line) in "Auto Power" mode, if V¢ min =0 V

3b = Linear function in "Auto Power" mode, if Vg, min > 0 V

4a = Linear function (dashed line) in "Auto Normalized" mode, if V¢ min =0 V
4b = Linear function in "Auto Normalized" mode, if V¢ min > 0 V

Vi, = Operating point

VeNorm = V¢ in "Auto Normalized" mode

V. .Powg = V. in "Auto Power" mode and V¢ i, = 0 V

V. .Pow;, = V¢ in "Auto Power" mode and V min > 0V

For information on the provided shaping functions and their formulas, see:
® Chapter 2.2.3.1, "About the linear functions", on page 13

® Chapter 2.2.3.2, "About the detroughing function", on page 14

® Chapter 2.2.3.3, "About the polynomial function", on page 14
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Generation of envelope tracking signals

ing

About the envelope track

The group of examples in this section uses the same linear shaping function to explain
the representation in the different voltage adaptation modes. The example explains the
displayed values and how they are calculated and converted. The same principle
applies for the other shaping methods.

Common settings

® "Envelope Voltage Adaptation > Auto Power"

® V. .Max=1V

® PEP;,Min =-30 dBm corresponds to V;, i, = 0.0071 V
® PEP,,Max = 0 dBm corresponds to V, nax = 0.2236 V
® P, =-15dBm corresponds V,, = 0.04 V

e PEP=-34dB

® "Shaping > Linear (Voltage)"

"Graphic Scale > Power"

"Graphic Scale > Voltage"

-3.4 dBm i

0 T T T
32 26 26 24 22 20 18 16 14 12 10 B 6 4 2 [] 2
Pin /dBm

.04 V] :
EIEE02 0.04 0.06 0.08 0.1 0.12 0.14 0.16 0.18 02

Vin V' (~sqrt(Pin))

Example: Calculating the current V_..Pow, ("Auto Power" mode, V.. Min =0 V)

Configuration as described in Common settings and:

° vcc,min =0V
® f(X) =b*x + Vcc,min

(see Chapter 2.2.3.1, "About the linear functions”, on page 13)
VccPOWO = [(Vcc,max - Vcc,min)/(vin,max - Vin,min)] * (Vin - Vin,min) * Vcc,min
V4Pow, = [(1 - 0)/(0.2236 - 0.0071)]*(0.04 - 0.0071) + O

V..Pow, = 0.151 V
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About the envelope tracking

Example: Calculating the current V_..Pow, ("Auto Power" mode, V.. Min > 0 V)
Configuration as described in Common settings and:

® Viemin =200 mV

VeePoWs = [(Vee max = Veemin) (Vinmax = Vinmin)]l * (Vin = Vinmin) + Veemin

VPow, =[(1-0.2)/(0.2236 - 0.0071)]*(0.04 - 0.0071) + 0.2

V.Pow, =0.321V

LKIF§02 0.04 0.06 0.08 0.1 0.12 0.14 0.16 0.18 0.2
Vin V' (~sqrt(Pin))

Example: Calculating the current V_.Norm ("Auto Normalized" mode)
Configuration as described in Common settings and:
® "Envelope Voltage Adaptation > Auto Normalized"
® The x-axis shows the normalized values V,/Vi, max
The operating point with V;, = 0.04 V corresponds to
Vin/Vinmax = 0.04 / 0.2236 = 0.178
® f(x)=x,i.e.
VeeNorm = Vio/Vi max
V..Norm =0.178 V

0 01 02 03 04 05 06 07 08B 09 1 1.1
Vin / VinMax
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About the envelope tracking

If the V¢, min Value is changed (V. min > 0 V), then the following applies:
® If0 < Vip/Vinmax < Veemins the signal is clipped and V ,Norm =V, qin
i If Vin/Vin,max > Vcc,minv then Vchorm = Vin/vin,max

For the previous example, if V; min = 200 mV, that V ;Norm =V pin = 0.2 V.

0 01 02 03 04 05 06 07 08 09 g 141
Vin / VinMax

A -

Example: Calculating the current V¢ in "Manual” mode

In "Envelope Voltage Adaptation > Manual" mode, set the parameter "Pre-Gain = PEP
=-3.4dB".

The displayed shaping function resembles the shaping function in "Auto Normalized"
mode; the same formulas apply, too.

M Envelope Settings n fj::ae'(r{’g{mge)

Shaping i
Linear (Voltage)
Pre-Gain
-3.40 dB
Post-Gain
0.00dB
Scale - 0 0102 03 04 05 06 07 08 09 [ 11
Voltage Venv / VenvMax

You can also query the V¢ values for any specified x in the supported voltage adapta-
tion mode and units.

See [:SOURce<hw>] :IQ:0UTPut [ :ANALog] :ENVelope:VCC:VALue?

on page 89.
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General RF envelope settings

Additional information
The described principle applies for any shaping function.

Only if linear shaping is used, the VccNorm can also be directly converted to VocPow
according to the following formula:

frow(X) = [fvorm(X) = Vinmin/Vinmax] "[(Vee.max = Veemin) (1 = Vinmin/Vinmax)]
For example, if fyom(X) = VecNorm = 0.178 V, fpou(X) = VcPowy is:
VPowy =[0.178 - 0.0071/0.2236]*[(1 - 0)/(1 - 0.0071/0.2236)]
VPowy =0.151V

2.3 General RF envelope settings

Access:

1. In the block diagram, select the "I/Q OUT" connector to unfold the "I/Q Analog"
block.

2. Select "I/Q Analog > 1/Q Analog Settings > General".
3. Select "RF Envelope > On".

1/Q Analog Outputs — X

. . Shaping
Envelope Voltage Adaptation i eTrak Interface Type J
Auto Power User Defined
1/Q Output Type - Envelope Voltage Reference J
Differential Vce
Vou Max 9
2.500V DC Modulator
You T 500 mVo EMF O e 100.0 Q ' Maxd ooov
Envelope — —— = . -
Bias @ | Termination o Gain
0.0 mVv Wire to Wire 0.00 dB
Offset . Ve Offset
0.0 mV Bipolar Input O omv
Vee Max
Power Offset & 2.500V
_ 0.00 dB Ve Min
PEP; Max 500 mV
0.00 dBm
[ P
N T BEP . Min out
-30.00 dBm

Figure 2-3: RF Envelope Settings (Example)
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General RF envelope settings

1 = Termination and input impedance of the circuit board

2 = Voltage level measured at the circuit board

3 = Signal characteristics of the DC Modulator

4 = Signal characteristics at the inputs of the PA (see the documentation of the PA, for example its data
sheet)

The remote commands required to define these settings are described in Chap-
ter 6.2, "SOURce:1Q:OUTPut:ENVelope commands", on page 80.

Settings:
S ALttt ——————————————aaaaaaaaes 22
RS T= R (o T I 1= = 11 ] PP 22
T2 Y= L= o || U 23
[ =1 1YY (o] 1= T 23
Envelope Voltage Adaptation.............eeeeiiiiii e 23
L =] Gl 01 (=Y g 7= Lot N 1Y/ o= YRR 24
L@ I @ U o T A Y/ o =S 24
Envelope Voltage ReferenCe..........ueeii i 24
BT 1oV 1Y = PRSPPI 24
= S 25
DC Modulator characteriStiCS........oii e e e 25
L EMIF ettt sttt en et en e, 25
L R ittt e et ettt ettt e et et n e e et e e nen et neens 26
O 1=V 1 T4 1101 DO 26
L T o Yo F Tl 121 10| SO 26
LV 0MBX s 27
N C 711 OO 27
LN L LOTFSE ..ttt e e e et e e e ee e e e e 27
o B = T3 (=T ] o 28
LV LMIN/MBX. ettt ettt ee e e e s e ee e e s seeeeen 28
L POWET OffSBL... .ttt eeee e et et s s e en s ee st e nn e e se s e 29
L PEP IMIN/MAX..... ettt et e en e e et s en s e e ses e 29
State

Enables/disables the analog I/Q output.

Note: By default, these output connectors are deactivated.

Note: Interdependencies

You cannot use some functions simultaneously. They deactivate each other.

Remote command:
[ :SOURce<hw>] : IQ:0UTPut :ANALog:STATe on page 78

Set to Default

Calls the default settings. The values of the main parameters are listed in the following
table.
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General RF envelope settings

Parameter Value

"State" Not affected by the "Set to Default"

"RF Envelope" Off

"1/Q Output Type" Depends on "System Configuration > External RF and 1/Q > Preset behavior:

Keep connections to external instruments":
®  "Off": Single Ended
®  "On": Not affected by the "Set to Default"

"I/Q Level Vp (EMF)" 1V

"Bias (EMF)" omv

Remote command:
[ :SOURce<hw>] : IQ:0UTPut [ :ANALog] : PRESet on page 78

Save/Recall

Accesses the "Save/Recall" dialog, that is the standard instrument function for saving
and recalling the complete dialog-related settings in a file. The provided navigation
possibilities in the dialog are self-explanatory.

The settings are saved in a file with predefined extension. You can define the filename
and the directory, in that you want to save the file.

See also, chapter "File and Data Management" in the R&S SMBV100B user manual.

Remote command:

[ :SOURce<hw>] :IQ:0UTPut [:ANALog] : SETTing:CATalog? on page 78

[: ]
[ :SOURce<hw>] : IQ:0UTPut [ : ANALog] : SETTing: STORe on page 79
[ :SOURce<hw>] : IQ:0UTPut [ :ANALog] : SETTing: LOAD on page 79
[ :SOURce<hw>] : IQ:0UTPut[:ANALog] : SETTing:DELete ONn page 79
RF Envelope

Enables the output of a control signal that follows the RF envelope. This control signal
is provided for power amplifiers envelope tracking testing. The signal is output at the |
out and | Bar out connectors.

Remote command:
[ :SOURce<hw>] :IQ:0UTPut [ :ANALog] :ENVelope:STATe on page 83

Envelope Voltage Adaptation
Defines the way you configure the voltage of the envelope tracking generator (see
Chapter 2.2.1, "Envelope voltage adaptation modes", on page 11).

"Auto Normalized"
Generation based on the physical characteristics of the power ampli-
fier; the power values are normalized based on the selected PEPIn
Max value.
This mode enables you to use the complete range of a selected
detroughing function.
See also Shaping settings and compare the values on the X axis on
the graphical display.
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General RF envelope settings

"Auto Power" Generation based on the physical characteristics of the power ampli-
fier, where the input power of the PA "PEP,," is defined with its min
and max values.

"Manual" Generation, in that the operating range of the amplifier is defined
based on a pre-gain and a post-gain range.

Remote command:
[ :SOURce<hw>] :IQ:0UTPut [ :ANALog] :ENVelope: ADAPtion on page 83

eTrak® Interface Type
Selects one of the predefined interface types or allows user-defined settings.

See Chapter 2.2.2, "Signal parameters for testing according to the eTrak® specifica-
tion", on page 12.

Remote command:
[ :SOURce<hw>] : IQ:0UTPut [ : ANALog] :ENVelope : ETRak on page 84

1/Q Output Type
Selects the type of output signal.

The provided parameters in the "I/Q Analog Outputs" dialog depend on the selected
output mode.
"Single-Ended" e If "RF Envelope > Off"
Single-ended output at the I/Q connectors.
® |f "RF Envelope > On"
The envelope signal E is output at the | connectors.

You can define a bias between the output signal and ground.
"Differential" Option: R&S SMBVB-K17
® |f "RF Envelope > Off"
The analog 1/Q signal components are output at the 1/Q and 1/Q
Bar connectors.

® |f "RF Envelope > On"
The inverted envelope signal E is output at the | Bar connectors.

Remote command:
[ :SOURce<hw>] : IQ:0UTPut [ :ANALog] : TYPE on page 79

Envelope Voltage Reference
Defines whether the envelope voltage V. is set directly or it is estimated from the
selected supply voltage V...

Remote command:
[ :SOURce<hw>] :IQ:0UTPut [ :ANALog] :ENVelope: VREF on page 84

VoutMin/Max
Displays the minimum and maximum values of the peak-to-peak voltage V, voltage
on the interface between the circuit board and the DC modulator.

For "Envelope Voltage Reference" , sets the value of this parameter.
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General RF envelope settings

To measure the V,,; voltage:

® Use a suitable probe, i.e. use a differential probe if a "Wire to Wire" termination is
used and a single ended probe otherwise

® Measure at the circuit board after the termination impedance R;,.

Estimated "V, ,Min/Max" values are calculated based on the selected supply voltage
V..Min/Max, enabled Gain and V.Offset in the DC modulator.

Remote command:

[ :SOURce<hw>] : IQ:0UTPut [ : ANALog] : ENVelope:VOUT:MIN on page 85
[ :SOURce<hw>] : IQ:0UTPut [ : ANALog] : ENVelope:VOUT : MAX On page 85

Bias
Sets a DC voltage, superimposed upon the envelope signal E and the inverted enve-
lope signal E Bar.

Use this parameter to define the operating point of a DUT.

"l/Q Output Type" | Termination "Bias" defines
"Single Ended" - The bias between the envelope signal E and ground
"Differential" "To Ground" Superimposed DC voltage, where "Bias" is related to

the selected R;..

See also Table 2-4

"Wire To Wire" Superimposed DC voltage, where "Bias" is related to
high impedance (1 MQ).

Table 2-4: Effect of enabled bias

Effect of a positive bias Effect of a negative bias

4 Vewr

VouMax
VouMax

[y A S A SA—— — oV
Bias (negative)
Bias (positive)

ov

=4 Vg

Remote command:
[ :SOURce<hw>] : IQ:0UTPut [ : ANALog] : ENVelope :BIAS on page 85

DC Modulator characteristics
Refer to the product documentation of the external DC modulator for information on its
characteristics.

The following settings are required:

EMF — DC Modulator characteristics
Activates EMF, which defines whether the EMF or the voltage value is displayed.
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General RF envelope settings

An EMF-based calculation assumes an open-end circuit. Disable this parameter for
testing in more realistic conditions, where you define the input impedance of the used
external DC modulator R;,. The R&S SMBV100B then calculates the envelope output
voltage V, Min/Max based on it.

Remote command:
[ :SOURce<hw>] : IQ:0UTPut [ : ANALog] :ENVelope:EMF [ : STATe] on page 86

R;, < DC Modulator characteristics
If "EMF > Off", sets the input impedance R;, of the external DC modulator.

Remote command:
[ :SOURce<hw>] : IQ:0UTPut [ :ANALog] :ENVelope:RIN on page 86

Termination < DC Modulator characteristics
If "I/Q Output Type > Differential" and "EMF > Off", defines the way the inputs of the
DC modulator are terminated.

The termination influences the way an enabled Bias is applied.

"To Ground" "Wire to Wire"
—_— ——
Pin Pout Pin Pout
VL,; VL‘.L
DC Modulator DC Modulator
+an* 'Vnut* +Vﬂul* 'Vnut*
E E E E
*) Bias = 0 and V_Offset = 0 *) Bias = 0 and V. Offset = 0
Both inputs of the DC modulator are terminated to This termination is also referred as a common mode
ground. voltage.

Remote command:
[ : SOURce<hw>] :IQ:0UTPut [ :ANALog] :ENVelope: TERMination on page 86

Bipolar Input < DC Modulator characteristics
If "I/Q Output Type> Differential", enables the instrument to generate a bipolar signal.

The envelope signal E swings above and below the inverted envelope signal E Bar; the
R&S SMBV100B calculates and applies a suitable envelope V . Offset automatically.
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VecMax

VouMax

Offset = -0.5"V,,
oV

Figure 2-4: Effect of a "Bipolar Input > On"

This parameter influences the lower limit of the supply voltage V...

The generated signal is conformed with the MIPI®Alliance specification "Specification
for Analog Reference Interface for Envelope Tracking".

Remote command:
[ : SOURce<hw>] :IQ:0UTPut [:ANALog] :ENVelope:BINPut on page 87

VppMax < DC Modulator characteristics
Sets the maximum value of the peak-to-peak driving voltage V,, of the external DC
modulator.

The V, limits:

® The value range of the supply voltage V., Min/Max
Vpp 2 VecMax

® |n "l/Q Output Type > Differential”, the voltage of the generated envelope signal
V,Min/Max as follows:
Vo 2 VouMax[E] - VMax[E Bar], where [E] and [E Bar] refer to the envelope sig-
nal and the inverted envelope signal.

Remote command:

[ :SOURce<hw>] : IQ:0UTPut [ : ANALog] : ENVelope: VPP [ :MAX] on page 86

Gain — DC Modulator characteristics
Sets the gain of the external DC modulator.

Remote command:
[ :SOURce<hw>] : IQ:0UTPut [ : ANALog] : ENVelope : GAIN on page 87

V.. Offset — DC Modulator characteristics
Applies a voltage offset on the supply voltage V .Min/Max, i.e. compensates a possible

offset from the external DC modulator. Reduces the envelope output voltage
V,iMin/Max by this value to maintain the supply voltage V.. in the defined value range.
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VecMax

V. Offset
Vommﬂ)(

ov

Figure 2-5: Effect of a Vcc offset

Remote command:
[ :SOURce<hw>] : IQ:0UTPut [ : ANALog] :ENVelope:VCC:OFFSet on page 87

PA characteristics
Refer to the product documentation of the power amplifier (PA) for information on its
characteristics.

The following settings are required:

V..Min/Max — PA characteristics
Displays the minimum and maximum values of the supply voltage V., as required by
the power amplifier (PA).

For "Envelope Voltage Reference > Vcc", sets the minimum and maximum values of
the supply voltage V..

The value range of the supply voltage V. is determined by the allowed peak-to-peak
driving voltage V,, of the external DC modulator and the enabled V.Offset.

Ve Max <V ,Max
The V. is calculated as follows:
V.. = Vout * Gain + Vcc Offset

Example:

Envelope Voltage Reference =V

V Offset = 0 mV

V. Max =1V =0dBV

Gain=3dB

V. Max [dBV] - Gain [dB] = V,,Max or
VoiMax=0dBV -3dB =-3dBV =0.708 V
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Envelope settings

"Bipolar Input” Value range "V .Min"

"State > On" VeMin = - 0.5*V ,Max
Note: Implemented as a V. Offset, see Effect of a "Bipolar
Input > On".

"State > Off" VMin =0 to V ,Max

Remote command:
[ :SOURce<hw>] : IQ:0UTPut [ : ANALog] : ENVelope:VCC:MIN on page 88
[ :SOURce<hw>] :IQ:0UTPut [:ANALog] :ENVelope:VCC:MAX on page 88

Power Offset < PA characteristics

Indicates an enabled power offset, for example to compensate power attenuation
because of cable lengths.

The displayed value is applied as level offset to the generated RF signal and considers
the following settings:

® "RF > RF Level > Level > Offset"

® "RF > RF Level > UCOR"

Remote command:

[ :SOURce<hw>] : IQ:0UTPut [ : ANALog] : ENVelope: POWer:OFFSet?

on page 90

PEP;,Min/Max < PA characteristics

Sets the minimum and maximum values of the input power PEP;,,, as required by the
power amplifier (PA).

The "PEP;,Min/Max" parameters define the linear range of the PA. Refer to the product

documentation of the PA for information on the characteristics of the required input sig-
nal.

The value range corresponds to the value range of output level.

Remote command:
[ :SOURce<hw>] : IQ:0UTPut [ : ANALog] : ENVelope: PIN:MIN on page 89
[ :SOURce<hw>] : IQ:0UTPut [ : ANALog] : ENVelope: PIN:MAX on page 89

Envelope settings

Access:

1. Enable the generation of envelope tracking signal.
See Chapter 2.3, "General RF envelope settings", on page 21.

2. Select "I/Q Analog Settings > Envelope Settings".
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Envelope settings

1/Q Analog Uutputs
Envelope to RF Delay . .
248.000 ns Calculate Envelope from Predistorted Signal ¥
O
Pre-Gain Shaping Post-Gain e
dB 9 50 @B 2 o1
Ok
1 = Enabled Digital Predistortion
2 = Envelope detector, V[I(t)?+Q(t)?]; indication changes, depending on the Envelope Voltage
Adaptation
3a, 3b = (for "Envelope Voltage Adaptation > Manual") Pre-Gain/Post-Gain
4 = Shaping state and shaping function; gray background color = deactivated shaping
5 = Enabled Envelope to RF Delay
6 = Indicates the output connectors, depending on the I/Q Output Type

The dialog displays an interactive overview diagram of the ET processing chain.
The diagram displays information on shaping state, incl. current shaping method
and setting, like gains or delay.

Tip: Hotspots for quick access. The displayed blocks are hotspots. Select one of
them to access the related function.

The remote commands required to define these settings are described in Chapter 6.2,
"SOURCce:1Q:OUTPut:ENVelope commands", on page 80.

Settings:
ENVvelope t0 RF DEIAY.......uiuiiiiiciiiie ettt e e e e e e e e e e e e e e e eeeeaees 30
Calculate Envelope from Predistorted Signal..........cccoiiiiiiiiiiii e, 31

Envelope to RF Delay

Sets the time delay of the generated envelope signal relative to the corresponding RF
signal. A positive value means that the envelope signal delays relative to the RF signal
and vice versa.
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2.5

Shaping settings

2013-07-09
10:38:01

Rec len: 100 kSa RT
Sel: 1 ps/div

: Trigger settings

~ ' Mode: Auto

[\ | Type-A: Edge £
Offset: -4.96 ps
Level: 108.793 mv

400 mV

200 sV
~

00 my/div
C 1Mo

Cpl: DC 1MQ
Dec:Sa | TA: Off

— -300 mV

-400 mV

2500 mv 4 us -3 s -2 s -1 ‘;JE s 1 ‘ux 2 s 3 s 4 s

Figure 2-6: Effect of enabled positive RF delay

1 = RF signal
2a, 2b = Envelope signal E and inverted envelope signal E BAR

Use this parameter to compensate possible timing delays caused by connected cables
and align the input signals at the PA to prevent unwanted effects, like memory effects
or decreased linearity.

Remote command:
[ :SOURce<hw>] : IQ:0UTPut [ : ANALog] : ENVelope:DELay on page 84

Calculate Envelope from Predistorted Signal
Option: R&S SMBV100B-K541

Enables the calculation of the envelope signal from the original baseband signal or
from the AM/AM and/or AM/FM predistorted signal.

See also Chapter 3, "Applying digital predistortion”, on page 46.

Remote command:
[ :SOURce<hw>] : IQ:0UTPut [ : ANALog] : ENVelope: FDPD on page 84

Shaping settings

Access:

1. Enable the generation of envelope tracking signal.
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Shaping settings

See Chapter 2.3, "General RF envelope settings", on page 21.

2. Enable "Envelope Voltage Adaptation > Auto Power/Normalized".

3. Select "I/Q Analog Outputs > Shaping".

1/Q Analog Outputs
. Shaping
Envelope Settings n e
Shaping |

Detroughing ¢
Detroughing Function
1:1(x) = x +d - er(-x/d)
Detroughing Factor - d 9
0.200

Detroughing Factor Behaviour
Coupled with Vee

Graphic Configuration

Scale

-
Power

Figure 2-7: Understanding the displayed information ("Envelope Voltage Adaptation > Auto
Power", "Shaping > Detroughing”)

1a, 1b = Indicates the values of V Min/Max

2a = Values smaller than PEP;,Min are clipped.

2b = Values greater than PEP;,Max are clipped.

3 = Operating point; corresponds to the RF RMS power level.

3a = Current RF RMS power level; an enabled "RF Level > Level Offset" is considered.
3b = Current V¢

4 = Crest factor of the generated signal

5a, 5b = The values correspond to the PEP of the generated RF signal and the V¢; shaded area indi-
cates the calculated Pre-Gain.
6 = Current envelope shape, defined by the detroughing function and detroughing factor

The settings allow the configuration of the shape of the RF envelope signal. The
instrument applies the settings and calculates the shaping function. A diagram vis-
ualizes the resulting envelope shape, as function of the selected supply voltage V.
and PEP;, value limits, the calculated pre-gain and the estimated operating point of
the PA.

See also:

e Chapter 4, "How to generate a control signal for power amplifier envelope
tracking tests", on page 68.

e Chapter 2.2.3.6, "Converting shaping functions and understanding the dis-
played values", on page 16.
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Shaping settings

The remote commands required to define these settings are described in Chapter 6.2,
"SOURCce:1Q:OUTPut:ENVelope commands", on page 80.

Settings:
] =T 01T 33
Detroughing FUNCLON.... .ot 37
Detroughing FaCtor (d)......cuueeeee et 38
Couple Detroughing Factor With VCC......cccoiuiiiiiiiii e 38
EXPONENT (8). e e e e e s e e e e 38
g (=T = T o 1SR 38
POST-GaIN. ...ttt e e e e e e e e e e e e e e eeas 38
Polynomial CoeffiCieNtS..... ... e e e e e e e e e e ee e 39
ShapiNg TabBIE......eeiii e e e e e e s b e e e 39
T (=T o] =1 o o S 39
Graphic ConfIQUIatioN.........ciii e 40
L S0 ..ottt ettt en e 40
e 1Yo = 111 TR 40
Shaping

Enables envelope shaping and selects the method to define the shaping function.

For detailed information on the shaping functions, see:

® Chapter 2.2.3, "Envelope shaping and shaping methods", on page 12

® Chapter 2.2.3.6, "Converting shaping functions and understanding the displayed
values", on page 16.
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Shaping settings

"Off" Envelope shaping is not adopted.
Previously configured values of the parameters Pre-Gain and Post-
Gain are ignored.

2013-07-09
12:836:21
Horizontal settings

Rec len: 1 MSa RT
Sel 20 ps/div

Trigger settings
Fode:  Auto
Type-A: Edas £ Cho
Offset: 0

: Os
Level: 1088 my

-400 mi-

soomy  “80Ks

Figure 2-8: Generated RF, envelope and inverted envelope signal

1 = RF signal (simple ramp function)
2a, 2b = Envelope signal E and inverted envelope signal E Bar

"Linear (Voltage)/Linear (Power)"
The shaping function is a simple linear function.
The linear shaping is not used in practice but can be used for less
demanding applications, simple analysis, and the first interactions by
designing the optimum envelope shape. For "Envelope Voltage Adap-
tion > Manual", this function is suitable to determine the "Pre-/Post-
Gain" values, because the shaping gain of the linear function is 0 dB.
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Shaping settings

"Polynomial" The shaping function is defined by a polynomial with configurable
order and coefficients.
Select Polynomial coefficients settings to access the settings.

2013-07-09
12:36:30
Horizontal settings

Rec len: 1 MSa RT
Sel 20 ps/div

Trigger settings
Mode:  Auto
Type-A: Edge f cha
offsett 05
Level:  108.8 my

400 my — - —

300 my

eli 40 mu/div
Cpl: DC 500
DeeiSa| TA: Off

80ps 60ps 40 s 203 205 40ps 60 s 804
i i i L i 1 i

Figure 2-9: Effect of a polynomial shaping on the envelope and inverted envelope
signal

1 = RF signal (simple ramp function)
2a, 2b = Envelope signal E and inverted envelope signal E Bar
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Shaping settings

"From Table" The shaping function is defined by user-defined value pairs in form of
a shaping table.
This shaping function is suitable if you have knowledge on or aim to
achieve an exact relation between the supply voltage and RF output
power. For example, by describing the transition region of a PA.
Select "Shaping Table" to access the settings.

2013-07-00
12:35:54

Horizontal settings
Res: 200 ps/5 GSafs
Rec lsn: 1 MSa RT
seli 20 ps/div

Trigger settings

Mode:  Aut
Type-A: Edge £ 1o
Offset 05

Level: 108.8 my

400 miy

0wy B0MS B0 s 20us

Figure 2-10: Effect of a table shaping on the envelope and inverted envelope sig-
nal

1 = RF signal (simple ramp function)
2a, 2b = Envelope signal E and inverted envelope signal E Bar
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Shaping settings

"Detroughing”  The shaping function applies a detroughing to prevent that the supply
voltage V. drops down to zero.
Use the "Detroughing Factor" to limit the supply voltage V.. in the
low-power region.
e &

480 my

Trigger settings
Mode:  Auto
Type-A: Edge f 12
offsett  -6.94 us
Level -312.97 m¥

Seli 100 mv/div

-480 v

80 ps B0 ps 40 ps -20ps Os 20ps 40ps B0 s an
600 mY ‘IJ ‘IJ ‘U IU g IIJ ‘U ‘U B

Figure 2-11: Effect of a detroughing function on the envelope and inverted enve-
lope signal

1 = RF signal (simple ramp function)

2a, 2b = Envelope signal E and inverted envelope signal E Bar

Remote command:
[ :SOURce<hw>] :IQ:0UTPut [ :ANALog] :ENVelope: SHAPing:MODE on page 90

Detroughing Function
Selects the mathematical function describing the detroughing.

The following functions are available:

® f(x)=x+d*e>

® f(x)=1-(1-d)*cos(x*pi/2)

® fx)=d+(1-d)*x®

Where:

® x depends on the "Envelope Voltage Adaptation" mode, see Table 2-2

® d = Detroughing Factor (d)

® a=Exponent(a)

For more information, see Chapter 2.2.3.6, "Converting shaping functions and under-
standing the displayed values", on page 16.

Remote command:
[ :SOURce<hw>] : IQ:0UTPut [ :ANALog] :ENVelope:SHAPing:DETRoughing:
FUNCtion on page 93
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Shaping settings

Detroughing Factor (d)
For inactive coupling of the detroughing factor with V., sets a start offset to limit the
supply voltage V. in the low-power region.

The detroughing factor also controls the shaping. "Detroughing Factor = 0" defines a
linear function.

See also "Couple Detroughing Factor with VVcc" on page 38.

Remote command:

[ :SOURce<hw>] : IQ:0UTPut [ :ANALog] : ENVelope:SHAPing:DETRoughing:
FACTor on page 94

Couple Detroughing Factor with Vcc

Enable this parameter to derive the detroughing factor (d) from the selected V. value.
This ensures that the minimum supply voltage V.. does not drop under the specified
limits and the signal is not clipped.

The detroughing factor is calculated as follows:
d =V Min/V ,Max
Remote command:

[ :SOURce<hw>] : IQ:0UTPut [ :ANALog] :ENVelope:SHAPing:DETRoughing:
COUP1ling on page 94

Exponent (a)
For the third detroughing function, sets the exponent (a), see Detroughing Function.

Remote command:
[ :SOURce<hw>] : IQ:0UTPut [ :ANALog] :ENVelope:SHAPing:DETRoughing:
PEXPonent on page 94

Pre-Gain

For "Envelope Voltage Adaptation > Manual”, sets a pre-gain (i.e. an attenuation) to
define the operating range of the power amplifier. The pre-gain can be used to define
and test only a specific (required) part of the operating range.

For "Envelope Voltage Adaptation > Auto”, calculates the value automatically as follow-
ing:

"Pre-Gain" = "Pin max" - "RF Level" + "Crest Factor"

Remote command:

[ :SOURce<hw>] : IQ:0UTPut [ :ANALog] :ENVelope:SHAPing:GAIN: PRE

on page 91

Post-Gain
For "Envelope Voltage Adaption > Manual", sets a post-gain to compensate the attenu-
ation introduced by the pre-gain and the gain of the shaping function.

Remote command:
[ :SOURce<hw>] : IQ:0UTPut [ :ANALog] :ENVelope:SHAPing:GAIN:POST
on page 91
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Shaping settings

Polynomial Coefficients
For "Shaping > Polynomial", accesses a dialog to describe the envelope shape as a
polynomials function, see Chapter 2.7, "Polynomial coefficients settings", on page 43.

Shaping Table
For "Shaping > From Table", accesses the standard "Envelope Select" dialog with
functions to define a new shaping table file, select or edit an existing one.

The shaping table files are files with predefined extension and file format, see "File for-
mat of the shaping table file" on page 15.

You can create a shaping table externally or internally.

"Select" Selects and loads an existing file.
"New" Creates a file
"Edit" Access a standard built-in table editor, see Chapter 2.6, "Edit I/Q

envelope shape settings", on page 40.

Remote command:

For "Envelope Voltage Adaption > Manual":

[ :SOURce<hw>] : IQ:0UTPut [ :ANALog] :ENVelope: SHAPing:FILE:CATalog?
on page 91

[ :SOURce<hw>] : IQ:0UTPut [ :ANALog] :ENVelope:SHAPing:FILE[:SELect]
on page 91

For "Envelope Voltage Adaption > Auto":

[ :SOURce<hw>] : IQ:0UTPut [ :ANALog] :ENVelope:SHAPing:PV:FILE:
CATalog? on page 91

[ :SOURce<hw>] : IQ:0UTPut [ : ANALog] :ENVelope: SHAPing:PV:FILE[:
SELect] on page 91

Interpolation
For "Shaping > From Table", enables a linear interpolation between limited number of
defined value pairs in the table, to prevent abrupt changes.

Table 2-5: Effect of parameter "Interpolation”

"Interpolation > Off" "Interpolation > Linear Voltage"

Vout / Vmax
o
in

=)
I
Vout / Vmax

=
=i
=] 5

0 0.1 0.2 0.3 04 05 06 0.7 0.8 0.8% 1 ] 0.1 0.2 03 04 0.5 0.6 0.7 08 089 1
Vin / Vmax Vin / Vmax

Remote command:
[ :SOURce<hw>] : IQ:0UTPut [ :ANALog] :ENVelope:SHAPing: INTerp
on page 92
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2.6

Edit 1/Q envelope shape settings

Graphic Configuration
Comprises settings to configure the graphical display.

Scale < Graphic Configuration
Determines the units, "Voltage" or "Power", used on the x and y axis.

Table 2-6: Units on the x axis

"Envelope Voltage Adaption™ "Scale > Power" "Scale > Voltage"
Auto Power Pin [dBm] V., [V] = VP;,
Auto Normalized Pin/Pmax Vin/Vimax

Remote command:
[ :SOURce<hw>] : IQ:0UTPut [ :ANALog] :ENVelope:SHAPing:SCALe
on page 90

Diagram — Graphic Configuration
Visualizes the resulting envelope shape, as function of the selected supply voltage V.

and PEP,, value limits, the calculated pre-gain and the estimated operating point of the
PA.

See Figure 2-7.

Remote command:

[ :SOURce<hw>] : IQ:0UTPut [ : ANALog] :ENVelope:VCC:VALue:LEVel?

on page 88

[ :SOURce<hw>] : IQ:0UTPut [ : ANALog] : ENVelope:VCC:VALue:PEP?

on page 88
[:SOURce<hw>}:IQ:OUTPut[:ANALog]:ENVelope:VCC:VALue?Onpa9689

Edit I/Q envelope shape settings

The envelope shaping table is a method to define the shaping function.

Access:

1. Enable the generation of envelope tracking signal.
See Chapter 2.3, "General RF envelope settings", on page 21.

Select "Envelope Voltage Adaptation > Manual".
Select "Shaping Settings > Shaping > From Table".
Select "Shaping Table > New"

o > oD

Enter the "File Name", e.g. MyLUT

The "Envelope Shaping File" dialog closes.
The "Shaping > Shaping Table" confirms that the newly created file is assigned.

6. Select "Shaping Table > MyLUT > Edit"
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Edit 1/Q envelope shape settings

7. Define the value pairs "Vin/Vmax" and "Vcc/Vmax". The order is uncritical.

Edit Envelope Shaping Table - MyLUT _ X

Vin/ Vmax Vcc/ Vmax

0 0.300 0.400
1 0.350 0.450
2 0.560 0.550
3 0.400 0.500

4 0.600 0.650

5 0.000 0.135

QGOTO | Edit | SaveAs... | Save

Figure 2-12: Shaping table in "Envelope Voltage Adaptation > Manual” mode

8. Select "Save".

The instrument loads the configured values automatically and displays the shaping
function.

9. Select "Shaping Settings > Interpolation > Linear (Voltage)".

0 01 02 03 04 05 06 07 08 09 ﬂ 1.1
Venv / VenvMax

The display confirms the used interpolation.

The remote commands required to define these settings are described in Chapter 6.2,
"SOURCce:IQ:OUTPut:ENVelope commands", on page 80.

Settings:

Vin/Vmax, Vec/Vmax/Power (dBm), VCC (V). 42
Fill Table AUtOMAtICAIIY........oeeiiiieeee e e e e e e 42
GOtO, Edit, SAVE AS, SAVE.... oottt 42
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Edit 1/Q envelope shape settings

Vin/Vmax, Vcc/Vmax/Power (dBm), Vcc (V)
Sets the normalized values of the value pairs.

"Vin/VVmax, Vcc/Vmax"
Value pairs in "Envelope Voltage Adaptation > Manual/Auto Normal-
ized" mode.

"Power(dBm), Vcc(V)"
Value pairs in "Envelope Voltage Adaptation > Auto Power" mode.

Remote command:
n.a.

Fill Table Automatically
Standard function for filling a table automatically with user-defined values.

e e

From Range
0 1
Column To Fill
Vin / Vmax M
Start Value End Value 9
0.000 0.000

Increment Value

°Fill

0.000

"From / Range"
Defines the start line and number of the rows to be filled.

"Select Column to Fill"
Selects the respective value, including the unit.

"Start / End Value"
Default values corresponding to the selected column.

"Increment" Determines the step size.

"Fill" Fills the table.
Fill both columns and then save the list. Otherwise the entries are
lost.

Goto, Edit, Save As, Save
Standard functions for editing of data lists.

Changed and unsaved values are displayed on a yellow background.

Remote command:
n.a.
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Polynomial coefficients settings

2.7 Polynomial coefficients settings

Access:

1.

Enable the generation of envelope tracking signal.
See Chapter 2.3, "General RF envelope settings", on page 21.

Select "Envelope Voltage Adaptation > Auto Normalized".

Select "Shaping Settings > Shaping > Polynomial".

Select "Polynomial Coefficients".
N |

Save/Recall Polynomial ... |

Polynomial Order

Vee/Veemax(x) = 0.134 000 000 0

0.693 0000000 | X

- x2
0.212 0000000

where: X = Va/Vara

@Apply | °0K

Figure 2-13: Polynomial Coefficients: Understanding the displayed information

The polynomial function is an analytical method to describe a shaping function.
With the provided settings, you can define a polynomial function with up to 10™
order to describe the envelope shape.

Select "Polynomial Order = 2" (n = 2).

Set the constant a, and the polynomial coefficients a; and a,.

Select "Apply".

The instrument loads the configured values and displays the shaping function.

To store the defined shaping function:

a) Select "Save/Recall Polynomial"

b) Navigate throughout the file system.

c) Enter a "File Name", e.g. MyPolynomial_2thOrder
d) Select "OK".

Select "Polynomial Coefficients > OK" to close the dialog.
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Polynomial coefficients settings

The remote commands required to define these settings are described in Chapter 6.2,
"SOURCce:1Q:OUTPut:ENVelope commands", on page 80.

Settings:

Save/Recall POlYNOMIAL........uu i s e e e e e e e e e e e e e e e e e e e eeeeaeaees 44
POIYNOMUAT OFAET ... . i e e e e e e e e e e e e e e e e e e e e e e e e aeee b aea b as 44
Polynomial constant and coefficients...........oooo i 44
Y o] 0]/ RS 44

Save/Recall Polynomial

Accesses the "Save/Recall" dialog, that is the standard instrument function for saving
and recalling the complete dialog-related settings in a file. The provided navigation
possibilities in the dialog are self-explanatory.

The settings are saved in a file with predefined extension. You can define the filename
and the directory, in that you want to save the file.

See also, chapter "File and Data Management" in the R&S SMBV100B user manual.

The polynomial files are files with extension *.ig poly, see "File format of the poly-
nomial function file" on page 15.

Remote command:

[ :SOURce<hw>] : IQ:0UTPut [ :ANALog] :ENVelope:SHAPing:COEFficients:
CATalog? on page 93

[ :SOURce<hw>] : IQ:0UTPut [ :ANALog] :ENVelope:SHAPing:COEFficients:
STORe on page 93

[ :SOURce<hw>] : IQ:0UTPut [ :ANALog] :ENVelope:SHAPing:COEFficients:
LOAD on page 93

Polynomial Order
Defines the polynomial order n, that is the number of polynomial coefficients (see
Chapter 2.2.3.3, "About the polynomial function", on page 14).

To confirm the settings, select "Apply".

Remote command:
See [ :SOURce<hw>] :IQ:0UTPut[:ANALog] :ENVelope:SHAPing:
COEFficients on page 92.

Polynomial constant and coefficients
Sets the polynomial constant ay and the polynomial coefficients a4 to a,,.

The polynomial constant and coefficients influence the envelope shape.

Remote command:
[ :SOURce<hw>] : IQ:0UTPut [ :ANALog] :ENVelope:SHAPing:COEFficients
on page 92

Apply, OK
Triggers the instrument to adopt the selected function.

Use "OK" to apply the setting and exits the dialog.
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Polynomial coefficients settings

Remote command:
See [:SOURce<hw>] :IQ:0UTPut [:ANALog] :ENVelope:SHAPing:
COEFficients on page 92
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3

3.1

3.2

About digital predistortion

Applying digital predistortion

Digital predistortion (DPD) is a method to improve the efficiency of RF power amplifi-
ers. In the R&S SMBV100B, the generated digital signal can be deliberately AM/AM
and AM/PM predistorted.

Required options

The equipment layout for digital predistortion includes:

® Base unit

® Option AM/AM AM/PM predistortion (R&S SMBVB-K541)
® Optional option envelope tracking (R&S SMBVB-K540)

About digital predistortion

Power amplifiers are an essential part of any telecommunication systems. While ampli-
fying the transmitted signal, power amplifiers sometimes also distort this signal and
change its amplitude and/or phase characteristics. Such distortions result in undesired
effects like spectrum regrowth, harmonic generation, intermodulation (IM) products, or
increased bit error rate.

The principle of the digital predistortion

To compensate for the distortions caused by the transmission system, the signal is
deliberately digitally predistorted. Digital predistortion (DPD) is a method to apply wan-
ted and well-defined predistortion on the transmitted signal. When this signal is ampli-
fied, the resulting signal features the identical characteristics, as the initial signal before
the predistortion.

= signal =4 DPD »
Pm Pout

Figure 3-1: lllustration of predistortion principle

DPD = Digital predistortion
PA = Power amplifier

a = Predistortion function

b = Characteristic of the power amplifier, for example the non-linear input power vs. output power
(AM/AM) function

[¢ = Ideal linearized characteristic of the amplified signal
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3.21

About digital predistortion

Digital predistortion models

When testing power amplifiers, it is important to measure and analyze signal distor-
tions.

Of several known models, this implementation focuses on the following two types of
distortion:

® The AM/AM (amplitude-to-amplitude) distortion and
® The AM/PM (amplitude-to-phase) distortion.

An AM/AM representation is a standard method that shows the signal power level at
the input of the DUT against the power level at the output of the DUT. The default unit
for both axes is dBm but the AM/AM representation can also be normalized.

An AM/PM curve shows the phase difference in degrees (y-axis) for every input power
level (x-axis).

With option R&S SMBVB-K541, you can define both, an AM/AM and an AM/PM predis-
tortion and apply them separately or superimposed on each other on the generated
digital baseband signal.

If your instrument is equipped with the option R&S SMBVB-K540, you can also apply
predistortions on the generated envelope signal.

Refer to Chapter 2, "Generation of envelope tracking signals", on page 10 for more
information.

Defining the power level of the generated signal

You can define the level of the generated signal in one of the following ways:

® "Level Reference > Before DPD"
In this mode, the "Level" parameter in the status bar of the instrument defines the
signal level before the DPD is applied.
Signal with selected level is pre-distorted and depending on the selected AM/AM
and AM/PM functions, attenuated or boosted.
See Table 3-1.

e "Level Reference > After DPD"
In this mode, you define the resulting signal level. Based on this value and depend-
ing on current predistortion function, the R&S SMBV100B calculates the level of
the signal to be pre-distorted.
The level calculation requires several interaction cycles; the number of iterations is
a trade-off between level accuracy and speed.
See "To perform manual iterations to achieve a desired resulting signal level after
the DPD" on page 74 for explanation of how the interactions are performed.
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Table 3-1: Difference between the level reference modes

Applying digital predistortion
About digital predistortion

"Level Reference > Before DPD"

"Level Reference > After DPD"

2.143 000 000 000 - -15.00 éBm 2.143 000 000 000 otz ® -15.00 éem
n General Predistortion Settings n General Predistortion Settings
AM/AM + AM/PM (R R ETS AMAM + AM/PM. [ P
Se076 : s | @ |
E Uefa‘ull G Recall Save |j etatit Recall (=) save
Level Reference . Level Reference i
Before DpBF~ AM/AM First AfterDpD 7| AM/AM First
Maximum Output Level Error Maximum Number of Iterations
0.10dB 3
° @ Achieved Qutput Level Error L
s -3.43dBm | DPD pr -3.68dBm 0.00dB
o Gl
tevel  -15.00 dBm tevel | -15.42 dBm el -3.86 dBm°. DPD - 3.57dBm”
1/Qp,, TS 9 —-———=ubPD s g
cestractor___11-57 dB J oestracer | 117448 Qs e 1343d8m d | 1500dem” o
BB TS 9| CJIL L1 o DPD
Cestracor  11.58 dB Crest Factor 1143 dB

1: "Levely = Level = -15 dBm", i.e. signal level before DPD
:"PEP) = PEP -3.43 dBm", i.e. PEP of the signal before DPD

: "Levelgyt = -15.42 dBm", resulting signal level after DPD

A W N

1 "PEPqyr = -3.68 dBm", resulting PEP of the signal after DPD

1: "Levelgyr = Level = -15 dBm", i.e. signal level after DPD

2: "PEPoyr = PEP = -3.57 dBm", i.e. PEP of the signal after
DPD

3: "Levely =-15.43 dBm", calculated signal level before DPD
4: "PEP,y = -3.86 dBm", calculated of the signal before DPD
5: allowed maximum level error

6: maximum number of iterations used to achieve the required
level error

3.2.2 Defining the correction values

In the R&S SMBV100B, you can select the way you define the predistortion function

and choose between:

® A polynomial function with up to 10 polynomial coefficients
(see Chapter 3.2.2.1, "Polynomial function", on page 48)

® A predistortion function defined as a look-up table
(see Chapter 3.2.2.2, "Shaping table", on page 49)

® A normalized data

(see Chapter 3.2.2.3, "Normalized data", on page 50)

® To set the correction values in raw format with a single remote control command
(see Chapter 3.2.2.4, "Predistortion function in raw data format", on page 51).

3.2.2.1 Polynomial function

The polynomial function is an analytical method to describe a predistortion function.
When using the polynomial function, you do not define the correction values (APower
and APhase) directly as it is in the look-up table. You describe the predistortion func-
tion and the R&S SMBV100B derives the correction values out of it.

See Chapter 3.3.4, "Polynomial coefficients settings", on page 62.

This implementation uses a polynomial with complex coefficients defined as follows:

Poep(X) = Z[(an*j*bn)*x",
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About digital predistortion

Where:

® n ="Polynomial Order" < 10

® x=P,/PiyMax

® 3, and b, are user-defined coefficients, defined as Cartesian (polar) or cylindrical

coordinates.
In Cartesian coordinates system, the coefficients b, are expressed in degrees.

The R&S SMBV100B calculates the AM/AM and AM/PM predistortion functions as fol-
lows:

®  AM/AM(x) = abs[Pppp(X)]

*  AM/PM(x) = tan"{Im[Pppp(x)/Re[Pppo(X)]}

A dedicated graphical display visualizes the resulting functions, see Figure 3-4.

The R&S SMBV100B calculates the correction values (AAM/AM and AAM/PM func-
tions) as follows:

°*  AAM/AM(x) = AM/AM(x) - x = abs[Pppp(Xx)] -x

®*  AAM/PM(x) = AM/PM(x) = tan"{Im[Pppp(X)I/Re[Pppp(X)]}

File format of the polynomial file

You can store a polynomial function in a file or even define the polynomial coefficients,
store them as a file and load this file into the instrument. The polynomial files are files
with the extension *.dpd poly.

The file contains an optional header # Rohde & Schwarz - Digital
Predistortion Polynomial Coefficients # a0,b0, al,bl, a2,b2,
and a list of comma-separated coefficient value pairs, stored in Cartesian coordinates.

For values above the selected Input Range (PEP;,) From/To, the predistortion function
assumes a linear ratio of the input to output power.

Example: Polynomial function file content

# Rohde & Schwarz - Digital Predistortion Polynomial Coefficients
# a0,b0, al,bl, a2,b2, ...
0,0,-0.25,0.2,0.6,-0.3,0.3,0.3,0.5,-0.4

3.2.2.2 Shaping table

In the R&S SMBV100B, there are two ways to define the predistortion function in form
of a shaping table:

e Externally
Create a correction table file as a CSV file with Microsoft Excel, with a Notepad or
a similar tool. Save the file with the predefined extension, transfer and load it into
the instrument.
See also "File format of the correction table file" on page 50.

® |nternally
Use the built-in editor table editor, see Chapter 3.3.3, "Edit predistortion table set-
tings", on page 60.
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About digital predistortion

File format of the correction table file

The correction table files are files with predefined extension and simple file format, see

Table 3-2.

Table 3-2: Shaping table files: format and extensions

Predistortion model File extension Header (optional)

AM/AM *.dpd magn # Rohde & Schwarz - Digital AM/AM
Predistortion

Table Pin[dBm],deltaPower [dB]

AM/PM *.dpd phase # Rohde & Schwarz - Digital AM/PM
Predistortion
Table Pin[dBm],deltaPhase[deg]lx

The header is optional. The file content is a list of up to 4000 comma-separated value
pairs, describing the delta values for amplitude or phase related to the absolute input
power P;,. A new line indicator separates the pairs.

For values above the selected Input Range (PEP;,) From/To, the predistortion function
assumes a linear ratio of the input to output power.

Example: Shaping table file content (*.dpd_magn file)
# Rohde & Schwarz - Digital AM/AM Predistortion Table
Pin[dBm] ,deltaPower [dBm]

-30,0.5

3,-0.01

3.2.2.3 Normalized data

In the R&S SMBV100B, there are two ways to define the predistortion function as nor-
malized data:

® Externally
We recommend that you calculate the normalized correction data by a connected
R&S®FSW equipped with R&S®FSW-K18 power amplifier and envelope tracking
measurements option.
You can also create the correction table file as a CSV file with Microsoft Excel, with
a Notepad or a similar tool. Save the file with the predefined extension, transfer
and load it into the instrument.
See also "File format of the correction table file" on page 50.

® |[nternally
Use the built-in editor table editor, see Chapter 3.3.3, "Edit predistortion table set-
tings", on page 60.

File format of the normalized data

The normalized data files are files with predefined extension * . dpd norm and simple
file format, see "File format of the normalized data" on page 50.

The file contains an optional header # Rohde & Schwarz - Digital
Predistortion Normalized Table Data # PinMax [dBm] # number of
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points # Vin/Vmax, deltaV/V, deltaPhase [deg], the values of the Piny,,,

the number of the subsequent points and a list of comma-separated groups of three
values.

Example: Normalized data file content

# Rohde & Schwarz - Digital Predistortion Normalized Table Data
# PinMax [dBm]

# number of points

# Vin/Vmax, deltaV/V, deltaPhase [deg]
10

4096

0,0,0

0.0002442,-0.00018246,0.28052
.0004884,-0.00036487,0.28041
.0007326,-0.00054723,0.2803
.0009768,-0.00072954,0.28019
.001221,-0.00091181,0.28008
.0014652,-0.001094,0.27996

o O o o o

3.2.2.4 Predistortion function in raw data format

The predistortion values are defined directly, with a single remote control command:
® Define up to 4000 comma-separated value pairs, describing the absolute input
power P;, and the delta values for amplitude or phase (APower and APhase).
Example:
SOURcel:IQ:DPD:SHAPing:TABLe:AMAM:FILE:DATA -30.4,-5.2,
-25.1,-4.5, -18.5,-2.5, -10.5,-1
See:
— [:SOURce<hw>] :IQ:DPD:SHAPing:TABLe:AMAM: FILE :DATA
on page 106

[ : SOURce<hw>] :IQ:DPD:SHAPing: TABLe:AMPM: FILE : DATA
on page 106

— [:SOURce<hw>] :IQ:DPD:SHAPing:TABLe:AMAM: FILE :NEW on page 105

[ :SOURce<hw>] : IQ:DPD:SHAPing: TABLe:AMPM: FILE : NEW on page 105

® Define the absolute maximum input power Pin,,,,, the number of subsequent
points, and the normalized values Vin/Vmax, AV/V, APhase [deg] as binary data.
See [ :SOURce<hw>] :I1Q:DPD:SHAPing:NORMalized:DATA on page 108.

3.2.3 Finding out the correction values

If you know the properties of the used power amplifier, you can calculate suitable cor-
rection values.

We assume that the characteristics of a power amplifier have been measured and that
the left graphic in the following table shows the AM/AM curve of this amplifier.
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Defining correction coefficients for an AM/AM predistortion Resulting AM/AM predistortion function (example)
(example)

K

©
o

0.6

0.4

0.2

o

V
\
I
\
\
)
\
v

0 0.4 0.6 0.8 1 .
02 05 0 0.2 04 0% 06 08 1
a = ideal characteristic; if the amplifier did not distort the signal, | g = ideal characteristic

the normalized magnitude would be a line b = measured AM/AM curve

b = measured AM/AM curve; the normalized magnitude varies

- ) ¢ = resulting AM/AM predistortion function, i.e. correction values
as a function of input power

curve

d = ideal predistorted signal

The required correction coefficient APower is the difference between the ideal and the
real normalized amplitude for one particular input power. To compensate for the nonli-
nearity and the deviation from the ideal line: select a negative correction value (-A) for
any input power where the real normalized amplitude is greater than the ideal one (1).
Logically, a positive correction value (+A) compensates for (i.e. boost) an amplitude
that is smaller than the ideal one (2).

Ideally, a signal predistorted with a suitable function (¢) and then amplified by the par-
ticular PA would have a linear characteristic (a).

In the practice, however, you do not calculate the correction coefficients manually but
they are calculated automatically. A suitable solution is the R&S®FS-K130PC software
or the R&S®FSW-K18 power amplifier and envelope tracking measurements option,
see Chapter 5, "How to apply a DPD to improve the efficiency of RF PAs",

on page 72.

3.3 Digital predistortions AM/AM and AM/PM settings

You can add digital predistortion to the generated baseband signal and thus compen-
sate an amplitude and a phase distortion of the DUT, for example of the tested power
amplifier.
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Digital predistortions AM/AM and AM/PM settings

Access:

> Select "I/Q Mod > Digital Predistortion > AM/AM AM/PM".

Digital Predistortion AM/AM, AM/PM

n General Predistortion Settings
AM/AM + AM/PM RaGIONELTE
SetTo i
Default @Recall | Save |

Level Reference AM/AM First

Before DPD |

PEP PEP
-15.45 dBm -15.45 dBm
Level j Level j
1/Qpg — 15.45 dBm 15.45 dBm 1/Qppp
Crest Crest
Factor Factor
0.00dB 0.00dB

The dialog covers the settings for digital predistortion, like select and enabling an
AM/AM and/or AM/PM predistortion, select the way the predistortion function is
defined and specify the correction values.

The remote commands required to define these settings are described in Chapter 6.3,
"SOURce:1Q:DPD subsystem", on page 95.

Settings:

General settings

S ALttt ———————————aaaaaaaaaas 53
S0 DEfAUIL......cceeeeeeee e e e e e e e e e e e e e e e e e eeaaeaara—a 54
SAVE/RECAIL....cceeeeeeeeee e e e e e e e e e e e e e e e a e —————— 54
N Y T = S 54
LEVEI REFEIENCE. ......ceeeeeeeeeee ettt e e e e e e e e eeaaaaaeeeeeeeeeereees 54
Maximum OULPUL LEVEI EITON.......uuiiiiieiie ettt e e e ree e e e 55
Maximum Number of HerationS...........occiiiiiiiie e 55
Achieved OULPUL LEVEI EITOr........uuiiiieiiccceeie et e e 55
Input/Output PEP, Level and Crest FaCtOr......cooovi i 55
AM/AM and AM/PM SEate........uuiiiiiiiiieie e e e 55
State

Enables/disables the generation of digital predistorted signals.

Remote command:
[ :SOURce<hw>] :IQ:DPD:STATe on page 98
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Set to Default

Calls the default settings. The values of the main parameters are listed in the following
table.

Parameter Value

"State" Not affected by the "Set to Default"
"Level Reference" Before DPD

"AM/AM First" Off

"AM/PM, AM/AM" Off

Remote command:
[ :SOURce<hw>] :IQ:DPD:PRESet on page 98

Save/Recall

Accesses the "Save/Recall" dialog, that is the standard instrument function for saving
and recalling the complete dialog-related settings in a file. The provided navigation
possibilities in the dialog are self-explanatory.

The settings are saved in a file with predefined extension. You can define the filename
and the directory, in that you want to save the file.

See also, chapter "File and Data Management" in the R&S SMBV100B user manual.

Remote command:

[ :SOURce<hw>] : IQ:DPD:SETTing:CATalog? on page 98
[ :SOURce<hw>] :1Q:DPD:SETTing:STORe on page 99

[ :SOURce<hw>] : IQ:DPD:SETTing:LOAD on page 99
[:SOURce] : TQ:DPD: SETTing:DELete on page 98

AM/AM First
Toggles the order the AM/AM and AM/PM predistortions are applied.

Remote command:
[ :SOURce<hw>] :IQ:DPD:AMFirst on page 102

Level Reference

Switches between dynamic and static adaptation of the range the selected DPD is
applied on.

"Before DPD/After DPD"
Selects dynamic range calculation and defines whether the selected
"Level" value corresponds to the signal level before or after the pre-
distortion, see Chapter 3.2.1, "Defining the power level of the gener-
ated signal”, on page 47.

"Static DPD" Selects static (constant) range limits. To adjust the range, use the
parameter Pre-Gain.

Remote command:
[ :SOURce<hw>]:IQ:DPD:LREFerence on page 102
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Maximum Output Level Error
For "Level Reference > After DPD", sets the allowed maximum error, see Chap-
ter 3.2.1, "Defining the power level of the generated signal", on page 47.

Remote command:
[ :SOURce<hw>] :IQ:DPD:0UTPut:ERRor :MAX on page 102

Maximum Number of Iterations
For "Level Reference > After DPD", sets the maximum number of performed iterations
to achieving the required Maximum Output Level Error.

See also Chapter 3.2.1, "Defining the power level of the generated signal”, on page 47.

Remote command:
[ :SOURce<hw>] : IQ:DPD:QUTPut : ERRor : MAX on page 102

Achieved Output Level Error
Displays the resulting level error, see Chapter 3.2.1, "Defining the power level of the
generated signal”, on page 47.

Remote command:
[ :SOURce<hw>] :IQ:DPD:0UTPut : ERRor? on page 102

Input/Output PEP, Level and Crest Factor
Displays the calculated values the before and after the DPD.

A value of -1000 indicates that the calculation is impossible or there are no measure-
ments results available.

Remote command:

[ :SOURce<hw>] :IQ:DPD:INPut:PEP? on page 103

[ :SOURce<hw>] :TQ:DPD: INPut:LEVel? on page 103

[ :SOURce<hw>]:IQ:DPD:INPut:CFACtor? on page 103
[ :SOURce<hw>] :IQ:DPD:0UTPut:PEP? on page 103

[ :SOURce<hw>] :IQ:DPD:0UTPut:LEVel? on page 103

[ :SOURce<hw>]:IQ:DPD:OUTPut:CFACtor? on page 103

AM/AM and AM/PM State
Enables/disables the AM/AM and AM/PM digital predistortion.

If both predistortions are enabled simultaneously, the instrument applies the AM/AM
predistortion first and compensates the phase error of the PA afterwards.

Compare the displayed signal processing chain.

Remote command:
[ :SOURce<hw>] : IQ:DPD:AMAM: STATe on page 99
[ :SOURce<hw>] :TQ:DPD:AMPM: STATe on page 99

Predistortion settings

Access:

1. Select "I/Q Mod > Digital Predistortion > AM/AM AM/PM > Predistortion Settings".
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2. Select a shaping function, for example the shaping file form Example"Shaping
table file content (*.dpd_magn file)" on page 50.

Digital Predistortion AM/AM, AM/PM

| General Predistortion Settings
YT RNV From Table

Shaping -
From Table
AM/AM Table ... AM/PM Table ..
My_DPD_AM-AM My_DPD_AM-PM
Interpolation .
Linear (Voltage)
Invert Correction Values ]

Input Range (PEP;,) From To
-35.00dBm 3.00 dBm

Graphic Configuration

Scale . 35 30 25 20 -5 10 5 0 3
Power Pin /dBm

Figure 3-2: Predistortion Settings > From Table: Understanding the displayed information

1a = Normalized value of the current RF RMS power level

2a = Normalized value of the current PEP of the generated RF signal

1b, 2b = Correction values

White dashed line = Ideal zero correction function; no correction is necessary.

Yellow curve = Predistortion function

3a, 3b = Input Range (PEP;,) From/To

4 = Positive correction coefficients to compensate values below the ideal ones
5 = Values greater than the PEPin Max are ignored.

The dialog covers the settings for digital predistortion, like select and enabling an
AM/AM and/or AM/PM predistortion, select the way the predistortion function is
defined and specify the correction values.

Settings:

T =1 o1 1 o SRR 57
1] =Y 0o =1 i o T 57
INVert CorreCtion ValUES. ..........e it a e 57
Input Range (PEP;;) FrOM/TO...c.ci ittt e 58
g (=T - {1 o 1SR 58
] =T o] 1T R = o) L= RPN 59
Polynomial CoeffiCieNtS.........ccciiiee e ee e 59
NOrMAlIZEA DAta........ ettt e e e e e e e e e e nnee s 60
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Graphic ConfigUIration.......cccoooiii i e e e e e e e e e e e e e e e e ee e aaa—a 60
L S0l ...t 60
L AM/AM and AM/PM DIi@Qrams.........c.ccueueveeeeeeerereeersreeseeseseesessssesesessesesasesenes 60

Shaping

Selects the method to define the correction coefficients.

"From Table" As value pairs in form of a shaping table.

Select "AM/AM or AM/PM Shaping Table" to access the settings, see
Chapter 3.3.3, "Edit predistortion table settings", on page 60.

"Polynomial" By a polynomial with configurable order and coefficients.
Select "Polynomial Coefficients" to access the settings, see Chap-
ter 3.3.4, "Polynomial coefficients settings", on page 62.

"Normalized" As a normalized data.
Select "Normalized Data" to access the settings, see Chapter 3.3.5,
"Normalized data settings", on page 66.

Remote command:
[ :SOURce<hw>] : IQ:DPD: SHAPing:MODE on page 104

Interpolation
For "Shaping > From Table/Normalized", enables a linear interpolation between limited

number of defined value pairs in the table, to prevent abrupt changes.

Table 3-3: Effect of parameter Interpolation

"Interpolation > Off" "Interpolation > Linear (Power)"

AM/PM AM/PM

delta_Phase /de:

delta_Phase /de:

30 28 26 24 22 20 18 16 14 12 10 B 6 4 2 0 23 30 28 26 24 22 20 118 16 14 12 10 8 6 4 2 0 23
Pin /dBm Pin /dBm

Remote command:
[ :SOURce<hw>] :IQ:DPD:SHAPing:TABLe: INTerp on page 106

Invert Correction Values
Inverts the defined correction values.

Applies the exact invert predistortion coefficients without changing the defined predis-
tortion table.

This function is also useful to toggle between predistortions with corrections related to
the input power and to the output power.
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Table 3-4: Effect of parameter Invert correction values

"Invert correction values > Off" "Invert correction values > On"

— AM/AM AM/AM

delta_Power /dB

delta_Power /dB

0.1

30 28 26 24 22 20 18 16 14 12 10 8 6 4 2 0 23 30 28 26 24 22 20 18 16 14 12 10 8 6 4 2 0 23
Pin /dBm Pin /dBm

Remote command:
[ :SOURce<hw>] :IQ:DPD:SHAPing[:TABLe] : INVert on page 106

Input Range (PEP;,) From/To
Defines the minimum and maximum input power PEP;,,.

If you apply digital predistortion on signals used for power amplifier tests with envelope
tracking, set the PEP;,Max value to the maximum value of the input power PEPin Max,
as required by the power amplifier (PA).

Remote command:

[ :SOURce<hw>] :IQ:DPD:PIN:MIN on page 104

[ :SOURce<hw>] :IQ:DPD:PIN:MAX on page 104

Pre-Gain

For "General > Level Reference > Static DPD", sets a pre-gain (i.e. an attenuation) to
define the range the DPD is applied in. The pre-gain can be used to define and test
only a specific (required) part of the operating range.

For "General > Level Reference > Before/After DPD", the range is limited by the cur-
rent PEP of the signal.

See Figure 3-2.
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Digital Predistortion AM/AM, AM/PM

) General Predistortion Settings
AM/AM + AM/PM NZELRETT

Shaping -
From Table
AM/AM Table ... AM/PM Table ..
My_DPD_AM-AM My_DPD_AM-PM
Interpolation -
Linear (Voltage)
Invert Correction Values O
Input Range (PEP;,) From To
-35.00 dBm 3.00dBm
Pre-Gain
-18.00 dB
Graphic Configuration
Scale -
Power

1 = Pre-gain limits the effective range of the shaping function
2 = Values above this limit are ignored

Remote command:
[ :SOURce<hw>] : TQ:DPD:GAIN: PRE on page 104

Shaping Table
Accesses the standard "Predistortion Select" dialog with functions to define a new
shaping table file, select, or edit an existing one.

The shaping table files are files with predefined extension and file format, see "File for-
mat of the correction table file" on page 50.

You can create a shaping table externally or internally.

"Select" Selects and loads an existing file.
"New" Creates a file.
"Edit" Access a standard built-in table editor, see Chapter 3.3.3, "Edit pre-

distortion table settings", on page 60.

Remote command:
For AM/AM distortions:

[ :SOURce<hw>] :IQ:DPD:
[ :SOURce<hw>] :IQ:DPD:
For AM/PM distortions:

[ :SOURce<hw>] :IQ:DPD:
[ :SOURce<hw>] :IQ:DPD:

Polynomial Coefficients

SHAPing:TABLe: AMAM
SHAPing:TABLe: AMAM

SHAPing:TABLe : AMPM
SHAPing:TABLe : AMPM

:FILE:CATalog? on page 105
:FILE[:SELect] on page 105

:FILE:CATalog? on page 105
:FILE[:SELect] on page 105

For "Shaping > Polynomial", accesses a dialog to describe the predistortion function as
a polynomial function, see Chapter 3.3.4, "Polynomial coefficients settings”,

on page 62.
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Normalized Data
For "Shaping > Normalized", accesses a dialog to describe the predistortion function
as a normalized data, see Chapter 3.3.5, "Normalized data settings", on page 66.

Graphic Configuration
Comprises setting to configure the graphical display.

Scale — Graphic Configuration
Determines the unit of the x-axis, "Voltage" or "Power".

Remote command:
[ :SOURce<hw>] :IQ:DPD:SCALe on page 105

AM/AM and AM/PM Diagrams < Graphic Configuration

Visualize the resulting correction functions, as function of the selected PEP;, value lim-
its.

See Figure 3-2.

Remote command:

[ :SOURce<hw>] :IQ:DPD:AMAM: VALue : LEVel? on page 100
[ :SOURce<hw>] :IQ:DPD:AMAM: VALue: PEP? on page 100

[ :SOURce<hw>] : IQ:DPD:AMAM: VALue? on page 99

[ :SOURce<hw>] :IQ:DPD:AMPM:VALue:LEVel? on page 101
[ :SOURce<hw>] : IQ:DPD:AMPM: VALue: PEP? on page 101

[ :SOURce<hw>] :IQ:DPD:AMPM:VALue? on page 100

3.3.3 Edit predistortion table settings

The predistortion table is an internal editor where you define the correction values,
APower and APhase, in form of a look-up table.

Access:

1. Select "I/Q Mod > Digital Predistortion > AM/AM AM/PM > Predistortion Settings".
2. Select "Shaping > From Table".

3. Select "AM/AM > Shaping Table > Predistortion AM/AM Shaping File > New"

4

Enter the "File Name", e.g. My DPD_AM-AM

The "Predistortion AM/AM Shaping File" dialog closes.
The "Shaping Table > My DPD_AM-AM" confirms that the newly created file is
assigned.

5. Select "Shaping Table > Predistortion AM/AM Shaping File > Edit"

6. Define the value pairs "Pin/dBm" and "APower/dB". The order is uncritical.
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Edit Predistortion AM/AM Table -: My_DPD_AM-AM

Figure 3-3: Example of an AM-AM predistortion table values

7. Select "Save".

The instrument loads the configured values automatically and displays the function
of the delta correction values.

8. Select "Predistortion Settings > Interpolation > Linear".

The display confirms the used interpolation.

Settings:

Pin (dBm), Delta Power (dB)/Pin (dBm), Delta Phase (deg).......cccceeeereeeeeeiiiicciirineenenn. 61
Fill Table AUtOMAtICAIlY........evveieiiiieccceee e e e e e e e e e e e eeeees 61
Goto, Edit, SAVE AS, SAVE......ueeiiiiiiiiieie s 62

Pin (dBm), Delta Power (dB)/Pin (dBm), Delta Phase (deg)
Sets the correction value pairs.
"Pin, APower"

Value pairs for the AM/AM predistortion

"Pin, APhase"
Value pairs for the AM/PM predistortion

Remote command:

See [ :SOURce<hw>] :IQ:DPD:SHAPing:TABLe:AMAM:FILE [ :SELect]
on page 105

and [ :SOURce<hw>] :IQ:DPD:SHAPing: TABLe:AMPM:FILE[:SELect]
on page 105

Fill Table Automatically
Standard function for filling a table automatically with user-defined values.

User Manual 1178.8165.02 — 08 61



R&S®SMBVB-K540, R&S®SMBVB-K541 Applying digital predistortion

3.3.4

Digital predistortions AM/AM and AM/PM settings

From Range
0 1
Column To Fill
Vin / Vmax M
Start Value End Value 9
0.000 0.000

Increment Value

°Fill

0.000

"From / Range"
Defines the start line and number of the rows to be filled.

"Select Column to Fill"
Selects the respective value, including the unit.

"Start / End Value"
Default values corresponding to the selected column.

"Increment" Determines the step size.

"Fill" Fills the table.
Fill both columns and then save the list. Otherwise the entries are
lost.

Goto, Edit, Save As, Save
Standard functions for editing of data lists.

Changed and unsaved values are displayed on a yellow background.

Remote command:
n.a.

Polynomial coefficients settings

Alternatively to the look-up table, you can define the predistortion functions as a poly-
nomial function. The R&S SMBV100B calculates the AM/AM and AM/PM predistortion
functions and the required correction coefficients out of the defined polynomial.

To access the polynomial coefficients setting and define a higher-order polyno-
mial

1. Select "I/Q Mod > Digital Predistortion > AM/AM AM/PM > Predistortion Settings".
2. Select "Shaping > Polynomial".
3. Select "AM/PM > Polynomial Coefficients".
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DPD: Polynomial Coefficients
Save!RecallPonnomial |

System Coordinates

Cartesianv
Polynomial Order
4
- t]
Poro(x) = 0.000 0.000
- +] _
-0.250 0.200 *
+ +] X2
0.600 -0.300
+ +] o
0.300 0.300
* *i x4
0.500 -0.400
where: X = Pa/Pra
0 0.2 0.4 0.6 0.8 1
@Apply | OUK Pin/PEPinMax

Figure 3-4: Polynomial Coefficients: Understanding the displayed information

n = Polynomial order

a0, b0, ... = Polynomial coefficients

1 = |deal AM/AM function (the normalized amplitude is a line).

2 = Resulting AM/AM predistortion function, calculated as AM/AM(x) = abs[Pppp(X)]

3 = Ideal AM/PM function (constant phase at 0 degrees)

4 = Resulting AM/PM predistortion function, calculated as AM/PM(x) = tan{Im[Pppp(X)]/

Re[Pppp(X)]}

With the provided settings, you can define a polynomial function with up to 10t
order to describe the predistortion function.

The graphical display updates on-the-fly and visualizes the resulting AM/AM and
AM/PM functions.

4. Select "Polynomial Order = 4" (n = 4).

5. Set the polynomial coefficients ag to b,.
Use, for example, the values shown on Figure 3-4.

6. Select "Apply".

The instrument loads the configured values, calculates the correction values, and
displays the predistortion functions.
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Digital Predistortion AM/AM, AM/PM

1 General Predistortion Settings
AM/AM + AM/PM IEEITELIE

Shaping

Polynomial Coefficients ...

Invert Correction Values

Input Range (PEP;,) From To

-35.00dBm
SS  -30 -25 -20 s -10 -5 0 =
Pin \
AM/PM
Graphic Configuration
Scale 35 30 25 20 -15 -0 -5 0 3

Power Pin /dBm

Figure 3-5: Predistortion Settings > Polynomial: Understanding the displayed information

1a = Current RF RMS power level

2a = Current PEP of the generated RF signal

1b, 2b = Correction values

White dashed line = Ideal zero function; no correction is necessary.

AM/AM yellow curve = AM/AM correction values, calculated as AAM/AM(x) = AM/AM(X) - x
AM/PM yellow curve = AM/PM correction values, calculated as AAM/PM(x) = AM/PM(x)

3a, 3b = X-axis scale, calculated from the Input Range (PEP;,) From/To
4 = Negative correction coefficients
5 = Values greater than the PEPin Max are ignored.

7. To store the defined predistortion function:

a) Select "Save/Recall Polynomial"

b) Navigate throughout the file system.

c) Enter a "File Name", e.g. MyPolynomial_4thOrder
d) Select "OK".

8. Select "Polynomial Coefficients > OK" to close the dialog.

Settings:

Save/Recall POIYNOMIAL........uuu i s e e e e e e e e e e e e e e e e e e eeeaaeaees 65
SYStEM COOrdINALES. ... e e e e e e e aaaaaes 65
POIYNOMIAT OFAEN ... et e e e 65
Y o] 0]/ P 65
Polynomial COEfICIENTS.........oiiiiiiiee e 65
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Save/Recall Polynomial

Accesses the "Save/Recall" dialog, that is the standard instrument function for saving
and recalling the complete dialog-related settings in a file. The provided navigation
possibilities in the dialog are self-explanatory.

The settings are saved in a file with predefined extension. You can define the filename
and the directory, in that you want to save the file.

See also, chapter "File and Data Management" in the R&S SMBV100B user manual.

The polynomial files are files with extension * . dpd poly, see "File format of the poly-
nomial file" on page 49. The polynomial function is stored in Cartesian format.

Remote command:
[ :SOURce<hw>] : IQ:DPD:SHAPing:POLYnomial:COEFficients:CATalog?

on page 107

[ :SOURce<hw>] : IQ:DPD:SHAPing:POLYnomial : COEFficients:LOAD
on page 107

[ :SOURce<hw>] : IQ:DPD:SHAPing:POLYnomial :COEFficients:STORe
on page 108

System Coordinates
Defines whether the polynomial function is defined in Cylindrical (Polar) or in Cartesian
coordinates.

Remote command:
n.a.

Polynomial Order
Defines the polynomial order n, that is the number of polynomial coefficients (see
Chapter 3.2.2.1, "Polynomial function", on page 48).

The polynomial order defines the degree, complexity, and the number of terms in the
polynomial function.

Remote command:
See [:SOURce<hw>] :IQ:DPD:SHAPing:POLYnomial :COEFficients
on page 106.

Apply, OK
Triggers the instrument to adopt the selected function.

Use "OK" to apply the setting and exits the dialog.

Remote command:
[ :SOURce<hw>]:IQ:DPD:SHAPing:POLYnomial :COEFficients on page 106

Polynomial coefficients
Sets the polynomial coefficients a, to a,, and by to b,,.

In "System Coordinates > Cylindrical", the polynomial coefficients by to b, are
expressed in degrees.
Select "Apply" to confirm the settings.

Remote command:
See "Apply, OK" on page 65.
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3.3.5 Normalized data settings

The normalized data table is an internal editor where you define the correction values,
Vin/Vmax, AV/V and APhase, in form of a table.

To access the internal editor
1. Select "I/Q Mod > Digital Predistortion > AM/AM AM/PM > Predistortion Settings".
2. Select "Shaping > Normalized Data".

3. Select "Normalized Data".

DPD: Normalized Data

SavelRecaII Normalized Data ... |

Pirl\‘ax

10.00dBm

APhase
/deg

1= 0.000 00 0.000 00 0.00

V‘ll}"d‘max‘ﬁ\'!\i‘ ‘

0 01 02 03 04 05 06 07 08 0% 1

2 0.000 24 -0.000 18 0.28 Vin/Vmax
AM/PM
3 0.000 49 -0.000 36 0.28
4 0.000 73 -0.000 55 0.28
5 0.000 98 -0.000 73 0.28
0.001 22 -0.00091 0.28 I

[
@Apply | OOK | o 01 02 03 u.:_ .:‘}5 m:.s 0.7 08 09 1

4. Enter the Ping,a.

Note: Enter the correction values in the required order. The value range of the sub-
sequent correction values adjusts automatically.

5. To store the setting in a file, select "Save/Recall Normalized Data > Save".
Enter a "File Name", e.g. My_DPD_Normalized.

Settings:

Save/Recall Normalized Data.........ccc.ueviiiiieeeeieieecciiieee e ee e e e e e e e s enaeeees 66
P I axe et eeeee e e e ettt e e e e e e e e e e e e e et e e e e e e s b e e e re e et e e e e e e e e e aaanrnreeeeeeas 67
Vin/Vmax, Delta V/V, Delta Phase (d€g)......ccuueriiiiiiiiiieiiieie et 67
Y 0] 0] Y/ U 67

Save/Recall Normalized Data

Accesses the "Save/Recall" dialog, that is the standard instrument function for saving
and recalling the complete dialog-related settings in a file. The provided navigation
possibilities in the dialog are self-explanatory.

The settings are saved in a file with predefined extension. You can define the filename
and the directory, in that you want to save the file.
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See also, chapter "File and Data Management" in the R&S SMBV100B user manual.

The normalized data files are files with extension *.dpd norm, see "File format of the
normalized data" on page 50.

Remote command:

[ : SOURce<hw>]:IQ:DPD:SHAPing:NORMalized:DATA:CATalog? on page 109
[ :SOURce<hw>] :IQ:DPD:SHAPing:NORMalized:DATA: LOAD on page 109

[ :SOURce<hw>] : IQ:DPD:SHAPing:NORMalized:DATA: STORe on page 109

Piny.yx
Sets the value of the maximum input power level.

Pinax corresponds to a normalized input power of 1, that is the max. allowed value on
the x-axis.

Select "Apply" to confirm the settings.

Remote command:
n.a.

Vin/Vmax, Delta V/V, Delta Phase (deg)
Sets the correction as a group of three values.

Select "Apply" to confirm the settings.

Remote command:
See "Apply, OK" on page 67.

Apply, OK
Triggers the instrument to adopt the normalized data.

Use "OK" to apply the setting and exits the dialog.

Remote command:
[ :SOURce<hw>] : IQ:DPD: SHAPing:NORMalized:DATA on page 108
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4 How to generate a control signal for power
amplifier envelope tracking tests

Refer to Figure 2-1 for an example of a simplified test setup for power amplifier testing
with envelope tracking. The illustration is intended to explain the principle in general,
not all connections and required equipment are considered.

The R&S SMBV100B in this setup is configured to generate an LTE RF signal with
complex modulation scheme and high peak to average power (PAPR), and the
required envelope signal. A polynomial shaping function is defined. The PA receives
the RF input signal and the dynamically adapted supply voltage. Ideally, the gain of the
PA should stay constant.

Required are the following values:
® Characteristics of the power amplifier: supply voltage V¢, the input power PEP;,

® Characteristics of the external DC modulator: gain, peak-to-peak voltage Vpp, input
impedance R;,

To configure the R&S SMBV100B to generate the RF and RF envelope signal

1. Enable the R&S SMBV100B to generate an EUTRA/LTE FDD DL signal.
Select "Baseband > EUTRA/LTE" and enable for example:

a) Select "Link Direction > Downlink"
b) Select "Test Model > E-TM1_1--5MHZ"
c) Enable "State > On"

2. Set "Frequency = 2.143 GHz" and "Level = -15 dB"

3. Inthe block diagram, select "I/Q Out > 1/Q Analog > I/Q Analog Outputs > Gen-
eral":

a) Select "RF Envelope > On".

b) Select "Envelope Voltage Adaptation > Auto Power"

c) Select "I/Q Output Type > Differential"

d) Configure the settings as shown on Figure 2-3.

e) Select "I/Q Analog Outputs > Envelope Settings" and set for example "Enve-
lope to RF Delay = 10 ps"

f) Select "I/Q Analog Outputs > Shaping > Shape > Detroughing".

g) Set "Detroughing Function = 1: f(x) = x + d*e™/d)",

h) Set "Detroughing Factor (d) > Coupled with Vcc = On".

i) Select "Graphic Configuration > Scale > Power".
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1/Q Analog Outputs
Envelope Settings n Shaping
Detroughing
Shaping |
LT 2.6
. . Detroughing.
Detroughing Function J| 24
1:f(x) = x +d - er(-x/d)
Detroughing Factor - d o 22
0.200 2
Detroughing Factor Behaviour
Coupled with Ve 18
2 1.6
8
>1.4
1.2
1
0
0.6
0.5}
Graphic Configuration L3
Scale -
Power

1a, 1b = Veemin = 0.5V, Veemax = 2.5V
2a, 2b = P;ymin = -30 dBm, P;;max = 0 dBm

3 = RF Level = -15 dBm (operating point)
3a, 3b = Current V¢ = 0.612 V (operating point)
4 = Crest factor = 11.6 dB

5a = PEP =-3.4 dBm; current P;;max limit
5b = Current V¢ limit

Select "I/Q Analog Output > State > On"
Enable "RF > State > On".
Trigger the signal generation

Select "I/Q Out > 1/Q Analog > 1/Q Analog Outputs > General", enable "Power Off-
set = 1 dB" and compare the operating point.

The level display value in the status bar of the instrument shows "Level = -14 dBm"
and confirms that a "Level Offset = Power Offset = 1 dB" is enabled.

The instrument generates and outputs:
e An RF signal with the specified level and level offset
e An RF envelope signal that follows the power changes of the RF signal.

The envelope signal E is output at the | Out connector; the inverted envelope sig-
nal E BAR at the | Bar Out. The voltage of this envelope signal is automatically
adjusted so that the supply voltage stays within the specified limits.

To observe the impact of baseband signal and its crest factor on the generated

envelope signal, try out the following:

e Select "Baseband > Off" and compare the displayed envelope shape, in partic-
ular the shaded area.
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e Select "Baseband > On", enable "Baseband > EUTRA/LTE > Filter/Clipping/
ARB... > Clipping > State > On" and select "Clipping Level = 75%"

Possible extensions

Consider to extend the test setup as follows:

® To apply digital predistortion (DPD) on the baseband signal and compare the
behavior of the power amplifier (DUT)
See Chapter 5, "How to apply a DPD to improve the efficiency of RF PAs",
on page 72.

® To perform RF analysis, use the R&S®FSW

® To measure and evaluate the AM/AM and AM/PM distortions, use the R&S®FSW-
K18 Power Amplifier and Envelope Tracking Measurements.

® To observe the characteristics of the generated signal, use an oscilloscope, for
example R&S®RTO

How to optimize the signal to improve the linearity and efficiency of the power
amplifier

Refer to Figure 4-1 for an example of a simplified test setup for power amplifier testing
with envelope tracking and digital predistortion. The illustration is intended to explain
the principle in general, not all connections and required equipment are considered.

R&S®FSW, equipped with R&S*FSW-K18

R&S®SMBV100B

Pout

RF Signal

LAN | Bar Out

(Rear Panel) | (RearPane]

| Out

(Rear Pane|

Vout

Envelope Signal (E)

Inverted Envelope Signal (£

Figure 4-1: Simplified test setup for power amplifier envelope tracking tests with DPD

Use the following general guidelines:

1. Provide the output signal of the DUT to the R&S®FSW and measure the signal.
Suitable RF measurements are the ACLR and EVM characteristics of the signal.

2. Inthe R&S SMBV100B, select "lI/Q Analog Outputs > Envelope Settings" and vary
the "Envelope to RF Delay" to minimize the ACLR and EVM measured with the
R&SCFSW.

3. Change the shaping method and shaping function and measure the power ampli-
fier characteristics.
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Did its linearity and efficiency improved?

4. Use the R&S®FSW-K18 to evaluate the signal, calculate suitable predistortion val-
ues, and store the AM/AM and AM/PM tables.

5. Transfer the predistortion functions to R&S SMBV100B and load them (select "I/Q
Mod > AM/AM AM/PM > Predistortion Settings").
See Chapter 5, "How to apply a DPD to improve the efficiency of RF PAs",
on page 72.

6. Inthe R&S®FSW, measure the power amplifier characteristics.

Did its linearity improved?
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5 How to apply a DPD to improve the effi-
ciency of RF PAs

Refer to Figure 5-1 for an example of a simplified test setup for power amplifier testing
with envelope tracking and digital predistortion. The illustration is intended to explain
the principle in general, not all the connections and required equipment are consid-
ered.

R&S®FSW, equipped with R&S*FSW-K18

R&S®SMBV100B

] . . "
 Ceccoce o i1 © ¢ 0 (€F€NT

Pout

RF Signal

LAN | Bar Out I Qut

(Rear Panel) | (RearPane] (Rear Panel|

- : A_/.\/\

Envelope Signal (E)

Inverted Envelope Signal (£

Figure 5-1: Simplified test setup for power amplifier envelope tracking tests with DPD

A real test setup comprises of the following equipment:

e R&S SMBV100B to generate the RF signal, and to calculate and apply the DPD.
In test setups for envelope tracking tests, the R&S SMBV100B also generates the
envelope tracking signal.

® R&S®FSW equipped with R&S®FSW-K18 Power Amplifier and Envelope Tracking
Measurements to:

— Measure and analyze the AM/AM and AM/PM predistortion
— Calculate the AM/AM and AM/PM correction tables
— Store and export the correction tables

e DUT, that is the power amplifier.

® Optional, R&S®RTO to monitor the generated envelope signal.

General steps for tests to improve the efficiency of RF power amplifiers
Consider the following general steps:

1. Enable the R&S SMBV100B to generate a baseband signal. A suitable baseband
signal is a simple ramp function or, to minimize memory effects, a signal with small
bandwidth.

2. Compare the input waveform to the output of the power amplifier and determine
how the amplifier is distorting the signal.
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The normalized AM/AM and AM/PM curves show the variation of the magnitude
and phase over the variation of the input power and thus provide a suitable repre-
sentation and good basis for analysis.

A simple straightforward method to retrieve the DPD correction values is to "invert"
the curves, see Chapter 3.2.3, "Finding out the correction values", on page 51.
Use the R&S®FSW-K18 to retrieve the AM/AM and AM/PM correction values auto-
matically.

Use the retrieved correction values and define the predistortion functions.

Enable the AM/AM and AM/PM predistortion and predistort the original baseband
signal.

See "To configure the R&S SMBV100B to predistort the baseband signal"

on page 73

Measure the behavior of the power amplifier, for example perform EVM and ACP
measurements or evaluate the AM/AM and AM/PM curves.

Does the output signal of the DUT have a better performance with regards to ACP
and/or EVM?

To configure the R&S SMBV100B to predistort the baseband signal

1.
2.
3.

4.
5.

Enable the R&S SMBV100B to generate an EUTRA/LTE FDD DL signal.
Set "Frequency = 2.143 GHZz" and "Level = -15 dB".

In the block diagram, select "I/Q Mod > Digital Predistortion > AM/AM, AM/PM",
and perform the following:

a) Select "Digital Predistortion AM/AM, AM/PM > Predistortion Settings" and
enable "Shaping > From Table".

b) Select "AM/AM Table > New", enter a file name, and select "AM/AM Table >
Edit".

c) Enter the correction values and select "Save".
See the example on Figure 3-3.

d) Adjust the AM/PM correction values in the same way.

e) Select "Interpolation > Liner (Power)".

f) Select "Digital Predistortion AM/AM, AM/PM > General".

g) Select "Maximum Input Power PEP Max > 3 dBm".

h) Select "AM/AM State > On", "AM/PM State > On" and "Predistortion State >
On".

i) Select "Level Reference > After DPD", "Maximum Output Level Error = 0.1 dB"
and "Maximum Number of Iterations = 3".

Enable "RF > State > On".

Trigger the signal generation
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To perform manual iterations to achieve a desired resulting signal level after the
DPD

To explain the iteration principle, we assume that the R&S SMBV100B has been con-
figured as described in "To configure the R&S SMBV100B to predistort the baseband

signal" on page 73 and the DPD uses an AM/AM predistortion function as shown on
Figure 5-2.

To achieve a signal level of -15 dB after the DPD, perform the following steps and obey
the rule:

@ Vary the "Level" with small steps.
Always start with small value and increase the "Level" at the subsequent iterations.

1. Select "Digital Predistortion AM/AM, AM/PM > General > Level reference > Before
DPD".

n General Predistortion Settings
AM/AM + AM/PM RECLUNELTE
SetTo
n Default @Recall | Save

Level Reference

Before DPD AM/AM First
[~ [~
PEP -3.43dBm DPD PEP -3.15 dBm
[~ @
level -15.00dBm Level -14.57 dBm
1/Qgp = = 1/Qppp
Crest Factor 11.57 dB Crest Factor 11.42 dB

2. Calculate the Ap 4.

( AM/AM \
0.55

=
n

(%5

delta_Power /dB

=
-

A7 16.5 16 15.5 15 145 14 135 13
Pin /dBm

. 7

Figure 5-2: Manual iterations on an example AM/AM predistortion function ("Input Range PEPin =
-17 dBm to -12 dBm"): Stepi#1
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1 = current operating point: P,y = Levely 4 =-15 dBm

2 = first iteration with Levely »

a=Ap 4

b = difference between the correction values at the current and the new operating points

Levely | = Level =-15 dBm
LeVeIOUT_1 =-15.42 dBm
e Ap =Level-Levelgyr 1 =-15+15.42=0.42 dBm

3. Setthe "Level" = Level + Ap ;1 =-15.45 dBm.

The diagram displays the achieved output values; Levelgyr , = - 15.02 dBm.

[~ [~
PEP -3.88 dBm DPD PEP -3.59 dBm
[~ (=
Level =-15.45 dBm Level -15.02dBm
1/Qgg — = 1/Qppp
Crest Factor 11.58 dB

Crest Factor 11.43dB

4. Calculate the Ap ».

r AM/AM \
0.55

=
n

delta_Power /dB
f
tn

=
=

0.35

A7 -16.5 -16 1% 15 -14.5 14 135 13
Pin /dBm

\. J

Figure 5-3: Manual iterations on an example AM/AM predistortion function ("Input Range PEPin =
-17 dBm to -12 dBm"): Step#2

1 = initial operating point: P,y = Levely ; =-15 dBm

2 = current operating point: P\ = Levely , =-15.45 dBm

3 = second iteration with Levely 3

a=~»7p,

b = difference between the correction values at the current and the new operating points

LeVeI|N_2 =-15.55
LeVeIOUT_2 =-15.02 dBm
e Ap,=Level-Levelgyr , =-15+15.02 =-0.02 dBm

5. Set"Level" = Level + Ap , =-15.43 dBm

The diagram confirms the achieved output value; Levelgyr 3 = - 15 dBm.
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[~ [~
PEP -3.86 dBm DPD PEP -3.57 dBm
[~ @
1Q level -15.43 dBm Level -15.00 dBm Q
BB 5 = 1/Qopp
Crest Factor 11.57 dB Crest Factor 11.43 dB

6. Compare the operating point on the AM/AM functions.

- AM/AM
0.55

=
in

(=]
—
wn

=
-
&N
ot

delta_Power /dB

-
=

0.35

A7 -16.5 16 15.5 15 -14.5 14 135 13
L Pin /dBm
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6

®

Remote-control commands

The following commands are required to perform signal generation in a remote envi-
ronment. We assume that the R&S SMBV100B has already been set up for remote
operation in a network as described in the R&S SMBV100B user manual. Knowledge
about the remote control operation and the SCPI command syntax is assumed.

Conventions used in SCPI command descriptions

For a description of the conventions used in the remote command descriptions, see
section "Remote Control Commands" in the R&S SMBV100B user manual.

Common suffixes

The following common suffixes are used in remote commands:

Suffix Value range Description

SOURce<hw> 1 Available baseband signals

Programming examples

The corresponding sections of the same title provide simple programming examples for
the R&S SMBV100B. The purpose of the examples is to present all commands for a
given task. In real applications, one would rather reduce the examples to an appropri-
ate subset of commands.

The programming examples have been tested with a software tool which provides an
environment for the development and execution of remote tests. To keep the examples
as simple as possible, only the "clean" SCPI syntax elements are reported. Non-exe-
cutable command lines (e.g. comments) start with two // characters.

At the beginning of the most remote control program, an instrument (p) reset is recom-
mended to set the R&S SMBV100B to a definite state. The commands *RST and
SYSTem:PRESet are equivalent for this purpose. *CLS also resets the status registers
and clears the output buffer.

In all the examples, we assume that a remote PC is connected to the instrument, the
remote PC and the instrument are switched on, a connection between them is estab-
lished. We also assume that the security setting "System Config > Setup > Security >
SCPI over LAN" is enabled.

The following commands specific to the R&S SMBVB-K540/-K541 options are descri-
bed here:

o SOURCE:IQ:OUTPUL SUDSYSIEM...cciiiiiiiiiiiiiieee ettt 78
e SOURCce:IQ:OUTPut:ENVelope comMmaNnds.......c.cceeeeeiiieicnvininiiieeee e e seecvvseeeeeeeas 80
® SOURCE:IQ:DPD SUDSYSIEM.......ciiiiiiiiiiiieeee e e e e e e e e e 95
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6.1 SOURce:IQ:OUTPut subsystem

This section describes the commands of the output of an analog 1/Q signal.

[:SOURce<hw>]:1Q:OUTPULANALOG:STATE. ...eueutuaaaaaaaeeeeeeeeeeeaeaeeeeeeeeeeeeeeeeeenennneeaae e ens 78
[:SOURce<hw>]:1Q:OUTPU[:ANALOGI:PRESEL......cceeeeeeeeeeeeeeeeeeeeeeeee e 78
[:SOURce<hw>]:IQ:OUTPut[:ANALOQG]:SETTING:CATaIOg?. . cceuuieieneieeieeeee e e e 78
[:SOURce<hw>]:1Q:OUTPUt[:ANALOQ]:SETTING:STORE......ceteeriitiiieeeeeeriee e e e eeere e e eeennaans 79
[:SOURce<hw>]:IQ:OUTPUt[:ANALOQ]:SETTING:LOAD. ...t eaee 79
[:SOURce<hw>]:IQ:OUTPUt[:ANALOG]:SETTING:DELEte......ccieiiiiiiiiiiiiiiiee e 79
[:SOURce<hw>]:1Q:OUTPU[:ANALOGTYPE...... et 79

[:SOURce<hw>]:1Q:OUTPut:ANALog:STATe <State>
Activates the specified analog I/Q output.
Note: Interdependencies

The following functions cannot be activated simultaneously. They deactivate each

other.

® The internal baseband generator ([ : SOURce<hw>] :BB:<DigStd>:STATe) and
the external digital baseband input ([ : SOURce<hw>] : BBIN: STATe)

Parameters:

<State> 1| ON |0 | OFF
*RST: 0

Example: SOURce:IQ:0UTPut:ANALog:STATe ON
Activates the output of the analog 1/Q signal on the [I/Q Out 1]
connectors.

Manual operation: See "State" on page 22

[:SOURce<hw>]:1Q:OUTPut[:ANALog]:PRESet
Sets the default settings (*RST values specified for the commands).

Not affected are:
® The state set with the command [ : SOURce<hw>] : I1Q:0UTPut : ANALog: STATe.

® |fSCONfiguration:EXTernal:PBEHaviour 1, the I/Q ouptput type set with
the command [ : SOURce<hw>] : TQ:0UTPut [ :ANALog] : TYPE.

Example: SOURcel:IQ:0UTPut:ANALog:PRESet
Usage: Event

Manual operation: See "Set to Default" on page 22

[:SOURce<hw>]:1Q:OUTPut[:ANALog]:SETTing:CATalog?

Queries the files with 1/Q output settings in the default directory. Listed are files with the
file extension *.iqgout.
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Return values:
<Catalog> string

Usage: Query only

Manual operation: See "Save/Recall" on page 23

[:SOURce<hw>]:1Q:OUTPut[:ANALog]:SETTing:STORe <Filename>

Stores the current settings into the selected file; the file extension (* . igout)is
assigned automatically.

Setting parameters:
<Filename> "<filename>"

Filename or complete file path
Usage: Setting only

Manual operation: See "Save/Recall" on page 23

[:SOURce<hw>]:1Q:OUTPut[:ANALog]:SETTing:LOAD <Filename>

Loads the selected file from the default or the specified directory. Loaded are files with
extension *.igout.

Setting parameters:
<Filename> "<filename>"

Filename or complete file path
Usage: Setting only

Manual operation: See "Save/Recall" on page 23

[:SOURce<hw>]:1Q:OUTPut[:ANALog]:SETTing:DELete <Filename>

Deletes the selected file from the default or specified directory. Deleted are files with
the file extension * . igout.

Setting parameters:
<Filename> "<filename>"

Filename or complete file path
Usage: Setting only

Manual operation: See "Save/Recall" on page 23

[:SOURce<hw>]:1Q:OUTPut[:ANALog]:TYPE <Type>
Sets the type of the analog signal.

Example: SOURcel:IQ:0UTPup:ANALog:TYPE DIFFerential

Options: DIFFerential requires R&S SMBVB-K17
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Manual operation: See "I/Q Output Type" on page 24

6.2 SOURce:IQ:OUTPut:ENVelope commands

The following remote control commands require software option R&S SMBV100B-
K540.

Example: Generating an RF envelope signal and defining the shaping function

// define the RF level and frequency
SOURcel :FREQuency:CW 2143000000
SOURcel:POWer:LEVel:IMMediate:AMPLitude -15
SOURcel :POWer:LEVel:IMMediate:OFFSet 0.5
SOURcel :CORRection:VALue?

// Response: 1

// enable RF envelope generation and define the settings
SOURcel:IQ:0UTPut:ANALog:ENVelope:STATe 1
SOURcel:IQ:0UTPut:ANALog:ENVelope:ADAPtion AUTO
SOURcel:IQ:0UTPut:ANALog:TYPE DIFF
SOURcel:IQ:0UTPut:ANALog:ENVelope:ETRak USER
SOURcel:IQ:0UTPut:ANALog:ENVelope:VREF VCC
SOURcel:IQ:0UTPut:ANALog:ENVelope:POWer:OFFSet?

// Response: 1.5

SOURcel:IQ:0UTPut:ANALog:ENVelope:VPP:MAX 4
SOURcel:IQ:0UTPut:ANALog:ENVelope:GAIN 0O
SOURcel:IQ:0UTPut:ANALog:ENVelope:EMF:STATe 1
SOURcel:IQ:0UTPut:ANALog:ENVelope:RIN 50
SOURcel:IQ:0UTPut:ANALog:ENVelope:TERMination GROund
SOURcel:IQ:0UTPut:ANALog:ENVelope:BINPut 1
SOURcel:IQ:0UTPut:ANALog:ENVelope:VCC:0FFSet 2

SOURcel:IQ:0UTPut:ANALog:ENVelope:VCC:MIN 0.5
SOURcel:IQ:0UTPut:ANALog:ENVelope:VCC:MAX 2.5

SOURcel:IQ:0UTPut:ANALog:ENVelope:BIAS 0
SOURcel:IQ:0UTPut:ANALog:ENVelope:OFFSet -2
SOURcel:IQ:0UTPut:ANALog:ENVelope:VOUT :MAX?
// Response: 0.5
SOURcel:IQ:0UTPut:ANALog:ENVelope:VOUT :MIN?
// Response: -1.5

SOURcel:IQ:0UTPut:ANALog:ENVelope:PIN:MIN -30
SOURcel:IQ:0UTPut:ANALog:ENVelope:PIN:MAX 0

SOURcel:IQ:0UTPut:ANALog:ENVelope:DELay 0.00000000001
SOURcel:IQ:0UTPut:ANALog:ENVelope:FDPD OFF
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// enable envelope shaping

// SOURcel:IQ:0UTPut:ANALog:ENVelope:SHAPing:MODE DETR

// SOURcel:IQ:0UTPut:ANALog:ENVelope:SHAPing:DETRoughing:FUNCtion F3
// SOURcel:IQ:0UTPut:ANALog:ENVelope:SHAPing:DETRoughing:COUPling OFF
// SOURcel:IQ:0UTPut:ANALog:ENVelope:SHAPing:DETRoughing:FACtor 0.225
// SOURcel:IQ:0UTPut:ANALog:ENVelope:SHAPing:DETRoughing:PEXPonent 1

// quering the oprating point level, current PEP and levels
// SOURcel:IQ:0UTPut:ANALog:ENVelope:ADAPtion?

// Response: Auto

// SOURcel:IQ:0UTPut:ANALog:ENVelope:VCC:VALue:LEVel?

// Response: 0.927

// SOURcel:IQ:0UTPut:ANALog:ENVelope:VCC:VALue:PEP?

// Response: 1.922

// SOURcel:IQ:0UTPut:ANALog:ENVelope:VCC:VALue? 1,NORM,VOLT
// Response: 2.5

// SOURcel:IQ:0UTPut:ANALog:ENVelope:VCC:VALue? 0,NORM,VOLT
// Response: 0.563

// SOURcel:IQ:0UTPut:ANALog:ENVelope:PIN:MAX?

// Response: 0

// SOURcel:IQ:0UTPut:ANALog:ENVelope:PIN:MIN?

// response: -30

// SOURcel:IQ:0UTPut:ANALog:ENVelope:VCC:VALue? 0,DBM, POW
// Response: 2.5

// SOURcel:IQ:0UTPut:ANALog:ENVelope:VCC:VALue? -30,DBM, POW
// Response: 0.563

SOURcel:IQ:0UTPut:ANALog:ENVelope:SHAPing:MODE TABL
SOURcel:IQ:0UTPut:ANALog:ENVelope:SHAPing:PV:FILE:CATalog?

// Response: myLUT pv

SOURcel:IQ:0UTPut:ANALog:ENVelope:SHAPing:PV:FILE:SELect "/var/user/myLUT pv.iq_lutpv"
SOURcel:IQ:0UTPut:ANALog:ENVelope:SHAPing:INTerp LIN
SOURcel:IQ:0UTPut:ANALog:ENVelope:SHAPing:SCALe POWer

// change the envelope shaping mode

SOURcel:IQ:0UTPut:ANALog:ENVelope:SHAPing:MODE POLY

// query files with polynomial functions in the default user directory
SOURcel:IQ:0UTPut:ANALog:ENVelope:SHAPing:COEFficients:CATalog?

// Response: env_poly evm,myPoly
SOURcel:IQ:0UTPut:ANALog:ENVelope:SHAPing:COEFficients:LOAD "myPoly"
SOURcel:IQ:0UTPut:ANALog:ENVelope:SHAPing:COEFficients?

// Response: 0.135,0.82

SOURcel:IQ:0UTPut:ANALog:ENVelope:SHAPing:COEFficients 0.135,0.83
SOURcel:IQ:0UTPut:ANALog:ENVelope:SHAPing:COEFficients:STORe "/var/user/myPoly.iqg poly"

// enable the outputs
SOURcel:IQ:0UTPut:ANALog:STATe 1

OUTPutl:STATe 1

// store the settings
MMEMory:CDIRectory "/var/user/setups"
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SOURcel:IQ:0UTPut:ANALog:SETTings:CATalog?
// Response: etrak v1-2
SOURcel:IQ:0UTPut:ANALOg:SETTings:STORe "my ET"

SOURcel:IQ:0UTPut:ANALog:PREset
// change the envelope voltage adaptation mode
SOURcel:IQ:0UTPut:ANALog:ENVelope:ADAPtion MAN

SOURcel:IQ:0UTPut:LEVel 4

SOURcel:IQ:0UTPut:ANALog:ENVelope: SHAPing:GAIN:PRE -3
SOURcel:IQ:0UTPut:ANALog:ENVelope:SHAPing:GAIN:POST 2.5

// change the envelope shaping mode
SOURcel:IQ:0UTPut:ANALog:ENVelope:SHAPing:MODE TABL
SOURcel:IQ:0UTPut:ANALog:ENVelope:SHAPing:FILE:CATalog?

// Response: myLUT vv

SOURcel:IQ:0UTPut:ANALog:ENVelope:SHAPing:FILE:SELect "/var/user/myLUT vv.iq_lut"

// set the shaping values in raw format

// SOURcel:IQ:0UTPut[:ANALog] :ENVelope:SHAPing:FILE:DATA 0,0, 0.1,0.2, 1,1

// SOURcel:IQ:0UTPut|[:ANALog] :ENVelope:SHAPing:FILE:CATalog?

// Response: myLUT vv

// set the shaping values and store them into a file

// SOURcel:IQ:0UTPut[:ANALog]:ENVelope:SHAPing:FILE:NEW "LUT vv_ raw", 0,0, 0.1,0.2, 1,1.5
// SOURcel:IQ:0UTPut[:ANALog] :ENVelope:SHAPing:FILE:CATalog?

// Response: myLUT vv, LUT vv_raw

[:SOURce<hw>]:1Q:OUTPUt[:ANALOG]:ENVEIOPE:STATE. ...ceeieeiei e eeeeettce e et e e 83
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope: ADAPLION. ....cc.iieeeieeieeeee e e 83
[:SOURce<hw>]:1Q:OUTPUt[:ANALOG]:ENVEIOPE:ETRAK. ...cceiieieiiiieiiiiaaaaa e e e e e e eeeeaeeaeeeeeees 84
[:SOURce<hw>]:IQ:OUTPut[:ANALOG]:ENVeEIOPE:VREF......c.coiiiiiieeei et 84
[:SOURce<hw>]:1Q:OUTPUt[:ANALOG]:ENVelope:DELAY........ccoeeeieiriieeeeeeeiiceeee e 84
[:SOURce<hw>]:1Q:OUTPUt[:ANALOG]:ENVEIOPE:FDPD......cciiiiiiiieieeieeeiiie s eeeeeeiene e eeeennaans 84
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:VOUTMIN......ccouiiiiiieieieee e 85
[:SOURce<hw>]:1Q:OUTPUt[:ANAL0g]:ENVeEIOpPe:VOUTMAX......ciiiieeiiiieeeeeeeiie s eeeeeeinae e 85
[:SOURce<hw>]:IQ:OUTPut[:ANALOG]:ENVEIOPe:BIAS......coeooieeie e 85
[:SOURce<hw>]:IQ:OUTPut[:ANALOg]:ENVelope:OFFSet......ccccvuiiiiieiiiieeeeee e 85
[:SOURce<hw>]:1Q:OUTPuUt[:ANALOG]:ENVelope:VPPIMAX]......covtvererrrrerirrrriiieineeeseseeeeenns 86
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:EMF[:STATE].....cceuueiieiieeeeie et 86
[:SOURce<hw>]:1Q:OUTPUt[:ANALOG:ENVEIOPE:RIN......ciiiiiiiieieeeeeeiiie e eeeeeen e eeie e 86
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:TERMination...........cccoeiiiiiiiiiiiiiiiieeee. 86
[:SOURce<hw>]:1Q:OUTPUt[:ANALOG]:ENVeIope:BINPUL......ccceuiiiieiieiie e 87
[:SOURce<hw>]:IQ:OUTPut[:ANALOG]:ENVEIOPE:GAIN......ccommirieeieeee e 87
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:VCC:OFFSet.....cccceiieiniiiieiiiieeeeeeeeeens 87
[:SOURce<hw>]:1Q:OUTPuUt[:ANALOG]:ENVelope:VCC:MIN.......uuuueiaiiaieieeeeeeeeeeeeeeeeeeeeeeennes 88
[:SOURce<hw>]:1Q:OUTPUt[:ANALOG]:ENVEIOPE:VCCIMAX....ciiiieiiiieieeieetiie e eeeeeie e eeeeaeas 88
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:VCC:VALUE:PEP ..o, 88
[:SOURce<hw>]:1Q:OUTPut[:ANALog]:ENVelope:VCC:VALUe:LEVel?......cccccceeveerevinceieneennne. 88
[:SOURce<hw>]:1Q:OUTPUt[:ANAL0G]:ENVelope:VCC:VALUE?......cuvueieeeeeeieee e e eeeeeie e e e e eeeenns 89
[:SOURce<hw>]:1Q:OUTPut[:ANALog]:ENVelope:PIN:MIN..........cccoerirriiiieieereeeicee e, 89
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[:SOURce<hw>]:1Q:OUTPUt[:ANALOG]:ENVeIope:PIN:MAX..... oottt eeeee e 89
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:POWer:OFFSet?.........cccovviivireeiniiieeneees 90
[:SOURce<hw>]:1Q:OUTPut[:ANALog]:ENVelope:SHAPING:MODE..........ccceieiieiiiiieieeeeeeee 90
[:SOURce<hw>]:1Q:OUTPut[:ANALog]:ENVelope:SHAPING:SCALE....cccceeeeeeeieeeeeeeeeeeeeeeeeeaaes 90
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:SHAPING:GAIN:PRE......cc.c.cceviiiiiiieennnnns 91
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:SHAPING:GAIN:POST......cccciveevniriiineeeennn. 91
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:SHAPIng:FILE:CATalog?.....cccceuiiieieeniaennns 91
[:SOURce<hw>]:1Q:OUTPut[:ANALog]:ENVelope:SHAPing:PV:FILE:CATalog?.......cccvvuueerens 91
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:SHAPIng:FILE[:SELeCt].....c..ceeevmrirennnennnn. 91
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:SHAPIng:PV:FILE[:SELecCt].........ccvuirreennnnes 91
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:SHAPING:FILE:DATA........ccccvrrrrrrreeeraeeennnn 92
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:SHAPINg:PV:FILE:DATA......cccceuiriiieeeeenn. 92
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:SHAPINg:FILE:NEW.........cccoiiiiiiiiiieie. 92
[:SOURce<hw>]:1Q:OUTPut[:ANALog]:ENVelope:SHAPING:PV:FILEINEW.......c.cccvueieriieennnnnn. 92
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:SHAPING:INTErp......ccouiieiiieiiieiiiieeeeeeas 92
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:SHAPing:COEFficients..........ccceveevuiveeennnnns 92
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:SHAPing:COEFficients:CATalog?............... 93
[:SOURce<hw>]:1Q:OUTPut[:ANALog]:ENVelope:SHAPing: COEFficients:STORe.................. 93
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:SHAPing:COEFficients:LOAD...........cccuuun.. 93
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:SHAPing:DETRoughing:FUNCtion............. 93
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:SHAPing:DETRoughing: COUPIing............. 94
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:SHAPing:DETRoughing:FACTor................. 94
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:SHAPing:DETRoughing:PEXPonent........... 94

[:SOURce<hw>]:1Q:OUTPut[:ANALog]:ENVelope:STATe <State>

Enables the output of a control signal that follows the RF envelope.

Parameters:
<State> 1|/ON|0|OFF
*RST: 0
Example: See Example"Generating an RF envelope signal and defining

the shaping function" on page 80

Manual operation: See "RF Envelope" on page 23

[:SOURce<hw>]:1Q:OUTPut[:ANALog]:ENVelope:ADAPtion <AdaptionMode>
Defines the envelope voltage adaption mode.

Parameters:
<AdaptionMode> AUTO | MANual | POWer

AUTO = Auto Normalized, POWer = Auto Power, MANual = Man-

ual
*RST: AUTO
Example: See Example"Generating an RF envelope signal and defining

the shaping function" on page 80

Manual operation: See "Envelope Voltage Adaptation" on page 23
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[:SOURce<hw>]:1Q:OUTPut[:ANALog]:ENVelope:ETRak <ETraklfcType>

Selects one of the predefined interface types or allows user-defined settings.

See Table 2-1.
Parameters:
<ETraklfcType> USER | ET1V2 | ET1V5 | ET2VO
*RST: USER
Example: SOURcel:IQ:0UTPut:ANALog:ENVelope:ETRak ET2V0

Manual operation:  See "eTrak® Interface Type" on page 24

[:SOURce<hw>]:1Q:OUTPut[:ANALog]:ENVelope:VREF <VoltageReferenc>

Defines whether the envelope voltage V is set directly or it is estimated from the
selected supply voltage V...

Parameters:
<VoltageReferenc> VCC | VOUT
*RST: VCC
Example: See Example"Generating an RF envelope signal and defining

the shaping function" on page 80

Manual operation: See "Envelope Voltage Reference" on page 24

[:SOURce<hw>]:1Q:OUTPut[:ANALog]:ENVelope:DELay <Delay>

Enables a time delay of the generated envelope signal relative to the corresponding

RF signal.
Parameters:
<Delay> float
Range: -500E-9 to 500E-9
Increment: 1E-12
*RST: 0
Example: See Example"Generating an RF envelope signal and defining

the shaping function" on page 80

Manual operation: See "Envelope to RF Delay" on page 30

[:SOURce<hw>]:1Q:OUTPut[:ANALog]:ENVelope:FDPD <CalcFromDpdStat>
Enables calculation of the envelope from predistorted signal.

Parameters:
<CalcFromDpdStat> 1| ON |0 | OFF

*RST: 0
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Example: See Example"Generating an RF envelope signal and defining
the shaping function" on page 80
Options: R&S SMBV100B-K540/K541

Manual operation: See "Calculate Envelope from Predistorted Signal" on page 31

[:SOURce<hw>]:1Q:OUTPut[:ANALog]:ENVelope:VOUT:MIN <VoutMin>
[:SOURce<hw>]:1Q:OUTPut[:ANALog]:ENVelope:VOUT:MAX <VoutMax>

Queries the minimum and maximum values of the estimated envelope output voltage

Vout-
Parameters:
<VoutMax> float
Range: 0.04 to 8
Increment: 1E-3
*RST: 1
Example: See Example"Generating an RF envelope signal and defining

the shaping function" on page 80

Manual operation: See "V, Min/Max" on page 24

[:SOURce<hw>]:1Q:OUTPut[:ANALog]:ENVelope:BIAS <Bias>

Sets a bias.
Parameters:
<Bias> float
Range: -3.6V to 3.6V
Increment: 1E-4
*RST: 0
Default unit: V
Example: See Example"Generating an RF envelope signal and defining

the shaping function" on page 80.

Manual operation: See "Bias" on page 25

[:SOURce<hw>]:1Q:OUTPut[:ANALog]:ENVelope:OFFSet <Offset>

Sets an offset between the envelope and the inverted envelope signal.

Parameters:
<Offset> float
Range: -8V to 8V
Increment: 1E-4
*RST: 0
Default unit: V
Example: See Example"Generating an RF envelope signal and defining

the shaping function" on page 80.
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[:SOURce<hw>]:1Q:OUTPut[:ANALog]:ENVelope:VPP[:MAX] <VppMax>

Set the maximum value of the driving voltage V, of the used external DC modulator.

Parameters:
<VppMax> float
Range: -0.02V to 8V
Increment: 1E-3
*RST: 1
Default unit: V
Example: See Example"Generating an RF envelope signal and defining

the shaping function" on page 80.

Manual operation:  See "V ,Max" on page 27

[:SOURce<hw>]:1Q:OUTPut[:ANALog]:ENVelope:EMF[:STATe] <EmfState>

Defines whether the EMF or the voltage value is used.

Parameters:
<EmfState> 1|ON |0 | OFF
*RST: 1
Example: See Example"Generating an RF envelope signal and defining

the shaping function" on page 80

Manual operation: See "EMF" on page 25

[:SOURce<hw>]:1Q:OUTPut[:ANALog]:ENVelope:RIN <InputResistance>
Sets the input impedance R;, of the used external DC modulator.

Parameters:
<InputResistance> float

Range: 50[100 to 1E6
Increment: 0.1
*RST: 50

Example: See Example"Generating an RF envelope signal and defining
the shaping function" on page 80

Manual operation: See "R;," on page 26

[:SOURce<hw>]:1Q:OUTPut[:ANALog]:ENVelope: TERMination <Termination>
Sets how the inputs of the DC modulator are terminated.

Parameters:
<Termination> GROund | WIRE

*RST: GROund
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Example: See Example"Generating an RF envelope signal and defining
the shaping function" on page 80

Manual operation: See "Termination" on page 26

[:SOURce<hw>]:1Q:OUTPut[:ANALog]:ENVelope:BINPut <Bipolarinput>

Enables the generation of a bipolar signal.

Parameters:
<Bipolarlnput> 1|ON |0 | OFF
*RST: 0
Example: See Example"Generating an RF envelope signal and defining

the shaping function" on page 80

Manual operation: See "Bipolar Input" on page 26

[:SOURce<hw>]:1Q:OUTPut[:ANALog]:ENVelope:GAIN <Gain>

Sets the gain of the used external DC modulator.

Parameters:
<Gain> float
Range: -50 to 50
Increment: 0.01
*RST: 0
Example: See Example"Generating an RF envelope signal and defining

the shaping function" on page 80

Manual operation: See "Gain" on page 27

[:SOURce<hw>]:1Q:OUTPut[:ANALog]:ENVelope:VCC:OFFSet <VccOffset>

Applies a voltage offset on the supply voltage V...

Parameters:
<VccOffset> float
Range: 0 to 30
Increment: 1E-3
*RST: 0
Default unit: mV
Example: See Example"Generating an RF envelope signal and defining

the shaping function" on page 80

Manual operation: See "V . Offset" on page 27
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[:SOURce<hw>]:1Q:OUTPut[:ANALog]:ENVelope:VCC:MIN <VccMin>
[:SOURce<hw>]:1Q:OUTPut[:ANALog]:ENVelope:VCC:MAX <VccMax>

Sets the maximum value of the supply voltage V..

Parameters:
<VccMax>

Example:

Manual operation:

float

Range: 0.04 to 8
Increment: 0.001
*RST: 1

See Example"Generating an RF envelope signal and defining
the shaping function" on page 80

See "V Min/Max" on page 28

[:SOURce<hw>]:1Q:OUTPut[:ANALog]:ENVelope:VCC:VALue:PEP?

Queries the Vcc value of the current PEP of the generated RF signal.

Return values:
<VccForCrtPep>

Example:

Usage:

Manual operation:

float

Range: 0 to 38
Increment: 1E-3
*RST: 0

See Example"Generating an RF envelope signal and defining
the shaping function" on page 80

Query only

See "Diagram" on page 40

[:SOURce<hw>]:1Q:OUTPut[:ANALog]:ENVelope:VCC:VALue:LEVel?

Queries the Vcc value of the current RMS power level (operating point).

Return values:
<VccForRfLevel>

Example:

Usage:

Manual operation:
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float

Range: 0 to 38
Increment: 1E-3
*RST: 0

See Example"Generating an RF envelope signal and defining
the shaping function" on page 80

Query only

See "Diagram” on page 40
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[:SOURce<hw>]:1Q:OUTPut[:ANALog]:ENVelope:VCC:VALue? <xValue>, <xUnit>,
<xScale>

Queries the V¢ value for the selected <xvalue>.
Query parameters:

<xValue> float

Value on the x-axis
Value range depends on the selected "Envelope Voltage Adap-
tation" and PEP;,Min and PEP;,Max values.

<xUnit> NORMalized | DBM | V
*RST: NORMalized
<xScale> VOLTage | POWer
*RST: VOLTage

Return values:
<VccValue> float

Range: 0 to 38
Increment: 1E-3
*RST: 0

Example: See Example"Generating an RF envelope signal and defining
the shaping function" on page 80

Usage: Query only

Manual operation: See "Diagram” on page 40

[:SOURce<hw>]:1Q:OUTPut[:ANALog]:ENVelope:PIN:MIN <PinMin>

Sets the minimum value of the input power Pj,.

Parameters:
<PinMin> float
Range: -145 to 20
Increment: 0.01
*RST: -30
Example: See Example"Generating an RF envelope signal and defining

the shaping function" on page 80

Manual operation: See "PEP;,Min/Max" on page 29

[:SOURce<hw>]:1Q:OUTPut[:ANALog]:ENVelope:PIN:MAX <PinMax>

Sets the maximum value of the input power Py,,.
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Parameters:
<PinMax>

Example:

Manual operation:

SOURCce:1Q:OUTPut:ENVelope commands

float

Range: -145 to 20
Increment: 0.01

*RST: -20

See Example"Generating an RF envelope signal and defining
the shaping function" on page 80

See "PEP;,Min/Max" on page 29

[:SOURce<hw>]:1Q:OUTPut[:ANALog]:ENVelope:POWer:OFFSet?

Queries the current power offset, that is the sum of enabled "RF Level > Offset" and

"User Correction".

Return values:
<PowerOffset>

Example:

Usage:

Manual operation:

float

Range: -200 to 200
Increment: 0.01

*RST: 0

See Example"Generating an RF envelope signal and defining
the shaping function" on page 80

Query only
See "Power Offset" on page 29

[:SOURce<hw>]:1Q:OUTPut[:ANALog]:ENVelope:SHAPing:MODE <ShapingMode>

Enables envelope shaping and selects the method to define the shaping function.

Parameters:
<ShapingMode>

Example:

Manual operation:

OFF | LINear | TABLe | POLYnomial | DETRoughing | POWer

LINear = Linear (Voltage)
POWer = Linear (Power)

*RST: OFF

See Example"Generating an RF envelope signal and defining
the shaping function" on page 80.

See "Shaping" on page 33

[:SOURce<hw>]:1Q:OUTPut[:ANALog]:ENVelope:SHAPing:SCALe <Scale>

Determines the units used on the x and y axis.

Parameters:
<Scale>
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POWer | VOLTage
*RST: VOLTage
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Example: See Example"Generating an RF envelope signal and defining
the shaping function" on page 80

Manual operation: See "Scale" on page 40

[:SOURce<hw>]:1Q:OUTPut[:ANALog]:ENVelope:SHAPing:GAIN:PRE <PreGain>
[:SOURce<hw>]:1Q:OUTPut[:ANALog]:ENVelope:SHAPing:GAIN:POST
<PostGain>

Sets a post-gain.

Parameters:
<PostGain> float
Range: -3 to 20
Increment: 1E-2
*RST: 0
Example: See Example"Generating an RF envelope signal and defining

the shaping function" on page 80

Manual operation: See "Post-Gain" on page 38

[:SOURce<hw>]:1Q:OUTPut[:ANALog]:ENVelope:SHAPing:FILE:CATalog?
[:SOURce<hw>]:1Q:OUTPut[:ANALog]:ENVelope:SHAPing:PV:FILE:CATalog?

Queries the available table shaping files in the default directory. Only files with the file
extension *.iq lut or *.iqg lutpv are listed.

Return values:
<Catalog> string

Example: See Example"Generating an RF envelope signal and defining
the shaping function" on page 80

Usage: Query only

Manual operation: See "Shaping Table" on page 39

[:SOURce<hw>]:1Q:OUTPut[:ANALog]:ENVelope:SHAPing:FILE[:SELect]
<Filename>

[:SOURce<hw>]:1Q:OUTPut[:ANALog]:ENVelope:SHAPing:PV:FILE[:SELect]
<Filename>

Selects an envelope shaping file (extension *.ig lut or *.ig lutpv).

Parameters:
<Filename> string
Example: See Example"Generating an RF envelope signal and defining

the shaping function" on page 80

Manual operation: See "Shaping Table" on page 39
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[:SOURce<hw>]:1Q:OUTPut[:ANALog]:ENVelope:SHAPing:FILE:DATA
[:SOURce<hw>]:1Q:OUTPut[:ANALog]:ENVelope:SHAPing:PV:FILE:DATA

Defines the shaping function in a raw data format.

See also [ : SOURce<hw>] : IQ:0UTPut [ :ANALog] :ENVelope: SHAPing:PV:
FILE:NEW on page 92.

Example: See Example"Generating an RF envelope signal and defining
the shaping function" on page 80

[:SOURce<hw>]:1Q:OUTPut[:ANALog]:ENVelope:SHAPing:FILE:NEW
[:SOURce<hw>]:1Q:OUTPut[:ANALog]:ENVelope:SHAPing:PV:FILE:NEW

Stores the shaping values into a file with the selected file name and loads it.

The file is stored in the default directory or in the directory specified with the absolute
file path. If the file does not yet exist, a new file is created. The file extension is
assigned automatically.

Example: See Example"Generating an RF envelope signal and defining
the shaping function" on page 80

Usage: Setting only

[:SOURce<hw>]:1Q:OUTPut[:ANALog]:ENVelope:SHAPing:INTerp <Interpolation>

For envelope shaping with shaping tables, enables linear interpolation.

Parameters:
<Interpolation> OFF | LINear | POWer
LINear = Linear (Voltage)
POWer = Linear (Power)
*RST: OFF
Example: See Example"Generating an RF envelope signal and defining

the shaping function" on page 80

Manual operation: See "Interpolation” on page 39

[:SOURce<hw>]:1Q:OUTPut[:ANALog]:ENVelope:SHAPing:COEFficients
Sets the polynomial coefficients.

Example: See Example"Generating an RF envelope signal and defining
the shaping function" on page 80

Manual operation: See "Polynomial Order" on page 44
See "Polynomial constant and coefficients" on page 44
See "Apply, OK" on page 44

User Manual 1178.8165.02 — 08 92



R&S®SMBVB-K540, R&S®SMBVB-K541 Remote-control commands
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[:SOURce<hw>]:1Q:OUTPut[:ANALog]:ENVelope:SHAPing:COEFficients:
CATalog?

Queries the available polynomial files in the default directory. Only files with the file
extension *.iq poly are listed.

Return values:
<Catalog> string

Example: See Example"Generating an RF envelope signal and defining
the shaping function" on page 80

Usage: Query only

Manual operation: See "Save/Recall Polynomial" on page 44

[:SOURce<hw>]:1Q:OUTPut[:ANALog]:ENVelope:SHAPing:COEFficients:STORe
<Filename>

Saves the polynomial function as polynomial file.

Setting parameters:
<Filename> string

Example: See Example"Generating an RF envelope signal and defining
the shaping function" on page 80

Usage: Setting only

Manual operation: See "Save/Recall Polynomial" on page 44

[:SOURce<hw>]:1Q:OUTPut[:ANALog]:ENVelope:SHAPing:COEFficients:LOAD
<Filename>

Loads the selected polynomial file.

Setting parameters:
<Filename> string

Example: See Example"Generating an RF envelope signal and defining
the shaping function" on page 80

Usage: Setting only

Manual operation: See "Save/Recall Polynomial" on page 44

[:SOURce<hw>]:1Q:OUTPut[:ANALog]:ENVelope:SHAPing:DETRoughing:
FUNCtion <DetrFunction>

Sets the detroughing function.

Parameters:
<DetrFunction> F1|F2|F3

*RST: F1
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Example: See Example"Generating an RF envelope signal and defining
the shaping function" on page 80

Manual operation:  See "Detroughing Function" on page 37

[:SOURce<hw>]:1Q:OUTPut[:ANALog]:ENVelope:SHAPing:DETRoughing:
COUPIling <CouplingState>

Enables/disables deriving the detroughing factor (d) from the selected V. value.

Parameters:
<CouplingState> 1]ON| 0| OFF
*RST: 0
Example: See Example"Generating an RF envelope signal and defining

the shaping function" on page 80

Manual operation: See "Couple Detroughing Factor with VVcc" on page 38

[:SOURce<hw>]:1Q:OUTPut[:ANALog]:ENVelope:SHAPing:DETRoughing:FACTor
<DetrFactor>

Sets the detroughing factor.

Parameters:
<DetrFactor> float
Range: 0to 2
Increment: 1E-3
*RST: 0.2
Example: See Example"Generating an RF envelope signal and defining

the shaping function" on page 80

Manual operation: See "Detroughing Factor (d)" on page 38

[:SOURce<hw>]:1Q:OUTPut[:ANALog]:ENVelope:SHAPing:DETRoughing:
PEXPonent <PowerExponent>

Sets the exponent (a) for the detroughing function F3.

Parameters:
<PowerExponent>  float

Range: 1 to 10
Increment: 1E-3
*RST: 2

Example: See Example"Generating an RF envelope signal and defining
the shaping function" on page 80

Manual operation: See "Exponent (a)" on page 38
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6.3

SOURce:IQ:DPD subsystem

SOURCce:IQ:DPD subsystem

The SOURce: IQ:DPD subsystem contains the commands for enabling and configuring

of digital predistortion.
Option: see Chapter 3.1, "Required options", on page 46.

Example: Defining correction coefficients and enabling digital predistortion

*RST

// enable LTE signal
SOURcel:BB:EUTRa:SETTing:TMOD:DL "E-TM1 1 S5MHz"
SOURcel:BB:EUTRa:STATe 1

// define the RF level and frequency
SOURcel :FREQuency:CW 2143000000
SOURcel:POWer:LEVel:IMMediate:AMPLitude -15

SOURcel:IQ:DPD:PIN:MIN -35
SOURcel:IQ:DPD:PIN:MAX -2.5

// select look-up table files with correction values
SOURcel:IQ:DPD:SHAPing:MODE TABLe
SOURcel:IQ:DPD:SHAPing:TABLe:AMAM:FILE:CATalog?

// Response: My DPD AM-AM,MyDPD AM-AM
SOURcel:IQ:DPD:SHAPing:TABLe:AMAM:FILE:SELect "My DPD AM-AM"
SOURcel:IQ:DPD:SHAPing:TABLe:AMPM:FILE:CATalog?

// Response: My DPD AM-PM,MyDPD AM-PM
SOURcel:IQ:DPD:SHAPing:TABLe:AMPM:FILE:SELect "My DPD AM-PM"
SOURcel:IQ:DPD:SHAPing:TABLe:INTerp LINear
SOURcel:IQ:DPD:SHAPing:TABLe:INVert?

// Response: 0

// enable digital predistortion
SOURcel:IQ:DPD:AMPM:AMFirst 1
SOURcel:IQ:DPD:AMAM: STATe 1
SOURcel:IQ:DPD:AMPM:STATe 1
SOURcel:IQ:DPD:LREFerence BDPD
SOURcel:IQ:DPD:STATe 1

// enable the output
SOURcel:IQ:STATe 1
OUTPutl:STATe 1

// query the PEP, level and crest factor values before and after the
SOURcel:IQ:DPD:INPut:PEP?

// Response: -3.43

SOURcel:IQ:DPD:INPut:LEVel?

// Response: -15
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SOURce:IQ:DPD subsystem

SOURcel:IQ:DPD:INPut:CFACtor?
// Response: 11.57

SOURcel:IQ:DPD:OUTPut:PEP?
SOURcel:IQ:DPD:OUTPut:LEVel?
SOURcel:IQ:DPD:0OUTPut:CFACtor?

// change level reference and

// query the PEP, level and crest factor values before and after the DPD
SOURcel:IQ:DPD:LREFerence ADPD
SOURcel:IQ:DPD:0OUTPut:ERRor:MAX 0.1
SOURcel:IQ:DPD:0OUTPut:ITERations:MAX 3
SOURcel:IQ:DPD:MEASurement:STATe?

// Response: 1
SOURcel:IQ:DPD:0OUTPut:ERRoOr?

// Response: 0
SOURcel:IQ:DPD:0OUTPut:PEP?

// Response: -3.57
SOURcel:IQ:DPD:OUTPut:LEVel?

// Response: -15
SOURcel:IQ:DPD:0OUTPut:CFACtor?

// Response: 11.43

// enable static DPD and set the pre-gain

SOURcel:IQ:DPD:LREFerence SDPD

SOURcel:IQ:DPD:GAIN:PRE -18

// set the predistorion values in raw format
SOURcel:IQ:DPD:SHAPing:TABLe:AMAM:FILE:DATA -30.4,-5.2, -25.1,-4.5, -18.5,-2.5, -10.5,-1
SOURcel:IQ:DPD:SHAPing:TABLe:AMPM:FILE:DATA -30.4, -5, -25.1, 5, -10, O
SOURcel:IQ:DPD:SHAPing:TABLe:AMPM:FILE:CATalog?

// Response: My DPD AM-PM,MyDPD AM-PM

// set the predistorion values and store them into a file
SOURcel:IQ:DPD:SHAPing:TABLe:AMPM:FILE:NEW "DPD AM-PM raw", -30.4, -5, -25.1, 5, -10, O
SOURcel:IQ:DPD:SHAPing:TABLe:AMPM:FILE:CATalog?

// Response: My DPD AM-PM,MyDPD AM-PM,DPD_AM-PM raw

SOURcel:IQ:DPD:AMPM:VALue:PEP?

// Response: 4.255

SOURcel:IQ:DPD:AMPM:VALue:VALue? -30,DBM

// Response:-4.439

// change the shaping mode

SOURcel:IQ:DPD:SHAPing:MODE POLYnomial

// query files with polynomial functions in the default user directory
SOURcel:IQ:DPD:SHAPing:POLYnomial:COEFficients:CATalog?

// Response: MyDTD Poly,myDTD Poly4th
SOURcel:IQ:DPD:SHAPing:POLYnomial:COEFficients:LOAD "MyDTD Poly4th"
SOURcel:IQ:DPD:SHAPing:POLYnomial :COEFficients?

// Response: 0,0,-0.25,0.2,0.6,-0.3,0.3,0.3,0.5,-0.4
SOURcel:IQ:DPD:SHAPing:POLYnomial:COEFficients:STORe "/var/user/myPoly.dpd poly"
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Commands:

[[SOURCESNWS]: QD P D S TATE. - teteeeeeeeeeeeeeeeeieeeeeeeeeaeeaeeeensanaaaaaaeaeeeeeeeaaaaaeeaeeeeeeeeennennnnns 98
[[SOURCESNW>]:IQ:DP D :PRESE . .t uuuiiieieieeeeeeeeeieeeeeeeeeeeeessstabr e aeseseeeeeaeaaaaessseseseeereses 98
[:SOURCce<hw>]:IQ:DPD:SETTING:CATAIOg?. .cttuuuttittitiiiiieeeeeeteraseeereeinesseesseesansessesasnnnneaans 98
[:SOURCE]:IQ:DPD:SETTING:DELELE. .. .iiiiieiiiie e eeeeeeice et e e e e e e e e e eer e e e e eeeeen 98
[:SOURce<hw>]:IQ:DPD:SETTING:LOAD.....cuiieiee ettt e e e e e e e e ea e 99
[:SOURce<hw>]:IQ:DPD:SETTING:STORE. ...ttt ee e e 99
[:SOURCEe<hW>]:IQ:DPD:AMAM:STATE. ettt ettt e e e e e e e e e e e e ees 99
[:SOURCEe<hW>]:1Q:DPD:AMPM:STATE. ..ccieiee et e e eeeeeeeee et eeeeeeeeeaaenbeeeaeaeaeeeeeeeaeaaaaaeeeeeeneennes 99
[:SOURCe<hw>]:IQ:DPD:AMAM:VALUE?........cceeeeeeeeeeeeeretstritsseaaaeseseeeeeaeaeeeseseereeessesssraranes 99
[:SOURCce<hw>]:IQ:DPD:AMAM:VALUEIPEP 2. .. ittt ettt 100
[:SOURCce<hw>]:IQ:DPD:AMAM:VALUE:LEVEI?.....ccevitie ettt eeeeae e 100
[:SOURCe<hW>]:IQ:DPD:AMPM:VALUE?. ...ttt ettt e et e e e eaeaaas 100
[:SOURce<hw>]:IQ:DPD:AMPM:VALUE:PEP ... 101
[:SOURce<hw>]:IQ:DPD:AMPM:VALUEILEVEI?. ...t 101
[:SOURCE<NW>]:IQ:DPD:AMEIISE. .. etetieieaeaaeaeie e e e e e e eeeeeeeeeeeeeeeeaeeeeeernsnnnaaaaaaaeeeeesaaaaaaeees 102
[:SOURCE<hW>]:IQ:DPD:LREFEIENCE. .. .iieiieetieieeeeeetiieeeeeeeetee e e e e e et eeeeeseetae e e e e eeeanaeeaaes 102
[:SOURCce<hw>]:IQ:DPD:OUTPULERROIM?....ccciviteii ittt s e e eeeeten e s et e e s eaan e s e e e eaaa s 102
[:SOURCce<hw>]:IQ:DPD:OUTPUt:ERROIMMAX. .. .iiiiiiiiieei ettt s e e st e e e e et e e e eeabe e e e eees 102
[:SOURce<hw>]:IQ:DPD:OUTPULITERAIONS:IMAX. ... eas 103
[:SOURce<hw>]:IQ:DPD:MEASUIEMENt:STATE?. ....uuuaaaaaaeeeeeeeeeeeeeaeeeeeeeeeeeeeeenennnnaeae e ens 103
[:SOURce<hw>]:IQ:DPD:INPUt:CFACIOIT?. ...ceiieeeeeeeeeeeeeeeeeeiieeeieeeeeaeae e e e e e e e e aaaeaaeeeeeeeeeneees 103
[:SOURCce<hw>]:1Q:DPD:OUTPUL:CFACION?. ..cieieieeeeeeeeeeeeeeeeeeeeeeeeverab e e e e e e e e e e e 103
[:SOURCce<hw>]:IQ:DPD:INPULLEVEI?....cciiiiieiee ettt e e 103
[:SOURCce<hw>]:IQ:DPD:OUTPULLEVEI?....cceiiiiee ettt 103
[:SOURCe<hW>]:IQ:DPD:INPULIPEP . ... et e e e 103
[:SOURCce<hw>]:IQ:DPD:OUTPULIPEP ... et e e 103
[:SOURGE<hWSTIQ:DPD:PINIMIN ...t eseee st ese s ese s ee s eeesessseeneseseseseeseneanes 104
[:SOURCe<hW>]:1Q:DPD:PINIMAX.....cceieieeeeeeeeeieieeeeteaaaaa s e s e e e e eeeeaaeaeeeeeseeeaeeneenennnnannnnnns 104
[:SOURCE<hW>]:1Q:DPD:GAIN:PRE. ... uuuuieieieieeeeieeeeeeeeeeeeeeeeeeeeersb b e e e s eseeeeaaaaeeees 104
[:SOURCce<hw>]:IQ:DPD:SHAPING:MODE........cctuiiiiiiiiiiiiiee et eeei e e ee s 104
[:SOURCE<hW>]:IQ:DPD:SCALE. ...ccttutieeeeiieiie e e e eetetae e e et eeaaae e e e s eetr s e e eeeesaanseeeeeernaaeaaes 105
[:SOURce<hw>]:IQ:DPD:SHAPing: TABLe:AMAM:FILE:CATalog?..c.cieuiieiieiiieeeeeeeeeeeee e 105
[:SOURce<hw>]:IQ:DPD:SHAPIng: TABLe:AMPM:FILE:CATalog?. ... ivuiiiiiiiiieeieeeeeeeeee e 105
[:SOURce<hw>]:1Q:DPD:SHAPING: TABLE:AMAM:FILE[:SELECH ...veeeeeesereseeseseesereenens 105
[:SOURce<hw>]:IQ:DPD:SHAPiIng: TABLe:AMPM:FILE[:SELECt]....ceevvuiieeniiiieiieeeeeeeee 105
[:SOURce<hw>]:1Q:DPD:SHAPINg: TABLE:AMAM:FILE:NEW.......uuuiueiieieieieeeeeeeeeeeeeeeeeeeeens 105
[:SOURce<hw>]:1Q:DPD:SHAPINg: TABLE:AMPM:FILEINEW.......coiiiiiiiiiiee e 105
[:SOURce<hw>]:1Q:DPD:SHAPINg: TABLE:AMAM:FILE:DATA......uciiiiiieiiiieeeeeeeeie e e e eeenans 106
[:SOURce<hw>]:IQ:DPD:SHAPIng: TABLe:AMPM:FILE:DATA. ... 106
[:SOURce<hw>]:1Q:DPD:SHAPING: TABLEINTEIP....ceeeeeeeeeeeeeeeeeeeeeeieeeeee e e e e e 106
[:SOURce<hw>]:1Q:DPD:SHAPING[:TABLELINVE. ... eeseseeeeeenenseeeeeeees 106
[:SOURce<hw>]:1Q:DPD:SHAPiIng:POLYnomial: COEFfICIENtS........cceeeeeeeeeeeeeeeeeeeeeeeieiieeee 106
[:SOURce<hw>]:1Q:DPD:SHAPing:POLYnomial: COEFficients:CATalog?........coevverevvnnnrerienns 107
[:SOURce<hw>]:1Q:DPD:SHAPing:POLYnomial: COEFficients:LOAD.......cc.cccceterreeruniieraennnns 107
[:SOURce<hw>]:1Q:DPD:SHAPing:POLYnomial: COEFficients:STORE.......c.ccvueeveeiierininnnans 108
[:SOURce<hw>]:IQ:DPD:SHAPINg:NORMalized:DATA. ...t 108
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[:SOURce<hw>]:IQ:DPD:SHAPiIng:NORMalized:DATA:CATalOg?. ... eeueieeeieeeeeeeeeeeee e 109
[:SOURce<hw>]:IQ:DPD:SHAPiIng:NORMalized:DATA:LOAD......ccoiiiiiiieei e 109
[:SOURce<hw>]:1Q:DPD:SHAPing:NORMalized:DATA:STORE........coeeeeeeeeeeeeeiinnniaaaaeen e 109

[:SOURce<hw>]:1Q:DPD:STATe <State>

Enabels/disables the generation of digitally pre-distorted signals.

Parameters:
<State> 1|/ON |0 | OFF
*RST: 0
Example: See Example"Defining correction coefficients and enabling digi-

tal predistortion" on page 95

Manual operation: See "State" on page 53

[:SOURce<hw>]:1Q:DPD:PRESet

Sets the default DPD settings (*RST values specified for the commands).

Not affected is the state set with the command [ : SOURce<hw>] : IQ:DPD: STATe.
Usage: Event

Manual operation: See "Set to Default" on page 54

[:SOURce<hw>]:1Q:DPD:SETTing:CATalog?

Queries the files with digital predistortion setting in the default directory. Listed are files
with the file extension * . dpd.

Return values:
<Catalog> string

Usage: Query only

Manual operation: See "Save/Recall" on page 54

[:SOURce]:IQ:DPD:SETTing:DELete <Filename>

Deletes the selected file from the default or specified directory. Deleted are files with
the file extension * . dpd.

Setting parameters:
<Filename> "<filename>"

Filename or complete file path
Usage: Setting only

Manual operation: See "Save/Recall" on page 54
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[:SOURce<hw>]:1Q:DPD:SETTing:LOAD <Filename>

Loads the selected file from the default or the specified directory. Loaded are files with
extension * . dpd.

Setting parameters:
<Filename> "<filename>"

Filename or complete file path
Usage: Setting only

Manual operation: See "Save/Recall" on page 54

[:SOURce<hw>]:1Q:DPD:SETTing:STORe <Filename>

Stores the current settings into the selected file; the file extension (* . dpd) is assigned
automatically.

Setting parameters:
<Filename> "<filename>"

Filename or complete file path
Usage: Setting only

Manual operation: See "Save/Recall" on page 54

[:SOURce<hw>]:1Q:DPD:AMAM:STATe <State>
[:SOURce<hw>]:1Q:DPD:AMPM:STATe <State>

Enabels/disables the AM/AM and AM/PM digital predistortion.

Parameters:
<State> 1|ON |0 | OFF
*RST: 0
Example: See Example"Defining correction coefficients and enabling digi-

tal predistortion" on page 95

Manual operation: See "AM/AM and AM/PM State" on page 55

[:SOURce<hw>]:1Q:DPD:AMAM:VALue? <XValue>, <XUnit>

Queries the delta power value of the generated RF signal for a selected <xvalue>.
Query parameters:

<XValue> float

Value on the x-axis.
Value range depends on the selected PEP;,Min and PEP;,Max
values.

Range: -100 to 100
Increment: 0.01

<XUnit> DBM |V
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Return values:

<DeltaPower> float
Range: -20 to 20
Increment: 0.01
*RST: 0
Example: See Example"Defining correction coefficients and enabling digi-

tal predistortion" on page 95.
Usage: Query only
Manual operation: See "AM/AM and AM/PM Diagrams" on page 60

[:SOURce<hw>]:1Q:DPD:AMAM:VALue:PEP?

Queries the delta power value for the current peak envelope power (PEP) level of the
generated RF signal.

Return values:

<DeltaPower> float
Range: -20 to 20
Increment: 0.01
*RST: 0
Example: See Example"Defining correction coefficients and enabling digi-

tal predistortion" on page 95.
Usage: Query only
Manual operation: See "AM/AM and AM/PM Diagrams" on page 60

[:SOURce<hw>]:1Q:DPD:AMAM:VALue:LEVel?

Queries the delta power value for the current root mean square (RMS) power level of
the generated RF signal.

Return values:

<DeltaPower> float
Range: -20 to 20
Increment: 0.01
*RST: 0
Example: See Example"Defining correction coefficients and enabling digi-

tal predistortion" on page 95.
Usage: Query only
Manual operation: See "AM/AM and AM/PM Diagrams" on page 60

[:SOURce<hw>]:1Q:DPD:AMPM:VALue? <XValue>, <XUnit>

Queries the delta phase value of the generated RF signal for a selected <xvalue>.
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Query parameters:
<XValue> float

Value on the x-axis.
Value range depends on the selected PEP;,Min and PEP;,Max

values.
Range: -100 to 100
Increment: 0.01
<XUnit> DBM |V
*RST: DBM
Return values:
<DeltaPhase> float
Range: -180 to 180
Increment: 0.01
*RST: 0
Example: See Example"Defining correction coefficients and enabling digi-

tal predistortion" on page 95.
Usage: Query only
Manual operation: See "AM/AM and AM/PM Diagrams" on page 60

[:SOURce<hw>]:1Q:DPD:AMPM:VALue:PEP?

Queries the delta phase value for the current peak envelope power (PEP) level of the
generated RF signal.

Return values:

<DeltaPhase> float
Range: -180 to 180
Increment: 0.01
*RST: 0
Example: See Example"Defining correction coefficients and enabling digi-

tal predistortion" on page 95.
Usage: Query only
Manual operation: See "AM/AM and AM/PM Diagrams" on page 60

[:SOURce<hw>]:IQ:DPD:AMPM:VALue:LEVel?

Queries the delta phase value for the current root mean square (RMS) power level of
the generated RF signal.

Return values:

<DeltaPhase> float
Range: -180 to 180
Increment: 0.01
*RST: 0
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Example: See Example"Defining correction coefficients and enabling digi-
tal predistortion" on page 95.

Usage: Query only
Manual operation: See "AM/AM and AM/PM Diagrams" on page 60

[:SOURce<hw>]:1Q:DPD:AMFirst <AmAmFirstState>
Sets that the AM/AM predistortion is applied before the AM/PM.

Parameters:
<AmAmFirstState> 1| ON |0 | OFF
*RST: 0
Example: See Example"Defining correction coefficients and enabling digi-

tal predistortion" on page 95

Manual operation: See "AM/AM First" on page 54

[:SOURce<hw>]:1Q:DPD:LREFerence <LevelReference>

Sets whether a dynamic (BDPD | ADPD) or a static (SDPS) adaptation of the range the
selected DPD is applied on.

Parameters:
<LevelReference> BDPD | ADPD | SDPD
*RST: BDPD
Example: See Example"Defining correction coefficients and enabling digi-

tal predistortion" on page 95

Manual operation: See "Level Reference" on page 54

[:SOURce<hw>]:1Q:DPD:OUTPut:ERRor?
Queries the resulting level error.

Return values:
<AchievedError> float

Example: see Example"Defining correction coefficients and enabling digi-
tal predistortion" on page 95

Usage: Query only

Manual operation: See "Achieved Output Level Error" on page 55

[:SOURce<hw>]:1Q:DPD:OUTPut:ERRor:MAX <MaximumError>

Sets the allowed maximum error.
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Parameters:
<MaximumError> float
Range: 0.01 to 1
Increment: 0.01
*RST: 0.1
Example: see Example"Defining correction coefficients and enabling digi-

tal predistortion" on page 95

Manual operation: See "Maximum Output Level Error" on page 55
See "Maximum Number of lterations"” on page 55

[:SOURce<hw>]:1Q:DPD:OUTPut:ITERations:MAX <Maxlterations>

Sets the maximum number of performed iterations to achieving the required error set
with [ : SOURce<hw>] :IQ:DPD:0UTPut:ERRor : MAX.

Parameters:
<Maxlterations> integer
Range: 1 to 10
*RST: 3
Example: See Example"Defining correction coefficients and enabling digi-

tal predistortion" on page 95

[:SOURce<hw>]:1Q:DPD:MEASurement:STATe?

Queries whether the interactions are competed.

Return values:

<MeasureValidity> 1| ON |0 | OFF
*RST: 1

Example: See Example"Defining correction coefficients and enabling digi-
tal predistortion" on page 95

Usage: Query only

[:SOURce<hw>]:1Q:DPD:INPut:CFACtor?
[:SOURce<hw>]:1Q:DPD:OUTPut:CFACtor?
[:SOURce<hw>]:1Q:DPD:INPut:LEVel?
[:SOURce<hw>]:1Q:DPD:OUTPut:LEVel?
[:SOURce<hw>]:IQ:DPD:INPut:PEP?
[:SOURce<hw>]:1Q:DPD:OUTPut:PEP?

Queries the measured values the before and after the enabled digital predistortion.

Return values:
<PEP> float

The query returns -1000 if the calculation is impossible or there
are no measurements results available.
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Example:

Usage:

Manual operation:

SOURce:IQ:DPD subsystem

see Example"Defining correction coefficients and enabling digi-
tal predistortion" on page 95

Query only
See "Input/Output PEP, Level and Crest Factor" on page 55

[:SOURce<hw>]:1Q:DPD:PIN:MIN <PepInMin>
[:SOURce<hw>]:1Q:DPD:PIN:MAX <PepInMax>

Sets the value range of the input power.

Parameters:
<PepInMax>

Example:

Manual operation:

float

Range: -145 to 20
Increment: 0.01

*RST: 10

See Example"Defining correction coefficients and enabling digi-
tal predistortion" on page 95

See "Input Range (PEP,,) From/To" on page 58

[:SOURce<hw>]:1Q:DPD:GAIN:PRE <PreGain>

Sets a pre-gain (i.e. an attenuation) to define the range the static DPD is applied in.

Parameters:
<PreGain>

Example:

Manual operation:

float

Range: -50 to 20
Increment: 1E-2
*RST: 0

see Example"Defining correction coefficients and enabling digi-
tal predistortion" on page 95

See "Pre-Gain" on page 58

[:SOURce<hw>]:1Q:DPD:SHAPing:MODE <Shaping>

Selects the method to define the correction coefficients.

Parameters:
<Shaping>

Example:

Manual operation:
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TABLe | POLYnomial | NORMalized
*RST: TABLe

See Example"Defining correction coefficients and enabling digi-
tal predistortion" on page 95.

See "Shaping" on page 57
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[:SOURce<hw>]:1Q:DPD:SCALe <Scale>
Determines the units used on the x and y-axis.

Parameters:
<Scale> POWer | VOLTage

*RST: POWer

Manual operation: See "Scale" on page 60

[:SOURce<hw>]:IQ:DPD:SHAPing:TABLe:AMAM:FILE:CATalog?
[:SOURce<hw>]:IQ:DPD:SHAPing:TABLe:AMPM:FILE:CATalog?

Queries the available table files in the default directory. Only files with the extension
*.dpd_magn(AM/AM) or * .dpd phase(AM/PM) are listed.

Return values:
<Catalog> string

Example: See Example"Defining correction coefficients and enabling digi-
tal predistortion" on page 95

Usage: Query only

Manual operation: See "Shaping Table" on page 59

[:SOURce<hw>]:1Q:DPD:SHAPing:TABLe:AMAM:FILE[:SELect] <Filename>
[:SOURce<hw>]:1Q:DPD:SHAPing:TABLe:AMPM:FILE[:SELect] <Filename>

Selects a file with correction values (extension * . dpd_magn (AM/AM) or
*.dpd_phase(AM/FM)).

Parameters:
<Filename> string
Example: See Example"Defining correction coefficients and enabling digi-

tal predistortion" on page 95

Manual operation: See "Shaping Table" on page 59
See "Pin (dBm), Delta Power (dB)/Pin (dBm), Delta Phase
(deg)" on page 61

[:SOURce<hw>]:1Q:DPD:SHAPing:TABLe:AMAM:FILE:NEW
[:SOURce<hw>]:1Q:DPD:SHAPing:TABLe:AMPM:FILE:NEW

Stores the correction values into a file with the selected file name and loads it.

The file is stored in the default directory or in the directory specified with the absolute
file path. If the file does not yet exist, a new file is created. The file extension is
assigned automatically.

Example: See Example"Defining correction coefficients and enabling digi-
tal predistortion" on page 95

Usage: Setting only
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[:SOURce<hw>]:1Q:DPD:SHAPing:TABLe:AMAM:FILE:DATA
[:SOURce<hw>]:1Q:DPD:SHAPing:TABLe:AMPM:FILE:DATA

Defines the predistortion function in a raw data format.

See also [ : SOURce<hw>] : IQ:DPD:SHAPing:TABLe : AMPM: FILE : NEW
on page 105.

Example: See Example"Defining correction coefficients and enabling digi-
tal predistortion" on page 95

[:SOURce<hw>]:1Q:DPD:SHAPing:TABLe:INTerp <Interpolation>

Enables a linear (voltage or power) interpolation between the defined correction val-

ues.
Parameters:
<Interpolation> OFF | POWer | LINear
POWer
Linear power interpolation
LINear
Linear voltage interpolation
*RST: OFF
Example: See Example"Defining correction coefficients and enabling digi-

tal predistortion" on page 95

Manual operation: See "Interpolation” on page 57

[:SOURce<hw>]:1Q:DPD:SHAPing[: TABLe]:INVert <InvertValues>

Inverts the defined correction values.

Parameters:
<InvertValues> 1|ON |0 | OFF
*RST: 0
Example: See Example"Defining correction coefficients and enabling digi-

tal predistortion" on page 95

Manual operation: See "Invert Correction Values" on page 57

[:SOURce<hw>]:1Q:DPD:SHAPing:POLYnomial: COEFficients <I0>, <J0>, <J1>,
<J1>

Sets the polynomial coefficients as a list of up to 10 comma separated value pairs.

In Cartesian coordinates system, the coefficients b, are expressed in degrees.
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Parameters:
<|0>

<JO>

<J1>

<J1>

Example:

Manual operation:

SOURce:IQ:DPD subsystem

float

Range: -1E6 to 1E6
Increment: 1E-3

*RST: 0

float

Range: -1E6 to 1E6
Increment: 1E-3

*RST: 0

float

Range: -1E6 to 1E6
Increment: 1E-3

*RST: 0

float

Range: -1E6 to 1E6
Increment: 1E-3

*RST: 0

See Example"Defining correction coefficients and enabling digi-
tal predistortion" on page 95.

See "Polynomial Order" on page 65
See "Apply, OK" on page 65

[:SOURce<hw>]:1Q:DPD:SHAPing:POLYnomial: COEFficients:CATalog?

Queries the available polynomial files in the default directory. Only files with the file
extension *.dpd poly are listed.

Return values:
<Catalog>

Example:

Usage:

Manual operation:

string

See Example"Defining correction coefficients and enabling digi-
tal predistortion" on page 95

Query only

See "Save/Recall Polynomial” on page 65

[:SOURce<hw>]:1Q:DPD:SHAPing:POLYnomial: COEFficients:LOAD <Filename>

Loads the selected polynomial file.

Setting parameters:
<Filename>
Example:

Usage:
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string

See Example"Defining correction coefficients and enabling digi-
tal predistortion" on page 95

Setting only
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Manual operation: See "Save/Recall Polynomial" on page 65

[:SOURce<hw>]:1Q:DPD:SHAPing:POLYnomial:COEFficients:STORe <Filename>
Saves the polynomial function as polynomial file.

Setting parameters:
<Filename> string

Example: See Example"Defining correction coefficients and enabling digi-
tal predistortion" on page 95

Usage: Setting only

Manual operation: See "Save/Recall Polynomial” on page 65

[:SOURce<hw>]:1Q:DPD:SHAPing:NORMalized:DATA <Data>

Defines the normalized predistortion function in a raw data format (binary data).

Parameters:

<Data> <#><LengthNoBytes><NoBytes><NormData>
<#>
The binary data must start with the sign #
<LengthNoBytes>
ASCII format

Sets the length of <NoBytes>, i.e. the number of digits used to
write <NoBytes>

<NoBytes>

An ASCII integer value that specifies the number of bytes that
follow in the <NormData> part

Each of the <NormData> parameters is coded with 8 bytes.
Then the number of bytes <NoBytes> is calculated as:
<NoBytes> =8 + 8 + n(8+8+8), where n is the number of points
<NoPoints>.

<NormbData>
<PinMax><NoPoints>{<VinVmax><DeltaV><DeltaPhase>}
Values in binary format, describing the maximum absolute input
power Pin,,.., the number of subsequent points n and the nor-
malized values Vin/Vmax, AV/V, APhase [deg].
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Example: SOURcel:IQ:DPD:SHAPing:NORMalized:DATA #240<values>
// the binary <values> are not printable
SOURcel:IQ:DPD:SHAPing:NORMalized:DATA:CATalog?
// norm
SOURcel:IQ:DPD:SHAPing:NORMalized:DATA:STORe "My DPD Normalized"
SOURcel:IQ:DPD:SHAPing:NORMalized:DATA:CATalog?
// norm,My DPD Normalized
SOURcel:IQ:DPD:SHAPing:NORMalized:DATA:LOAD "norm"
SOURcel:IQ:DPD:SHAPing:NORMalized:DATA?
// #3112
// the binary data <NormData> is 112 bytes long (3 points are defined)

// binary data is machine readable but not printable

Manual operation: See "Apply, OK" on page 67

[:SOURce<hw>]:1Q:DPD:SHAPing:NORMalized:DATA:CATalog?

Queries the available files with normalized data in the default directory. Only files with
the file extension *.dpd norm are listed.

Return values:

<Catalog> string

Example: See [:SOURce<hw>] :I1Q:DPD:SHAPing:NORMalized:DATA
on page 108.

Usage: Query only

Manual operation: See "Save/Recall Normalized Data" on page 66

[:SOURce<hw>]:1Q:DPD:SHAPing:NORMalized:DATA:LOAD <Filename>
Loads the selected file.

Setting parameters:

<Filename> string

Example: See [ :SOURce<hw>]:IQ:DPD:SHAPing:NORMalized:DATA
on page 108.

Usage: Setting only

Manual operation: See "Save/Recall Normalized Data" on page 66

[:SOURce<hw>]:IQ:DPD:SHAPing:NORMalized:DATA:STORe <Filename>
Saves the normalized data in a file.

Setting parameters:

<Filename> string
Example: See [:SOURce<hw>] :IQ:DPD:SHAPing:NORMalized:DATA
on page 108.
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Usage: Setting only

Manual operation: See "Save/Recall Normalized Data" on page 66
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List of commands

[:SOURCE]:IQ:DPD:SETTING:DELELE. ...ttt 98
[:SOURCE<hW>]:IQ:DPD:AMAM:ISTATE. ...ttt ettt ettt et as 99
[:SOURce<hw>]:IQ:DPD:AMAM:VALUEILEVEI?. ... 100
[:SOURce<hw>]:|Q:DPD:AMAM:VALUEIPEP? ...ttt 100
[:SOURCe<hW>]:IQ:DPD:AMAMVALUE? ..ottt ettt ettt 99
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[:SOURce<hw>]:1Q:DPD:SHAPING[: TABLE]:INVEL. ..ottt 106
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[:SOURce<hw>]:IQ:OUTPUt[:ANALOG]:SETTING:CATAIOG?. ...ttt 78
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Envelope tracking
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SettiNgS .eeeiiieiee 29
Envelope Tracking
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F
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File, save
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Gain

DC modulator .......coceiiiieeee e 27
Getting started .........cccoiiiiiiiii e 6
Graphic, DPD

SCAIE i 60
Graphic, ET shaping

SCAIE i 40
Ground

Termination, DC modulator ...........cccooeeieiiiiiiieeeces 26
H
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High crest factor signals
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Hotspots

Envelope tracking ..........ccccoiiiiiiiiiii 29
|
1/Q impairments

NON-INEAK ... 46
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NON-INEAT ..o 46
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Installation
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L
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About .... .. 13
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M
Memory effects

Preventing, settings ........cccoooiviiiiiii 30
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Polynomial coefficients
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Envelope tracking .........ccccooiiiiiiiiiice 68

HOW £0 i 68
Power amplifiers testing

ENVEIOpe ....oooiiii 23
Power offset

Cable loss compensation ...........cccceveiieiiiiiiecceen. 29
Predistortion

DiIGItAl e 46

Interpolation, shaping table .............cccocoeiiiiiniinn. 57
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